!guide_close_btn!

pc不能自动获取交换机dhcp地址。

[复制链接]
发表于 : 2020-4-2 23:26:57 最新回复:2020-04-04 15:28:32
121 6
  求助帖: (未解决)

拓扑图浏览器传不了,描述一下,sw1做汇聚+dhcp,sw2做接入,(pc接sw2,sw2上接sw1,sw1配置dhcp)现在pc无法获得sw1分配的地址。如果指定pc地址,可以ping通网关,但是自动获取就无效了。请各位高手前辈指教,谢谢。

sw2配置:

#

sysname home

#

vlan batch 102

#

cluster enable

ntdp enable

ndp enable

#

drop illegal-mac alarm

#

dhcp enable

#

dhcp server bootp

#

diffserv domain default

#

drop-profile default

#

aaa

 authentication-scheme default

 authorization-scheme default

 accounting-scheme default

 domain default

 domain default_admin

 local-user admin password simple admin

 local-user admin service-type http

#

interface Vlanif1

#

interface Vlanif102

 ip address 192.168.102.254 255.255.255.0

#

interface MEth0/0/1

#

interface GigabitEthernet0/0/1

 port link-type access

 port default vlan 102

#

interface GigabitEthernet0/0/2

 port link-type access

 port default vlan 102

#

interface GigabitEthernet0/0/3

#

interface GigabitEthernet0/0/4

#

interface GigabitEthernet0/0/5

#

interface GigabitEthernet0/0/6

#

interface GigabitEthernet0/0/7

#

interface GigabitEthernet0/0/8

#

interface GigabitEthernet0/0/9

#

interface GigabitEthernet0/0/10

#

interface GigabitEthernet0/0/11

#

interface GigabitEthernet0/0/12

#

interface GigabitEthernet0/0/13

#

interface GigabitEthernet0/0/14

#

interface GigabitEthernet0/0/15

#

interface GigabitEthernet0/0/16

#

interface GigabitEthernet0/0/17

#

interface GigabitEthernet0/0/18

#

interface GigabitEthernet0/0/19

#

interface GigabitEthernet0/0/20

#

interface GigabitEthernet0/0/21

#

interface GigabitEthernet0/0/22

#

interface GigabitEthernet0/0/23

#

interface GigabitEthernet0/0/24

 port link-type trunk

 port trunk allow-pass vlan 102

#

interface NULL0

#

user-interface con 0

user-interface vty 0 4

#

return


sw1配置:
#
sysname total
#
vlan batch 102
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
drop-profile default
#
ip pool vlan102
 gateway-list 192.168.102.254
 network 192.168.102.0 mask 255.255.255.0
 excluded-ip-address 192.168.102.200 192.168.102.253
 lease day 10 hour 0 minute 0
 dns-list 222.222.222.222
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface Vlanif102
 ip address 192.168.102.254 255.255.255.0
 dhcp select global
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
interface GigabitEthernet0/0/4
#
interface GigabitEthernet0/0/5
#
interface GigabitEthernet0/0/6
#
interface GigabitEthernet0/0/7
#
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
 port link-type trunk
 port trunk allow-pass vlan 102
#
interface NULL0
#
user-interface con 0
user-interface vty 0 4
#
return

现在pc无法获得sw1分配的地址。请各位高手前辈指教,谢谢。
  • x
  • 常规:

点评 回复

跳转到指定楼层
新手老郑   发表于 2020-4-3 08:13:18 已赞(0) 赞(0)

自己顶一顶
  • x
  • 常规:

点评 回复

niuhai211  导师 发表于 2020-4-3 08:47:17 已赞(0) 赞(0)

[home]undo dhcp server bootp
  • x
  • 常规:

点评 回复

吃了糖的嘴   发表于 2020-4-3 09:45:47 已赞(0) 赞(0)

楼主,你的SW1汇聚交换机24接口没有划分接口所属Vlan,你要加上port trunk pvid vlan 102,pc就能获取到IP了。pc不能自动获取交换机dhcp地址。-3261440-1
  • x
  • 常规:

点评 回复

麻柳湾清明
麻柳湾清明  新锐 发表于 2020-4-3 15:22:20 已赞(0) 赞(0)

楼主,我直接刷了你这个配置试了一下,两台PC都能正常获取到IP啊,抓包看了也没有报文被丢掉。你看看是不是你线连错口了
  • x
  • 常规:

点评 回复

小虎牙
小虎牙   发表于 2020-4-4 11:54:19 已赞(0) 赞(0)

如果是模拟器搭建的环境,PC尝试更改为dhcp模式。
如果是企业环境,上面的楼敲打命令开启。pc不能自动获取交换机dhcp地址。-3262736-1pc不能自动获取交换机dhcp地址。-3262736-2
  • x
  • 常规:

点评 回复

陈海峰  精英 发表于 2020-4-4 15:28:32 已赞(0) 赞(0)

我想起来昨天我的群里面有人问了同样的问题,他是PC点了DHCP之后没有点应用,也就是设置未生效,PC上点一下应用,再ipconfig /renew一下。
  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!

登录参与交流分享

登录

华为企业互动社区
华为企业互动社区
屏蔽
!block_confirm_cont!