VxLAN静态配置实验分享

[复制链接]
发表于 : 2020-2-10 15:43:16 最新回复:2020-02-16 17:25:14
305 3
Beirvin
Beirvin  

论坛各位朋友好,我只是初步了解VxLAN,前期在论坛上找了一些VxLAN的实验工程文件,收益也颇多,特别感谢如下链接帖子的作者,我在他的基础上搞清楚了一部分问题,表示感谢!
参考链接:

论坛中的朋友可能会问,既然上述链接的作者既然已经给出了eNSP的Demo配置,我为什么还要再发一个帖子呢?无外乎就是增加一些经验分享,让论坛中的朋友解惑!我做出的改善主要有以下几点:
1. 参考帖中的eNSP工程文件中LSW1的交换机似乎是缺少配置的,所以PC1 ping PC2是肯定Ping不通的,我补充了LSW1配置.

2.简化了SW1和SW2 CE12800交换机的配置,去除个人认为无效配置,比如VLAN 2和13,interface VLANIF13无效配置,方便学习者理解。

3.修改交换机SW3配置,个人去除VLANIF 13和VLANIF 23及其IP配置,新增ip地址配置至GE 1/0/0和GE 1/0/1。

原来上传附件没有成功,图片也没有显示,直接贴配置吧~另外如果根据如下配置直接导入,还是Ping不通,就清空配置,需要手动将命令在CE12800上重配置一遍,基本上就能通了(本人亲证,原因不明)。

SW1:
!CfgFileCrc:3dd317a1
!Software Version V200R005C10SPC607B607
!Last configuration was updated at 2020-02-10 13:56 UTC
!Last configuration was saved at 2020-02-10 13:56 UTC
!MKHash 0000000000000000
#
sysname SW1
#
device board 17 board-type CE-MPUB
device board 1 board-type CE-LPUE
#
vlan batch 10
#
bridge-domain 10
 vxlan vni 2
#
aaa
 #
 authentication-scheme default
 #
 authorization-scheme default
 #
 accounting-scheme default
 #
 domain default
 #
 domain default_admin
#
interface MEth0/0/0
 undo shutdown
#
interface GE1/0/0
 undo portswitch
 undo shutdown
 ip address 192.168.2.1 255.255.255.0
#
interface GE1/0/1
 shutdown
#
interface GE1/0/2
 shutdown
#
interface GE1/0/3
 shutdown
#
interface GE1/0/4
 shutdown
#
interface GE1/0/5
 shutdown
#
interface GE1/0/6
 shutdown
#
interface GE1/0/7
 shutdown
#
interface GE1/0/8
 shutdown
#
interface GE1/0/9
 undo shutdown
#
interface GE1/0/9.10 mode l2
 encapsulation dot1q vid 10
 bridge-domain 10
#
interface LoopBack1
 ip address 1.1.1.1 255.255.255.255
#
interface Nve1
 source 1.1.1.1
 vni 2 head-end peer-list 2.2.2.2
#
interface NULL0
#
ospf 10
 area 0.0.0.0
  network 1.1.1.1 0.0.0.0
  network 192.168.2.0 0.0.0.255
#
ssh authorization-type default aaa
#
ssh server cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
ssh server dh-exchange min-len 1024
#
ssh client cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
user-interface con 0
#
vm-manager
#
return

SW2:
!CfgFileCrc:9a572396
!Software Version V200R005C10SPC607B607
!Last configuration was updated at 2020-02-10 13:56 UTC
!Last configuration was saved at 2020-02-10 13:56 UTC
!MKHash 0000000000000000
#
sysname SW2
#
device board 17 board-type CE-MPUB
device board 1 board-type CE-LPUE
#
vlan batch 10
#
bridge-domain 10
 vxlan vni 2
#
aaa
 #
 authentication-scheme default
 #
 authorization-scheme default
 #
 accounting-scheme default
 #
 domain default
 #
 domain default_admin
#
interface MEth0/0/0
 undo shutdown
#
interface GE1/0/0
 undo portswitch
 undo shutdown
 ip address 192.168.3.1 255.255.255.0
#
interface GE1/0/1
 shutdown
#
interface GE1/0/2
 shutdown
#
interface GE1/0/3
 shutdown
#
interface GE1/0/4
 shutdown
#
interface GE1/0/5
 shutdown
#
interface GE1/0/6
 shutdown
#
interface GE1/0/7
 shutdown
#
interface GE1/0/8
 shutdown
#
interface GE1/0/9
 undo shutdown
#
interface GE1/0/9.10 mode l2
 encapsulation dot1q vid 10
 bridge-domain 10
#
interface LoopBack1
 ip address 2.2.2.2 255.255.255.255
#
interface Nve1
 source 2.2.2.2
 vni 2 head-end peer-list 1.1.1.1
#
interface NULL0
#
ospf 10
 area 0.0.0.0
  network 2.2.2.2 0.0.0.0
  network 192.168.3.0 0.0.0.255
#
ssh authorization-type default aaa
#
ssh server cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
ssh server dh-exchange min-len 1024
#
ssh client cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
user-interface con 0
#
vm-manager
#
return

SW3:
!CfgFileCrc:1876cb33
!Software Version V200R005C10SPC607B607
!Last configuration was updated at 2020-02-10 13:56 UTC
!Last configuration was saved at 2020-02-10 13:56 UTC
!MKHash 0000000000000000
#
sysname SW3
#
device board 17 board-type CE-MPUB
device board 1 board-type CE-LPUE
#
vlan batch 10
#
aaa
 #
 authentication-scheme default
 #
 authorization-scheme default
 #
 accounting-scheme default
 #
 domain default
 #
 domain default_admin
#
interface MEth0/0/0
 undo shutdown
#
interface GE1/0/0
 undo portswitch
 undo shutdown
 ip address 192.168.2.2 255.255.255.0
#
interface GE1/0/1
 undo portswitch
 undo shutdown
 ip address 192.168.3.2 255.255.255.0
#
interface GE1/0/2
 shutdown
#
interface GE1/0/3
 shutdown
#
interface GE1/0/4
 shutdown
#
interface GE1/0/5
 shutdown
#
interface GE1/0/6
 shutdown
#
interface GE1/0/7
 shutdown
#
interface GE1/0/8
 shutdown
#
interface GE1/0/9
 shutdown
#
interface LoopBack1
 ip address 3.3.3.3 255.255.255.255
#
interface NULL0
#
ospf 10
 area 0.0.0.0
  network 3.3.3.3 0.0.0.0
  network 192.168.2.0 0.0.0.255
  network 192.168.3.0 0.0.0.255
#
ssh authorization-type default aaa
#
ssh server cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
ssh server dh-exchange min-len 1024
#
ssh client cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
user-interface con 0
#
vm-manager
#
return



  • x
  • 常规:

点评 回复

跳转到指定楼层
Beirvin
Beirvin   发表于 2020-2-10 20:33:10 已赞(0) 赞(0)

FYI
  • x
  • 常规:

点评 回复

gggggggggx
gggggggggx   发表于 2020-2-13 17:39:28 已赞(0) 赞(0)

你好 能发一下配置吗
  • x
  • 常规:

点评 回复

Beirvin
Beirvin   发表于 2020-2-16 17:25:14 已赞(0) 赞(0)

gggggggggx 发表于 2020-02-13 17:39 你好 能发一下配置吗
原来上传附件没有成功,图片也没有显示,直接贴配置吧:

SW1:
!CfgFileCrc:3dd317a1
!Software Version V200R005C10SPC607B607
!Last configuration was updated at 2020-02-13 17:39 UTC
!Last configuration was saved at 2020-02-13 17:39 UTC
!MKHash 0000000000000000
#
sysname SW1
#
device board 17 board-type CE-MPUB
device board 1 board-type CE-LPUE
#
vlan batch 10
#
bridge-domain 10
vxlan vni 2
#
aaa
#
authentication-scheme default
#
authorization-scheme default
#
accounting-scheme default
#
domain default
#
domain default_admin
#
interface MEth0/0/0
undo shutdown
#
interface GE1/0/0
undo portswitch
undo shutdown
ip address 192.168.2.1 255.255.255.0
#
interface GE1/0/1
shutdown
#
interface GE1/0/2
shutdown
#
interface GE1/0/3
shutdown
#
interface GE1/0/4
shutdown
#
interface GE1/0/5
shutdown
#
interface GE1/0/6
shutdown
#
interface GE1/0/7
shutdown
#
interface GE1/0/8
shutdown
#
interface GE1/0/9
undo shutdown
#
interface GE1/0/9.10 mode l2
encapsulation dot1q vid 10
bridge-domain 10
#
interface LoopBack1
ip address 1.1.1.1 255.255.255.255
#
interface Nve1
source 1.1.1.1
vni 2 head-end peer-list 2.2.2.2
#
interface NULL0
#
ospf 10
area 0.0.0.0
network 1.1.1.1 0.0.0.0
network 192.168.2.0 0.0.0.255
#
ssh authorization-type default aaa
#
ssh server cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
ssh server dh-exchange min-len 1024
#
ssh client cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
user-interface con 0
#
vm-manager
#
return

SW2:
!CfgFileCrc:9a572396
!Software Version V200R005C10SPC607B607
!Last configuration was updated at 2020-02-13 17:39 UTC
!Last configuration was saved at 2020-02-13 17:39 UTC
!MKHash 0000000000000000
#
sysname SW2
#
device board 17 board-type CE-MPUB
device board 1 board-type CE-LPUE
#
vlan batch 10
#
bridge-domain 10
vxlan vni 2
#
aaa
#
authentication-scheme default
#
authorization-scheme default
#
accounting-scheme default
#
domain default
#
domain default_admin
#
interface MEth0/0/0
undo shutdown
#
interface GE1/0/0
undo portswitch
undo shutdown
ip address 192.168.3.1 255.255.255.0
#
interface GE1/0/1
shutdown
#
interface GE1/0/2
shutdown
#
interface GE1/0/3
shutdown
#
interface GE1/0/4
shutdown
#
interface GE1/0/5
shutdown
#
interface GE1/0/6
shutdown
#
interface GE1/0/7
shutdown
#
interface GE1/0/8
shutdown
#
interface GE1/0/9
undo shutdown
#
interface GE1/0/9.10 mode l2
encapsulation dot1q vid 10
bridge-domain 10
#
interface LoopBack1
ip address 2.2.2.2 255.255.255.255
#
interface Nve1
source 2.2.2.2
vni 2 head-end peer-list 1.1.1.1
#
interface NULL0
#
ospf 10
area 0.0.0.0
network 2.2.2.2 0.0.0.0
network 192.168.3.0 0.0.0.255
#
ssh authorization-type default aaa
#
ssh server cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
ssh server dh-exchange min-len 1024
#
ssh client cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
user-interface con 0
#
vm-manager
#
return
SW3:
!CfgFileCrc:1876cb33
!Software Version V200R005C10SPC607B607
!Last configuration was updated at 2020-02-13 17:39 UTC
!Last configuration was saved at 2020-02-13 17:39 UTC
!MKHash 0000000000000000
#
sysname SW3
#
device board 17 board-type CE-MPUB
device board 1 board-type CE-LPUE
#
vlan batch 10
#
aaa
#
authentication-scheme default
#
authorization-scheme default
#
accounting-scheme default
#
domain default
#
domain default_admin
#
interface MEth0/0/0
undo shutdown
#
interface GE1/0/0
undo portswitch
undo shutdown
ip address 192.168.2.2 255.255.255.0
#
interface GE1/0/1
undo portswitch
undo shutdown
ip address 192.168.3.2 255.255.255.0
#
interface GE1/0/2
shutdown
#
interface GE1/0/3
shutdown
#
interface GE1/0/4
shutdown
#
interface GE1/0/5
shutdown
#
interface GE1/0/6
shutdown
#
interface GE1/0/7
shutdown
#
interface GE1/0/8
shutdown
#
interface GE1/0/9
shutdown
#
interface LoopBack1
ip address 3.3.3.3 255.255.255.255
#
interface NULL0
#
ospf 10
area 0.0.0.0
network 3.3.3.3 0.0.0.0
network 192.168.2.0 0.0.0.255
network 192.168.3.0 0.0.0.255
#
ssh authorization-type default aaa
#
ssh server cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
ssh server dh-exchange min-len 1024
#
ssh client cipher aes256_gcm aes128_gcm aes256_ctr aes192_ctr aes128_ctr aes256_cbc aes128_cbc 3des_cbc
#
user-interface con 0
#
vm-manager
#
return

  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录