S5720s交换机如何配置外网固定IP,开启DHCP上网?

新人帖[复制链接]
发表于 : 2019-11-13 09:30:13 最新回复:2019-11-26 15:30:13
712 9
各位,s5720s如何配置外网固定IP,开启DHCP上网?
例如,外网ip地址 192.168.6.100 网关192.168.6.1
dhcp分配192.168.100.0/24
48口作为上联口
帮忙看看这个配置不能ping通192.168.6.1,需要如何配置?
Please Press ENTER.


Login authentication


Username:admin
Password:
<HUAWEI>dis cu
!Software Version V200R011C10SPC600
#
sysname HUAWEI
#
vlan batch 10 20
#
authentication-profile name default_authen_profile
authentication-profile name dot1x_authen_profile
authentication-profile name mac_authen_profile
authentication-profile name portal_authen_profile
authentication-profile name dot1xmac_authen_profile
authentication-profile name multi_authen_profile
#
dhcp enable
#
radius-server template default
#
pki realm default
 certificate-check none
#
free-rule-template name default_free_rule
#
portal-access-profile name portal_access_profile
#
ip pool pool0                             
 gateway-list 192.168.100.1
 network 192.168.100.0 mask 255.255.255.0
#
aaa
 authentication-scheme default
 authentication-scheme radius
  authentication-mode radius
 authorization-scheme default
 accounting-scheme default
 local-aaa-user password policy administrator
  password history record number 0
  password expire 0
 domain default
  authentication-scheme radius
  radius-server default
 domain default_admin
  authentication-scheme default
 local-user admin password irreversible-cipher $1a$4$J\#_CY<X$:v|O/L!QiC,+0H++"lV%<YT(Rzy~0+_yl-,~sBw*$
 local-user admin privilege level 15
 local-user admin service-type terminal http
#
interface Vlanif1
#                                         
interface Vlanif10
 ip address 192.168.100.1 255.255.255.0
 dhcp select global
#
interface Vlanif20
 ip address 192.168.6.100 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/5            
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/7
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/8
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/9
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/10
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/11           
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/12
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/13
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/14
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/15
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/16
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/17           
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/18
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/19
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/20
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/21
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/22
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/23           
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/24
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/25
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/26
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/27
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/28
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/29           
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/30
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/31
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/32
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/33
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/34
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/35           
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/36
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/37
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/38
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/39
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/40
 port link-type trunk
 port trunk allow-pass vlan 20
#
interface GigabitEthernet0/0/41           
#
interface GigabitEthernet0/0/42
#
interface GigabitEthernet0/0/43
#
interface GigabitEthernet0/0/44
#
interface GigabitEthernet0/0/45
#
interface GigabitEthernet0/0/46
#
interface GigabitEthernet0/0/47
#
interface GigabitEthernet0/0/48
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/49
#
interface GigabitEthernet0/0/50
#
interface GigabitEthernet0/0/51
#
interface GigabitEthernet0/0/52           
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.6.1
#
user-interface con 0
 authentication-mode aaa
user-interface vty 0 4
user-interface vty 16 20
#
dot1x-access-profile name dot1x_access_profile
#
mac-access-profile name mac_access_profile
#
return
<HUAWEI>

  • x
  • 常规:

点评 回复

跳转到指定楼层
hzg
hzg   发表于 2019-11-13 09:53:54 已赞(0) 赞(0)

你确定5720有NAT功能?
  • x
  • 常规:

点评 回复

路由器、防火墙、无线组网,你的问题, 我来解决。Q/W:2387648880
guanbj
guanbj  新锐 发表于 2019-11-13 09:55:03 已赞(0) 赞(0)

首先你看看100的ip能不能ping通6.1,还有你的上联口是个什么鬼?连去哪?
  • x
  • 常规:

点评 回复

dzdes
dzdes   发表于 2019-11-13 10:21:55 已赞(0) 赞(0)

不用配置,默认电脑插上去配置运营商分配的 IP、掩码、网关、dns 就能上。
  • x
  • 常规:

点评 回复

小谦
小谦   发表于 2019-11-13 17:59:20 已赞(0) 赞(0)

上联加个回程路由, 5720没有nat
  • x
  • 常规:

点评 回复

HUC韦小宝
HUC韦小宝   发表于 2019-11-14 10:25:39 已赞(0) 赞(0)

看你PC端自动获取的是什么地址,拿到的DHCP对吗?对的话就写静态、配回程,不对的话先配好DHCP再说喽。虽然5720没有NAT功能但是看你的外网地址是192段的,不需要NAT。
  • x
  • 常规:

点评 回复

wwjjhh1980
wwjjhh1980   发表于 2019-11-17 19:50:25 已赞(0) 赞(0)

交换机上没有NAT
  • x
  • 常规:

点评 回复

Mark009
Mark009   发表于 2019-11-21 09:16:34 已赞(0) 赞(0)

用路由和外网对接,你的5720做DHCP服务下发地址就好了。交换机上是没有NAT能力的,无法让你的内网地址共享上网。
  • x
  • 常规:

点评 回复

卿哥哥V58
卿哥哥V58   发表于 2019-11-21 09:47:34 已赞(0) 赞(0)

如果你的192.168.6.1是你内部的路由器,就可以在路由器上设置回城静态路由指向你交换机的IP
  • x
  • 常规:

点评 回复

陈海峰
陈海峰  新锐 发表于 2019-11-26 15:30:13 已赞(0) 赞(0)

交换机不能当路由器用,不过你的上层地址是192段的,上层应该是有NAT或者ISP的路由,在上层加回程路由就行了。192.168.100.0 255.255.255.0 192.168.6.100
  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录