交换机做MCE,PE间vpn无法相互传递,求各位大侠帮助解决

[复制链接]
发表于 : 2019-9-21 21:24:52 最新回复:2019-09-23 09:58:45
206 1
chaos
chaos  

QQ图片20190921212503



AR1
<Huawei>disp cur
[V200R003C00]
#
 board add 0/6 24GE 
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
mpls lsr-id 200.183.0.3
mpls
#
mpls ldp
#
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 200.176.0.1 255.255.255.252 
 ospf enable 100 area 0.0.0.0
 mpls
 mpls ldp
#
interface GigabitEthernet0/0/1
 ip address 200.176.0.5 255.255.255.252 
 ospf enable 100 area 0.0.0.0
 mpls
 mpls ldp
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet6/0/0
#
interface GigabitEthernet6/0/1
#
interface GigabitEthernet6/0/2
#
interface GigabitEthernet6/0/3
#
interface GigabitEthernet6/0/4
#
interface GigabitEthernet6/0/5
#
interface GigabitEthernet6/0/6
#
interface GigabitEthernet6/0/7
#
interface GigabitEthernet6/0/8
#
interface GigabitEthernet6/0/9
#
interface GigabitEthernet6/0/10
#
interface GigabitEthernet6/0/11
#
interface GigabitEthernet6/0/12
#
interface GigabitEthernet6/0/13
#
interface GigabitEthernet6/0/14
#
interface GigabitEthernet6/0/15
#
interface GigabitEthernet6/0/16
#
interface GigabitEthernet6/0/17
#
interface GigabitEthernet6/0/18
#
interface GigabitEthernet6/0/19
#
interface GigabitEthernet6/0/20
#
interface GigabitEthernet6/0/21
#
interface GigabitEthernet6/0/22
#
interface GigabitEthernet6/0/23
#
interface NULL0
#
interface LoopBack0
 ip address 200.183.0.3 255.255.255.255 
#
ospf 100 router-id 200.183.0.3 
 area 0.0.0.0 
  network 200.0.0.0 0.0.0.255 
  network 200.183.0.3 0.0.0.0 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

AR2
<Huawei>disp cur
[V200R003C00]
#
 board add 0/6 24GE 
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
ip vpn-instance ***server-client
 ipv4-family
  route-distinguisher 200:2
  vpn-target 222:2 export-extcommunity
  vpn-target 222:2 import-extcommunity
#
ip vpn-instance huawieserver-client
 ipv4-family
  route-distinguisher 200:1
  vpn-target 111:1 export-extcommunity
  vpn-target 111:1 import-extcommunity
#
mpls lsr-id 200.183.0.1
mpls
#
mpls ldp
#
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 200.176.0.6 255.255.255.252 
 ospf enable 100 area 0.0.0.0
 mpls
 mpls ldp
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/1.100
 dot1q termination vid 100
 ip binding vpn-instance huawieserver-client
 ip address 200.176.0.13 255.255.255.252 
#
interface GigabitEthernet0/0/1.200
 dot1q termination vid 200
 ip binding vpn-instance ***server-client
 ip address 200.176.0.13 255.255.255.252 
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet6/0/0
#
interface GigabitEthernet6/0/1
#
interface GigabitEthernet6/0/2
#
interface GigabitEthernet6/0/3
#
interface GigabitEthernet6/0/4
#
interface GigabitEthernet6/0/5
#
interface GigabitEthernet6/0/6
#
interface GigabitEthernet6/0/7
#
interface GigabitEthernet6/0/8
#
interface GigabitEthernet6/0/9
#
interface GigabitEthernet6/0/10
#
interface GigabitEthernet6/0/11
#
interface GigabitEthernet6/0/12
#
interface GigabitEthernet6/0/13
#
interface GigabitEthernet6/0/14
#
interface GigabitEthernet6/0/15
#
interface GigabitEthernet6/0/16
#
interface GigabitEthernet6/0/17
#
interface GigabitEthernet6/0/18
#
interface GigabitEthernet6/0/19
#
interface GigabitEthernet6/0/20
#
interface GigabitEthernet6/0/21
#
interface GigabitEthernet6/0/22
#
interface GigabitEthernet6/0/23
#
interface NULL0
#
interface LoopBack0
 ip address 200.183.0.1 255.255.255.255 
#
bgp 100
 peer 200.183.0.2 as-number 100 
 peer 200.183.0.2 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo synchronization
  peer 200.183.0.2 enable
 # 
 ipv4-family vpnv4
  policy vpn-target
 #
 ipv4-family vpn-instance ***server-client 
  import-route direct
  peer 200.176.0.14 as-number 65005 
 #
 ipv4-family vpn-instance huawieserver-client 
  import-route direct
  peer 200.176.0.14 as-number 65005 
#
ospf 1 
#
ospf 100 router-id 200.183.0.1 
 area 0.0.0.0 
  network 200.0.0.0 0.0.0.255 
  network 200.183.0.1 0.0.0.0 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

AR3

<Huawei>disp cur
[V200R003C00]
#
 board add 0/6 24GE 
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
ip vpn-instance ***server-client
 ipv4-family
  route-distinguisher 100:2
  vpn-target 222:2 export-extcommunity
  vpn-target 222:2 import-extcommunity
#
ip vpn-instance huawieserver-client
 ipv4-family
  route-distinguisher 100:1
  vpn-target 111:1 export-extcommunity
  vpn-target 111:1 import-extcommunity
#
mpls lsr-id 200.183.0.2
mpls
#
mpls ldp
#
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 200.176.0.2 255.255.255.252 
 ospf enable 100 area 0.0.0.0
 mpls
 mpls ldp
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/2.100
 dot1q termination vid 100
 ip binding vpn-instance huawieserver-client
 ip address 200.176.0.9 255.255.255.252 
#
interface GigabitEthernet0/0/2.200
 dot1q termination vid 200
 ip binding vpn-instance ***server-client
 ip address 200.176.0.9 255.255.255.252 
#
interface GigabitEthernet6/0/0
#
interface GigabitEthernet6/0/1
#
interface GigabitEthernet6/0/2
#
interface GigabitEthernet6/0/3
#
interface GigabitEthernet6/0/4
#
interface GigabitEthernet6/0/5
#
interface GigabitEthernet6/0/6
#
interface GigabitEthernet6/0/7
#
interface GigabitEthernet6/0/8
#
interface GigabitEthernet6/0/9
#
interface GigabitEthernet6/0/10
#
interface GigabitEthernet6/0/11
#
interface GigabitEthernet6/0/12
#
interface GigabitEthernet6/0/13
#
interface GigabitEthernet6/0/14
#
interface GigabitEthernet6/0/15
#
interface GigabitEthernet6/0/16
#
interface GigabitEthernet6/0/17
#
interface GigabitEthernet6/0/18
#
interface GigabitEthernet6/0/19
#
interface GigabitEthernet6/0/20
#
interface GigabitEthernet6/0/21
#
interface GigabitEthernet6/0/22
#
interface GigabitEthernet6/0/23
#
interface NULL0
#
interface LoopBack0
 ip address 200.183.0.2 255.255.255.255 
#
bgp 100
 peer 200.183.0.1 as-number 100 
 peer 200.183.0.1 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo synchronization
  peer 200.183.0.1 enable
 # 
 ipv4-family vpnv4
  policy vpn-target
 #
 ipv4-family vpn-instance ***server-client 
  import-route direct
  peer 200.176.0.10 as-number 65004 
 #
 ipv4-family vpn-instance huawieserver-client 
  import-route direct
  peer 200.176.0.10 as-number 65004 
#
ospf 100 router-id 200.183.0.2 
 area 0.0.0.0 
  network 200.0.0.0 0.0.0.255 
  network 200.183.0.2 0.0.0.0 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

LSW1
<Huawei>
<Huawei>disp cur
#
sysname Huawei
#
vlan batch 10 20 100 200
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
ip vpn-instance ***server-client
 ipv4-family
  route-distinguisher 100:2
#
ip vpn-instance huawieserver-client
 ipv4-family
  route-distinguisher 100:1
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface Vlanif10
 ip binding vpn-instance huawieserver-client
 ip address 201.176.0.3 255.255.128.0
#
interface Vlanif20
 ip binding vpn-instance ***server-client
 ip address 202.176.0.3 255.255.128.0
#
interface Vlanif100
 ip binding vpn-instance huawieserver-client
 ip address 200.176.0.10 255.255.255.252
#
interface Vlanif200
 ip binding vpn-instance ***server-client
 ip address 200.176.0.10 255.255.255.252
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/4
#
interface GigabitEthernet0/0/5
#
interface GigabitEthernet0/0/6
#
interface GigabitEthernet0/0/7
#
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
#
interface NULL0
#
interface LoopBack0
 ip address 200.183.0.4 255.255.255.255
#
bgp 65004
 #
 ipv4-family unicast
  undo synchronization
 #
 ipv4-family vpn-instance ***server-client
  import-route direct
  peer 200.176.0.9 as-number 100
 #
 ipv4-family vpn-instance huawieserver-client
  import-route direct
  peer 200.176.0.9 as-number 100
#
user-interface con 0
user-interface vty 0 4
#
return


lsw2
<Huawei>
<Huawei>disp cur
#
sysname Huawei
#
vlan batch 10 20 100 200
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
ip vpn-instance ***server-client
 ipv4-family
  route-distinguisher 200:2
#
ip vpn-instance huawieserver-client
 ipv4-family
  route-distinguisher 200:1
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface Vlanif10
 ip binding vpn-instance huawieserver-client
 ip address 201.176.0.4 255.255.128.0
#
interface Vlanif20
 ip binding vpn-instance ***server-client
 ip address 202.176.0.4 255.255.128.0
#
interface Vlanif100
 ip binding vpn-instance huawieserver-client
 ip address 200.176.0.14 255.255.255.252
#
interface Vlanif200
 ip binding vpn-instance ***server-client
 ip address 200.176.0.14 255.255.255.252
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/4
#
interface GigabitEthernet0/0/5
#
interface GigabitEthernet0/0/6
#
interface GigabitEthernet0/0/7
#
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
#
interface GigabitEthernet0/0/22
#
interface GigabitEthernet0/0/23
#
interface GigabitEthernet0/0/24
#
interface NULL0
#
interface LoopBack0
 ip address 200.183.0.5 255.255.255.255
#
bgp 65005
 #
 ipv4-family unicast
  undo synchronization
 #
 ipv4-family vpn-instance ***server-client
  import-route direct
  peer 200.176.0.13 as-number 100
 #
 ipv4-family vpn-instance huawieserver-client
  import-route direct
  peer 200.176.0.13 as-number 100
#
user-interface con 0
user-interface vty 0 4
#
return





  • x
  • 常规:

点评 回复

跳转到指定楼层
Zwalker
Zwalker   发表于 2019-9-23 09:58:45 已赞(0) 赞(0)

bgp 100
peer 200.183.0.2 as-number 100
peer 200.183.0.2 connect-interface LoopBack0
#
ipv4-family vpnv4
policy vpn-target
你MP-BGP邻居关系都没建吧,怎么传VPNv4路由?在ip-family-vpnv4下加一句(2边都加),
peer 200.183.0.2 enable
  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录