eNSP V100R003C00SPC100在win10下运行大约1~2小时后virtualbox不工作

新人帖[复制链接]
发表于 : 2019-9-14 17:57:39 最新回复:2019-10-11 13:40:15
660 14
  求助帖: (未解决)
劝告Win10的兄弟直接放弃吧,在Win10下你会遇到各种各样的问题导致无法顺畅的使用ensp,我是用hyper-v安装win7系统搞定的,win7下非常稳定。下面的方法可以忽略了……
      
本来我是想提出一个在本版里找不到解决方案的问题,但是一个习惯性的动作给我推开了一扇窗,希望能给大家一些帮助。
      PS:我重点拜读了本版置顶三贴“Windows 10 1809版本与eNSP V100R003C00完美运行测试之路
”,“【eNSP v1.3.00.100 发布公告 日期:2019-03-09】“,“【汇总】eNSP启动问题经验分享帖“,确认没有找到与我相同的问题,提出问题的初衷是想依靠别人的力量来解决我(也可能有幸变成一个共同的问题)遇到的问题。

一、环境描述:eNSP V100R003C00SPC100,virtualbox VirtualBox-5.2.0-118431-Win(尝试过VirtualBox-5.2.26-128414-Win),win10 64位专业版 版本号1842,内存16G,CPU i7-7500U 2.7GHz。

二、问题描述:AR2220路由器在运行1~2个小时之后出现,无法再启动新的AR2220路由器的情况,启动过程进入无限#模式,而且已经启动的AR2220路由器如果重启一样会进入无限#模式。

三、排错过程描述及原因试分析:eNSP是最新的1.3c0spc100(没有想过要换版本,因为新版本是为了解决老版本的问题才出现的),virtulbox换过很多本版但是问题现象一样,期初通过删除box里的虚拟网卡得到了暂时的解决,但是一到1~2小时的点问题就有出现了,所以可能是设置的问题。排错过程中ensp重来没有重装过,反复注册设备也没有问题,个人认为ensp还是比较稳定,暂时不想考虑esnp的问题,但是问题来了,virtulbox的问题近乎无解了。我的电脑是64位的操作系统,所以virtualbox这块是没办法了,只能吧ensp阿江到x86的目录下,但凡有问题彻底重装还是可以的。

四、推开一扇“窗”
      平时工作遇到问题养成的看官方“版本说明书”和“安装指导手册”,所以我下载了《eNSP V100R003C00SPC100  版本说明书》和《eNSP V100R003C00SPC100 软件安装指南》,详细看过之后发现软件安装指南对我们帮助不大,可以忽略。版本说明是2019年3月2日发布的,几乎与新版ensp同步发布,所以匹配度最高,其中发现了一些关于设置方面的说明,个人认为知道在这里和大家分享一下,未来考虑更新我的使用情况。现在列举一下参数设置:

1、CE\NE\CX和USG6000V需要在bios里开启Virtualization支持功能。

2、软件依赖性列表,最好与下面列表的版本相同
  WinPcap  4.1.3
  Wireshark  2.6.6
  VirtualBox  4.2.X-5.2.X

3、文档中虽然没有强调win版本64位还是32位,但是实际上ensp是32位的应用程序,建议安装到progam files(x86)目录下。个人建议对应的virtualbox也要32位的,但是平时下载的box安装软件是64和32位集成安装包,安装时会自动根据操作系统选择对应的安装包,64位操作系统是不能安装32位的virtualbox的,所以建议大家还是用32位操作系统吧(鲜血总结出来的经验)。

4、安装新版本之前,请先卸载原有软件,将安装目录下的eNSP文件夹完全删除,同时将User->AppData(隐藏文件夹)->Local->eNSP文件夹完全删除。

5.交换机启动长时间提示###,eNSP_switch.exe已停止工作。
问题原因:本机计数器无法使用,导致交换机程序无法启动。
解决方法:
(1)选择“开始-所有程序-附件”。
(2)右键单击“命令提示符”,选择“以管理员身份运行”。
(3)在弹出的命令行窗口中,输入相应的命令,重启计数器。
对于Win7/ Win8/Win10系统,输入“lodctr /R”。
对于Windows xp系统,输入“lodctr/R:PerfStringBackup.ini”。

6.【windows 10 兼容性设置】
(1)、打开vbox安装目录,将C:\ProgramFiles(x86)\Oracle\VirtualBox\VirtualBox.exe 和C:\Program Files(x86)\Oracle\VirtualBox\VBoxManage.exe设置为win7兼容性模式,并且勾选以管理员身份运行此程序。
(2)、打开ensp安装目录,将eNSP_Client.exe和vboxsever文件夹中的eNSP_VBoxServer.exe设置为win7兼容性模式,并且勾选以管理员身份运行此程序。

7、【安装VirtualBox5.0版本仍无法启动AR】
问题原因:VirtualBox5.0版本的功能不稳定。
解决方法:需要到控制面板\网络和 Internet\网络连接”中找到名为“VirtualBox Host-OnlyNetwork”的网卡,右键选择“属性”,将“VirtualBoxNDIS6 Bridged Networking Driver”勾选上,单击“确定”。

2019-9-14日晚情况更新:
我的ensp安装到默认路径,按照兼容性设置操作了一下。没有出现运行了2个小时后再重启新的路由器进入无限#模式。由此可见按照上面的方式安装软件是没有问题的。
2019-9-15情况更新:
昨晚安装上面的操作新安装了所有的软件后稳定运行了3个小时,点击停止路由器后关闭ensp。今天开启ensp后发现路由器无法运行了又进入了无限#模式。先使用重启计数器的方式测试一下是否能正常运行,测试发现能正常运行了。建议如果出现无限#模式,先用重启计数器的方式排障。



  • x
  • 常规:

点评 回复

sun_zhiq
sun_zhiq 发表于 2019-9-16 15:38
2019-9-16无限#魔咒还是没有排除,现象又出现了。 重置计数器——无效;重启后重置计数器、重置计数器后重启——无效;删除添加virtualbox虚拟网卡——无效(192.168.56.1);就差重装虚拟机了,希望有效,但是如果这样就太麻烦了。  
sun_zhiq
sun_zhiq 回复 sun_zhiq  发表于 2019-9-16 15:50
2019-9-16-154200没有重新安装虚拟机可以运行了,没有原因仅仅是多等了半个小时左右。我想说脏话……  
跳转到指定楼层
sun_zhiq
sun_zhiq   发表于 2019-9-14 21:22:13 已赞(0) 赞(0)

ok,更新一下。
eNsp重新安装,按照默认路径安装;virtualbox版本VirtualBox-5.2.32-132073-Win;win10的64位操作系统。
按照6.【windows 10 兼容性设置】操作之后,运行2个小时,再运行新的路由器之后,可以正常加载,目前我认为问题解决了。
  • x
  • 常规:

点评 回复

sun_zhiq
sun_zhiq   发表于 2019-9-14 21:23:06 已赞(1) 赞(1)

解决了
  • x
  • 常规:

点评 回复

石油储备seattle22
石油储备seattle22   发表于 2019-9-15 00:52:17 已赞(0) 赞(0)

是的我之前的帖子 就有。关键是要安装默认路径。
  • x
  • 常规:

点评 回复

石油储备seattle22
石油储备seattle22   发表于 2019-9-15 00:55:35 已赞(0) 赞(0)

关键的一 c 盘默认路径安装(vbox nesp WinPcap Wireshark )都要安装再C 盘 二 使用管理员方式运行。可以不使用兼容模式。我现在的WIN 版本 1903 所有 设备正常运行。 三 VirtualBox

4.2.X-5.2.X 一定注意 。版本太高直接没搞。
  • x
  • 常规:

点评 回复

sun_zhiq
sun_zhiq   发表于 2019-9-15 11:09:35 已赞(0) 赞(0)

我的拓扑里路由器有30多台,所有的设备有将近60台,应该算能满足大部分的实验要求了。
  • x
  • 常规:

点评 回复

sun_zhiq
sun_zhiq   发表于 2019-9-16 15:59:57 已赞(0) 赞(0)

石油储备seattle22 发表于 2019-09-15 00:52 是的我之前的帖子 就有。关键是要安装默认路径。
我把安装路由指向c:/program files(x86)下也是可以运行的。因为windows操作系统是64位的,我更换安装目录的原因是怀疑ensp对32位操作系统的兼容性更好,测试后发现应该关系不大。实际上软件兼容性设置对软件的正常运行影响更大。
  • x
  • 常规:

点评 回复

sun_zhiq
sun_zhiq   发表于 2019-9-17 09:29:10 已赞(0) 赞(0)

2019-9-17-0927还是没有受到眷顾。又出现无限#模式了,最后还是重装virtualbox来解决的。win10下virtualbox一定要安装5.2.x版本,如果安装5.1.x版本ensp会报40错误。
  • x
  • 常规:

点评 回复

sun_zhiq
sun_zhiq   发表于 2019-9-17 09:31:22 已赞(0) 赞(0)

还是没有受到眷顾。又出现无限#模式了,最后还是通过重装virtualbox来解决的。win10下一定要安装virtualbox的5.2.x版本,如果5.1.x版本回报40错误。
  • x
  • 常规:

点评 回复

nm.sl
nm.sl   发表于 2019-9-23 09:08:07 已赞(0) 赞(0)

这糟糕的黄字
  • x
  • 常规:

点评 回复

12
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录