同一台交换机两个VLAN通过网线直连无法互通

新人帖[复制链接]
发表于 : 2019-9-9 11:45:16 最新回复:2019-09-20 16:24:01
1129 17
hyz
hyz  

  求助帖: (未解决)
同一台交换机配置VLAN10、VLAN20,所有端口都为access模式,用一条网线将VLAN10和VLAN20连接起来,此时VLAN10下的主机与VLAN20下的主机应该是同一个广播域,应该可以互通的。
但是我们实际组网结果是两个VLAN下的主机不能互通,不能PING通,请教问题出在哪里?
附配置如下:
sysname ABC
#
vlan batch 10 20 30 50
#
observe-port 1 interface GigabitEthernet0/0/24
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher %@%@sdfadfasfasT:GMCdafas%@
 local-user admin service-type http
#
interface Vlanif1
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
 port-mirroring to observe-port 1 both 
 #
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 10
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 10
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 10
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/5
 port link-type access
 port default vlan 10
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 10
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/7
 port link-type access
 port default vlan 20
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/8
 port link-type access
 port default vlan 20
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/9
 port link-type access
 port default vlan 20
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/10
 port link-type access
 port default vlan 20
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/11
 port link-type access
 port default vlan 30
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/12
 port link-type access
 port default vlan 30
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/13
 port link-type access
 port default vlan 30
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/14
 port link-type access
 port default vlan 30
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/15
 port link-type access
 port default vlan 30
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/16
 port link-type access
 port default vlan 30
 port-mirroring to observe-port 1 both 
#
interface GigabitEthernet0/0/17
 port link-type access
 port default vlan 50
#                                         
interface GigabitEthernet0/0/18
 port link-type access
 port default vlan 50
#
interface GigabitEthernet0/0/19
 port link-type access
 port default vlan 50
#
interface GigabitEthernet0/0/20
 port link-type access
 port default vlan 50
#
interface GigabitEthernet0/0/21
 port link-type access
 port default vlan 50
#
interface GigabitEthernet0/0/22
 port link-type access
 port default vlan 50
#
interface GigabitEthernet0/0/23
 port link-type access
 port default vlan 50
#                                         
interface GigabitEthernet0/0/24
 port link-type access
#
interface NULL0
#
user-interface con 0
user-interface vty 0 4
user-interface vty 16 20
#
return
#
save
#
y
#

  • x
  • 常规:

点评 回复

跳转到指定楼层
zhaoyanchaozy
zhaoyanchaozy   发表于 2019-9-9 13:02:37 已赞(0) 赞(0)

同一交换机不通VLAN,不是一个广播域,肯定不能ping通。
  • x
  • 常规:

点评 回复

hyz
hyz   发表于 2019-9-9 13:17:42 已赞(0) 赞(0)

zhaoyanchaozy 发表于 2019-09-09 13:02 同一交换机不通VLAN,不是一个广播域,肯定不能ping通。
用网线将两个vlan连起来。
  • x
  • 常规:

点评 回复

鱼秋猫
鱼秋猫   发表于 2019-9-9 13:41:25 已赞(0) 赞(0)

一根网线将两个交换机连接起来,跑两个VLan的数据吗?
  • x
  • 常规:

点评 回复

zhaoyanchaozy
zhaoyanchaozy   发表于 2019-9-9 17:22:13 已赞(0) 赞(0)

hyz 发表于 2019-09-09 13:17 用网线将两个vlan连起来。
那不是说连起来就能通的啊,你几个交换机?是一个交换机 然后你用网线将两个不通vlan连起来?
  • x
  • 常规:

点评 回复

Zwalker
Zwalker   发表于 2019-9-9 17:41:47 已赞(0) 赞(0)

你有没考虑过生成树协议啊,看下端口的状态,有可能会被阻塞
  • x
  • 常规:

点评 回复

hzg
hzg   发表于 2019-9-10 10:08:14 已赞(2) 赞(2)

前提条件交换机是二层交换机,二层交换机工作在数据链路层,ip是啥东西?不知道!!
划分vlan之后广播域变小了而已。
如果你用网线连接2个vlan能通的话,,就不用三层交换机啦同一台交换机两个VLAN通过网线直连无法互通-3057013-1
  • x
  • 常规:

点评 回复

路由器、防火墙、无线组网,你的问题,加我好友,我来解决。位置-江西南昌
不带风
不带风   发表于 2019-9-10 10:28:28 已赞(1) 赞(1)

高人,划分了VLAN 就打上了不同标记,要在三层用IP通信,要不划分VLAN 的意义何在,就是隔离广播域。
  • x
  • 常规:

点评 回复

Zwalker
Zwalker   发表于 2019-9-10 11:26:02 已赞(0) 赞(0)

不带风 发表于 2019-09-10 10:28 高人,划分了VLAN 就打上了不同标记,要在三层用IP通信,要不划分VLAN 的意义何在,就是隔离广播域。 ...
先不说他的意思是什么,我觉得他的实验意图是把广播域物理连起来,如果是做原理性的测试,不考虑其他因素,他说的情况在两个vlan下用相同的IP地址段,是可以通信的。
  • x
  • 常规:

点评 回复

涛涛不覺
涛涛不覺   发表于 2019-9-11 22:04:58 已赞(0) 赞(0)

且不说是否是两个VLAN,这么组网本是就是自身环回。网络构架简单点
  • x
  • 常规:

点评 回复

冉勇军
冉勇军 发表于 2019-9-17 08:19
我感觉也是这样的。都环起了 咋过还能通信呢!  
12
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录