求助哪位大神,帮我解决下NAT的问题

新人帖[复制链接]
发表于 : 2019-9-5 11:37:53 最新回复:2019-09-29 17:02:22
1135 19
  悬赏: 1E币   (未解决)

求助,下面的这个例子,为什么在AR1 上配置NAT后,却不通,用PC1  ping  AR2 却不同,这是怎么回事???

截图01截图00


AR1的配置如下:


[AR1]dis cu

[V200R003C00]

#

 sysname AR1

#

 snmp-agent local-engineid 800007DB03000000000000

 snmp-agent 

#

 clock timezone China-Standard-Time minus 08:00:00

#

portal local-server load portalpage.zip

#

 drop illegal-mac alarm

#

 set cpu-usage threshold 80 restore 75

#

acl number 2000  

 rule 5 permit source 192.168.1.0 0.0.0.255 

#

aaa 

 authentication-scheme default

 authorization-scheme default

 accounting-scheme default

 domain default 

 domain default_admin 

 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$

 local-user admin service-type http

#

firewall zone Local

 priority 15

#

 nat address-group 1 12.1.1.10 12.1.1.12

#

interface Ethernet0/0/0

#

interface Ethernet0/0/1

#

interface Ethernet0/0/2

#

interface Ethernet0/0/3

#

interface Ethernet0/0/4

#

interface Ethernet0/0/5

#

interface Ethernet0/0/6

#

interface Ethernet0/0/7

#

interface GigabitEthernet0/0/0

 ip address 192.168.1.1 255.255.255.0 

#

interface GigabitEthernet0/0/1

 ip address 12.1.1.1 255.255.255.0 

 nat outbound 2000 address-group 1 no-pat

#

interface NULL0

#

user-interface con 0

 authentication-mode password

user-interface vty 0 4

user-interface vty 16 20

#

wlan ac

#

return


AR2的配置如下


<AR2>dis cu

[V200R003C00]

#

 sysname AR2

#

 snmp-agent local-engineid 800007DB03000000000000

 snmp-agent 

#

 clock timezone China-Standard-Time minus 08:00:00

#

portal local-server load portalpage.zip

#

 drop illegal-mac alarm

#

 set cpu-usage threshold 80 restore 75

#

aaa 

 authentication-scheme default

 authorization-scheme default

 accounting-scheme default

 domain default 

 domain default_admin 

 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$

 local-user admin service-type http

#

firewall zone Local

 priority 15

#

interface Ethernet0/0/0

#

interface Ethernet0/0/1

#

interface Ethernet0/0/2

#

interface Ethernet0/0/3

#

interface Ethernet0/0/4

#

interface Ethernet0/0/5

#

interface Ethernet0/0/6

#

interface Ethernet0/0/7

#

interface GigabitEthernet0/0/0

 ip address 12.1.1.2 255.255.255.0 

#

interface GigabitEthernet0/0/1

#

interface NULL0

#

user-interface con 0

 authentication-mode password

user-interface vty 0 4

user-interface vty 16 20

#

wlan ac

#

return



可是用PC1  ping  AR2 却不同,这是怎么回事???

截图02

附件: 您需要 登录 才可以下载或查看,没有帐号?注册
  • x
  • 常规:

点评 回复

COSl
COSl 发表于 2019-9-27 09:22
如问题已解决,请点击右下角设置“最佳答案”,谢谢!  
跳转到指定楼层
秋天的落寞
秋天的落寞  新锐 发表于 2019-9-5 14:31:34 已赞(0) 赞(0)

AR1路由器上将这条删除 nat address-group 1 12.1.1.10 12.1.1.12

接口下的配置将nat outbound 2000 address-group 1 no-pat 改成 nat outbound 2000
interface GigabitEthernet0/0/1
nat outbound 2000

这样就可以NAT成功了求助哪位大神,帮我解决下NAT的问题-3053789-1
希望可以帮到你哦
  • x
  • 常规:

点评 回复

只想过理想生活,每天睡到自然醒,起来吃个饭,接着再睡。
驰驹荡江湖
驰驹荡江湖  导师 发表于 2019-9-5 16:40:09 已赞(1) 赞(1)

你这配置没问题,就是no-pat最好别加了,要不然ip地址都被占用了,就三个公网地址池,三个包就满了,得等下次刷新才能通。还是复用比较好。不会有这些问题。另外你的不通,你可以保存配置,重启一下ensp试试。我的电脑测试是没问题的这个配置
  • x
  • 常规:

点评 回复

小小00
小小00   发表于 2019-9-6 08:57:13 已赞(0) 赞(0)

秋天的落寞 发表于 2019-09-05 14:31 AR1路由器上将这条删除 nat address-group 1 12.1.1.10 12.1.1.12接口下的配置将nat outbound 2000 address ...
你好,我要用地址池的方式,而不是Esay-ip方式,而且你的建议我试了,还是不行啊,大哥,求求你我该怎么办??求助哪位大神,帮我解决下NAT的问题-3054407-1求助哪位大神,帮我解决下NAT的问题-3054407-2求助哪位大神,帮我解决下NAT的问题-3054407-3
  • x
  • 常规:

点评 回复

小小00
小小00   发表于 2019-9-6 09:00:03 已赞(0) 赞(0)

驰驹荡江湖 发表于 2019-09-05 16:40 你这配置没问题,就是no-pat最好别加了,要不然ip地址都被占用了,就三个公网地址池,三个包就满了,得等下 ...
还是不通啊,我用了PAT方式,还是不通啊,怎么回事啊,是啥原因啊
  • x
  • 常规:

点评 回复

驰驹荡江湖
驰驹荡江湖  导师 发表于 2019-9-6 09:10:03 已赞(0) 赞(0)

user_3543685 发表于 2019-09-06 09:00 还是不通啊,我用了PAT方式,还是不通啊,怎么回事啊,是啥原因啊
这个跟你电脑系统有关吧,之前也有很多人说nat不好用,但是我从来没遇到过,一直都好用。我也看了你配置,没有问题,所以还是你电脑的问题。
  • x
  • 常规:

点评 回复

秋天的落寞
秋天的落寞  新锐 发表于 2019-9-6 09:13:05 已赞(0) 赞(0)

user_3543685 发表于 2019-09-06 08:57 你好,我要用地址池的方式,而不是Esay-ip方式,而且你的建议我试了,还是不行啊,大哥,求求你我该怎么 ...
sysname AR1
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
acl number 2001
rule 5 permit source 192.168.1.0 0.0.0.255
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
nat address-group 1 12.1.1.3 12.1.1.4
#
interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 12.1.1.1 255.255.255.0
nat outbound 2001 address-group 1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
_________________________________________________________________________

sysname AR2
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 12.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return


我这样配置是成功的
  • x
  • 常规:

点评 回复

只想过理想生活,每天睡到自然醒,起来吃个饭,接着再睡。
小小00
小小00   发表于 2019-9-6 09:47:12 已赞(0) 赞(0)

驰驹荡江湖 发表于 2019-09-06 09:10 这个跟你电脑系统有关吧,之前也有很多人说nat不好用,但是我从来没遇到过,一直都好用。我也看了你配置 ...
您好,您测试成功了吗,您用的电脑系统是什么系统啊,求求您了,跪求
  • x
  • 常规:

点评 回复

小小00
小小00   发表于 2019-9-6 09:48:40 已赞(0) 赞(0)

秋天的落寞 发表于 2019-09-06 09:13 sysname AR1# snmp-agent local-engineid 800007DB03000000000000 snmp-agent # clock timezone China-S ...
您能截个成功的图片吗
  • x
  • 常规:

点评 回复

小小00
小小00   发表于 2019-9-6 11:27:41 已赞(0) 赞(0)

小小00 发表于 2019-09-06 09:47 您好,您测试成功了吗,您用的电脑系统是什么系统啊,求求您了,跪求
您的系统是什么系统啊,ENSP版本是哪个啊,我一直测试都没有成功,求您帮帮我啊
  • x
  • 常规:

点评 回复

12
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录