策略路由问题

新人帖[复制链接]
发表于 : 2019-8-15 17:51:29 最新回复:2019-08-28 11:26:39
1169 23
未标题-1

请教一下策略路由问题
lsw1交换机配置如下:
sysname Huawei
#
vlan batch 10 20 30 70
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
acl number 3000
 rule 5 permit ip source 192.168.1.0 0.0.0.255 destination 192.168.254.0 0.0.0.2
55
acl number 3001
 rule 5 permit ip source 192.168.4.0 0.0.0.255 destination 192.168.252.0 0.0.0.2
55
#
traffic classifier Internet operator and
 if-match acl 3001
traffic classifier SERVER1 operator and
 if-match acl 3000
#
traffic behavior Internet
 redirect ip-nexthop 192.168.253.1
traffic behavior SERVER1
 redirect ip-nexthop 192.168.254.1
#
traffic policy P1
 classifier SERVER1 behavior SERVER1
 classifier Internet behavior Internet
#
drop-profile default
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password simple admin
 local-user admin service-type http
#
interface Vlanif1
#
interface Vlanif10
 ip address 192.168.1.1 255.255.255.0
#
interface Vlanif20
 ip address 192.168.2.1 255.255.255.0
#
interface Vlanif30
 ip address 192.168.3.1 255.255.255.0
#
interface Vlanif70
 ip address 192.168.4.1 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/3
 port link-type trunk
#
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 70
 loopback-detect enable
 traffic-policy P1 inbound
#
interface GigabitEthernet0/0/5
 loopback-detect enable
#
interface GigabitEthernet0/0/6
 loopback-detect enable
#
interface GigabitEthernet0/0/7
 loopback-detect enable
#
interface GigabitEthernet0/0/8
 loopback-detect enable
#
interface GigabitEthernet0/0/9
 loopback-detect enable
#
interface GigabitEthernet0/0/10
 loopback-detect enable
#
interface GigabitEthernet0/0/11
 loopback-detect enable
#
interface GigabitEthernet0/0/12
 loopback-detect enable
#
interface GigabitEthernet0/0/13
 loopback-detect enable
#
interface GigabitEthernet0/0/14
 loopback-detect enable
#
interface GigabitEthernet0/0/15
 loopback-detect enable
#
interface GigabitEthernet0/0/16
 loopback-detect enable
#
interface GigabitEthernet0/0/17
 loopback-detect enable
#
interface GigabitEthernet0/0/18
 loopback-detect enable
#
interface GigabitEthernet0/0/19
 loopback-detect enable
#
interface GigabitEthernet0/0/20
 loopback-detect enable
#
interface GigabitEthernet0/0/21
 loopback-detect enable
#
interface GigabitEthernet0/0/22
 loopback-detect enable
#
interface GigabitEthernet0/0/23
 loopback-detect enable
#
interface GigabitEthernet0/0/24
 loopback-detect enable
#
interface NULL0
#
ip route-static 192.168.252.0 255.255.255.0 192.168.2.2
ip route-static 192.168.252.0 255.255.255.0 192.168.3.2
ip route-static 192.168.253.0 255.255.255.0 192.168.3.2
ip route-static 192.168.254.0 255.255.255.0 192.168.2.2
#
user-interface con 0
user-interface vty 0 4
#
return
  • x
  • 常规:

点评 回复

跳转到指定楼层
querysql1
querysql1   发表于 2019-8-15 17:53:38 已赞(1) 赞(1)

pc1想走上面那条链路访问pc6
pc2走下面的链路访问pc6
  • x
  • 常规:

点评 回复

彪彪
彪彪  导师VIP 发表于 2019-8-15 23:04:45 已赞(1) 赞(1)

traffic behavior Internet
redirect ip-nexthop 192.168.253.1
traffic behavior SERVER1
redirect ip-nexthop 192.168.254.1


不要指定下一跳,指向出接口
  • x
  • 常规:

点评 回复

。。。。。。。。。。
驰驹荡江湖
驰驹荡江湖  导师 发表于 2019-8-16 08:49:12 已赞(1) 赞(1)

ensp里的交换机能配置策略,但是功能不能实现,有bug,换成路由器可以实现。
  • x
  • 常规:

点评 回复

querysql1
querysql1   发表于 2019-8-16 10:46:11 已赞(1) 赞(1)

彪彪 发表于 2019-08-15 23:04 traffic behavior Internet redirect ip-nexthop 192.168.253.1traffic behavior SERVER1 redirect ip-next ...
traffic behavior Internet
redirect ip-nexthop 192.168.2.2
traffic behavior SERVER1
redirect ip-nexthop 192.168.3.2

请问是该成这样吗、?
  • x
  • 常规:

点评 回复

querysql1
querysql1   发表于 2019-8-16 10:47:24 已赞(1) 赞(1)

驰驹荡江湖 发表于 2019-08-16 08:49 ensp里的交换机能配置策略,但是功能不能实现,有bug,换成路由器可以实现。 ...
谢谢 我在试试
  • x
  • 常规:

点评 回复

querysql1
querysql1   发表于 2019-8-16 11:07:41 已赞(1) 赞(1)

未标题-1

我改成路由器连接了!
下面是AR4的配置:
<Huawei>dis cur
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
acl number 3000  
 rule 5 permit ip source 192.168.1.0 0.0.0.255 
acl number 3001  
 rule 5 permit ip source 192.168.4.0 0.0.0.255 
#
traffic classifier Internet operator or
 if-match acl 3001
traffic classifier SERVER1 operator or
 if-match acl 3000
#
traffic behavior Internet
 redirect ip-nexthop 192.168.3.2
traffic behavior SERVER1
 redirect ip-nexthop 192.168.2.2
#
traffic policy P1
 classifier SERVER1 behavior SERVER1
 classifier Internet behavior Internet
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 192.168.1.1 255.255.255.0 
 traffic-policy P1 inbound
#
interface GigabitEthernet0/0/1
 ip address 192.168.2.1 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 192.168.3.1 255.255.255.0 
#
interface NULL0
#
ip route-static 192.168.253.0 255.255.255.0 192.168.3.2
ip route-static 192.168.254.0 255.255.255.0 192.168.2.2
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
  • x
  • 常规:

点评 回复

驰驹荡江湖
驰驹荡江湖 发表于 2019-8-16 13:52
以现在这个图没意义啊,用路由就能区分开了,用不到策略路由啊,应该在加个路由器,跟上面交换机一样,出接口配置默认路由,这样策略路由才有效果  
querysql1
querysql1 回复 驰驹荡江湖  发表于 2019-8-16 18:30
我马上改一下 你在看看,一会重新发一张拓扑图!  
querysql1
querysql1   发表于 2019-8-16 18:36:30 已赞(1) 赞(1)

querysql1 发表于 2019-08-16 11:07我改成路由器连接了!下面是AR4的配置:<Huawei>dis cur[V200R003C00]# snmp-agent local-engineid 8000 ...


未标题-1
我在路由器AR4的前面加了一个交换机,交换机下接2个vlan  vlan10(192.168.1.0)和vlan60(192.168.4.0),
通过路由策略让vlan10的只能访问192.168.254.0;vlan60只能访问192.168.253.0;

帮忙在看看!还有哪里不合适!谢谢大家的关注!!!

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
  • x
  • 常规:

点评 回复

querysql1
querysql1   发表于 2019-8-16 18:37:45 已赞(0) 赞(0)

querysql1 发表于 2019-08-16 18:36 我在路由器AR4的前面加了一个交换机,交换机下接2个vlan  vlan10(192.168.1.0)和vlan60(192.168.4.0 ...
我在路由器AR4的前面加了一个交换机,交换机下接2个vlan  vlan10(192.168.1.0)和vlan60(192.168.4.0),

通过路由策略让vlan10的只能访问192.168.254.0;vlan60只能访问192.168.253.0;

帮忙在看看!还有哪里不合适!谢谢大家的关注!!!

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
  • x
  • 常规:

点评 回复

querysql1
querysql1   发表于 2019-8-16 18:40:48 已赞(0) 赞(0)

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
  • x
  • 常规:

点评 回复

123
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录