华为S5720死活上不了网

新人帖[复制链接]
发表于 : 2018-10-6 11:54:07 最新回复:2018-10-17 17:05:38
1106 14
loh    

  求助帖: (已解决)

交换机型号是S5720,跟路由器互联后,接在交换机上的电脑死活上不了网,这是结构图

 

 

 

路由器IP地址为为20.20.20.1

 

在交换机上建2vlan,分别为vlan 20vlan30

vlan20绑定在交换机的第2个口,模式是access,连接路由器的lan

vlan30绑定在交换机的第3个口,模式是access,连接到台式机电脑

 

交换机配置如下

 

!Software Version V200R010C00SPC600

sysname HUAWEI

vlan batch 20 30

authentication-profile name default_authen_profile

authentication-profile name dot1x_authen_profile

authentication-profile name mac_authen_profile

authentication-profile name portal_authen_profile

authentication-profile name dot1xmac_authen_profile

authentication-profile name multi_authen_profile

diffserv domain default

radius-server template default

free-rule-template name default_free_rule

portal-access-profile name portal_access_profile

drop-profile default

aaa

 authentication-scheme default            

 authentication-scheme radius

  authentication-mode radius

 authorization-scheme default

 accounting-scheme default

 local-aaa-user password policy administrator

  password expire 0

 domain default

  authentication-scheme radius

  radius-server default

 domain default_admin

  authentication-scheme default

 local-user admin password irreversible-cipher $1a$lYLc6Z,bb!$Y[~832fy_-(@$>BMd=}OBzeZL9o~5>iH4YQa&K+D$

 local-user admin privilege level 15

 local-user admin service-type terminal http

interface Vlanif1

interface Vlanif20

 ip address 20.20.20.2 255.255.255.0

interface Vlanif30

 ip address 30.30.30.2 255.255.255.0

interface MEth0/0/1                       

interface GigabitEthernet0/0/1

interface GigabitEthernet0/0/2

 port link-type access

 port default vlan 20

interface GigabitEthernet0/0/3

 port link-type access

 port default vlan 30

interface GigabitEthernet0/0/4

interface GigabitEthernet0/0/5

interface GigabitEthernet0/0/6

interface GigabitEthernet0/0/7

interface GigabitEthernet0/0/8

interface GigabitEthernet0/0/9

interface GigabitEthernet0/0/10           

interface GigabitEthernet0/0/11

interface GigabitEthernet0/0/12

interface GigabitEthernet0/0/13

interface GigabitEthernet0/0/14

interface GigabitEthernet0/0/15

interface GigabitEthernet0/0/16

interface GigabitEthernet0/0/17

interface GigabitEthernet0/0/18

interface GigabitEthernet0/0/19

interface GigabitEthernet0/0/20

interface GigabitEthernet0/0/21

interface GigabitEthernet0/0/22           

interface GigabitEthernet0/0/23

interface GigabitEthernet0/0/24

interface GigabitEthernet0/0/25

interface GigabitEthernet0/0/26

interface GigabitEthernet0/0/27

interface GigabitEthernet0/0/28

interface XGigabitEthernet0/0/1

interface XGigabitEthernet0/0/2

interface XGigabitEthernet0/0/3

interface XGigabitEthernet0/0/4

interface NULL0

ip route-static 0.0.0.0 0.0.0.0 20.20.20.1

user-interface con 0

 authentication-mode aaa

user-interface vty 0 4

user-interface vty 16 20

dot1x-access-profile name dot1x_access_profile

mac-access-profile name mac_access_profile

return

vlan信息如下

The total number of VLANs is: 3

--------------------------------------------------------------------------------

U: Up;         D: Down;         TG: Tagged;         UT: Untagged;

MP: Vlan-mapping;               ST: Vlan-stacking;

#: ProtocolTransparent-vlan;    *: Management-vlan;

--------------------------------------------------------------------------------

 

VID  Type    Ports                                                          

--------------------------------------------------------------------------------

1    common  UT:GE0/0/1(D)      GE0/0/4(D)      GE0/0/5(D)      GE0/0/6(D)      

                GE0/0/7(D)      GE0/0/8(D)      GE0/0/9(D)      GE0/0/10(D)     

                GE0/0/11(D)     GE0/0/12(D)     GE0/0/13(D)     GE0/0/14(D)     

                GE0/0/15(D)     GE0/0/16(D)     GE0/0/17(D)     GE0/0/18(D)     

                GE0/0/19(D)     GE0/0/20(D)     GE0/0/21(D)     GE0/0/22(D)     

                GE0/0/23(D)     GE0/0/24(D)     GE0/0/25(D)     GE0/0/26(D)     

                GE0/0/27(D)     GE0/0/28(D)     XGE0/0/1(D)     XGE0/0/2(D)     

                XGE0/0/3(D)     XGE0/0/4(D)                                     

20   common  UT:GE0/0/2(U)                                                      

30   common  UT:GE0/0/3(U)                                                      

 

VID  Status  Property      MAC-LRN Statistics Description      

--------------------------------------------------------------------------------

1    enable  default       enable  disable    VLAN 0001                         

20   enable  default       enable  disable    VLAN 0020                         

30   enable  default       enable  disable    VLAN 0030    

电脑配置如下

 

 

交换机能ping能公网地址,比如114.114.114.114,也能ping通路由器。

 

电脑能ping通交换机的IP地址30.30.30.220.20.20.2,但ping不通路由器的IP地址,更ping不通公网的IP地址,死活上不了网。

 

把电脑直接接到路由器上,设好IP,网关指向路由器20.20.20.1,电脑能上网,说明路由器是没问题的,问题100%出在交换机上。


本人菜鸟一只,刚刚接触到华为的交换机,这个问题搞得我都都大了,问题出在哪里?怎么解决?

 

附件: 您需要 登录 才可以下载或查看,没有帐号?注册
  • x
  • 常规:

点评 回复

跳转到指定楼层
dennis_chen     发表于 2018-10-17 17:05:38 已赞(1) 赞(1)

没有回城路由啊,路由器上配路由到PC就好。
路由器上:
ip route-static 30.30.30.0 24 20.20.20.2
  • x
  • 常规:

点评 回复

Rybin  新锐   发表于 2018-10-12 20:35:44 已赞(0) 赞(0)

vlan 20 的网段应该是可以上到公网的..但vlan30的是上不了.

路由器上要写静态路由让它找到30网段的.

路由器上:
ip route-static 30.30.30.0 24 20.20.20.2


  • x
  • 常规:

点评 回复

loh     发表于 2018-10-6 11:58:28 已赞(0) 赞(0)

有谁会解决吗?在线等,本人的联系方式 18775812967,或QQ443200223
  • x
  • 常规:

点评 回复

iamsamzhang  新锐   发表于 2018-10-6 13:24:39 已赞(2) 赞(2)

路由器上加一条指向VLAN 30的路由。现在你的数据包可以路由出去,但回来的数据包到了路由器上不知道怎么走。
  • x
  • 常规:

点评 回复

loh     发表于 2018-10-6 13:56:05 已赞(0) 赞(0)

iamsamzhang 发表于 2018-10-6 13:24 路由器上加一条指向VLAN 30的路由。现在你的数据包可以路由出去,但回来的数据包到了路由器上不知道怎么走 ...
OK,我马上去试试看
  • x
  • 常规:

点评 回复

一一一     发表于 2018-10-6 16:15:55 已赞(0) 赞(0)

你这样,交换机什么配置都不做就是通的啊
  • x
  • 常规:

点评 回复

哇哈哈嘿嘿  新锐   发表于 2018-10-7 08:55:29 已赞(0) 赞(0)

交换机连接路由器的是ACCESS口?为什么要这样配啊。。。
交换机默认就可以的,你配了acc口,还有不同的VLAN,能通才怪了
  • x
  • 常规:

点评 回复

mike999999     发表于 2018-10-8 00:06:46 已赞(0) 赞(0)

路由器的内网口检查一下是不是 20.20.20.1,还有路由器到VLAN30的路由
  • x
  • 常规:

点评 回复

抱着学习的心态     发表于 2018-10-12 17:38:24 已赞(0) 赞(0)

20 和 30 都没通 。。。
  • x
  • 常规:

点评 回复

zhangzhaoxin  新锐   发表于 2018-10-15 08:31:00 已赞(0) 赞(0)

路由器没写向下的路由吧
  • x
  • 常规:

点评 回复

12
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
快速回复 返回顶部