【交换机在江湖】实战案例三十五 交换机在校园网中的应用

[复制链接]
发表于 : 2015-11-2 16:42:47 最新回复:2019-09-08 20:40:29
11577 20
交换机在江湖
交换机在江湖 官方号

交换机在校园网中的应用

1.1 组网需求

1-1所示,校园网内部采用典型的核心-汇聚-接入的树形网络结构。接入交换机(图中的ACC)下连宿舍楼、行政楼、科技楼、教学楼和图书馆的LAN交换机、主机或者无线AP,再通过汇聚交换机(图中的AGG)接入到核心交换机(图中的Core)。核心交换机与数据中心机房、AC相连,并且上连双出口,一个出口是学校向ISP、教育网租赁的宽带业务出口,另一个出口是普通的ISP宽带业务出口。

校园网络接入&汇聚&核心组网图

【交换机在江湖】实战案例三十五 交换机在校园网中的应用-1340177-1

学校现对接入&汇聚&核心组网具体需求如下:

1.         简化网络结构,减少网络配置。

2.         网络易于维护管理,可扩展性强。

3.         能够传输视频数据,进行视频教学、电视电话会议等。

 

1.2 业务规划

1.         对于有线业务,接入&汇聚&核心采用扁平化的大二层网络,有线用户网关配置在与核心设备相连的上游设备,降低网络的运维难度,简化网络结构。

对于无线业务,核心层设备作为无线接入用户的网关和DHCP服务器,旁挂的AC仅用于管理AP

 

2.         核心&汇聚&核心通过层次化、模块化,实现网络易管理、可扩展。

a 核心设备连接所有的汇聚交换机,转发各个楼栋的流量。

b 汇聚设备作为各个楼栋数据流量的汇聚点,转发本区域用户到其他区域用户的横向流量,同时发送本区域用户流量到核心层。

c)接入设备作为楼层有线业务、无线业务的接入点。

对于有线用户接入多的宿舍楼、行政楼和科技楼,在接入层交换机上配置QinQ功能,内层VLAN表示宿舍、办公室等最小的独立单元,外层VLAN表示楼栋;有线用户接入少的图书馆和教学楼,每个楼栋分配一个VLAN

对于无线业务,每个楼栋分配一个无线业务VLAN

 

3.         在接入&汇聚&核心交换机上配置组播功能,用于视频教学、电视电话会议等,传输数据中心机房发往接入层的视频数据。

 

1.3 产品规划

根据楼栋的整体分布情况,对各个楼栋的产品规划如下:

-          宿舍楼:总共4栋,每栋有5层楼,每层楼有20个宿舍,每个宿舍1Lan Switch,每4个宿舍共用1AP,每1层楼一个普通接入交换机。

 

-          行政楼:总共1栋,每栋有5层楼,每层楼有10个办公室,每个办公室1Lan Switch,每4个办公室共用1AP,每2层楼共用一个普通接入交换机。

 

-          科技楼:总共1栋,每栋有5层楼,每层楼有10个科研室,每个科研室1Lan Switch,每4个科研室共用1AP,每2层楼共用一个普通接入交换机。

 

-          教学楼:总共4栋,每栋有5层楼,每层楼有20个教室,每个教室2AP,每1层楼一个普通接入交换机。

 

-          图书馆:总共1栋,每栋有5层楼,只有一楼的3个区域有无线需求,在这三个位置各布置1AP

 

各个楼栋的具体设备部署及接口连线如下图所示。

【交换机在江湖】实战案例三十五 交换机在校园网中的应用-1340177-2

【交换机在江湖】实战案例三十五 交换机在校园网中的应用-1340177-3【交换机在江湖】实战案例三十五 交换机在校园网中的应用-1340177-4

 

1.4 数据规划

1.4.1 有线业务的VLAN规划

【交换机在江湖】实战案例三十五 交换机在校园网中的应用-1340177-5

 

1.4.2 无线业务的VLAN规划

【交换机在江湖】实战案例三十五 交换机在校园网中的应用-1340177-6

 

1.4.3 无线业务的IP地址池规划

【交换机在江湖】实战案例三十五 交换机在校园网中的应用-1340177-7

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
交换机在江湖
交换机在江湖 官方号 发表于 2015-11-2 16:43:42 已赞(1) 赞(1)

1.5 配置步骤

说明:本案例仅提供了交换机与下游用户通信的配置步骤。

                                步骤 1     配置VLAN业务。

在各交换机上创建VLAN,配置接口加入VLAN,有线用户多的楼栋配置VLAN QinQ功能。

1. 配置宿舍楼的接入交换机。以D-ACC10-1D-ACC11为例,宿舍楼其他接入交换机

与其配置过程相似。

# 有线侧

<D-ACC11> system-view

[D-ACC11] vlan batch 2 to 21 1111

[D-ACC11] interface gigabitethernet 0/0/1

[D-ACC11-GigabitEthernet0/0/1] port link-type hybrid

[D-ACC11-GigabitEthernet0/0/1] port hybrid untagged vlan 1111

[D-ACC11-GigabitEthernet0/0/1] qinq vlan-translation enable

[D-ACC11-GigabitEthernet0/0/1] port vlan-stacking vlan 2 stack-vlan 1111

[D-ACC11] interface gigabitethernet 0/0/2

[D-ACC11-GigabitEthernet0/0/2] port link-type hybrid

[D-ACC11-GigabitEthernet0/0/2] port hybrid untagged vlan 1111

[D-ACC11-GigabitEthernet0/0/2] qinq vlan-translation enable

[D-ACC11-GigabitEthernet0/0/2] port vlan-stacking vlan 3 stack-vlan 1111

[D-ACC11] interface gigabitethernet 0/0/3

[D-ACC11-GigabitEthernet0/0/3] port link-type hybrid

[D-ACC11-GigabitEthernet0/0/3] port hybrid untagged vlan 1111

[D-ACC11-GigabitEthernet0/0/3] qinq vlan-translation enable

[D-ACC11-GigabitEthernet0/0/3] port vlan-stacking vlan 4 stack-vlan 1111

……

……

[D-ACC11] interface gigabitethernet 0/0/20

[D-ACC11-GigabitEthernet0/0/20] port link-type hybrid

[D-ACC11-GigabitEthernet0/0/20] port hybrid untagged vlan 1111

[D-ACC11-GigabitEthernet0/0/20] qinq vlan-translation enable

[D-ACC11-GigabitEthernet0/0/20] port vlan-stacking vlan 21 stack-vlan 1111

[D-ACC11] interface gigabitethernet 0/0/24

[D-ACC11-GigabitEthernet0/0/24] port link-type trunk

[D-ACC11-GigabitEthernet0/0/24] port trunk allow-pass vlan 1111

[D-ACC11-GigabitEthernet0/0/24] quit

# 无线侧

<D-ACC10-1> system-view

[D-ACC10-1] vlan batch 511

[D-ACC10-1] port-group dormitory1-acc-wlan

[D-ACC10-1-port-group-dormitory1-wlan] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/15

[D-ACC10-1-port-group-dormitory1-acc-wlan] port link-type trunk

[D-ACC10-1-port-group-dormitory1-acc-wlan] port trunk allow-pass vlan 511

[D-ACC10-1-port-group-dormitory1-acc-wlan] quit

[D-ACC10-1] interface gigabitethernet 0/0/24

[D-ACC10-1-GigabitEthernet0/0/24] port link-type trunk

[D-ACC10-1-GigabitEthernet0/0/24] port trunk allow-pass vlan 511

[D-ACC10-1-GigabitEthernet0/0/24] quit

2. 配置宿舍楼的汇聚交换机。

# 有线侧

<D-AGG> system-view

[D-AGG] vlan batch 1111 to 1114

[D-AGG] port-group dormitory1-agg-cable

[D-AGG-port-group-dormitory1-agg-cable] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/5

[D-AGG-port-group-dormitory1-agg-cable] port link-type trunk

[D-AGG-port-group-dormitory1-agg-cable] port trunk allow-pass vlan 1111

[D-AGG-port-group-dormitory1-agg-cable] quit

[D-AGG] port-group dormitory2-agg-cable

[D-AGG-port-group-dormitory2-agg-cable] group member gigabitethernet 0/0/8 to gigabitethernet 0/0/12

[D-AGG-port-group-dormitory2-agg-cable] port link-type trunk

[D-AGG-port-group-dormitory2-agg-cable] port trunk allow-pass vlan 1112

[D-AGG-port-group-dormitory2-agg-cable] quit

[D-AGG] port-group dormitory3-agg-cable

[D-AGG-port-group-dormitory3-agg-cable] group member gigabitethernet 0/0/15 to gigabitethernet 0/0/19

[D-AGG-port-group-dormitory3-agg-cable] port link-type trunk

[D-AGG-port-group-dormitory3-agg-cable] port trunk allow-pass vlan 1113

[D-AGG-port-group-dormitory3-agg-cable] quit

[D-AGG] port-group dormitory4-agg-cable

[D-AGG-port-group-dormitory4-agg-cable] group member gigabitethernet 0/0/22 to gigabitethernet 0/0/26

[D-AGG-port-group-dormitory4-agg-cable] port link-type trunk

[D-AGG-port-group-dormitory4-agg-cable] port trunk allow-pass vlan 1114

[D-AGG-port-group-dormitory4-agg-cable] quit

[D-AGG] interface xgigabitethernet 0/0/1

[D-AGG-XGigabitEthernet0/0/1] port link-type trunk

[D-AGG-XGigabitEthernet0/0/1] port trunk allow-pass vlan 1111 to 1114

[D-AGG-XGigabitEthernet0/0/1] quit

# 无线侧

[D-AGG] vlan batch 511 to 514

[D-AGG] port-group dormitory1-agg-wlan

[D-AGG-port-group-dormitory1-agg-wlan] group member gigabitethernet 0/0/6 to gigabitethernet 0/0/7

[D-AGG-port-group-dormitory1-agg-wlan] port link-type trunk

[D-AGG-port-group-dormitory1-agg-wlan] port trunk allow-pass vlan 511

[D-AGG-port-group-dormitory1-agg-wlan] quit

[D-AGG] port-group dormitory2-agg-wlan

[D-AGG-port-group-dormitory2-agg-wlan] group member gigabitethernet 0/0/13 to gigabitethernet 0/0/14

[D-AGG-port-group-dormitory2-agg-wlan] port link-type trunk

[D-AGG-port-group-dormitory2-agg-wlan] port trunk allow-pass vlan 512

[D-AGG-port-group-dormitory2-agg-wlan] quit

[D-AGG] port-group dormitory3-agg-wlan

[D-AGG-port-group-dormitory3-agg-wlan] group member gigabitethernet 0/0/20 to gigabitethernet 0/0/21

[D-AGG-port-group-dormitory3-agg-wlan] port link-type trunk

[D-AGG-port-group-dormitory3-agg-wlan] port trunk allow-pass vlan 513

[D-AGG-port-group-dormitory3-agg-wlan] quit

[D-AGG] port-group dormitory4-agg-wlan

[D-AGG-port-group-dormitory4-agg-wlan] group member gigabitethernet 0/0/27 to gigabitethernet 0/0/28

[D-AGG-port-group-dormitory4-agg-wlan] port link-type trunk

[D-AGG-port-group-dormitory4-agg-wlan] port trunk allow-pass vlan 514

[D-AGG-port-group-dormitory4-agg-wlan] quit

[D-AGG] interface xgigabitethernet 0/0/1

[D-AGG-XGigabitEthernet0/0/1] port link-type trunk

[D-AGG-XGigabitEthernet0/0/1] port trunk allow-pass vlan 511 to 514

[D-AGG-XGigabitEthernet0/0/1] quit

3. 配置行政楼的接入交换机。以E-ACC10E-ACC11为例,行政楼其他接入交换机

与其配置过程相似。

# 有线侧

<E-ACC11> system-view

[E-ACC11] vlan batch 2 to 21 1211

[E-ACC11] interface gigabitethernet 0/0/1

[E-ACC11-GigabitEthernet0/0/1] port link-type hybrid

[E-ACC11-GigabitEthernet0/0/1] port hybrid untagged vlan 1211

[E-ACC11-GigabitEthernet0/0/1] qinq vlan-translation enable

[E-ACC11-GigabitEthernet0/0/1] port vlan-stacking vlan 2 stack-vlan 1211

[E-ACC11] interface gigabitethernet 0/0/2

[E-ACC11-GigabitEthernet0/0/2] port link-type hybrid

[E-ACC11-GigabitEthernet0/0/2] port hybrid untagged vlan 1211

[E-ACC11-GigabitEthernet0/0/2] qinq vlan-translation enable

[E-ACC11-GigabitEthernet0/0/2] port vlan-stacking vlan 3 stack-vlan 1211

[E-ACC11] interface gigabitethernet 0/0/3

[E-ACC11-GigabitEthernet0/0/3] port link-type hybrid

[E-ACC11-GigabitEthernet0/0/3] port hybrid untagged vlan 1211

[E-ACC11-GigabitEthernet0/0/3] qinq vlan-translation enable

[E-ACC11-GigabitEthernet0/0/3] port vlan-stacking vlan 4 stack-vlan 1211

……

……

[E-ACC11] interface gigabitethernet 0/0/20

[E-ACC11-GigabitEthernet0/0/20] port link-type hybrid

[E-ACC11-GigabitEthernet0/0/20] port hybrid untagged vlan 1211

[E-ACC11-GigabitEthernet0/0/20] qinq vlan-translation enable

[E-ACC11-GigabitEthernet0/0/20] port vlan-stacking vlan 21 stack-vlan 1211

[E-ACC11] interface gigabitethernet 0/0/24

[E-ACC11-GigabitEthernet0/0/24] port link-type trunk

[E-ACC11-GigabitEthernet0/0/24] port trunk allow-pass vlan 1211

[E-ACC11-GigabitEthernet0/0/24] quit

# 无线侧

<E-ACC10> system-view

[E-ACC10] vlan batch 521

[E-ACC10] port-group executive-building-acc-wlan

[E-ACC10-port-group-executive-building-acc-wlan] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/15

[E-ACC10-port-group-executive-building-acc-wlan] port link-type trunk

[E-ACC10-port-group-executive-building-acc-wlan] port trunk allow-pass vlan 521

[E-ACC10-port-group-executive-building-acc-wlan] quit

[E-ACC10] interface gigabitethernet 0/0/24

[E-ACC10-GigabitEthernet0/0/24] port link-type trunk

[E-ACC10-GigabitEthernet0/0/24] port trunk allow-pass vlan 521

[E-ACC10-GigabitEthernet0/0/24] quit

4. 配置科技楼的接入交换机。以S-ACC10S-ACC11为例,科技楼其他接入交换机

与其配置过程相似。

# 有线侧

<S-ACC11> system-view

[S-ACC11] vlan batch 2 to 21 1311

[S-ACC11] interface gigabitethernet 0/0/1

[S-ACC11-GigabitEthernet0/0/1] port link-type hybrid

[S-ACC11-GigabitEthernet0/0/1] port hybrid untagged vlan 1311

[S-ACC11-GigabitEthernet0/0/1] qinq vlan-translation enable

[S-ACC11-GigabitEthernet0/0/1] port vlan-stacking vlan 2 stack-vlan 1311

[S-ACC11] interface gigabitethernet 0/0/2

[S-ACC11-GigabitEthernet0/0/2] port link-type hybrid

[S-ACC11-GigabitEthernet0/0/2] port hybrid untagged vlan 1311

[S-ACC11-GigabitEthernet0/0/2] qinq vlan-translation enable

[S-ACC11-GigabitEthernet0/0/2] port vlan-stacking vlan 3 stack-vlan 1311

[S-ACC11] interface gigabitethernet 0/0/3

[S-ACC11-GigabitEthernet0/0/3] port link-type hybrid

[S-ACC11-GigabitEthernet0/0/3] port hybrid untagged vlan 1311

[S-ACC11-GigabitEthernet0/0/3] qinq vlan-translation enable

[S-ACC11-GigabitEthernet0/0/3] port vlan-stacking vlan 4 stack-vlan 1311

……

……

[S-ACC11] interface gigabitethernet 0/0/20

[S-ACC11-GigabitEthernet0/0/20] port link-type hybrid

[S-ACC11-GigabitEthernet0/0/20] port hybrid untagged vlan 1311

[S-ACC11-GigabitEthernet0/0/20] qinq vlan-translation enable

[S-ACC11-GigabitEthernet0/0/20] port vlan-stacking vlan 21 stack-vlan 1311

[S-ACC11] interface gigabitethernet 0/0/24

[S-ACC11-GigabitEthernet0/0/24] port link-type trunk

[S-ACC11-GigabitEthernet0/0/24] port trunk allow-pass vlan 1311

[S-ACC11-GigabitEthernet0/0/24] quit

# 无线侧

<S-ACC10> system-view

[S-ACC10] vlan batch 531

[S-ACC10] port-group sience-building-acc-wlan

[S-ACC10-port-group-sience-building-acc-wlan] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/15

[S-ACC10-port-group-sience-building-acc-wlan] port link-type trunk

[S-ACC10-port-group-sience-building-acc-wlan] port trunk allow-pass vlan 531

[S-ACC10-port-group-sience-building-acc-wlan] quit

[S-ACC10] interface gigabitethernet 0/0/24

[S-ACC10-GigabitEthernet0/0/24] port link-type trunk

[S-ACC10-GigabitEthernet0/0/24] port trunk allow-pass vlan 531

[S-ACC10-GigabitEthernet0/0/24] quit

5. 配置图书馆的接入交换机。

# 有线侧

<L-ACC11> system-view

[L-ACC11] vlan batch 1411

[L-ACC11] port-group library-acc-cable

[L-ACC11-port-group-library-acc-cable] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/5

[L-ACC11-port-group-library-acc-cable] port link-type access

[L-ACC11-port-group-library-acc-cable] port trunk default vlan 1411

[L-ACC11-port-group-library-acc-cable] quit

[L-ACC11] interface gigabitethernet 0/0/24

[L-ACC11-GigabitEthernet0/0/24] port link-type trunk

[L-ACC11-GigabitEthernet0/0/24] port trunk allow-pass vlan 1411

[L-ACC11-GigabitEthernet0/0/24] quit

# 无线侧

[L-ACC11] vlan batch 541

[L-ACC11] port-group library-acc-wlan

[L-ACC11-port-group-library-acc-wlan] group member gigabitethernet 0/0/6 to gigabitethernet 0/0/8

[L-ACC11-port-group-library-acc-wlan] port link-type trunk

[L-ACC11-port-group-library-acc-wlan] port trunk allow-pass vlan 541

[L-ACC11-port-group-library-acc-wlan] quit

[L-ACC11] interface gigabitethernet 0/0/24

[L-ACC11-GigabitEthernet0/0/24] port link-type trunk

[L-ACC11-GigabitEthernet0/0/24] port trunk allow-pass vlan 541

[L-ACC11-GigabitEthernet0/0/24] quit

6. 配置行政楼&科技楼&图书馆的汇聚交换机。

# 有线侧

<E&S&L-AGG> system-view

[E&S&L-AGG] vlan batch 1211 1311 1411

[E&S&L-AGG] port-group executive-building-agg-cable

[E&S&L-AGG-port-group-executive-building-agg-cable] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/3

[E&S&L-AGG-port-group-executive-building-agg-cable] port link-type trunk

[E&S&L-AGG-port-group-executive-building-agg-cable] port trunk allow-pass vlan 1211

[E&S&L-AGG-port-group-executive-building-agg-cable] quit

[E&S&L-AGG] port-group sience-building-agg-cable

[E&S&L-AGG-port-group-sience-building-agg-cable] group member gigabitethernet 0/0/5 to gigabitethernet 0/0/7

[E&S&L-AGG-port-group-sience-building-agg-cable] port link-type trunk

[E&S&L-AGG-port-group-sience-building-agg-cable] port trunk allow-pass vlan 1311

[E&S&L-AGG-port-group-sience-building-agg-cable] quit

[E&S&L-AGG] interface gigabitethernet 0/0/9

[E&S&L-AGG-GigabitEthernet0/0/9] description library's downlink interface of cable and wlan

[E&S&L-AGG-GigabitEthernet0/0/9] port link-type trunk

[E&S&L-AGG-GigabitEthernet0/0/9] port trunk allow-pass vlan 1411

[E&S&L-AGG-GigabitEthernet0/0/9] quit

[E&S&L-AGG] interface xgigabitethernet 0/0/1

[E&S&L-AGG-XGigabitEthernet0/0/1] port link-type trunk

[E&S&L-AGG-XGigabitEthernet0/0/1] port trunk allow-pass vlan 1211 1311 1411

[E&S&L-AGG-XGigabitEthernet0/0/1] quit

# 无线侧

[E&S&L-AGG] interface gigabitethernet 0/0/4

[E&S&L-AGG-GigabitEthernet0/0/4] description executive building's downlink interface of wlan

[E&S&L-AGG-GigabitEthernet0/0/4] port link-type trunk

[E&S&L-AGG-GigabitEthernet0/0/4] port trunk allow-pass vlan 521

[E&S&L-AGG-GigabitEthernet0/0/4] quit

[E&S&L-AGG] interface gigabitethernet 0/0/8

[E&S&L-AGG-GigabitEthernet0/0/8] description sience building's downlink interface of wlan

[E&S&L-AGG-GigabitEthernet0/0/8] port link-type trunk

[E&S&L-AGG-GigabitEthernet0/0/8] port trunk allow-pass vlan 531

[E&S&L-AGG-GigabitEthernet0/0/8] quit

[E&S&L-AGG] interface gigabitethernet 0/0/9

[E&S&L-AGG-GigabitEthernet0/0/9] port link-type trunk

[E&S&L-AGG-GigabitEthernet0/0/9] port trunk allow-pass vlan 541

[E&S&L-AGG-GigabitEthernet0/0/9] quit

[E&S&L-AGG] interface xgigabitethernet 0/0/1

[E&S&L-AGG-XGigabitEthernet0/0/1] port link-type trunk

[E&S&L-AGG-XGigabitEthernet0/0/1] port trunk allow-pass vlan 521 531 541

[E&S&L-AGG-XGigabitEthernet0/0/1] quit

  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2015-11-2 16:43:55 已赞(2) 赞(2)

7. 配置教学楼的接入交换机。以S-ACC10S-ACC11为例,科技楼其他接入交换机

与其配置过程相似。

# 有线侧

<T-ACC11> system-view

[T-ACC11] vlan batch 1511

[T-ACC11] port-group teach-building1-acc-cable

[T-ACC11-port-group-teach-building1-acc-cable] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/20

[T-ACC11-port-group-teach-building1-acc-cable] port link-type access

[T-ACC11-port-group-teach-building1-acc-cable] port trunk default vlan 1511

[T-ACC11-port-group-teach-building1-acc-cable] quit

[T-ACC11] interface gigabitethernet 0/0/24

[T-ACC11-GigabitEthernet0/0/24] port link-type trunk

[T-ACC11-GigabitEthernet0/0/24] port trunk allow-pass vlan 1511

[T-ACC11-GigabitEthernet0/0/24] quit

# 无线侧

<T-ACC10-1> system-view

[T-ACC10-1] vlan batch 551

[T-ACC10-1] port-group teach-building1-acc-wlan

[T-ACC10-1-port-group-teach-building1-acc-wlan] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/40

[T-ACC10-1-port-group-teach-building1-acc-wlan] port link-type trunk

[T-ACC10-1-port-group-teach-building1-acc-wlan] port trunk allow-pass vlan 551

[T-ACC10-1-port-group-teach-building1-acc-wlan] quit

[T-ACC10-1] interface gigabitethernet 0/0/42

[T-ACC10-1-GigabitEthernet0/0/42] port link-type trunk

[T-ACC10-1-GigabitEthernet0/0/42] port trunk allow-pass vlan 551

[T-ACC10-1-GigabitEthernet0/0/42] quit

8. 配置教学楼的汇聚交换机。

# 有线侧

<T-AGG> system-view

[T-AGG] vlan batch 1511 to 1514

[T-AGG] port-group teach-building1-agg-cable

[T-AGG-port-group-teach-building1-agg-cable] group member gigabitethernet 0/0/1 to gigabitethernet 0/0/5

[T-AGG-port-group-teach-building1-agg-cable] port link-type trunk

[T-AGG-port-group-teach-building1-agg-cable] port trunk allow-pass vlan 1511

[T-AGG-port-group-teach-building1-agg-cable] quit

[T-AGG] port-group teach-building2-agg-cable

[T-AGG-port-group-teach-building2-agg-cable] group member gigabitethernet 0/0/11 to gigabitethernet 0/0/15

[T-AGG-port-group-teach-building2-agg-cable] port link-type trunk

[T-AGG-port-group-teach-building2-agg-cable] port trunk allow-pass vlan 1512

[T-AGG-port-group-teach-building2-agg-cable] quit

[T-AGG] port-group teach-building3-agg-cable

[T-AGG-port-group-teach-building3-agg-cable] group member gigabitethernet 0/0/21 to gigabitethernet 0/0/25

[T-AGG-port-group-teach-building3-agg-cable] port link-type trunk

[T-AGG-port-group-teach-building3-agg-cable] port trunk allow-pass vlan 1513

[T-AGG-port-group-teach-building3-agg-cable] quit

[T-AGG] port-group teach-building4-agg-cable

[T-AGG-port-group-teach-building1-agg-cable] group member gigabitethernet 0/0/31 to gigabitethernet 0/0/35

[T-AGG-port-group-teach-building4-agg-cable] port link-type trunk

[T-AGG-port-group-teach-building4-agg-cable] port trunk allow-pass vlan 1514

[T-AGG-port-group-teach-building4-agg-cable] quit

[T-AGG] interface xgigabitethernet 0/0/1

[T-AGG-XGigabitEthernet0/0/1] port link-type trunk

[T-AGG-XGigabitEthernet0/0/1] port trunk allow-pass vlan 1511 to 1514

[T-AGG-XGigabitEthernet0/0/1] quit

# 无线侧

[T-AGG] vlan batch 551 to 554

[T-AGG] port-group teach-building1-agg-wlan

[T-AGG-port-group-teach-building1-agg-wlan] group member gigabitethernet 0/0/6 to gigabitethernet 0/0/10

[T-AGG-port-group-teach-building1-agg-wlan] port link-type trunk

[T-AGG-port-group-teach-building1-agg-wlan] port trunk allow-pass vlan 551

[T-AGG-port-group-teach-building1-agg-wlan] quit

[T-AGG] port-group teach-building2-agg-wlan

[T-AGG-port-group-teach-building2-agg-wlan] group member gigabitethernet 0/0/16 to gigabitethernet 0/0/20

[T-AGG-port-group-teach-building2-agg-wlan] port link-type trunk

[T-AGG-port-group-teach-building2-agg-wlan] port trunk allow-pass vlan 552

[T-AGG-port-group-teach-building2-agg-wlan] quit

[T-AGG] port-group teach-building3-agg-wlan

[T-AGG-port-group-teach-building3-agg-wlan] group member gigabitethernet 0/0/26 to gigabitethernet 0/0/30

[T-AGG-port-group-teach-building3-agg-wlan] port link-type trunk

[T-AGG-port-group-teach-building3-agg-wlan] port trunk allow-pass vlan 553

[T-AGG-port-group-teach-building3-agg-wlan] quit

[T-AGG] port-group teach-building4-agg-wlan

[T-AGG-port-group-teach-building4-agg-wlan] group member gigabitethernet 0/0/36 to gigabitethernet 0/0/40

[T-AGG-port-group-teach-building4-agg-wlan] port link-type trunk

[T-AGG-port-group-teach-building4-agg-wlan] port trunk allow-pass vlan 554

[T-AGG-port-group-teach-building4-agg-wlan] quit

[T-AGG] interface xgigabitethernet 0/0/1

[T-AGG-XGigabitEthernet0/0/1] port link-type trunk

[T-AGG-XGigabitEthernet0/0/1] port trunk allow-pass vlan 551 to 554

[T-AGG-XGigabitEthernet0/0/1] quit

9. 配置核心交换机。

<Core> system-view

[Core] vlan 1111

[Core-vlan1111] description dormitory1’s cable

[Core-vlan1111] quit

[Core] vlan 1112

[Core-vlan1112] description dormitory2’s cable

[Core-vlan1112] quit

[Core] vlan 1113

[Core-vlan1113] description dormitory3’s cable

[Core-vlan1113] quit

[Core] vlan 1114

[Core-vlan1114] description dormitory4’s cable

[Core-vlan1114] quit

[Core] vlan 1211

[Core-vlan1211] description executive building’s cable

[Core-vlan1211] quit

[Core] vlan 1311

[Core-vlan1311] description sience building’s cable

[Core-vlan1311] quit

[Core] vlan 1411

[Core-vlan1411] description library’s cable

[Core-vlan1411] quit

[Core] vlan 1511

[Core-vlan1511] description teach building1’s cable

[Core-vlan1511] quit

[Core] vlan 1512

[Core-vlan1512] description teach building2’s cable

[Core-vlan1512] quit

[Core] vlan 1513

[Core-vlan1513] description teach building3’s cable

[Core-vlan1513] quit

[Core] vlan 1514

[Core-vlan1514] description teach building4’s cable

[Core-vlan1514] quit

[Core] vlan 511

[Core-vlan511] description dormitory1’s wlan

[Core-vlan511] quit

[Core] vlan 512

[Core-vlan512] description dormitory2’s wlan

[Core-vlan512] quit

[Core] vlan 513

[Core-vlan513] description dormitory3’s wlan

[Core-vlan513] quit

[Core] vlan 514

[Core-vlan514] description dormitory4’s wlan

[Core-vlan514] quit

[Core] vlan 521

[Core-vlan521] description executive building’s wlan

[Core-vlan521] quit

[Core] vlan 531

[Core-vlan531] description sience building’s wlan

[Core-vlan531] quit

[Core] vlan 541

[Core-vlan541] description library’s wlan

[Core-vlan541] quit

[Core] vlan 551

[Core-vlan551] description teach building1’s wlan

[Core-vlan551] quit

[Core] vlan 552

[Core-vlan552] description teach building2’s wlan

[Core-vlan552] quit

[Core] vlan 553

[Core-vlan553] description teach building3’s wlan

[Core-vlan553] quit

[Core] vlan 554

[Core-vlan554] description teach building4’s wlan

[Core-vlan554] quit

[Core] interface xgigabitethernet 0/0/1

[Core-XGigabitEthernet0/0/1] description dormitory’s downlink interface

[Core-XGigabitEthernet0/0/1] port link-type trunk

[Core-XGigabitEthernet0/0/1] port trunk allow-pass vlan 511 to 514 1111 to 1114

[Core-XGigabitEthernet0/0/1] quit

[Core] interface xgigabitethernet 0/0/2

[Core-XGigabitEthernet0/0/2] description executive building&sience builing&library’s downlink interface

[Core-XGigabitEthernet0/0/2] port link-type trunk

[Core-XGigabitEthernet0/0/2] port trunk allow-pass vlan 521 531 541 1211 1311 1411

[Core-XGigabitEthernet0/0/2] quit

[Core] interface xgigabitethernet 0/0/3

[Core-XGigabitEthernet0/0/3] description teach building’s downlink interface

[Core-XGigabitEthernet0/0/3] port link-type trunk

[Core-XGigabitEthernet0/0/3] port trunk allow-pass vlan 551 to 554 1511 to 1514

[Core-XGigabitEthernet0/0/3] quit

                                步骤 2     配置为无线用户分配地址的DHCP业务。

[Core] dhcp enable

[Core] interface vlanif 511

[Core-Vlanif511] description dormitory1’s wlan gagteway

[Core-Vlanif511] ip address 192.168.0.255 23

[Core-Vlanif511] dhcp select interface

[Core-Vlanif511] quit

[Core] interface vlanif 512

[Core-Vlanif512] description dormitory2’s wlan gagteway

[Core-Vlanif512] ip address 192.168.2.255 23

[Core-Vlanif512] dhcp select interface

[Core-Vlanif512] quit

[Core] interface vlanif 513

[Core-Vlanif513] description dormitory3’s wlan gagteway

[Core-Vlanif513] ip address 192.168.4.255 23

[Core-Vlanif513] dhcp select interface

[Core-Vlanif513] quit

[Core] interface vlanif 514

[Core-Vlanif514] description dormitory4’s wlan gagteway

[Core-Vlanif514] ip address 192.168.6.255 23

[Core-Vlanif514] dhcp select interface

[Core-Vlanif514] quit

[Core] interface vlanif 521

[Core-Vlanif521] description executive building’s wlan gagteway

[Core-Vlanif521] ip address 192.168.8.255 23

[Core-Vlanif521] dhcp select interface

[Core-Vlanif521] quit

[Core] interface vlanif 531

[Core-Vlanif531] description sience building’s wlan gagteway

[Core-Vlanif531] ip address 192.168.10.255 23

[Core-Vlanif531] dhcp select interface

[Core-Vlanif531] quit

[Core] interface vlanif 541

[Core-Vlanif541] description library’s wlan gagteway

[Core-Vlanif541] ip address 192.168.16.255 21

[Core-Vlanif541] dhcp select interface

[Core-Vlanif541] quit

[Core] interface vlanif 551

[Core-Vlanif551] description teach building1’s wlan gagteway

[Core-Vlanif551] ip address 10.1.0.255 20

[Core-Vlanif551] dhcp select interface

[Core-Vlanif551] quit

[Core] interface vlanif 552

[Core-Vlanif552] description teach building2’s wlan gagteway

[Core-Vlanif552] ip address 10.1.16.255 20

[Core-Vlanif552] dhcp select interface

[Core-Vlanif552] quit

[Core] interface vlanif 553

[Core-Vlanif553] description teach building3’s wlan gagteway

[Core-Vlanif553] ip address 10.1.32.255 20

[Core-Vlanif553] dhcp select interface

[Core-Vlanif553] quit

[Core] interface vlanif 554

[Core-Vlanif554] description teach building4’s wlan gagteway

[Core-Vlanif554] ip address 10.1.48.255 20

[Core-Vlanif554] dhcp select interface

[Core-Vlanif554] quit

配置完成后,可执行命令display ip pool检查IP地址池的分配情况,“Used”字段显示已经分配出去的IP地址数量。

                                步骤 3     配置有线侧的组播业务。

在转发有线业务数据的业务VLAN内使能IGMP Snooping功能,通过二层组播功能,实现组播数据在二层网络的精确转发。

# T-ACC11为例,其他所有交换机与其配置相似。

[T-ACC11] igmp-snooping enable

[T-ACC11] igmp-snooping enable vlan 1111

# 配置完成后,可以通过display l2-multicast forwarding-table查看二层组播转发表。

                                步骤 4     配置无线侧的组播业务。

# 在核心交换机的网关接口使能IGMP功能,用于接收下游用户的IGMP报文,维持组成员关系。

[Core] multicast routing-enable

[Core] interface vlanif 511

[Core-Vlanif511] pim sm

[Core-Vlanif511] igmp enable

[Core-Vlanif511] quit

[Core] interface vlanif 512

[Core-Vlanif512] pim sm

[Core-Vlanif512] igmp enable

[Core-Vlanif512] quit

[Core] interface vlanif 513

[Core-Vlanif513] pim sm

[Core-Vlanif513] igmp enable

[Core-Vlanif513] quit

[Core] interface vlanif 514

[Core-Vlanif514] pim sm

[Core-Vlanif514] igmp enable

[Core-Vlanif514] quit

[Core] interface vlanif 521

[Core-Vlanif521] pim sm

[Core-Vlanif521] igmp enable

[Core-Vlanif521] quit

[Core] interface vlanif 531

[Core-Vlanif531] pim sm

[Core-Vlanif531] igmp enable

[Core-Vlanif531] quit

[Core] interface vlanif 541

[Core-Vlanif541] pim sm

[Core-Vlanif541] igmp enable

[Core-Vlanif541] quit

[Core] interface vlanif 551

[Core-Vlanif551] pim sm

[Core-Vlanif551] igmp enable

[Core-Vlanif551] quit

[Core] interface vlanif 552

[Core-Vlanif552] pim sm

[Core-Vlanif552] igmp enable

[Core-Vlanif552] quit

[Core] interface vlanif 553

[Core-Vlanif553] pim sm

[Core-Vlanif553] igmp enable

[Core-Vlanif553] quit

[Core] interface vlanif 554

[Core-Vlanif554] pim sm

[Core-Vlanif554] igmp enable

[Core-Vlanif554] quit

# 在转发无线业务数据的业务VLAN内使能IGMP Snooping功能,通过二层组播功能,实现组播数据在二层网络的精确转发。以T-ACC10-1为例,其他所有交换机与其配置相似。

[T-ACC10-1] igmp-snooping enable

[T-ACC10-1] igmp-snooping enable vlan 511

# 配置完成后,可以通过display igmp group命令用来查看通过主机发送报告报文动态加入的IGMP组播组信息;通过 display l2-multicast forwarding-table命令查看二层组播转发表。

 

 

  • x
  • 常规:

点评 回复

SherryL
SherryL  精英 发表于 2015-11-2 17:59:49 已赞(0) 赞(0)

干货啊,详细配置都有,收藏!!

  • x
  • 常规:

点评 回复

kmyd
kmyd  大师 发表于 2015-11-2 21:39:13 已赞(0) 赞(0)

很详细,感谢楼主!!

  • x
  • 常规:

点评 回复

小泽
小泽  导师VIP 发表于 2015-11-2 21:50:26 已赞(0) 赞(0)

谢谢分享是!!
  • x
  • 常规:

点评 回复

wk_dong
wk_dong   发表于 2015-11-3 17:02:18 已赞(0) 赞(0)

看看学习下

  • x
  • 常规:

点评 回复

haha4757
haha4757   发表于 2016-1-11 17:58:25 已赞(0) 赞(0)

交换机名称太长了。还有没其它的简介命名。

  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2016-1-13 11:20:48 已赞(0) 赞(0)

回复 9 楼

您好,本篇案例主要聚焦在业务规划上了,没有体现管理规划。目前管理规划,一般设备上都有管理网口,再单独分个地址段做管理地址即可。对于部分没有管理网口的设备,就用VLANIF口作管理网口。

  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2016-1-13 11:46:29 已赞(0) 赞(0)

回复 11 楼

您好,交换机的命名可参考http://forum.huawei.com/enterprise/thread-240471.html,对于本案例中的交换机命名,主要以他们对应网络层次位置来命名的,比如ACC即Access,位于接入层;AGG及Aggreate,位于汇聚层;Core,位于核心层

  • x
  • 常规:

点评 回复

123
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录