【交换机在江湖】实战案例二十二 敏捷特性HQoS配置案例

[复制链接]
发表于 : 2015-5-21 14:15:36 最新回复:2016-06-10 20:10:45
4705 3
交换机在江湖
交换机在江湖 官方号

HQoS简介

传统QoS技术可以满足语音、视频以及数据等业务的不同服务需求,可以针对不同的业务提供不同的服务。但是随着网络设备的高速发展,接入用户数量和每个用户的业务量不断增多,传统的QoS在应用中遇到了新问题:传统QoS是基于端口带宽进行调度并且用于出接口,不适用于用户接入侧,因此无区分用户,也无法同时对多个用户的多个业务进行调度。

 

为了解决上述问题,人们需要一种既能区分用户流量又能根据用户业务的优先级进行调度的技术,HQoSHierarchical Quality of Service)应运而生。HQoS通过多级队列进一步细化区分业务流量,对多个用户、多种业务等传输对象进行统一管理和分层调度。

 

HQoS原理

HQoS基于队列实现层次化调度,如下图所示。

555d7570e5972.jpg

l          第一级是流队列(Flow Queue)的调度。报文根据映射后的内部优先级进入对应的流队列,从而实现对业务的区分。每个用户都有8个流队列,分别对应8个业务优先级(BEAF1AF2AF3AF4EF CS6CS7),8个流队列可以配置PQ(优先级队列)或WFQ(加权公平队列)调度。每个流队列支持WRED(加权随机早期检)以及流量整形,保证高优先级的业务能够得到优先调度和更高的带宽。

 

l         第二级是用户队列(Subscriber Queue)的调度。用户队列主要用来区分不同的用户。这里的用户通常是指一个VLAN(虚拟局域网)、VPN(虚拟私人网络)等,用户的划分主要通过ACL进行。每个用户有一个用户队列,它由8个流队列聚合而来。用户队列可以配置流量整形,限制每个用户的总带宽。

 

l         第三级是端口队列(Interface Queue)的调度。目前设备不支持配置端口队列的调度方式,只支持配置流队列到端口队列的映射,即流队列的8个优先级队列在入8个端口队列时的入队列映射。通过建立从流队列到端口队列的映射,可以灵活的控制流队列某一服务等级队列中的业务流量进入端口队列的某一服务等级队列。

 

l         第四级是目标端口(Target Queue)的调度。目标端口即设备的物理接口,数据最终通过目标端口转发出去。在完成上面的流队列和用户队列HQoS调度以及端口队列调度后还可以为每个目标端口配置流量整形。

 

对于HQoS,目前设备支持流队列和用户队列的调度。报文先进入流队列,经过调度后,从用户队列发送出去。设备还支持从流队列到端口队列的映射功能,实现对不同用户的同一种业务的流量调度。

 

使用注意事项

56b1589807988.PNG

l  框式设备只有X1E系列单板支持配置HQoS

l  设备目前只支持出方向的HQoS功能。

l  当不同用户的各个业务流优先级相同时,无法对不同的用户进行拥塞管理配置。

 

组网需求

企业园区网中有多个用户,每个用户都有语音,视频和数据三种不同的业务,其携带的802.1p优先级分别为652。现在需要优先保证语音业务的带宽,其次是视频业务,最后是数据业务。

流队列调度(第一级调度)的需求如表1和表2所述。

1 流队列拥塞避免配置参数

56b158a75cf61.PNG

 

2 流队列拥塞管理配置参数

56b158b041111.PNG

 

由于带宽有限,除了需要区分不同业务的优先级之外还需要针对不同的用户进行流量整形,为多个用户提供不同的带宽。用户队列调度(第二级调度)的需求如表3所述。

3 用户队列流量整形配置参数

56b158bb6d1bc.PNG

 

555d75711c148.jpg

 

数据规划

组网中SwitchASwitchBSwitchCVLAN划分和接口配置如下表所示。

56b158c7a5d0e.PNG

 

配置思路

采用如下的思路配置HQoS

1.         创建VLAN,并配置各接口,使企业能够通过Switch访问网络。

2.         Switch上配置创建并配置DiffServ域,将802.1p优先级映射为PHB行为并为报文着色,并在Switch入接口上绑定DiffServ域。

3.         Switch上配置一级调度:配置流队列WRED模板和流队列模板及相关参数,以实现为不同的业务提供不同的调度优先级,丢弃参数及流量整形参数。

4.         Switch上配置ACL规则,通过VLAN区分来自不同用户的数据流量。

5.         Switch上配置二级调度:配置用户队列及流量整形参数,通过引用流队列WRED模板和流队列模板实现HQoS

 

操作步骤

步骤1:创建VLAN并配置各接口

#Switch上创建VLAN10VLAN20,将接口GE1/0/1GE1/0/2GE2/0/1的接入类型分别配置为trunk,并分别将接口GE1/0/1加入VLAN10GE1/0/2加入VLAN20GE2/0/1加入VLAN 10VLAN 20

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] vlan batch 10 20

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10

[Switch-GigabitEthernet1/0/1] quit

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 20

[Switch-GigabitEthernet1/0/2] quit

[Switch] interface gigabitethernet 2/0/1

[Switch-GigabitEthernet2/0/1] port link-type trunk

[Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 10 20

[Switch-GigabitEthernet2/0/1] quit

 

步骤2:配置优先级映射

#创建DiffServds1,将802.1p优先级652分别映射为服务等级EFAF3AF1,并分别将报文标记为绿色,***和红色。

[Switch] diffserv domain ds1

[Switch-dsdomain-ds1] 8021p-inbound 6 phb ef green  //配置DiffServ域模板,将不同业务携带的802.1p优先级映射为不同的PHB行为,保证其分别进入不同的队列

[Switch-dsdomain-ds1] 8021p-inbound 5 phb af3 yellow

[Switch-dsdomain-ds1] 8021p-inbound 2 phb af1 red

[Switch-dsdomain-ds1] quit

 

# Switch入接口GE1/0/1GE1/0/2上绑定DiffServ域。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] trust upstream ds1  //在接口上应用配置好的DiffServ域模板

[Switch-GigabitEthernet1/0/1] quit

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] trust upstream ds1  //在接口上应用配置好的DiffServ域模板

[Switch-GigabitEthernet1/0/2] quit

 

步骤3:配置一级调度

#Switch上配置流队列WRED模板wred1,并配置wred1的**报文参数。

[Switch] flow-wred-profile wred1  //配置流队列WRED模板

[Switch-flow-wred-wred1] color green low-limit 80 high-limit 100 discard-percentage 10  //配置将报文标记为绿色,当报文占队列长度达到80%时开始丢弃报文且丢弃概率为10%,当报文占队列长度达到100%时开始丢弃所有新到达报文

[Switch-flow-wred-wred1] color yellow low-limit 60 high-limit 80 discard-percentage 20  //配置将报文标记为黄色,当报文占队列长度达到60%时开始丢弃报文且丢弃概率为20%,当报文占队列长度达到80%时开始丢弃所有新到达报文

[Switch-flow-wred-wred1] color red low-limit 40 high-limit 60 discard-percentage 40  //配置将报文标记为红色,当报文占队列长度达到40%时开始丢弃报文且丢弃概率为40%,当报文占队列长度达到60%时开始丢弃所有新到达报文

[Switch-flow-wred-wred1] quit

 

#Switch上配置流队列模板flow1引用流队列WRED模板wred1,并配置各服务等级的调度参数。

[Switch] flow-queue-profile flow1  //配置流队列模板

[Switch-flow-queue-flow1] qos queue 5 pq flow-wred-profile wred1  //队列5配置为PQ调度并引用流队列WRED模板wred1

[Switch-flow-queue-flow1] qos queue 5 shaping 4000  //队列5配置整形参数,限制流量速率为4000kbit/s

[Switch-flow-queue-flow1] qos queue 3 wfq weight 20 flow-wred-profile wred1  //队列3配置为WFQ调度且调度权值为20,并引用流队列WRED模板wred1

[Switch-flow-queue-flow1] qos queue 1 wfq weight 10 flow-wred-profile wred1  //队列1配置为WFQ调度且调度权值为10,并引用流队列WRED模板wred1

[Switch-flow-queue-flow1] quit

 

步骤4:配置ACL规则区分用户

#Switch上配置ACL4001ACL4002,并分别配置匹配VLAN10VLAN20rule规则。

[Switch] acl number 4001

[Switch-acl-L2-4001] rule 1 permit vlan-id 10   //配置ACL匹配VLAN ID10的用户

[Switch-acl-L2-4001] quit

[Switch] acl number 4002

[Switch-acl-L2-4002] rule 1 permit vlan-id 20   //配置ACL匹配VLAN ID20的用户

[Switch-acl-L2-4002] quit

 

步骤5:配置二级调度

#Switch上配置基于ACL4001ACL4002的用户队列,并引用流队列模板flow1

[Switch] interface gigabitethernet 2/0/1

[Switch-GigabitEthernet2/0/1] traffic-user-queue outbound acl 4001 pir 8000 flow-queue-profile flow1  //根据ACL4001匹配用户队列配置其带宽为8000kbit/s,并引用流队列flow1

[Switch-GigabitEthernet2/0/1] traffic-user-queue outbound acl 4002 pir 5000 flow-queue-profile flow1  //根据ACL4002匹配用户队列配置其带宽为5000kbit/s,并引用流队列flow1

[Switch-GigabitEthernet2/0/1] quit

[Switch] quit

 

步骤6:验证配置结果

#查看流队列WRED模板的配置信息,包括流队列WRED模板名称以及红、黄、绿色报文的丢弃上下限和最大丢弃概率。

 56b159acad854.PNG

 

#查看流队列模板的配置信息,包括流队列模板名称以及WFQ调度的权重。

 56b159b99d622.PNG

 

#模拟VLAN 10用户的语音、视频、数据业务流量各以10000kbit/s的速率到达SwitchGE1/0/1接口。查看VLAN 10的用户队列的流量统计信息。

 56b159243d325.PNG

 

VLAN 10用户配置的峰值带宽为8000kbit/s,为语音业务流量配置的整形速率为4000kbit/s,因此视频和数据业务流量共享剩余4000kbit/s的带宽。根据以上显示结果可以看出,语音业务通过的流量(队列5通过的报文数)与视频和数据业务通过的流量(队列31通过的报文数)之比接近1:1

 

#模拟VLAN 20用户的语音、视频、数据业务流量各以7000kbit/s的速率到达SwitchGE1/0/2接口。查看VLAN 20的用户队列的流量统计信息。

 56b15943b63f1.PNG

 

VLAN 20用户配置的峰值带宽为5000kbit/s,为语音业务流量配置的整形速率为4000kbit/s,因此视频和数据业务流量共享剩余1000kbit/s的带宽。根据以上显示结果可以看出,语音业务通过的流量(队列5通过的报文数)与视频和数据业务通过的流量(队列31通过的报文数)之比接近4:1

 

配置小结

缺省情况下,流队列与端口队列是一一映射关系,即07号流队列分别映射为07号端口队列。本举例中采用的就是默认映射关系。

 

用户可以根据需要改变想要改变流队列到端口队列的映射关系,从而实现用户队列指定业务根据需要进入不同优先级的端口队列进行调度及其他QoS处理。

 

例如,配置流映射模板map1,并配置流队列1到端口队列2的映射。

<HUAWEI> system-view

[HUAWEI] flow-mapping-profile map1

[HUAWEI-flow-mapping-map1] map flow-queue 1 to port-queue 2

 

配置文件

Switch的配置文件

#

sysname Switch

#

vlan batch 10 20

#

diffserv domain ds1

 8021p-inbound 2 phb af1 red

 8021p-inbound 5 phb af3 yellow

 8021p-inbound 6 phb ef green

#

acl number 4001

 rule 1 permit vlan-id 10

acl number 4002

 rule 1 permit vlan-id 20

#

flow-wred-profile wred1

 color green low-limit 80 high-limit 100 discard-percentage 10

 color yellow low-limit 60 high-limit 80 discard-percentage 20

 color red low-limit 40 high-limit 60 discard-percentage 40

#

flow-queue-profile flow1

 qos queue 1 wfq weight 10 flow-wred-profile wred1

 qos queue 3 wfq weight 20 flow-wred-profile wred1

 qos queue 5 flow-wred-profile wred1

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

 trust upstream ds1

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 20

 trust upstream ds1

#

interface GigabitEthernet2/0/1

 port link-type trunk

 port trunk allow-pass vlan 10 20

 traffic-user-queue outbound acl 4001 pir 8000 flow-queue-profile flow1

 traffic-user-queue outbound acl 4002 pir 5000 flow-queue-profile flow1

#

return

 

猛戳我:交换机在江湖汇总贴

 

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
fcm
fcm  精英 发表于 2015-5-21 15:48:50 已赞(0) 赞(0)

学习了解一下!

  • x
  • 常规:

点评 回复

rjdhpl
rjdhpl   发表于 2016-3-28 16:19:13 已赞(0) 赞(0)

正在 学习中

  • x
  • 常规:

点评 回复

zjwshenxian
zjwshenxian  导师 发表于 2016-6-10 20:10:45 已赞(0) 赞(0)

感谢分享!


  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录