【交换机在江湖】交换机与IP话机对接典型案例(五)

digest [复制链接]
发表于 : 2014-12-16 15:08:57 最新回复:2015-01-03 18:49:11
4183 4
交换机在江湖
交换机在江湖 官方号

?

配置通过MAC VLAN方式实现IP话机接入交换机示例

简介

如果语音设备不支持LLDPDHCP协议,交换机就不能为其分配Voice VLAN。此时可以通过MAC VLAN方式实现IP话机接入,通过MAC VLAN功能识别语音报文,并提升语音报文的优先级。

配置注意事项

l?? 本举例适用于S系列交换机所有产品的所有版本。

l?? Avaya话机60秒内获取DHCP地址失败导致定时器超时后,话机就开始一直发送Tag0的报文。而交换机对Tag0的报文按照Untagged报文处理,在接口的PVID内转发认证,这样话机就无法使用Voice VLAN进行认证,最终导致IP话机认证失败,无法正常接入交换机。

可以使用下面两种方法规避:

??????????? V200R003C00及之后版本,建议使用Voice-VLAN include-untagged方式进行规避。具体配置方法,请参见“1.9 配置通过Voice-VLAN include-untagged方式实现IP话机接入交换机示例”。

??????????? 按如下步骤修改IP话机的VLAN TEST定时器:1,按*键,输入密码,进入菜单项;2,选择VLAN TEST项,修改默认值为0。注意话机重启后,定时器的设置将不生效,需要重新配置。

适用的IP话机

下面话机是已经经过测试可以正常和交换机对接的话机,后续会根据测试结果持续刷新。

l?? Cisco

cisco7962Gcisco7975Gcisco7942Gcisco9951Gcisco3905cisco7971Gcisco7960Gcisco7961Gcisco7941Gcisco7911Gcisco8961cisco7945Gcisco7821Gcisco7940GciscoSPA509GciscoSPA525GciscoSPA504Gcisco7965Gcisco7970cisco9971cisco7906Gcisco7937GciscoSPA942GciscoSPA508Gcisco8945cisco6945cisco8841ciscoSPA962cisco6941cisco8831

l?? Avaya

avaya1608-Iavaya9650avaya9611Gavaya4621avaya1616-Iavaya9630Gavaya1692avaya1120Eavaya9620avaya9621avaya9608avaya1608avaya9641avaya1230avaya1210avaya9610avaya1220avaya9640G

l?? Snom

Snom821

l?? Polycom

Polycom330PolycomCX3000

l?? Mitel

Mitel5340

l?? Nortel

Nortel1140E

组网需求

1-8所示:

l?? IP话机仅支持发送Untagged的语音报文。

l?? 为了保证通话质量,需要提升语音报文的优先级。

l?? 语音流使用VLAN 100进行通信。

l?? IP话机的IP地址和DHCP服务器的IP地址不在同一个网段。

l?? IP话机不需要认证就可以上线。

配置通过MAC VLAN方式实现IP话机接入交换机组网图

20161206113239098001.png

?

配置思路

采用如下的思路配置通过MAC VLAN方式实现IP话机接入交换机:

1.???????? 接口以Untagged方式加入VLAN,实现语音报文的转发。

2.???????? 配置MAC VLAN功能,为语音报文添加VLAN,并同时提升报文优先级。

3.???????? 配置DHCP RelayDHCP Server功能,为IP话机分配IP地址。

操作步骤

步骤一 把SwitchA的接口加入VLAN

??????????????????????????? ?# 创建VLAN100

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 100? //
语音流使用VLAN 100进行通信

??????????????????????????? # 把接口以Untagged方式加入VLAN 100

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid ??//
其中V200R005C00及之后版本,默认接口类型不是hybrid,需要手动配置
[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100? //IP
话机发送的报文不带Tag,所以接口必须要以Untagged方式加入语音VLAN 100
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] port link-type hybrid
[SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100
[SwitchA-GigabitEthernet1/0/2] quit

步骤二 配置MAC VLAN功能

[SwitchA] vlan 100
[SwitchA-vlan100] mac-vlan mac-address 001b-d4c7-1fa9 ffff-ffff-0000 priority 6? //
MAC地址对应话机的MAC地址,可以使用掩码。这里表示对于源MAC地址以为001b-d4c7开头的Untagged报文添加VLAN 100Tag,同时修改802.1p优先级为6
[SwitchA-vlan100] mac-vlan mac-address 0021-a08f-0000 ffff-ffff-0000 priority 6
[SwitchA-vlan100] quit
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] mac-vlan enable? //
接口下使能MAC VLAN的功能,表示该接口收到的Untagged报文根据VLAN视图下配置的MAC地址和VLAN的绑定进行处理
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] mac-vlan enable
[SwitchA-GigabitEthernet1/0/2] quit

步骤三 配置DHCP RelayDHCP Server功能

1.???????? 配置SwitchADHCP Relay功能

# 配置接口的DHCP Relay功能。

[SwitchA] dhcp enable? //全局使能DHCP功能,缺省未使能
[SwitchA] interface Vlanif 100? //
创建VLANIF100
[SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0? //
配置VLANIF100IP地址
[SwitchA-Vlanif100] dhcp select relay? //
使能VLANIF接口DHCP中继功能
[SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2? //
配置DHCP中继所代理的DHCP服务器地址
[SwitchA-Vlanif100] quit

# 创建VLANIF 200

[SwitchA] vlan batch 200
[SwitchA] interface Vlanif 200
[SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0? //
配置VLANIF200IP地址,用于和SwitchB交互
[SwitchA-Vlanif200] quit

# 把上行接口加入VLAN 200

[SwitchA] interface gigabitethernet 1/0/3
[SwitchA-GigabitEthernet1/0/3] port link-type hybrid
[SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200
[SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200
[SwitchA-GigabitEthernet1/0/3] quit

# 配置缺省静态路由。

[SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2? //该路由的下一跳对应SwitchB VLANIF200IP地址

2.???????? 配置SwitchBDHCP Server,为IP话机分配IP地址

# 配置地址池。

<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] ip pool ip-phone? //
创建一个地址池
[SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1? //
配置DHCP服务器的出口网关地址
[SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0? //
配置该地址池可以分配的网段地址
[SwitchB-ip-pool-ip-phone] quit

# 配置DHCP Server功能。

[SwitchB] dhcp enable? //全局使能DHCP功能,缺省未使能
[SwitchB] vlan batch 200
[SwitchB] interface Vlanif 200? //
创建VLANIF200
[SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0? //
配置VLANIFIP地址
[SwitchB-Vlanif200] dhcp select global? //
配置接口采用全局地址池方式为话机分配IP地址
[SwitchB-Vlanif200] quit

# 把下行接口加入VLAN 200

[SwitchB] interface gigabitethernet 1/0/3
[SwitchB-GigabitEthernet1/0/3] port link-type hybrid
[SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200
[SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200
[SwitchB-GigabitEthernet1/0/3] quit

# 配置回程路由。

[SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

步骤四 检查配置结果

l?? IP话机可以正常获取到正确的语音VLANIP地址。

l?? SwitchA上执行命令display mac-address vlan 100,可以看到IP话机的接入信息。

----结束

配置文件

l?? SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 100 200
#
dhcp enable
#
vlan 100
?mac-vlan mac-address 001b-d4c7-1fa9 ffff-ffff-0000 priority 6
?mac-vlan mac-address 0021-a08f-0000 ffff-ffff-0000 priority 6
#
interface Vlanif100
?ip address 10.20.20.1 255.255.255.0
?dhcp select relay
?dhcp relay server-ip 10.10.20.2
#
interface Vlanif200
?ip address 10.10.20.1 255.255.255.0
#
interface GigabitEthernet1/0/1???????
?port link-type hybrid
?port hybrid untagged vlan 100
?mac-vlan enable
#
interface GigabitEthernet1/0/2???????
?port link-type hybrid
?port hybrid untagged vlan 100
?mac-vlan enable
#
interface GigabitEthernet1/0/3???????
?port link-type hybrid
?port hybrid pvid vlan 200
?port hybrid untagged vlan 200
#
ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
#
return

l?? SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 200
#
dhcp enable
#
ip pool ip-phone
?gateway-list 10.20.20.1?
?network 10.20.20.0 mask 255.255.255.0?
#
interface Vlanif200
?ip address 10.10.20.2 255.255.255.0
?dhcp select global
#
interface GigabitEthernet1/0/3
?port link-type hybrid
?port hybrid pvid vlan 200
?port hybrid untagged vlan 200
#
ip route-static 10.20.20.0 255.255.255.0 10.10.20.1
#
return

?

????? 如需下载文档,请点击? S1720&2700&S3700&S5700&S6700&S7700&S9700 对接专题资料

?

?????????????????????????????????? 想要了解更多精彩内容,请猛戳我:交换机在江湖汇总贴

???????????????????

本帖最后由 交换机在江湖 于 2017-01-06 15:57 编辑

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
有约不来
有约不来   发表于 2014-12-28 18:57:29 已赞(0) 赞(0)

感谢分享!
感谢分享!
  • x
  • 常规:

点评 回复

kargay
kargay   发表于 2015-1-3 18:49:11 已赞(0) 赞(0)

多谢提供!

  • x
  • 常规:

点评 回复

员Lemon
员Lemon  专家 发表于 2014-12-16 15:25:28 已赞(0) 赞(0)

好资料,顶起来~
  • x
  • 常规:

点评 回复

wangbenlie
wangbenlie   发表于 2014-12-22 15:06:14 已赞(0) 赞(0)

感谢分享!
  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录