【交换机在江湖】交换机与IP话机对接典型案例(六)

digest [复制链接]
发表于 : 2014-12-11 16:40:01 最新回复:2015-03-19 09:47:33
6535 6
交换机在江湖
交换机在江湖 官方号

?

配置通过Voice-VLAN include-untagged方式实现IP话机接入交换机示例

?

简介

如果语音设备发送的是Untagged报文,可以通过识别语音报文的OUI地址,为语音报文添加Voice VLAN ID,然后再根据Voice VLAN提升语音报文的优先级。

配置注意事项

l?? 本例适用于V200R003C00及以后版本的所有产品。

l?? 使能Voice VLAN功能的接口不允许再配置VLAN MappingVLAN Stacking和应用流策略。

l?? IP话机通过Voice-VLAN include-untagged方式接入时,请不要全局使能LLDP,否则交换机会通过LLDP分配Voice VLAN给话机,话机发给交换机的就是Tagged报文,而交换机转发给话机的又是Untagged报文,从而导致话机无法正常上线。

l?? Avaya话机60秒内获取DHCP地址失败导致定时器超时后,话机就开始一直发送Tag0的报文。而交换机对Tag0的报文按照Untagged报文处理,在接口的PVID内转发认证,这样话机就无法使用Voice VLAN进行认证,最终导致IP话机认证失败,无法正常接入交换机。

可以使用下面两种方法规避:

??????????? V200R003C00及之后版本,建议使用Voice-VLAN include-untagged方式进行规避。具体配置方法,请参见“1.9 配置通过Voice-VLAN include-untagged方式实现IP话机接入交换机示例”。

??????????? 按如下步骤修改IP话机的VLAN TEST定时器:1,按*键,输入密码,进入菜单项;2,选择VLAN TEST项,修改默认值为0。注意话机重启后,定时器的设置将不生效,需要重新配置。

适用的IP话机

下面话机是已经经过测试可以正常和交换机对接的话机,后续会根据测试结果持续刷新。

l?? Cisco

cisco7962Gcisco7975Gcisco7942Gcisco9951Gcisco3905cisco7971Gcisco7960Gcisco7961Gcisco7941Gcisco7911Gcisco8961cisco7945Gcisco7821Gcisco7940GciscoSPA509GciscoSPA525GciscoSPA504Gcisco7965Gcisco7970cisco9971cisco7906Gcisco7937GciscoSPA942GciscoSPA508Gcisco8945cisco6945cisco8841ciscoSPA962cisco6941cisco8831

l?? AvayaV200R009及之前版本不适用)

avaya1608-Iavaya9650avaya9611Gavaya4621avaya1616-Iavaya9630Gavaya1692avaya1120Eavaya9620avaya9621avaya9608avaya1608avaya9641avaya1230avaya1210avaya9610avaya1220avaya9640G

l?? Polycom

Polycom330PolycomCX3000

l?? Mitel

Mitel5340

l?? Nortel

Nortel1140E

组网需求

1-9所示:

l?? IP话机发送Untagged的语音报文。

l?? 为了保证通话质量,需要提升语音报文的优先级。

l?? 语音流使用VLAN 100进行通信。

l?? IP话机的IP地址和DHCP服务器的IP地址不在同一个网段,同时配置DHCP Snooping功能提高用户的安全性。

l?? IP话机需要通过802.1x MAC混合认证接入交换机。

配置通过Voice-VLAN include-untagged方式实现IP话机接入交换机组网图

20161206113646594001.png

?

配置思路

采用如下的思路配置通过Voice-VLAN include-untagged方式实现IP话机接入交换机:

1.???????? 接口以Untagged方式加入VLAN,实现语音报文的转发。

2.???????? 接口使能Voice VLAN include-untagged功能,对语音报文提升优先级。

3.???????? 配置DHCP RelayDHCP Server功能,为IP话机分配IP地址。

4.???????? 配置DHCP Snooping功能,提高用户的安全性。

5.???????? 配置IP话机按照802.1x MAC混合认证方式进行认证。(如果不需要认证,这一步可以忽略)

操作步骤

步骤一 把SwitchA的接口加入VLAN

??????????????????????????? # 创建VLAN100

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 100? //
语音流使用VLAN 100进行通信

??????????????????????????? # 把接口以Untagged方式加入VLAN 100

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid?? //
其中V200R005C00及之后版本,默认接口类型不是hybrid,需要手动配置
[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100? //IP
话机发送的报文不带Tag,所以接口必须要以Untagged方式加入语音VLAN 100
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] port link-type hybrid
[SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100
[SwitchA-GigabitEthernet1/0/2] quit

步骤二 在SwitchA的接口上使能Voice VLAN include-untagged功能,并配置OUI

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] voice-vlan 100 enable include-untagged? //
接口使能Voice VLAN include-untagged功能
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] voice-vlan 100 enable include-untagged
[SwitchA-GigabitEthernet1/0/2] quit
[SwitchA] voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000? //
使能Voice VLAN include-untagged功能时,必须配置该命令。该MACIP话机的MAC地址
[SwitchA] voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000

步骤三 配置DHCP RelayDHCP Server功能

1.???????? 配置SwitchADHCP Relay功能

# 配置接口的DHCP Relay功能。

[SwitchA] dhcp enable? //全局使能DHCP功能,缺省未使能
[SwitchA] interface Vlanif 100? //
创建VLANIF100
[SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0? //
配置VLANIF100IP地址
[SwitchA-Vlanif100] dhcp select relay? //
使能VLANIF接口DHCP中继功能
[SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2? //
配置DHCP中继所代理的DHCP服务器地址
[SwitchA-Vlanif100] quit

# 创建VLANIF 200

[SwitchA] vlan batch 200
[SwitchA] interface Vlanif 200
[SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0? //
配置VLANIF200IP地址,用于和SwitchB交互
[SwitchA-Vlanif200] quit

# 把上行接口加入VLAN 200

[SwitchA] interface gigabitethernet 1/0/3
[SwitchA-GigabitEthernet1/0/3] port link-type hybrid
[SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200
[SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200
[SwitchA-GigabitEthernet1/0/3] quit

# 配置缺省静态路由。

[SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2? //该路由的下一跳对应SwitchB VLANIF200IP地址

2.???????? 配置SwitchBDHCP Server,为IP话机分配IP地址

# 配置地址池。

<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] ip pool ip-phone? //
创建一个地址池
[SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1? //
配置DHCP服务器的出口网关地址
[SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0? //
配置该地址池可以分配的网段地址
[SwitchB-ip-pool-ip-phone] quit

# 配置DHCP Server功能。

[SwitchB] dhcp enable? //全局使能DHCP功能,缺省未使能
[SwitchB] vlan batch 200
[SwitchB] interface Vlanif 200? //
创建VLANIF200
[SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0? //
配置VLANIFIP地址
[SwitchB-Vlanif200] dhcp select global? //
配置接口采用全局地址池方式为话机分配IP地址
[SwitchB-Vlanif200] quit

# 把下行接口加入VLAN 200

[SwitchB] interface gigabitethernet 1/0/3
[SwitchB-GigabitEthernet1/0/3] port link-type hybrid
[SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200
[SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200
[SwitchB-GigabitEthernet1/0/3] quit

# 配置回程路由。

[SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

步骤四 在SwitchA上配置DHCP Snooping功能

[SwitchA] dhcp snooping enable? //全局使能DHCP Snooping功能,缺省不使能
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] dhcp snooping enable? //
接口使能DHCP Snooping功能
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] dhcp snooping enable
[SwitchA-GigabitEthernet1/0/2] quit
[SwitchA] interface gigabitethernet 1/0/3
[SwitchA-GigabitEthernet1/0/3] dhcp snooping trusted? //
配置上行接口为信任接口
[SwitchA-GigabitEthernet1/0/3] quit

步骤五 配置IP话机按照802.1x MAC混合认证方式进行认证

1.???????? 配置AAA认证域

# 创建并配置RADIUS服务器模板。

[SwitchA] radius-server template cisco? //创建名为"cisco"RADIUS服务器模板
[SwitchA-radius-cisco] radius-server authentication 192.168.6.182 1812? //
配置RADIUS认证服务器的IP地址和端口号
[SwitchA-radius-cisco] radius-server accounting 192.168.6.182 1813? //
配置RADIUS计费服务器的IP地址和端口号
[SwitchA-radius-cisco] quit

# 配置认证方案。

[SwitchA] aaa
[SwitchA-aaa] authentication-scheme radius? //
创建AAA认证方案为“radius”
[SwitchA-aaa-authen-radius] authentication-mode radius? //
配置认证方式为RADIUS
[SwitchA-aaa-authen-radius] quit

# 创建AAA域并配置域的RADIUS服务器模板和认证方案。

[SwitchA-aaa] domain default? //配置default认证域
[SwitchA-aaa-domain-default] authentication-scheme radius? //
绑定AAA认证方案“radius”
[SwitchA-aaa-domain-default] radius-server cisco? //
绑定RADIUS服务器模板“cisco”
[SwitchA-aaa-domain-default] quit
[SwitchA-aaa] quit

2.???????? 配置IP话机按照802.1x MAC混合认证方式进行认证

??????????? V200R007C00及其之前版本、V200R008C00

# NAC配置模式切换成传统模式。

[SwitchA] undo authentication unified-mode? //设备默认为统一模式。传统模式与统一模式相互切换后,管理员必须保存配置后重启设备,新配置模式的各项功能才能生效

# 在接口上使能802.1x MAC认证。

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] dot1x mac-bypass? //
使能MAC旁路认证功能,先进行802.1x认证,认证失败,则启动MAC认证流程
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] dot1x mac-bypass
[SwitchA-GigabitEthernet1/0/2] quit

??????????? V200R009C00及其之后版本

# NAC配置模式切换成统一模式。

[SwitchA] authentication unified-mode? //设备默认为统一模式。传统模式与统一模式相互切换后,管理员必须保存配置后重启设备,新配置模式的各项功能才能生效

# 配置接入模板。

[SwitchA] dot1x-access-profile name cisco? //创建802.1x接入模板“cisco”
[SwitchA-dot1x-access-profile-cisco] quit
[SwitchA] mac-access-profile name cisco? //
创建MAC接入模板“cisco”
[SwitchA-mac-access-profile-cisco] quit

# 配置混合认证模板。

[SwitchA] authentication-profile name cisco? //配置认证模板
[SwitchA-authen-profile-cisco] dot1x-access-profile cisco? //
绑定802.1x接入模板
[SwitchA-authen-profile-cisco] mac-access-profile cisco? //
绑定MAC接入模板
[SwitchA-authen-profile-cisco] quit

# 在接口上应用认证模板。

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] authentication-profile cisco? //
绑定认证模板
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] authentication-profile cisco
[SwitchA-GigabitEthernet1/0/2] quit

3.????? 配置Agile ControllerAgile Controller界面显示版本间可能存在差异,请以实际为准。下面以V100R002C00SPC102版本为例,说明配置方法和配置步骤

a.???????? 登录Agile Controller

打开Internet Explorer浏览器,在地址栏输入Agile Controller的访问地址,并按“Enter”。

然后输入管理员帐号和密码。首次登录Agile Controller,请使用超级管理员帐号admin和密码Changeme123。首次登录之后请立即修改密码,否则无法使用Agile Controller

Agile Controller的访问地址支持以下形式:

访问方式

说明

https://Agile Controller-IP:8443

其中,“Agile Controller-IP”Agile ControllerIP地址。

Agile ControllerIP地址

如果在安装时启用了80端口,则允许不输入端口号。通过此种方式访问Agile ControllerURL地址将自动跳转为“https://Agile Controller-IP:8443”

?

b.???????? 增加普通账号。

i.????????? 选择“资源 > 用户 > 用户管理”。

ii.??????? 在右侧操作区域内单击“增加”,创建普通账号。

20161206113647852002.png

c.???????? Agile Controller中添加交换机SwitchA

i.????????? 选择“资源 > 设备 > 设备管理”。

ii.??????? 在右侧操作区域内单击“增加”,在“增加设备”页面,增加对IP话机进行认证的交换机SwitchA

20161206113648087003.png

d.???????? 添加认证规则。

选择“策略 > 准入控制 > 认证授权 > 认证规则”,并单击“增加”,分别创建认证规则。

20161206113648926004.png

e.???????? 添加授权结果。

选择“策略 > 准入控制 > 认证授权 > 授权结果”,并单击“增加”,创建授权结果。

20161206113649540005.png

f.????????? 增加授权规则。

认证阶段的检查通过后,用户的接入过程将进入授权阶段。授权阶段,Agile Controller通过授权规则授予用户权限。

选择“策略 > 准入控制 > 认证授权 > 授权规则”,并单击“增加”,创建授权规则。“业务类型”选择“接入业务”,“授权结果”选择为上一步骤创建的授权结果“允许接入voice-vlan 100”。

20161206113650604006.png

步骤六 检查配置结果

l?? IP话机可以正常获取到正确的语音VLANIP地址。

l?? SwitchA上执行命令display access-user,可以看到IP话机的接入信息。

----结束

配置文件

l?? SwitchA的配置文件(V200R007C00及其之前版本、V200R008C00

#
sysname SwitchA
#
voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000
voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000
#
vlan batch 100 200
#
undo authentication unified-mode
#??
dhcp enable
#
dhcp snooping enable
#
radius-server template cisco
?radius-server authentication 192.168.6.182 1812 weight 80
?radius-server accounting 192.168.6.182 1813 weight 80
#
aaa
?authentication-scheme radius
? authentication-mode radius
?domain default
? authentication-scheme radius
? radius-server cisco
#
interface Vlanif100
?ip address 10.20.20.1 255.255.255.0
?dhcp select relay
?dhcp relay server-ip 10.10.20.2
#
interface Vlanif200
?ip address 10.10.20.1 255.255.255.0
#
interface GigabitEthernet1/0/1???????
?port link-type hybrid
?voice-vlan 100 enable include-untagged
?port hybrid untagged vlan 100
?dot1x mac-bypass
?dhcp snooping enable
#
interface GigabitEthernet1/0/2???????
?port link-type hybrid
?voice-vlan 100 enable include-untagged
?port hybrid untagged vlan 100
?dot1x mac-bypass
?dhcp snooping enable
#
interface GigabitEthernet1/0/3???????
?port link-type hybrid
?port hybrid pvid vlan 200
?port hybrid untagged vlan 200
?dhcp snooping trusted
#
ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
#
return

l?? SwitchA的配置文件(V200R009C00及其之后版本)

#
sysname SwitchA
#
voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000???????????????????????
voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000
#
vlan batch 100 200
#
authentication-profile name cisco
?dot1x-access-profile cisco
?mac-access-profile cisco
#
dhcp enable
#
dhcp snooping enable
#
radius-server template cisco
?radius-server authentication 192.168.6.182 1812 weight 80
?radius-server accounting 192.168.6.182 1813 weight 80
#
aaa
?authentication-scheme radius
? authentication-mode radius
?domain default
? authentication-scheme radius
? radius-server cisco
#
interface Vlanif100
?ip address 10.20.20.1 255.255.255.0
?dhcp select relay
?dhcp relay server-ip 10.10.20.2
#
interface Vlanif200
?ip address 10.10.20.1 255.255.255.0
#
interface GigabitEthernet1/0/1???????
?port link-type hybrid
?voice-vlan 100 enable include-untagged
?port hybrid untagged vlan 100
?authentication-profile cisco
?dhcp snooping enable
#
interface GigabitEthernet1/0/2??? ????
?port link-type hybrid
?voice-vlan 100 enable include-untagged
?port hybrid untagged vlan 100
?authentication-profile cisco
?dhcp snooping enable
#
interface GigabitEthernet1/0/3???????
?port link-type hybrid
?port hybrid pvid vlan 200
?port hybrid untagged vlan 200
?dhcp snooping trusted
#
ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
#
dot1x-access-profile name cisco
#
mac-access-profile name cisco
#
return

l?? SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 200
#
dhcp enable
#
ip pool ip-phone
?gateway-list 10.20.20.1?
?network 10.20.20.0 mask 255.255.255.0?
#
interface Vlanif200
?ip address 10.10.20.2 255.255.255.0
?dhcp select global
#
interface GigabitEthernet1/0/3
?port link-type hybrid
?port hybrid pvid vlan 200
?port hybrid untagged vlan 200
#
ip route-static 10.20.20.0 255.255.255.0 10.10.20.1
#
return

?

????????????????????????????????

?

????????????????????? 如需下载文档,请点击? S1720&2700&S3700&S5700&S6700&S7700&S9700 对接专题资料

?

??????????????????????????????????? 想要了解更多精彩内容,请猛戳我:交换机在江湖汇总贴

???????????????????

本帖最后由 交换机在江湖 于 2017-01-06 15:58 编辑

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
kargay
kargay   发表于 2015-1-3 18:49:23 已赞(0) 赞(0)

多谢提供!
  • x
  • 常规:

点评 回复

员Lemon
员Lemon  专家 发表于 2014-12-11 17:21:35 已赞(0) 赞(0)

多谢分享~~~

  • x
  • 常规:

点评 回复

rmq-king
rmq-king  新锐 发表于 2015-3-10 15:03:01 已赞(0) 赞(0)

Q:如果和思科话机对接,是否需要在接口使能兼容CDP功能 voice-vlan legacy enable ?
  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2015-3-16 09:42:02 已赞(0) 赞(0)

回复 4 楼

是的,如果想要和思科话机对接,是需要使能voice-vlan legacy enable
  • x
  • 常规:

点评 回复

当交换机遇上路由
当交换机遇上路由  新锐 发表于 2015-3-19 09:46:55 已赞(0) 赞(0)

配置基于MAC地址的Voice VLAN示例(IP Phone上送Untagged语音报文)

组网需求

如图1所示,Switch下行连接数据业务和语音业务,Switch使用VLAN2传输语音报文,使用VLAN3传输数据报文。IP Phone A和PC A串行接入Switch,IP Phone B单独接入Switch,IP Phone发送的都是untagged语音报文。用户对语音质量较敏感,需要提高语音数据流的传输优先级,以保证用户的通话质量。

图1 配置基于MAC地址Voice VLAN组网
http://localhost:7894/pages/DZD0417A/01/DZD0417A/01/resources/dc/images/fig_dc_cfg_voicevlan_002101xs.png

配置思路

因为Switch收到的语音报文和数据报文都是untagged报文,需要配置OUI来区分语音和数据流量。采用如下的思路配置:
  1. 在Switch上创建VLAN,并配置各接口加入VLAN,实现二层互通。
  2. 配置OUI,实现根据收到报文的源MAC地址匹配OUI给语音报文加VLAN Tag。
  3. 配置VLAN 2为Voice VLAN,允许语音报文通过。
http://localhost:7894/pages/DZD0417A/01/DZD0417A/01/resources/public_sys-resources/icon-note.gif 说明:

Switch1的配置与Switch类似,略。

操作步骤

  1. 配置Switch的VLAN和接口

    # 创建VLAN

    <HUAWEI> system-view
    [HUAWEI] vlan batch 2 3
    

    # 配置接口GE0/0/1允许通过的VLAN,GE0/0/2的配置与GE0/0/1类似,不再赘述。

    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] port link-type hybrid
    [HUAWEI-GigabitEthernet0/0/1] port hybrid pvid vlan 3
    [HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 2 to 3
    [HUAWEI-GigabitEthernet0/0/1] quit
    

  2. 配置OUI

    [HUAWEI] voice-vlan mac-address 0003-6B00-0000 mask ffff-ff00-0000

  3. 配置接口Voice VLAN功能,GE0/0/2的配置与GE0/0/1类似,不再赘述。

    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] voice-vlan 2 enable include-untagged
    [HUAWEI-GigabitEthernet0/0/1] voice-vlan remark-mode mac-address
    [HUAWEI-GigabitEthernet0/0/1] return

  4. 检查配置结果

    执行命令display voice-vlan 2 status,查看Voice VLAN的配置是否正确。

    <HUAWEI> display voice-vlan 2 status
    Voice VLAN Configurations:
    ---------------------------------------------------
    Voice VLAN ID            : 2
    Voice VLAN status        : Enable
    Voice VLAN 8021p remark  : 6
    Voice VLAN dscp remark   : 46
    ----------------------------------------------------------
    Port Information:
    -------------------------------------------------------------------------------
    Port                     Add-Mode  Security-Mode  Legacy   PribyVLAN  Untag
    -------------------------------------------------------------------------------
    GigabitEthernet0/0/2     Manual    Normal         Disable  Disable    Enable
    GigabitEthernet0/0/1     Manual    Normal         Disable  Disable    Enable

配置文件

Switch的配置文件。

#
vlan batch 2 to 3
#
voice-vlan mac-address 0003-6b00-0000 mask ffff-ff00-0000
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 voice-vlan 2 enable include-untagged
 voice-vlan remark-mode mac-address    
 port hybrid pvid vlan 3
 port hybrid untagged vlan 2 to 3
#
interface GigabitEthernet0/0/2
 port link-type hybrid
 voice-vlan 2 enable include-untagged
 voice-vlan remark-mode mac-address    
 port hybrid untagged vlan 2
#
return
  • x
  • 常规:

点评 回复

当交换机遇上路由
当交换机遇上路由  新锐 发表于 2015-3-19 09:47:33 已赞(0) 赞(0)

配置基于VLAN的Voice VLAN示例(IP Phone上送带tag语音报文)

组网需求

如图1所示,Switch下行连接数据业务和语音业务,Switch使用VLAN2传输语音报文,使用VLAN3传输数据报文。IP Phone A和PC A串行接入Switch,IP Phone B单独接入Switch,IP Phone支持通过LLDP协议获取Voice VLAN信息,发送的是tagged语音报文。用户对语音通话质量较敏感,需要提高语音数据流的传输优先级,以保证用户的通话质量。网络管理员同时管理大量的IP Phone,希望能使用尽可能简单的配置来完成以上需求。

图1 配置基于VLAN提升优先级的Voice VLAN组网
http://localhost:7894/pages/DZD0417A/01/DZD0417A/01/resources/dc/images/fig_dc_cfg_voicevlan_002301xs.png

配置思路

采用如下的思路配置:
  1. 在Switch上创建VLAN,并配置各接口加入VLAN,实现二层互通。
  2. 使能LLDP,实现IP Phone能通过LLDP协议获取到Voice VLAN信息。
  3. 配置VLAN 2为Voice VLAN,允许语音报文通过;并使用基于VLAN的Voice VLAN(此为缺省情况),不用配置繁琐的OUI,简化配置。
http://localhost:7894/pages/DZD0417A/01/DZD0417A/01/resources/public_sys-resources/icon-note.gif 说明:

Switch1的配置与Switch类似,略。

操作步骤

  1. 配置Switch的VLAN和接口

    # 创建VLAN

    <HUAWEI> system-view
    [HUAWEI] vlan batch 2 3
    

    # 配置接口GE0/0/1允许通过的VLAN,GE0/0/2的配置与GE0/0/1类似,不再赘述。

    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] port link-type hybrid
    [HUAWEI-GigabitEthernet0/0/1] port hybrid pvid vlan 3
    [HUAWEI-GigabitEthernet0/0/1] port hybrid untagged vlan 3
    [HUAWEI-GigabitEthernet0/0/1] port hybrid tagged vlan 2
    [HUAWEI-GigabitEthernet0/0/1] quit
    

  2. 使能LLDP

    [HUAWEI] lldp enable

  3. 配置接口Voice VLAN功能,GE0/0/2的配置与GE0/0/1类似,不再赘述。

    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] voice-vlan 2 enable
    [HUAWEI-GigabitEthernet0/0/1] voice-vlan remark-mode vlan
    [HUAWEI-GigabitEthernet0/0/1] return

  4. 检查配置结果

    执行命令display voice-vlan 2 status,查看Voice VLAN的配置是否正确。

    <HUAWEI> display voice-vlan 2 status
    Voice VLAN Configurations:
    ---------------------------------------------------
    Voice VLAN ID            : 2
    Voice VLAN status        : Enable
    Voice VLAN 8021p remark  : 6
    Voice VLAN dscp remark   : 46
    ----------------------------------------------------------
    Port Information:
    -------------------------------------------------------------------------------
    Port                     Add-Mode  Security-Mode  Legacy   PribyVLAN  Untag
    -------------------------------------------------------------------------------
    GigabitEthernet0/0/2     Manual    Normal         Disable  Enable     Disable
    GigabitEthernet0/0/1     Manual    Normal         Disable  Enable     Disable

配置文件

Switch的配置文件。

#
vlan batch 2 to 3
#
lldp enable
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 voice-vlan 2 enable
 port hybrid pvid vlan 3
 port hybrid tagged vlan 2
 port hybrid untagged vlan 3
#
interface GigabitEthernet0/0/2
 port link-type hybrid
 voice-vlan 2 enable
 port hybrid tagged vlan 2
#
return
  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录