【交换机在江湖】交换机与IP话机对接典型案例(四)

[复制链接]
发表于 : 2014-12-4 16:25:14 最新回复:2015-07-26 21:31:05
5801 8
交换机在江湖
交换机在江湖 官方号

?

配置通过DHCP服务器实现IP话机接入交换机示例

?

简介

如果语音设备支持DHCP协议,可以在交换机上启用DHCP功能,通过DHCP协议为语音设备分配Voice VLAN

配置注意事项

适用的产品和版本如下表所示:

举例适用的产品和版本

系列

产品

支持版本

S1700

S1720GFR

V200R006C10V200R009C00V200R010C00

S2700

S2720EI

V200R009C00V200R010C00

S2750EI

V200R005C00SPC300V200R006C00V200R007C00V200R008C00V200R009C00V200R010C00

S3700

S3700SIS3700EI

V100R006C05

S3700HI

V200R001C00

S5700

S5700LI

V200R005C00SPC300V200R006C00V200R007C00V200R008C00V200R009C00V200R010C00

S5700S-LI

V200R005C00SPC300V200R006C00V200R007C00V200R008C00V200R009C00V200R010C00

S5710-X-LI

V200R008C00V200R009C00V200R010C00

S5700SI

V200R001C00V200R002C00V200R003C00V200R005C00

S5700EI

V200R001C00&C01)、V200R002C00V200R003C00V200R005C00&C01&C02&C03

S5710EI

V200R001C00V200R002C00V200R003C00V200R005C00&C02

S5720EI

V200R007C00V200R008C00V200R009C00V200R010C00

S5720LIS5720S-LI

V200R010C00

S5720SIS5720S-SI

V200R008C00V200R009C00V200R010C00

S5700HI

V200R001C00&C01)、V200R002C00V200R003C00V200R005C00SPC500&C01&C02

S5710HI

V200R003C00V200R005C00&C02&C03

S5720HI

V200R006C00V200R007C00&C10)、V200R008C00V200R009C00V200R010C00

S6700

S6700EI

V200R001C00&C01)、V200R002C00V200R003C00V200R005C00&C01

S6720EI

V200R008C00V200R009C00V200R010C00

S6720S-EI

V200R009C00V200R010C00

S7700

S7703S7706S7712

V200R001C00&C01)、V200R002C00V200R003C00V200R005C00V200R006C00V200R007C00V200R008C00V200R009C00V200R010C00

S7710

V200R010C00

S9700

S9703S9706S9712

V200R001C00&C01)、V200R002C00V200R003C00V200R005C00V200R006C00V200R007C00V200R008C00V200R009C00V200R010C00

?

说明

如需了解交换机软件配套详细信息,请参看华为以太网交换机版本配套速查

组网需求

1-7所示,IP话机支持通过DHCP协议获取语音VLAN,且IP话机发送的语音报文优先级比较高(比如802.1p的优先级为5)。此时可配置DHCP服务器下发给客户端的报文中option字段内容,将VLAN ID下发给语音设备。

配置通过DHCP服务器实现IP话机接入交换机组网图

20161206113005105002.png

?

配置思路

采用如下的思路配置通过DHCP服务器实现IP语音接入交换机:

1.???????? 创建VLAN

2.???????? 配置接口类型及缺省VLAN

3.???????? 配置接口信任报文的802.1p值。

4.???????? 使能地址池。

5.???????? 配置地址池中的option选项。

6.???????? 全局DHCP使能,通过DHCP分配IP地址。

操作步骤

步骤一 配置SwitchVLAN和接口

??????????????????????????? ?# 创建VLAN2VLAN6

<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] vlan batch 2 6

???????????????????????????? # 配置接口类型和缺省VLAN

[Switch] interface gigabitethernet 1/0/1
[Switch-GigabitEthernet1/0/1] port link-type hybrid
[Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 2
[Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 2? //
把接口加入用于数据转发的VLAN 2
[Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 6? //
把接口加入用于语音转发的VLAN 6
[Switch-GigabitEthernet1/0/1] quit

步骤二 配置Switch的地址池功能

?????????????????????????????# 创建一个地址池。

[Switch] ip pool ip_access

???????????????????????????? # 配置地址池中的地址。

[Switch-ip-pool-ip_access] network 192.168.10.0 mask 24
[Switch-ip-pool-ip_access] gateway-list 192.168.10.1? //
配置DHCP服务器的出口网关地址。该地址是接口PVID对应VLANIFIP地址
[Switch-ip-pool-ip_access] option184 voice-vlan 6? //
配置DHCP地址池的选项option184对应的语音VLAN6
[Switch-ip-pool-ip_access] quit

说明

配置DHCP服务器下发给客户端的报文中Option字段的目的是将VLAN ID下发给语音设备。本举例中DHCP地址池的选项Option数值以184为例,不同厂商的IP电话可能会使用不同的Option数值,具体请参考IP电话机的使用说明。配置方法请参见《IP业务命令-DHCP配置命令》中的option命令。

步骤三 配置接口信任报文的802.1p

???????????????????????????? # trust 8021p (inner)命令因设备形态不同有所区别,具体配置请以设备为准。

[Switch] interface gigabitethernet 1/0/1
[Switch-GigabitEthernet1/0/1] trust 8021p inner
[Switch-GigabitEthernet1/0/1] quit

步骤四 配置全局DHCP使能

[Switch] dhcp enable

步骤五 配置Switch的地址池功能

???????????????????????????? # 创建PVID对应的VLANIF接口,并配置按照全局分配地址。

[Switch] interface Vlanif2
[Switch-Vlanif2] ip address 192.168.10.1 255.255.255.0
[Switch-Vlanif2] dhcp select global? //
配置接口采用全局地址池的DHCP服务器模式为DHCP客户端分配IP地址

----结束

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 2 6
#???????????????????????????????????????????????????????????????????????????????
dhcp enable?????????????????????????????????????????????????????????????????????
#
ip pool ip_access?????????????????????????????? ?????????????????????????????????
?gateway-list 192.168.10.1
?network 192.168.10.0 mask 255.255.255.0????????????????????????????????????????
?option184 voice-vlan 6
#???????????????????????????????????????????????????????????????????????????????
interface Vlanif2???????????????????????????????????????????????????????????????
?ip address 192.168.10.1 255.255.255.0??????????????????????????????????????????
?dhcp select global?????????????????????????????????????????????????????????????
#????????????? ??????????????????????????????????????????????????????????????????
interface GigabitEthernet1/0/1
?port link-type hybrid
?port hybrid pvid vlan 2?????????????????????????????????????????????????????????
?port hybrid tagged vlan 6????
?port hybrid untagged vlan 2??
?trust 8021p inner
#?
return

?

???????

?????????????????????????????? 如需下载文档,请点击? S1720&2700&S3700&S5700&S6700&S7700&S9700 对接专题资料

????????????????????????

??????????????????????????????????? 想要了解更多精彩内容,请猛戳我:交换机在江湖汇总贴

???????????????????

本帖最后由 交换机在江湖 于 2017-01-06 15:55 编辑

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
POZHENZI
POZHENZI  新锐 发表于 2014-12-4 20:16:14 已赞(0) 赞(0)

不错,挺好的!!!
  • x
  • 常规:

点评 回复

宝鼎波波
宝鼎波波  精英 发表于 2014-12-5 11:44:35 已赞(0) 赞(0)

资料很好,留得以后看,现在还没有相应的硬件了
  • x
  • 常规:

点评 回复

kargay
kargay   发表于 2015-1-3 18:28:07 已赞(0) 赞(0)

很好的资料,学习了。
  • x
  • 常规:

点评 回复

w00188679
w00188679   发表于 2015-7-15 01:58:40 已赞(0) 赞(0)

是不是也要配置一个vlan 300的ip地址池

  • x
  • 常规:

点评 回复

yanyabo
yanyabo   发表于 2015-7-15 08:02:14 已赞(0) 赞(0)

这种情况下,vlan500和vlan300的终端的地址是实际上是一个网段的?能不能将IP话机的地址改成其他的?
  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2015-7-17 09:16:23 已赞(0) 赞(0)

回复 5 楼

初始状态语音话机没有语音vlan,所以使用接口的PVID分配IP地址,对已可以手动配置语音vlan的话机,ip地址池需要配置在语音vlan 300的ip地址。

  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2015-7-17 09:17:37 已赞(0) 赞(0)

回复 6 楼

可以根据实际情况进行修改,为语音和数据报文配置不同的IP地址
  • x
  • 常规:

点评 回复

不吃猫的鱼
不吃猫的鱼  版主 发表于 2015-7-26 21:31:05 已赞(0) 赞(0)

学习了,顶!!

  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录