【交换机在江湖】交换机与IP话机对接典型案例(一)

digest [复制链接]
发表于 : 2014-12-2 14:45:56 最新回复:2016-12-03 13:11:15
13742 18
交换机在江湖
交换机在江湖 官方号

相关推荐:S1720&S2700&S3700&S5700&S6700&S7700&S9700对接专题资料

?

对接原理&配置通过LLDP实现IP话机接入交换机示例

?

基本概念

l?? VoIP

VoIP(Voice over Internet Protocol),即指在IP网络上使用IP协议以数据包的方式传输语音。使用VoIP协议,不管是因特网、企业内部互连网还是局域网都可以实现语音通信。在使用VoIP协议的网络中,语音信号经过数字化,压缩并转换成IP包,然后在IP网络中进行传输。VoIP信令协议用于建立和取消呼叫,传输用于定位用户以及协商能力所需的信息。

相比于通过电信运营商网络的专线进行点对点连接的语音通信,使用VoIP协议传输语音通信具有投资省、价格低的优势,数据、语音和视频在同一网络上进行传输。

l?? OUI地址

OUIOrganizationally Unique Identifier)指的是MAC地址的前24位(二进制),是IEEEInstitute of Electrical and Electronics Engineers,电气和电子工程师学会)为不同设备供应商分配的一个全球唯一的标识符。

各设备厂商的MAC地址是需要向IEEE申请的,一般IEEE分配前24位,即一个地址段,设备厂商生产的设备再从这个地址段中分配地址。所以根据OUI可以识别话机,也就是根据话机厂商申请的MAC段来识别哪些报文是话机发送的,以此来判断哪些报文属于语音报文。当然这个OUI由用户来配置,而且可以使用掩码,即不需要一定是24位掩码的,掩码长度用户可以自己指定。

l?? 802.1Q

802.1Q定义了VLAN TAG的格式,如下图所示:

20170106152946758001.png

VLAN TAG总计有两个字节,即16bit,其中VID12bitsPRI3bitsPRI经常被称为COS优先级或者802.1p优先级),CFI1bit

按照报文对VLAN Tag的填充情况,可以分为如下几种:

a.???????? 报文中不带VLAN TAG,即UNTAG报文。

b.???????? 报文虽然携带VLAN TAG,但是VLAN ID0,即没有VLAN ID。一般称为优先级TAG报文。

c.???????? 报文携带VLAN TAG,且VLAN ID0,称为TAG报文。

所以按照802.1Q的报文定义,IP话机发送的语音流量的报文可以为TAG报文、优先级TAG报文、UNTAG报文三种。同时由于语音报文的COS值需要为高优先级(一般为5),以提高语音流的转发优先级。一般主流厂商的IP电话机(例如Cisco7960系列),其发送的语音流量是TAG的报文,且COS值默认是5。但是IP话机类型众多,可能会存在部分话机的语音流无法将COS置为5的情况(COS0)

综合考虑,电话机发送的报文有如下5种情况:

d.???????? 携带VLAN TAGCOS 5

e.???????? 携带VLAN TAGCOS 0

f.????????? 携带优先级TAGCOS 5

g.???????? 携带优先级TAGCOS 0

h.???????? 不携带VLAN TAG,即UNTAG方式

说明

华为交换机对优先级TAG的报文,目前都是按照Untagged的报文处理的,即接口对收到的优先级TAG报文打上PVIDVLAN Tag

l?? Voice VLAN

专门用于转发语音报文的VLAN,叫做Voice VLAN。华为交换机的Voice VLAN功能只能指定某个VLAN为语音VLAN,而不会把该语音VLAN分配给语音设备,需要借助于LLDPDHCP等协议,才可以把指定的Voice VLAN分配给语音设备。

IP话机接入部署方式

IP话机介绍

Cisco7960话机为例,IP话机内部构成如1-1所示。IP话机内部集成了一个三端口的交换芯片,其中:

l?? P1接口用于连接上行的交换机或者其他数通设备

l?? P2接口连接内部的Phone ASIC,用于承载语音流量

l?? P3接口用于连接PC机或者其他数据通讯设备

IP话机内部构成图

20170106152947670003.png

?

不同型号的IP话机对接方式支持情况汇总

不同型号的IP话机支持的对接方式不同,本表所示的IP话机是已经经过测试可以正常和交换机正常对接的话机,后续会根据测试结果持续刷新。
表1?不同型号的IP话机对接方式支持情况汇总(本表格适用于V200R009和V200R010版本的交换机)

IP话机型号

LLDP方式

LLDP_MED方式

HDP方式

MAC VLAN方式

Voice-VLAN include-untagged方式

PVID=Voice VLAN方式

ACL和流策略方式

推荐接入方式

Cisco CP-7962G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7965G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7975G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7942G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-9951G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7941G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7941G-GE

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-3905

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7961G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7961G-GE

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7971G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7911G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-8961G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7945G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7821G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-9971

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7906G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7937G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-8945

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-6945

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-8841

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-6941

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-8831

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7841

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-8945

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-6921

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-8961

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-8941

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7906

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco 3905

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-6961

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7811

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco SPA502G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco SPA504G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco SPA508G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco SPA512G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco SPA524G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco SPA525G

支持

支持

支持

支持

支持

支持

支持

LLDP方式

Cisco CP-7960G

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco CP-7940G

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco CP-7970

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco CP-7911

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco CP-3911

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco CP-7912

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco CP-3951

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco CP-7985

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco 6961

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco SPA509G

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco SPA942G

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco SPA962G

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Cisco SPA303

不支持

不支持

支持

支持

支持

支持

支持

HDP方式

Avaya 1608-I

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9650

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9611G

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 4621

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 1616-I

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9630G

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 1692

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9620

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9621

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9608

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 1608

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9641

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 1230

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 1210

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9610

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 1220

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9640G

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 9670G

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 4610sw

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya E129

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Avaya 1120E

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Polycom 330

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Polycom CX3000

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Polycom vvx500

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Polycom 550

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Polycom CX700

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Polycom 650sip

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Polycom 601sip

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Polycom 320

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Polycom 450

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Polycom 301SIP

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Snom 820

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Snom 821

支持

支持

不支持

支持

不支持

支持

不支持

LLDP方式

Snom 300

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Mitel 5340

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Mitel 5212

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Nortel 1140E

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

H3C 3120

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Linksys SPA 921

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

GXP 1450

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

GXP 1630

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Atcom A11

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Escene ES290-PN

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Escene WS290-PN

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Fanvil F52HP

不支持

不支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Yealink SIP T23P

支持

支持

不支持

支持

支持

支持

支持

Voice-VLAN include-untagged方式

Yealink SIP T22P

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

Yealink SIP T28P

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

HP 4120

支持

支持

不支持

支持

支持

支持

支持

LLDP方式

IP话机接入部署方式

根据1-1可知,IP话机外部一般有两个可见的接口,一个用于连接上行的交换机,一个用于连接PC机。因此IP话机和PC同时部署时,一般有两种部署方式:

l?? 一种部署方式是PC挂在IP话机之下,如1-2所示。这种部署的好处是只占用交换机的一个端口。对于一般的办公场景,办公桌面只需要出一个网口即可以满足语音和数据业务。

PC挂在IP话机之下组网图

20170106152948329004.png

?

l?? 另一种部署方式是PCIP话机分别连接到交换机,如1-3所示。这种部署的好处是语音流和数据流分开部署,更易于管理和维护。

PCIP话机分别连接到交换机组网图

20170106152949849005.png

?

交换机与IP话机对接典型配置方法

交换机与IP话机对接的配置方法有很多种。根据话机类型和交换机支持情况,可以分为几种,如1-1所示。

交换机与IP话机对接的配置方法汇总

配置方法

对话机的要求

代表话机

推荐级别

通过LLDP实现IP话机接入交换机

支持通过LLDP协议获取语音VLAN

CiscoPolycom

通过LLDP_MED方式实现IP话机接入交换机

支持通过LLDP协议的network-policy TLV字段获取语音VLAN

Cisco

一般

通过HDP方式实现Cisco话机接入交换机

支持通过CDP协议获取语音VLAN

Cisco

一般

通过DHCP方式实现IP话机接入交换机

支持通过DHCP协议获取语音VLAN

H3C

一般

通过MAC VLAN方式实现IP话机接入交换机

不支持通过任何协议获取语音VLAN

Huawei

通过Voice-VLAN include-untagged方式实现IP话机接入交换机

不支持通过任何协议获取语音VLAN

Huawei

通过PVID=Voice VLAN方式实现IP话机接入交换机

不支持通过任何协议获取语音VLAN

AvayaHuawei

一般

通过ACL或基于ACL的简化流策略方式实现IP话机接入交换机

不支持通过任何协议获取语音VLAN

AvayaHuawei

一般

?

? 配置通过LLDP实现IP话机接入交换机示例

简介

如果语音设备支持LLDP协议,可以在交换机上启用LLDPVoice VLAN功能实现IP话机接入。通过LLDP协议为语音设备分配Voice VLAN,然后再通过Voice VLAN功能提升语音报文的优先级。

配置注意事项

l?? 适用的产品和版本:除S2700SIS2710SI外,其他版本所有形态均支持。

l?? Avaya话机60秒内获取DHCP地址失败导致定时器超时后,话机就开始一直发送Tag0的报文。而交换机对Tag0的报文按照Untagged报文处理,在接口的PVID内转发认证,这样话机就无法使用Voice VLAN进行认证,最终导致IP话机认证失败,无法正常接入交换机。

可以使用下面两种方法规避:

??????????? V200R003C00及之后版本,建议使用Voice-VLAN include-untagged方式进行规避。具体配置方法,请参见“1.9 配置通过Voice-VLAN include-untagged方式实现IP话机接入交换机示例”。

??????????? 按如下步骤修改IP话机的VLAN TEST定时器:1,按*键,输入密码,进入菜单项;2,选择VLAN TEST项,修改默认值为0。注意话机重启后,定时器的设置将不生效,需要重新配置。

适用的IP话机

下面话机是已经经过测试可以正常和交换机对接的话机,后续会根据测试结果持续刷新。

l?? Cisco

cisco7962Gcisco7975Gcisco7942Gcisco9951Gcisco3905cisco7971Gcisco7961Gcisco7941Gcisco7911Gcisco8961cisco7945Gcisco7821GciscoSPA525GciscoSPA504Gcisco7965Gcisco9971cisco7906Gcisco7937GciscoSPA508Gcisco8945cisco6945cisco8841cisco6941cisco8831

l?? Avaya

avaya1608-Iavaya9650avaya9611Gavaya4621avaya1616-Iavaya9630Gavaya1692avaya9620avaya9621avaya9608avaya1608avaya9641avaya1230avaya1210avaya9610avaya1220avaya9640G

l?? Snom

Snom821

l?? Polycom

Polycom330PolycomCX3000

l?? Mitel

Mitel5340

l?? Nortel

Nortel1140E

组网需求

1-4所示:

l?? IP话机支持LLDP协议,可以通过LLDP协议获取语音VLAN

l?? IP话机发送的语音报文,优先级比较低,为了保证通话质量,需要提升报文的优先级。

l?? 语音流使用VLAN 100进行通信,PC数据流使用VLAN 101进行通信。

l?? IP话机的IP地址和DHCP服务器的IP地址不在同一个网段。

l?? IP话机需要通过MAC认证接入交换机。

配置通过LLDP实现IP话机接入交换机组网图

20170106152950961006.png

?

配置思路

采用如下的思路配置通过LLDP实现IP话机接入交换机:

1.???????? 全局和接口使能LLDP功能,为IP话机分配语音VLAN

2.???????? 配置Voice VLAN功能,为IP话机发送的语音报文提升优先级。

3.???????? 配置DHCP RelayDHCP Server功能,为IP话机分配IP地址。

4.???????? 配置IP话机按照MAC认证方式进行认证。(如果不需要认证,这一步可以忽略)

操作步骤

步骤一 使能SwitchALLDP功能

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] lldp enable? //
全局使能LLDP后,所有接口默认自动使能LLDP

步骤二 配置SwitchA转发数据流功能

???????????????????????????? # 创建VLAN101

[SwitchA] vlan batch 101? //数据流使用VLAN 101进行通信

???????????????????????????? # 设置接口的PVIDVLAN 101

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid?? //
其中V200R005C00及之后版本,默认接口类型不是hybrid,需要手动配置
[SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 101?

???????????????????????????? # 接口以Untagged方式加入VLAN 101

[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 101
[SwitchA-GigabitEthernet1/0/1] quit

步骤三 配置SwitchAVoice VLAN功能

???????????????????????????? # 创建VLAN100

[SwitchA] vlan batch 100? //语音流使用VLAN 100进行通信

???????????????????????????? # 把接口加入语音VLAN

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid?? //
其中V200R005C00及之后版本,默认接口类型不是hybrid,需要手动配置
[SwitchA-GigabitEthernet1/0/1] port hybrid tagged vlan 100? //
接口以Tagged方式加入语音VLAN 100
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] port link-type hybrid
[SwitchA-GigabitEthernet1/0/2] port hybrid tagged vlan 100
[SwitchA-GigabitEthernet1/0/2] quit

?????????????????????????????# 使能接口的Voice VLAN功能。

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] voice-vlan 100 enable ?
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] voice-vlan 100 enable ?
[SwitchA-GigabitEthernet1/0/2] quit
[SwitchA] voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000? //V200R003
之前版本,需要配置OUI地址,该OUI对应IP话机的MAC地址。V200R003及之后版本不需要
[SwitchA] voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000

步骤四 配置DHCP RelayDHCP Server功能

1.???????? 配置SwitchADHCP Relay功能

# 配置接口的DHCP Relay功能。

[SwitchA] dhcp enable? //全局使能DHCP功能,缺省未使能
[SwitchA] interface Vlanif 100? //
创建VLANIF100
[SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0? //
配置VLANIF100IP地址
[SwitchA-Vlanif100] dhcp select relay? //
使能VLANIF接口DHCP中继功能
[SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2? //
配置DHCP中继所代理的DHCP服务器地址
[SwitchA-Vlanif100] quit

# 创建VLANIF 200

[SwitchA] vlan batch 200
[SwitchA] interface Vlanif 200
[SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0? //
配置VLANIF200IP地址,用于和SwitchB交互
[SwitchA-Vlanif200] quit

# 把上行接口加入VLAN 200

[SwitchA] interface gigabitethernet 1/0/3
[SwitchA-GigabitEthernet1/0/3] port link-type hybrid
[SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200
[SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200
[SwitchA-GigabitEthernet1/0/3] quit

# 配置缺省静态路由。

[SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2? //该路由的下一跳对应SwitchB VLANIF200IP地址

2.???????? 配置SwitchBDHCP Server,为IP话机分配IP地址

# 配置地址池。

<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] ip pool ip-phone? //
创建一个地址池
[SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1? //
配置DHCP服务器的出口网关地址
[SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0? //
配置该地址池可以分配的网段地址
[SwitchB-ip-pool-ip-phone] quit

# 配置DHCP Server功能。

[SwitchB] dhcp enable? //全局使能DHCP功能,缺省未使能
[SwitchB] vlan batch 200
[SwitchB] interface Vlanif 200? //
创建VLANIF200
[SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0? //
配置VLANIFIP地址
[SwitchB-Vlanif200] dhcp select global? //
配置接口采用全局地址池方式为话机分配IP地址
[SwitchB-Vlanif200] quit

# 把下行接口加入VLAN 200

[SwitchB] interface gigabitethernet 1/0/3
[SwitchB-GigabitEthernet1/0/3] port link-type hybrid
[SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200
[SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200
[SwitchB-GigabitEthernet1/0/3] quit

# 配置回程路由。

[SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

步骤五 配置AAA认证域,并配置IP话机按照MAC认证方式进行认证

1.???????? 配置AAA认证域

# 创建并配置RADIUS服务器模板。

[SwitchA] radius-server template cisco? //创建名为"cisco"RADIUS服务器模板
[SwitchA-radius-cisco] radius-server authentication 192.168.6.182 1812? //
配置RADIUS认证服务器的IP地址和端口号
[SwitchA-radius-cisco] radius-server accounting 192.168.6.182 1813? //
配置RADIUS计费服务器的IP地址和端口号
[SwitchA-radius-cisco] quit

# 配置认证方案。

[SwitchA] aaa
[SwitchA-aaa] authentication-scheme radius? //
创建AAA认证方案为“radius”
[SwitchA-aaa-authen-radius] authentication-mode radius? //
配置认证方式为RADIUS
[SwitchA-aaa-authen-radius] quit

# 创建AAA域并配置域的RADIUS服务器模板和认证方案。

[SwitchA-aaa] domain default? //配置default认证域
[SwitchA-aaa-domain-default] authentication-scheme radius? //
绑定AAA认证方案“radius”
[SwitchA-aaa-domain-default] radius-server cisco? //
绑定RADIUS服务器模板“cisco”
[SwitchA-aaa-domain-default] quit
[SwitchA-aaa] quit

2.???????? 配置PCIP话机按照MAC方式进行认证

??????????? V200R007C00及其之前版本、V200R008C00

# NAC配置模式切换成统一模式。

[SwitchA] authentication unified-mode? //设备默认为统一模式。传统模式与统一模式相互切换后,管理员必须保存配置后重启设备,新配置模式的各项功能才能生效

# 在接口上使能MAC认证。

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] authentication mac-authen? //
使能MAC认证
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] authentication mac-authen
[SwitchA-GigabitEthernet1/0/2] quit

??????????? V200R009C00及其之后版本

# NAC配置模式切换成统一模式。

[SwitchA] authentication unified-mode? //设备默认为统一模式。传统模式与统一模式相互切换后,管理员必须保存配置后重启设备,新配置模式的各项功能才能生效

# 配置接入模板。

[SwitchA] mac-access-profile name cisco? //创建MAC接入模板“cisco”
[SwitchA-mac-access-profile-cisco] quit

# 配置认证模板。

[SwitchA] authentication-profile name cisco? //配置认证模板
[SwitchA-authen-profile-cisco] mac-access-profile cisco? //
绑定MAC接入模板
[SwitchA-authen-profile-cisco] quit

# 在接口上应用认证模板。

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] authentication-profile cisco? //
绑定认证模板,使能MAC认证
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] authentication-profile cisco
[SwitchA-GigabitEthernet1/0/2] quit

3.????? 配置Agile ControllerAgile Controller界面显示版本间可能存在差异,请以实际为准。下面以V100R002C00SPC102版本为例,说明配置方法和配置步骤

a.???????? 登录Agile Controller

打开Internet Explorer浏览器,在地址栏输入Agile Controller的访问地址,并按“Enter”。

然后输入管理员帐号和密码。首次登录Agile Controller,请使用超级管理员帐号admin和密码Changeme123。首次登录之后请立即修改密码,否则无法使用Agile Controller

Agile Controller的访问地址支持以下形式:

访问方式

说明

https://Agile Controller-IP:8443

其中,“Agile Controller-IP”Agile ControllerIP地址。

Agile ControllerIP地址

如果在安装时启用了80端口,则允许不输入端口号。通过此种方式访问Agile ControllerURL地址将自动跳转为“https://Agile Controller-IP:8443”

?

b.???????? 增加MAC账号。

i.????????? 选择“资源 > 用户 > 用户管理”。

ii.??????? 在左侧导航中选择“所有账号”。

iii.????? 在右侧操作区域内单击“增加”,创建两个MAC账号。其中,第一个“MAC账号”使用的是IP话机的MAC地址,第二个“MAC账号”使用的是PCMAC地址。

20170106152951683007.png

20170106152952059008.png

c.???????? Agile Controller中添加交换机SwitchA

i.????????? 选择“资源 > 设备 > 设备管理”。

ii.??????? 在右侧操作区域内单击“增加”,在“增加设备”页面,增加对IP话机进行认证的交换机SwitchA

20170106152953638009.png

d.???????? Agile Controller中添加终端IP话机。

i.????????? 选择“资源 > 终端 > 终端列表”。

ii.??????? 在右侧操作区域内单击“增加”,进入“增加设备组”页面。

iii.????? 在“增加设备组”页面,增加终端IP话机组。

20170106152953222010.png

iv.?????? 单击左侧导航中的设备组,选择创建的设备组“cisco_ipphone”,然后选择“设备列表”,单击“增加”,添加IP话机。

20170106152954369011.png

e.???????? Agile Controller中添加终端PC

i.????????? 选择“资源 > 终端 > 终端列表”。

ii.??????? 在右侧操作区域内单击“增加”,进入“增加设备组”页面。

iii.????? 在“增加设备组”页面,增加终端PC组。

20170106152955206012.png

iv.?????? 单击左侧导航中的设备组,选择创建的设备组“pc”,然后选择“设备列表”,单击“增加”,添加PC

20170106152956743013.png

f.????????? 添加认证规则。

选择“策略 > 准入控制 > 认证授权 > 认证规则”,并单击“增加”,分别为IP话机和PC创建认证规则。

20170106152957970014.png

??????????????????????????????????????????20170106152958220015.png

g.???????? 添加授权规则。

选择“策略 > 准入控制 > 认证授权 > 授权规则”,并单击“增加”,分别为IP话机和PC创建授权规则。“授权结果”选择为“允许接入”。

20170106152959595016.png

????????????????????????????????????????? 20170106152959398017.png

步骤六 检查配置结果

l?? IP话机可以正常获取到正确的语音VLANIP地址。

l?? SwitchA上执行命令display access-user,可以看到IP话机的接入信息。

----结束

配置文件

l?? SwitchA的配置文件(V200R007C00及其之前版本、V200R008C00

#
sysname SwitchA
#
voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000
voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000
#
vlan batch 100 to 101 200
#
lldp enable
#
dhcp enable
#
radius-server template cisco
?radius-server authentication 192.168.6.182 1812 weight 80
?radius-server accounting 192.168.6.182 1813 weight 80
#
aaa
?authentication-scheme radius
? authentication-mode radius
?domain default
? authentication-scheme radius
? radius-server cisco
#
interface Vlanif100
?ip address 10.20.20.1 255.255.255.0
?dhcp select relay
?dhcp relay server-ip 10.10.20.2
#
interface Vlanif200
?ip address 10.10.20.1 255.255.255.0
#
interface GigabitEthernet1/0/1???????
?port link-type hybrid
?voice-vlan 100 enable
?port hybrid pvid vlan 101??????????????????????????????????????????????????????????????????????????????????????????????????????????
?port hybrid tagged vlan 100??????????????????????????????????????????????????????????????? ?????????????????????????????????????????
?port hybrid untagged vlan 101
?authentication mac-authen
#
interface GigabitEthernet1/0/2???????
?port link-type hybrid
?voice-vlan 100 enable
?port hybrid tagged vlan 100
?authentication mac-authen
#
interface GigabitEthernet1/0/3???????
?port link-type hybrid
?port hybrid pvid vlan 200
?port hybrid untagged vlan 200
#
ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
#
return

l?? SwitchA的配置文件(V200R009C00及其之后版本)

#
sysname SwitchA
#
vlan batch 100 to 101 200
#
authentication-profile name cisco
?mac-access-profile cisco
#
lldp enable
#
dhcp enable
#
radius-server template cisco
?radius-server authentication 192.168.6.182 1812 weight 80
?radius-server accounting 192.168.6.182 1813 weight 80
#
aaa
?authentication-scheme radius
? authentication-mode radius
?domain default
? authentication-scheme radius
? radius-server cisco
#
interface Vlanif100
?ip address 10.20.20.1 255.255.255.0
?dhcp select relay
?dhcp relay server-ip 10.10.20.2
#
interface Vlanif200
?ip address 10.10.20.1 255.255.255.0
#
interface GigabitEthernet1/0/1???????
?port link-type hybrid
?voice-vlan 100 enable
?port hybrid pvid vlan 101????????????????????????????????????????????????????????????????????????????????? ?????????????????????????
?port hybrid tagged vlan 100????????????????????????????????????????????????????????????????????????????????????????????????????????
?port hybrid untagged vlan 101
?authentication-profile cisco
#
interface GigabitEthernet1/0/2???????
?port link-type hybrid
?voice-vlan 100 enable
?port hybrid tagged vlan 100
?authentication-profile cisco
#
interface GigabitEthernet1/0/3???????
?port link-type hybrid
?port hybrid pvid vlan 200
?port hybrid untagged vlan 200
#
ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
#
mac-access-profile name cisco
#
return

l?? SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 200
#
dhcp enable
#
ip pool ip-phone
?gateway-list 10.20.20.1?
?network 10.20.20.0 mask 255.255.255.0?
#
interface Vlanif200
?ip address 10.10.20.2 255.255.255.0
?dhcp select global
#
interface GigabitEthernet1/0/3
?port link-type hybrid
?port hybrid pvid vlan 200
?port hybrid untagged vlan 200
#
ip route-static 10.20.20.0 255.255.255.0 10.10.20.1
#
return

?

如需下载文档,请点击? S1720&2700&S3700&S5700&S6700&S7700&S9700 对接专题资料

???????????????????????????????????? 想要了解更多精彩内容,请猛戳我:交换机在江湖汇总贴

???????????????????

本帖最后由 dota 于 2017-06-21 17:46 编辑

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
员Lemon
员Lemon  专家 发表于 2014-12-4 14:00:01 已赞(0) 赞(0)

好资料顶起来~~
  • x
  • 常规:

点评 回复

QoS
QoS  新锐 发表于 2014-12-10 15:47:18 已赞(0) 赞(0)

不错的资料,顶

  • x
  • 常规:

点评 回复

t00277996
t00277996   发表于 2014-12-10 15:52:21 已赞(0) 赞(0)

好资料,好好学习下。

  • x
  • 常规:

点评 回复

wheat1230
wheat1230   发表于 2014-12-10 16:01:56 已赞(0) 赞(0)

技术贴,学习了!
  • x
  • 常规:

点评 回复

kargay
kargay   发表于 2015-1-3 18:27:14 已赞(0) 赞(0)

学习了,去年给公司上过IP话机。
  • x
  • 常规:

点评 回复

user_177517
user_177517   发表于 2014-12-13 10:57:19 已赞(0) 赞(0)

我想知道,在交换机上开启了LLDP,默认话机上是有LLDP功能开启的,需要在话机上启用vlan并手动配置vlan ID么。因为我这边现场出现过一次这个问题,我开启了交换机的LLDP,下挂的所有话机全部不能用了。设备是华为的S5700和eSpace7910.
  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2014-12-16 09:25:03 已赞(0) 赞(0)

回复 8 楼

LLDP只能用于给话机分配VLAN,可是具体要分配哪个VLAN,还是需要在交换机上配置的哦。如果没有配置,LLDP报文默认携带的VLAN ID 是0 。 可以选择配置下面其中一条命令,设置VLAN ID。

1、

[HUAWEI-GigabitEthernet0/0/1]lldp tlv-enable med-tlv network-policy voice-vlan vlan 300    //配置分配的Voice VLAN300适用于V200R001C00及之后版本

2、

[HUAWEI-GigabitEthernet0/0/1] port port link-type hybrid

[HUAWEI-GigabitEthernet0/0/1] voice-vlan 300 enable

 

  • x
  • 常规:

点评 回复

user_177517
user_177517   发表于 2014-12-17 13:07:13 已赞(0) 赞(0)

回复 9 楼

能有个什么方式能直接对话么,邮件或打字可能说不太清楚,对于这个对接方面我还是有一点疑问。
  • x
  • 常规:

点评 回复

fcm
fcm  精英 发表于 2014-12-2 14:48:53 已赞(0) 赞(0)

学习一下,虽然IP电话接的时没有开这个功能!
  • x
  • 常规:

点评 回复

12
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录