【交换机在江湖】交换机与NLB服务器对接典型案例(四)

digest [复制链接]
发表于 : 2014-11-27 18:58:35 最新回复:2015-01-03 18:24:24
4515 2
交换机在江湖
交换机在江湖 官方号

? 配置堆叠系统对接NLB服务器群集示例(通过物理链路环回方法)

设备通过物理链路环回方法对接NLB服务器群集简介

NLB是微软在Windows Server上开发的多服务器群集负载均衡特性。交换机与NLB服务器群集相连时,NLB服务器要求交换机能够将目的IP地址是NLB服务器群集IP地址的报文发给NLB服务器群集中的每台服务器。NLB服务器可以工作在单播模式、组播模式和IGMP多播模式。

目前交换机仅支持与工作在单播模式或组播模式的NLB服务器互连。如果交换机支持多端口ARP功能,建议使用多端口ARP方法实现与NLB服务器群集对接。对于不支持多端口ARP的交换机形态和版本,并且设备不足时,用户可以采用物理链路环回的方法实现交换机与NLB服务器群集的对接。

配置注意事项

l?? NLB服务器群集工作在单播模式时,不需要在交换机上配置静态ARP表项;当NLB服务器群集工作在组播模式时,需要在交换机上配置静态ARP表项。

l?? 本举例适用于S系列交换机所有产品的所有版本。

组网需求

4-4所示,交换机Switch_1Switch_2组成堆叠系统,通过接口GE0/0/1GE1/0/1分别与两台NLB服务器直连。NLB服务器群集工作在组播模式下,群集IP地址为10.128.246.252/24,对应的群集MAC地址为03bf-0a80-f6fcSwitch与客户端Client之间路由可达。

用户希望网络中客户端Client访问NLB服务器群集时,堆叠系统能够将发往群集IP地址的报文发送给群集中的所有NLB服务器。

堆叠系统对接组播模式的NLB服务器群集

20170106113712627001.png

?

数据规划

在开始配置之前,需要规划好以下数据。

准备项

数据

说明

IP地址

VLANIF20010.128.246.250/24

配置思路

通过物理链路环回方法实现对接的配置思路如下:

1.???????? 配置与NLB服务器直连的接口GE0/0/1GE1/0/1加入VLAN100

2.???????? 配置接口GE0/0/4GE1/0/4加入Eth-Trunk4、接口GE0/0/5GE1/0/5加入Eth-Trunk5

3.???????? 去使能自环接口Eth-Trunk4Eth-Trunk5STP/RSTP/VBST/MSTP功能,并以Access类型分别加入VLAN100VLAN200

4.???????? 配置三层接口VLANIF200IP地址,VLANIF200作为NLB服务器群集的网关。

5.???????? 配置静态ARP表项。静态ARP表项的IP地址为群集IP地址,MAC地址为群集组播MAC,出接口为自环口上NLB服务器群集网关VLAN所在的接口。

6.???????? 连接接口GE0/0/4GE0/0/5GE1/0/4GE1/0/5

操作步骤

步骤一 配置与NLB直连的接口加入VLAN100

# 配置接口GE0/0/1加入VLAN100

<HUAWEI> system-view
[HUAWEI] sysname Stack
[Stack] vlan batch 100 200
[Stack] interface gigabitethernet 0/0/1
[Stack-GigabitEthernet0/0/1] port link-type access ?
[Stack-GigabitEthernet0/0/1] port default vlan 100
[Stack-GigabitEthernet0/0/1] quit

# 配置接口GE1/0/1加入VLAN100

[Stack] interface gigabitethernet 1/0/1
[Stack-GigabitEthernet1/0/1] port link-type access ?
[Stack-GigabitEthernet1/0/1] port default vlan 100
[Stack-GigabitEthernet1/0/1] quit

步骤二 配置接口加入Eth-Trunk

# 配置接口GE0/0/4GE1/0/4加入Eth-Trunk4

[Stack] interface eth-trunk 4
[Stack-Eth-Trunk4] quit
[Stack] interface gigabitethernet 0/0/4
[Stack-GigabitEthernet0/0/4] eth-trunk 4
[Stack-GigabitEthernet0/0/4] quit
[Stack] interface gigabitethernet 1/0/4
[Stack-GigabitEthernet1/0/4] eth-trunk 4
[Stack-GigabitEthernet1/0/4] quit

# 配置接口GE0/0/5GE1/0/5加入Eth-Trunk5

[Stack] interface eth-trunk 5
[Stack-Eth-Trunk5] quit
[Stack] interface gigabitethernet 0/0/5
[Stack-GigabitEthernet0/0/5] eth-trunk 5
[Stack-GigabitEthernet0/0/5] quit
[Stack] interface gigabitethernet 1/0/5
[Stack-GigabitEthernet1/0/5] eth-trunk 5
[Stack-GigabitEthernet1/0/5] quit

步骤三 配置自环口Eth-Trunk4Eth-Trunk5

# 去使能接口Eth-Trunk4Eth-Trunk5STP/RSTP/VBST/MSTP功能。

[Stack] interface eth-trunk 4
[Stack-Eth-Trunk4] undo stp enable? //
去使能STP/RSTP/VBST/MSTP功能
[Stack-Eth-Trunk4] quit
[Stack] interface eth-trunk 5
[Stack-Eth-Trunk5] undo stp enable? //
去使能STP/RSTP/VBST/MSTP功能
[Stack-Eth-Trunk5] quit

# 配置接口Eth-Trunk4Eth-Trunk5Access类型分别加入VLAN100VLAN200

[Stack] interface eth-trunk 4
[Stack-Eth-Trunk4] port link-type access
[Stack-Eth-Trunk4] port default vlan 100
[Stack-Eth-Trunk4] quit
[Stack] interface eth-trunk 5
[Stack-Eth-Trunk5] port link-type access
[Stack-Eth-Trunk5] port default vlan 200
[Stack-Eth-Trunk5] quit

步骤四 配置NLB服务器群集网关的IP地址

[Stack] interface vlanif 200
[Stack-Vlanif200] ip address 10.128.246.250 24
[Stack-Vlanif200] quit

步骤五 配置静态ARP表项,静态ARP表项的IP地址为群集IP地址10.128.246.252MAC地址为群集组播MAC地址03bf-0a80-f6fc,出接口为VLAN200所在的接口Eth-Trunk5

[Stack] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface eth-trunk 5 ??//配置静态ARP表项

步骤六 连接接口Switch_1上的GE0/0/4GE0/0/5Switch_2上的GE1/0/4GE1/0/5

上述配置完成后,进行物理连线。

步骤七 检查配置结果

上述配置完成后,发往NLB服务器群集IP地址的报文Server_1Server_2都能收到。

----结束

配置文件

Stack的配置文件

#
sysname Stack
#
vlan batch 100 200
#???????????????????????????????????????????????????????????????????????????????
interface Vlanif200?????????????????????????????????????????????????????????????
?ip address 10.128.246.250 255.255.255.0????????????????????????????????????????
#
interface Eth-Trunk4????????????????????????????????????????????????????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100??????????????????????????????????????????????????????????
?stp disable????????????????????????????????????????????????????????????????????
#????????????????????????????????????????????????????????????????????????????????
interface Eth-Trunk5????????????????????????????????????????????????????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 200??????????????????????????????????????????????????????????
?stp disable???????????? ????????????????????????????????????????????????????????
#????????????????????????????????????????????????????????????????????????????????
interface GigabitEthernet0/0/1?????????????????????????????????????????????????
?port link-type access???????????? ??????????????????????????????????????????????
?port default vlan 100???????????????????????????????????????????????
#?
interface GigabitEthernet0/0/4
?eth-trunk 4
#?
interface GigabitEthernet0/0/5
?eth-trunk 5
#?
interface GigabitEthernet1/0/1??? ??????????????????????????????????????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100????????????????????????????????????????????????
#????????????????????????????????????????????????????? ??????????????????????????
interface GigabitEthernet1/0/4?????????????????????????????????????????????????
?eth-trunk 4????????????????????????????????????????????????????????????????????
#???????????????????????????????????????????????????????????????? ???????????????
interface GigabitEthernet1/0/5?????????????????????????????????????????????????
?eth-trunk 5????????????????????????????????????????????????????????????????????
#
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface Eth-Trunk5?
#
return

?

????????????????????????????????????? 了解更多精彩内容,请猛戳我:交换机在江湖汇总贴

???????????????????

本帖最后由 交换机在江湖 于 2017-01-06 11:38 编辑

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
kargay
kargay   发表于 2015-1-3 18:24:24 已赞(0) 赞(0)

学习了,多谢。

  • x
  • 常规:

点评 回复

kmyd
kmyd  大师 发表于 2014-11-27 19:31:56 已赞(0) 赞(0)

学习了,感谢楼主!!
  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录