【交换机在江湖】交换机与NLB服务器对接典型案例(三)

[复制链接]
发表于 : 2014-11-25 19:33:57 最新回复:2015-01-03 18:20:19
5266 2
交换机在江湖
交换机在江湖 官方号

?配置VRRP备份组对接NLB服务器群集示例(通过物理链路环回方法)

设备通过物理链路环回方法对接NLB服务器群集简介

NLB是微软在Windows Server上开发的多服务器群集负载均衡特性。交换机与NLB服务器群集相连时,NLB服务器要求交换机能够将目的IP地址是NLB服务器群集IP地址的报文发给NLB服务器群集中的每台服务器。NLB服务器可以工作在单播模式、组播模式和IGMP多播模式。

目前交换机仅支持与工作在单播模式或组播模式的NLB服务器互连。如果交换机支持多端口ARP功能,建议使用多端口ARP方法实现与NLB服务器群集对接。对于不支持多端口ARP的交换机形态和版本,并且设备不足时,用户可以采用物理链路环回的方法实现交换机与NLB服务器群集的对接。

配置注意事项

l?? NLB服务器群集工作在单播模式时,不需要在交换机上配置静态ARP表项;当NLB服务器群集工作在组播模式时,需要在交换机上配置静态ARP表项。

l?? 本举例适用于S系列交换机所有产品的所有版本。

组网需求

4-3所示,交换机Switch_1Switch_2通过接口GE0/0/2相连的心跳线组成VRRP备份组,其中Switch_1为主、Switch_2为备。Switch_1Switch_2上的接口GE0/0/1分别与两台NLB服务器直连。NLB服务器群集工作在组播模式下,群集IP地址为10.128.246.252/24,对应的群集MAC地址为03bf-0a80-f6fcSwitch与客户端Client之间路由可达。

用户希望网络中客户端Client访问NLB服务器群集时,VRRP备份组能够将发往群集IP地址的报文发送给群集中的所有NLB服务器。

VRRP备份组对接组播模式的NLB服务器群集

20170106113144609001.png

?

数据规划

在开始配置之前,需要规划好以下数据。

准备项

数据

说明

IP地址

l? Switch_1VLANIF200:10.128.246.10/24

l? Switch_2VLANIF200:10.128.246.11/24

l? 虚拟IP地址:10.128.246.250

配置思路

通过物理链路环回方法实现对接的配置思路如下:

1.???????? 配置与NLB服务器直连的接口GE0/0/1加入VLAN100

2.???????? 配置心跳线接口GE0/0/2加入VLAN100

3.???????? 去使能自环接口GE0/0/4GE0/0/5STP/RSTP/VBST/MSTP功能,并以Access类型分别加入VLAN100VLAN200

4.???????? 配置三层接口VLANIF200VRRP虚拟IP地址,该VRRP虚拟IP地址作为NLB服务器群集的网关。

5.???????? 配置静态ARP表项。静态ARP表项的IP地址为群集IP地址,MAC地址为群集组播MAC,出接口为自环口上NLB服务器群集网关VLAN所在的接口。

6.???????? 连接自环接口GE0/0/4GE0/0/5

操作步骤

步骤一 配置与NLB直连的接口GE0/0/1

# Switch_1上配置接口GE0/0/1加入VLAN100

<HUAWEI> system-view
[HUAWEI] sysname Switch_1
[Switch_1] vlan batch 100 200
[Switch_1] interface gigabitethernet 0/0/1
[Switch_1-GigabitEthernet0/0/1] port link-type access
[Switch_1-GigabitEthernet0/0/1] port default vlan 100
[Switch_1-GigabitEthernet0/0/1] quit

# Switch_2上配置接口GE0/0/1加入VLAN100

<HUAWEI> system-view
[HUAWEI] sysname Switch_2
[Switch_2] vlan batch 100 200
[Switch_2] interface gigabitethernet 0/0/1
[Switch_2-GigabitEthernet0/0/1] port link-type access
[Switch_2-GigabitEthernet0/0/1] port default vlan 100
[Switch_2-GigabitEthernet0/0/1] quit

步骤二 配置心跳线接口GE0/0/2加入VLAN100

# Switch_1上配置接口GE0/0/2加入VLAN100

[Switch_1] interface gigabitethernet 0/0/2
[Switch_1-GigabitEthernet0/0/2] port link-type trunk ?
[Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
[Switch_1-GigabitEthernet0/0/2] quit

# Switch_2上配置接口GE0/0/2加入VLAN100

[Switch_2] interface gigabitethernet 0/0/2
[Switch_2-GigabitEthernet0/0/2] port link-type trunk ?
[Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
[Switch_2-GigabitEthernet0/0/2] quit

说明

心跳线接口不能加入自环口上网关所在的VLAN,防止流量在VRRP备份组设备间循环。例如,该举例中GE0/0/2不能加入VLAN200

步骤三 配置自环接口GE0/0/4GE0/0/5

# Switch_1上去使能接口GE0/0/4GE0/0/5STP/RSTP/VBST/MSTP功能。

[Switch_1] interface gigabitethernet 0/0/4
[Switch_1-GigabitEthernet0/0/4] undo stp enable? //
去使能STP/RSTP/VBST/MSTP功能
[Switch_1-GigabitEthernet0/0/4] quit
[Switch_1] interface gigabitethernet 0/0/5
[Switch_1-GigabitEthernet0/0/5] undo stp enable? //
去使能STP/RSTP/VBST/MSTP功能
[Switch_1-GigabitEthernet0/0/5] quit

# Switch_1上配置接口GE0/0/4GE0/0/5Access类型分别加入VLAN100VLAN200

[Switch_1] interface gigabitethernet 0/0/4
[Switch_1-GigabitEthernet0/0/4] port link-type access
[Switch_1-GigabitEthernet0/0/4] port default vlan 100
[Switch_1-GigabitEthernet0/0/4] quit
[Switch_1] interface gigabitethernet 0/0/5
[Switch_1-GigabitEthernet0/0/5] port link-type access
[Switch_1-GigabitEthernet0/0/5] port default vlan 200
[Switch_1-GigabitEthernet0/0/5] quit

# Switch_2上去使能接口GE0/0/4GE0/0/5STP/RSTP/VBST/MSTP功能。

[Switch_2] interface gigabitethernet 0/0/4
[Switch_2-GigabitEthernet0/0/4] undo stp enable? //
去使能STP/RSTP/VBST/MSTP功能
[Switch_2-GigabitEthernet0/0/4] quit
[Switch_2] interface gigabitethernet 0/0/5
[Switch_2-GigabitEthernet0/0/5] undo stp enable? //
去使能STP/RSTP/VBST/MSTP功能
[Switch_2-GigabitEthernet0/0/5] quit

# Switch_2上配置接口GE0/0/4GE0/0/5Access类型分别加入VLAN100VLAN200

[Switch_2] interface gigabitethernet 0/0/4
[Switch_2-GigabitEthernet0/0/4] port link-type access
[Switch_2-GigabitEthernet0/0/4] port default vlan 100
[Switch_2-GigabitEthernet0/0/4] quit
[Switch_2] interface gigabitethernet 0/0/5
[Switch_2-GigabitEthernet0/0/5] port link-type access
[Switch_2-GigabitEthernet0/0/5] port default vlan 200
[Switch_2-GigabitEthernet0/0/5] quit

步骤四 配置NLB服务器群集网关的IP地址

# Switch_1上创建VRRP备份组1,配置Switch_1在该备份组中的优先级为120

[Switch_1] interface vlanif 200
[Switch_1-Vlanif200] ip address 10.128.246.10 24
[Switch_1-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250? //
创建VRRP备份组1
[Switch_1-Vlanif200] vrrp vrid 1 priority 120 ??//
配置Switch_1在该备份组中的优先级为120
[Switch_1-Vlanif200] quit

# Switch_2上创建VRRP备份组1,配置Switch_2在该备份组中的优先级为缺省优先级100

[Switch_2] interface vlanif 200
[Switch_2-Vlanif200] ip address 10.128.246.11 24
[Switch_2-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250? //
创建VRRP备份组1
[Switch_2-Vlanif200] quit

说明

l? 三层接口VLANIF200下配置的VRRP虚拟IP地址(10.128.246.250)作为NLB服务器群集的网关。

l? 为减少网络负担,建议将NLB服务器群集的网关与其他服务器的网关分开。

这是因为在以上组网中,本端设备发往NLB服务器群集的流量会通过心跳线发往对端设备,并经过对端设备的自环线。此时,如果其他服务器与NLB服务器具有相同网关,会导致其他服务器也收到发往NLB服务器群集的流量,给网络增加负担。例如:由Switch_1发往群集IP的流量会通过心跳线发往Switch_2。在Switch_2上,由自环口GE0/0/4通过自环线到达GE0/0/5。如果此时Switch_2上的非NLB服务器的网关也是VLANIF200。该流量就会由自环口GE0/0/5发往非NLB服务器。

步骤五 配置静态ARP表项

# Switch_1上配置静态ARP表项的IP地址为群集IP地址10.128.246.252MAC地址为群集组播MAC地址03bf-0a80-f6fc,出接口为VLAN200所在的接口GE0/0/5

[Switch_1] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

# Switch_2上配置静态ARP表项的IP地址为群集IP地址10.128.246.252MAC地址为群集组播MAC地址03bf-0a80-f6fc,出接口为VLAN200所在的接口GE0/0/5

[Switch_2] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

步骤六 连接自环接口GE0/0/4GE0/0/5

上述配置完成后,在Switch_1Switch_2上分别进行物理连线。

步骤七 验证配置结果

上述配置完成后,发往NLB服务器群集IP地址的报文Server_1Server_2都能收到。

----结束

配置文件

l?? Switch_1的配置文件

#
sysname Switch_1
#
vlan batch 100 200
#???????????????????????????????????????????????????????????????????????????????
interface Vlanif200
?ip address 10.128.246.10 255.255.255.0?
?vrrp vrid 1 virtual-ip 10.128.246.250
?vrrp vrid 1 priority 120
#???????????????????????????????????????????????????????????????????????????????
interface GigabitEthernet0/0/1????????????????????????????????????? ????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100?????????????????????????????????????????????????
#?
interface GigabitEthernet0/0/2?????????????????????????????????????????????????
?port link-type trunk???????????????????????????????????????????????????????????
?port trunk allow-pass vlan 100?????????????????????????????????????????????????
#???????????????????????????????????????????????????????????????????????????????
interface GigabitEthernet0/0/4????????????????????????????????????????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100??????????????????????????????????????????????????????????
?stp disable???????????? ????????????????????????????????????????????????????????
#?
interface GigabitEthernet0/0/5????????????????????????????????????????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 200?????????? ????????????????????????????????????????????????
?stp disable????????????????????????????????????????????????????????????????????
#?
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5
#??
return

l?? Switch_2的配置文件

#
sysname Switch_2
#
vlan batch 100 200
#???????????????????????????????????????????????????????????????????????????????
interface Vlanif200
?ip address 10.128.246.11 255.255.255.0?
?vrrp vrid 1 virtual-ip 10.128.246.250
#????????????????????????????????????? ??????????????????????????????????????????
interface GigabitEthernet0/0/1?????????????????????????????????????????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100??????????????????????????? ?????????????????????
#?
interface GigabitEthernet0/0/2?????????????????????????????????????????????????
?port link-type trunk???????????????????????????????????????????????????????????
?port trunk allow-pass vlan 100??????????????????????????????????? ??????????????
#???????????????????????????????????????????????????????????????????????????????
interface GigabitEthernet0/0/4????????????????????????????????????????????????
?port link-type access???????????????????????????????????????????????????????? ??
?port default vlan 100??????????????????????????????????????????????????????????
?stp disable????????????????????????????????????????????????????????????????????
#?
interface GigabitEthernet0/0/5????????????????????????????????????????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 200??????????????????????????????????????????????????????????
?stp disable????????????????????????????????????????????????????????????????????
#?
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5
#??
return

?

?????????????????????????????????????????了解更多精彩内容,请猛戳我:交换机在江湖汇总贴

???????????????????

本帖最后由 交换机在江湖 于 2017-01-06 11:34 编辑

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
kargay
kargay   发表于 2015-1-3 18:20:19 已赞(0) 赞(0)

多谢提供教程。
  • x
  • 常规:

点评 回复

kmyd
kmyd  大师 发表于 2014-11-25 20:34:44 已赞(0) 赞(0)

好资料,学习了,感谢楼主!!
  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录