【交换机在江湖】交换机与NLB服务器对接典型案例(二)

digest [复制链接]
发表于 : 2014-11-18 15:22:20 最新回复:2019-08-21 09:50:50
8611 11
交换机在江湖
交换机在江湖 官方号

?配置单台设备对接NLB服务器群集示例(通过物理链路环回方法)

设备通过物理链路环回方法对接NLB服务器群集简介

NLB是微软在Windows Server上开发的多服务器群集负载均衡特性。交换机与NLB服务器群集相连时,NLB服务器要求交换机能够将目的IP地址是NLB服务器群集IP地址的报文发给NLB服务器群集中的每台服务器。NLB服务器可以工作在单播模式、组播模式和IGMP多播模式。

目前交换机仅支持与工作在单播模式或组播模式的NLB服务器互连。如果交换机支持多端口ARP功能,建议使用多端口ARP方法实现与NLB服务器群集对接。对于不支持多端口ARP的交换机形态和版本,并且设备不足时,用户可以采用物理链路环回的方法实现交换机与NLB服务器群集的对接。

配置注意事项

l?? NLB服务器群集工作在单播模式时,不需要在交换机上配置静态ARP表项;当NLB服务器群集工作在组播模式时,需要在交换机上配置静态ARP表项。

l?? 本举例适用于S系列交换机所有产品的所有版本。

组网需求

4-2所示,Switch通过接口GE0/0/1GE0/0/2GE0/0/3分别与三台NLB服务器直连。NLB服务器群集工作在单播模式下,群集IP地址为10.128.246.252/24,群集MAC地址为02bf-0a80-f6fcSwitch与客户端Client之间路由可达。

用户希望网络中客户端Client访问NLB服务器群集时,交换机Switch能够将发往群集IP地址的报文发送给群集中的所有NLB服务器。

单台设备对接单播模式的NLB服务器群集

20170106111308163001.png

?

配置思路

通过物理链路环回方法实现对接的配置思路如下:

1.???????? 配置与NLB服务器直连的接口GE0/0/1GE0/0/3加入VLAN100

2.???????? 去使能自环接口GE0/0/4GE0/0/5STP/RSTP/VBST/MSTP功能,并以Access类型分别加入VLAN100VLAN200

3.???????? 配置三层接口VLANIF200IP地址,VLANIF200作为NLB服务器群集的网关。

4.???????? 连接自环接口GE0/0/4GE0/0/5

操作步骤

步骤一 配置与NLB直连的接口GE0/0/1GE0/0/3加入VLAN100

<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] vlan batch 100 200
[Switch] interface gigabitethernet 0/0/1
[Switch-GigabitEthernet0/0/1] port link-type access
[Switch-GigabitEthernet0/0/1] quit
[Switch] interface gigabitethernet 0/0/2
[Switch-GigabitEthernet0/0/2] port link-type access
[Switch-GigabitEthernet0/0/2] quit
[Switch] interface gigabitethernet 0/0/3
[Switch-GigabitEthernet0/0/3] port link-type access
[Switch-GigabitEthernet0/0/3] quit
[Switch] vlan 100
[Switch-vlan100] port gigabitethernet 0/0/1 to 0/0/3
[Switch-vlan100] quit

步骤二 配置自环接口GE0/0/4GE0/0/5

??????????????????????????? # 去使能接口GE0/0/4GE0/0/5STP/RSTP/VBST/MSTP功能。

[Switch] interface gigabitethernet 0/0/4
[Switch-GigabitEthernet0/0/4] undo stp enable? //
去使能STP/RSTP/VBST/MSTP功能
[Switch-GigabitEthernet0/0/4] quit
[Switch] interface gigabitethernet 0/0/5
[Switch-GigabitEthernet0/0/5] undo stp enable? //
去使能STP/RSTP/VBST/MSTP功能
[Switch-GigabitEthernet0/0/5] quit

????????????????????????? # 配置接口GE0/0/4GE0/0/5Access类型分别加入VLAN100VLAN200

[Switch] interface gigabitethernet 0/0/4
[Switch-GigabitEthernet0/0/4] port link-type access
[Switch-GigabitEthernet0/0/4] port default vlan 100
[Switch-GigabitEthernet0/0/4] quit
[Switch] interface gigabitethernet 0/0/5
[Switch-GigabitEthernet0/0/5] port link-type access
[Switch-GigabitEthernet0/0/5] port default vlan 200
[Switch-GigabitEthernet0/0/5] quit

步骤三 配置NLB服务器群集网关的IP地址

[Switch] interface vlanif 200
[Switch-Vlanif200] ip address 10.128.246.250 24
[Switch-Vlanif200] quit

步骤四 连接自环接口GE0/0/4GE0/0/5

???????????????? 上述配置完成后,进行物理连线。

步骤五 验证配置结果

???????????????? 上述配置完成后,发往NLB服务器群集IP地址的报文Server_1Server_3都能收到。

----结束

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 100 200
#??????????????????????????????????????????????????????????????? ????????????????
interface Vlanif200?????????????????????????????????????????????????????????????
?ip address 10.128.246.250 255.255.255.0????????????????????????????????????????
#????????????????????????????????????????????????????????????????????????? ??????
interface GigabitEthernet0/0/1??????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100????????????????????????????????????????????????
#?
interface GigabitEthernet0/0/2??????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100??????????????????????????????????????????????????
#???????????????????????????????????????????????????????????????????????????????
interface GigabitEthernet0/0/3??????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100??????????????????????????????????????????????????
#????????????????????????????????????????????????????????????????????? ??????????
interface GigabitEthernet0/0/4??????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 100??????????????????????????????????????????????????????????
?stp disable?????????????????????? ??????????????????????????????????????????????
#?
interface GigabitEthernet0/0/5??????????????
?port link-type access??????????????????????????????????????????????????????????
?port default vlan 200?????????????????????????????????????????????????????? ????
?stp disable????????????????????????????????????????????????????????????????????
#?
return

?

?????????????????????????????????? 了解更多精彩内容,请猛戳我:交换机在江湖汇总贴

???????????????????

本帖最后由 交换机在江湖 于 2017-01-06 11:14 编辑

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
员Lemon
员Lemon  专家 发表于 2014-11-18 16:04:10 已赞(0) 赞(0)

多谢分享~
  • x
  • 常规:

点评 回复

kmyd
kmyd  大师 发表于 2014-11-18 18:07:06 已赞(0) 赞(0)

好资料,学习了,感谢楼主!!!
  • x
  • 常规:

点评 回复

DoubleDong
DoubleDong  新锐 发表于 2014-11-21 16:51:12 已赞(0) 赞(0)

学习了,不知道 这和服务器的负载均衡 SLB有啥区别?
  • x
  • 常规:

点评 回复

luwj
luwj  导师VIP 发表于 2014-11-21 16:57:29 已赞(0) 赞(0)

学习了,感谢楼主!!!
  • x
  • 常规:

点评 回复

kargay
kargay   发表于 2015-1-3 18:16:51 已赞(0) 赞(0)

不错,学习了。
  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2014-11-27 20:14:36 已赞(0) 赞(0)

回复 4 楼

SLB是框式交换机插了SPU单板支持的负载均衡;NLB是微软服务器之间用的网络负载均衡,用于使流量在服务器间均衡分布,我们这个技术帖是说交换机跟微软NLB服务器如何对接的
  • x
  • 常规:

点评 回复

suname_
suname_   发表于 2015-9-30 14:53:10 已赞(0) 赞(0)

不错的  用处大大的有

  • x
  • 常规:

点评 回复

TACwlan加油站
TACwlan加油站  精英 发表于 2016-3-16 14:49:40 已赞(0) 赞(0)

请问大神是否对NLB的虚地址如何设置网关有所了解?这里遇到一个跨网段NLB虚地址就不通的问题,应该是NLB虚地址没有设置网关导致的,实地址设置了网关都是可以通的

  • x
  • 常规:

点评 回复

kevinsf21
kevinsf21   发表于 2016-3-17 20:42:16 已赞(0) 赞(0)

回复 9 楼

这两天也遇到同样的问题,跨网段无法ping通群集ip,添加好静态arp仍失败.

  • x
  • 常规:

点评 回复

12
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录