【交换机在江湖】交换机与NLB服务器对接典型案例(一)

[复制链接]
发表于 : 2014-11-13 16:58:37 最新回复:2019-02-28 13:46:03
14487 20
交换机在江湖
交换机在江湖 官方号

配置设备对接NLB服务器群集示例(通过多端口ARP方法)?

多端口ARP简介

NLB是微软在Windows Server上开发的多服务器群集负载均衡特性。交换机与NLB服务器群集相连时,NLB服务器要求交换机能够将目的IP地址是NLB服务器群集IP地址的报文发给NLB服务器群集中的每台服务器。NLB服务器可以工作在单播模式、组播模式和IGMP多播模式。

目前交换机仅支持与工作在单播模式或组播模式的NLB服务器互连。通过在交换机上配置多端口ARP功能,可以实现交换机与NLB服务器对接。

对于不支持多端口ARP的交换机形态和版本,当交换机需要与NLB服务器群集连接时可以采用如下两种方法。

l?? 在交换机与NLB服务器之间增加二层交换机(当NLB服务器工作在组播模式时,需要在交换机上使能ARP动态学习组播MAC的功能或者配置静态ARP表项)。这种方法需要多增加一台二层交换机,适用于设备资源充足的情况。

l?? 物理链路环回方法。这种方法与增加二层交换机的方法相比,配置较复杂。

配置注意事项

l?? 接口加入的VLAN不能是MAC VLANSuper-VLAN、专线VLANX系列单板上的MUX VLANSEPSmart Ethernet Protection)和RRPPRapid Ring Protection Protocol)的控制VLAN

l?? SA系列单板(EH1D2X12SSA0单板除外)不支持多端口ARP功能。

l?? 当出接口为Eth-Trunk时,需要通过执行命令unknown-unicast load-balance enhanced,将接口配置为非已知单播负载分担方式,否则配置不生效。

l?? 适用的产品和版本如4-1所示。

举例适用的产品和版本

系列

产品

支持版本

S5700

S5700HI

V200R003C00V200R005(C00&C01)

S5710HI

V200R003C00V200R005(C00&C01)

S5710EI

V200R003C00V200R005(C00&C01)

S5720EI

V200R007C00V200R008C00V200R009C00V200R010C00

S5720HI

V200R006C00V200R007C00&C10)、V200R008C00V200R009C00V200R010C00

S6700

S6700EI

V200R003C00V200R005(C00&C01)

S6720EI

V200R008C00V200R009C00V200R010C00

S6720S-EI

V200R009C00V200R010C00

S7700

S7703S7706S7712

V200R003C00V200R005C00V200R006C00V200R007C00V200R008C00V200R009C00V200R010C00

S7710

V200R010C00

S9700

S9703S9706S9712

V200R003C00V200R005C00V200R006C00V200R007C00V200R008C00V200R009C00V200R010C00

?

说明

如需了解交换机软件配套详细信息,请参看华为以太网交换机版本配套速查

组网需求

4-1所示,Switch通过属于VLAN10的三个接口GE1/0/1GE1/0/2GE1/0/3分别连接三台NLB服务器。NLB服务器群集工作在组播模式。NLB服务器群集中每台服务器除了各自拥有一个IP地址和MAC地址外,还共同使用一个群集IP地址和群集MAC地址。NLB服务器的群集IP地址为10.128.246.252/24,对应的群集MAC地址为03bf-0a80-f6fcSwitch与客户端Client之间路由可达。

用户希望网络中客户端访问NLB服务器群集IP地址时,Switch能够将发往NLB服务器群集IP地址的报文发送给NLB服务器群集中的每台服务器。

配置多端口ARP组网图

20170106110513708002.png

?

配置思路

多端口ARP的配置思路如下:

1.???????? 配置接口IP地址,并将接口加入相应VLAN

2.???????? 配置对应多出接口的MAC地址表项,并配置静态ARP表项,实现Switch将发往NLB群集IP地址的报文发送给NLB群集内三台服务器。

操作步骤

步骤一 创建VLAN,并将接口加入到VLAN

# Switch上创建VLAN,并将接口加入到VLAN中。

<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] interface gigabitethernet 1/0/1
[Switch-GigabitEthernet1/0/1] port link-type access
[Switch-GigabitEthernet1/0/1] quit
[Switch] interface gigabitethernet 1/0/2
[Switch-GigabitEthernet1/0/2] port link-type access
[Switch-GigabitEthernet1/0/2] quit
[Switch] interface gigabitethernet 1/0/3
[Switch-GigabitEthernet1/0/3] port link-type access
[Switch-GigabitEthernet1/0/3] quit
[Switch] vlan 10
[Switch-vlan10] port gigabitethernet 1/0/1 to 1/0/3
[Switch-vlan10] quit

步骤二 在Switch上创建VLANIF接口,并配置IP地址

[Switch] interface vlanif 10
[Switch-Vlanif10] ip address 10.128.246.251 24
[Switch-Vlanif10] quit

步骤三 在Switch上配置对应多出接口的MAC地址表项

[Switch] mac-address multiport 03bf-0a80-f6fc interface gigabitethernet 1/0/1 to gigabitethernet 1/0/3 vlan 10? //配置对应多出接口的MAC地址表项

步骤四 在Switch上配置静态ARP表项

[Switch] arp static 10.128.246.252 03bf-0a80-f6fc? //此处必须配置短静态ARP表项
[Switch] quit

步骤五 验证配置结果

??????????????????????????? # Switch上使用display mac-address multiport vlan 10命令,查看已配置的对应多出接口的MAC地址表项信息。

<Switch> display mac-address multiport vlan 10
--------------------------------------------------------------------------------
MAC Address?????? VLANID??? Out-Interface?????????????? Status??
--------------------------------------------------------------------------------
03bf-0a80-f6fc??? 10??????? GigabitEthernet1/0/1??????? Active????????????????????????????????
??????????????????????????? GigabitEthernet1/0/2??????? Active?????????????????????????? ??????
??????????????????????????? GigabitEthernet1/0/3??????? Active????????????????????????????????
??????????????????????????????????????????? 3 port(s)???????????????????????????
--------------------------------------------------------------------------------
?Total Group(s) : 1?

????????????????????????????# Switch上使用display arp static命令,查看静态ARP表项信息。

<Switch> display arp static
IP ADDRESS????? MAC ADDRESS???? EXPIRE(M) TYPE??????? INTERFACE?? VPN-INSTANCE??
????????????????????????????????????????? VLAN/CEVLAN??????????? ????????????????
------------------------------------------------------------------------------
10.128.246.252? 03bf-0a80-f6fc??????????? S--???????? Multi-port:3????????????
------------------------------------------------------------------------------ ??
Total:1??????? Dynamic:0????? Static:1???? Interface:0?

----结束

配置文件

??????????????????????????? Switch的配置文件

#
sysname Switch
#
vlan batch 10?
#
interface Vlanif10
?ip address 10.128.246.251 255.255.255.0
#
interface GigabitEthernet1/0/1
?port link-type access
?port default vlan 10
?mac-address multiport 03bf-0a80-f6fc vlan 10?
#
interface GigabitEthernet1/0/2
?port link-type access
?port default vlan 10
?mac-address multiport 03bf-0a80-f6fc vlan 10
#
interface GigabitEthernet1/0/3
?port link-type access
?port default vlan 10
?mac-address multiport 03bf-0a80-f6fc vlan 10
#
arp static 10.128.246.252 03bf-0a80-f6fc
#
return

?

????????????????????????????????????? 了解更多精彩内容,请猛戳我:交换机在江湖汇总贴

???????????????????

本帖最后由 交换机在江湖 于 2017-01-06 11:39 编辑

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

本帖被以下专题推荐:

  • x
  • 常规:

点评 回复

跳转到指定楼层
DoubleDong
DoubleDong  新锐 发表于 2014-11-21 16:31:21 已赞(0) 赞(0)

学习了,支持一下!
  • x
  • 常规:

点评 回复

QoS
QoS  新锐 发表于 2014-12-10 15:47:43 已赞(0) 赞(0)

不错的资料,顶

  • x
  • 常规:

点评 回复

翻过心中的山
翻过心中的山   发表于 2014-12-10 16:07:58 已赞(0) 赞(0)

案例最好添加一个附件word的案例吧,方便下载
  • x
  • 常规:

点评 回复

luwj
luwj  导师VIP 发表于 2014-11-13 17:36:29 已赞(0) 赞(0)

案例图上集群IP地址都错了,应该是10.128.246.252/24才对。
  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2014-11-13 18:34:49 已赞(0) 赞(0)

回复 2 楼

大意了,已经修改。
  • x
  • 常规:

点评 回复

kmyd
kmyd  大师 发表于 2014-11-13 21:51:58 已赞(0) 赞(0)

终于支持了,要V2R5的版本吗?
  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2014-11-14 10:45:10 已赞(0) 赞(0)

回复 4 楼

不用,V200R003版本就可以了。
  • x
  • 常规:

点评 回复

doudou0628
doudou0628   发表于 2015-8-12 20:23:54 已赞(0) 赞(0)

目前我这边的环境是这样,2台物理服务器,每台物理服务器的三个网卡绑定成一个,只有一个IP地址和MAC地址,而2个exchange服务器是2台物理服务器下虚拟机(hyper-v),2台exchange做NLB,生成一个虚拟机IP地址和MAC地址。

请问,这种环境S5700-EI如何做对接?

  • x
  • 常规:

点评 回复

交换机在江湖
交换机在江湖 官方号 发表于 2015-8-13 14:38:27 已赞(0) 赞(0)

回复 9 楼

S5700EI不支持多端口ARP,可以参考如下对接案例

http://forum.huawei.com/enterprise/thread-267197.html

通过增加二层交换机或者物理链路环回方法实现与NLB服务器的对接

  • x
  • 常规:

点评 回复

123
返回列表
发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录