换个法子看电影--eNSP的组播功能模拟实验

digest [复制链接]
发表于 : 2012-9-19 10:23:24 最新回复:2020-01-18 10:45:15
53706 52
周常青
周常青  专家

一、 下载eNSP和vlc播放器

eNSP正式版本下载地址:http://download.huawei.com/edownload/enterprise/download!download.action?contentId=SW1000002740&contentType=SOFT&partNo=2001

VLC是开源软件下载地址是: http://www.videolan.org/vlc/download-windows.html


二、 安装vlc播放器

下载后自行安装即可,注意要记下安装目录,等下要用。如果下载的是ZIP压缩包,解压到任意目录即可。


三、 配置eNSP的vlc参数
菜单->工具->选项->工具配置 VLC后面指定你刚才安装的目录\vlc.exe


四、 如图搭建拓扑(也可自己定义,第一次推荐照着来)

 

五、 配置网络里的各设备

1 路由器的配置(可以贴进去):

sysname ar1220
multicast routing-enable  # 全局开启组播功能的命令
interface Ethernet0/0/0
 undo shutdown
 ip address 192.168.200.1 255.255.255.0
 pim sm                        #接组播服务器的接口下配置pim为稀疏模式
interface Ethernet0/0/1
 undo shutdown
 ip address 192.168.100.1 255.255.255.0
 pim sm                        #接三层交换机的接口下配置pim为稀疏模式

ospf 1                          #配置OSPF保证路由器和交换机之间的单播路由互通
 area 0.0.0.0
  network 192.168.100.0 0.0.0.255
  network 192.168.200.0 0.0.0.255

pim                              #路由器上配置pim的c-bsr(候选自举路由器)和c-rp(候选汇聚点)
 c-bsr priority 10
 c-bsr Ethernet0/0/0      #pim稀疏模式配置c-bsr,用来集中通告rp(组播相关概念的详细说明请查HedEx)
 c-rp priority 10
 c-rp Ethernet0/0/0        #pim稀疏模式配置c-rp,用来选举rp

 

2 交换机的配置(可以贴进去)


sysname sw5700
vlan batch 10 20 100    # 创建vlan

multicast routing-enable # 全局开启组播功能的命令

interface Vlanif10
 ip address 192.168.10.1 255.255.255.0
 pim sm                      #vlanif 10接口下开启pim稀疏模式
 igmp enable               #接组播客户端的接口开启igmp功能,默认是V2

interface Vlanif20
 ip address 192.168.20.1 255.255.255.0
 pim sm                      #vlanif 20接口下开启pim稀疏模式
 igmp enable               #接组播客户端的接口开启igmp功能,默认是V2

interface Vlanif100
 ip address 192.168.100.100 255.255.255.0
 pim sm                      #vlanif 100接口下开启pim稀疏模式,此接口是接路由器的,可以不开igmp功能

interface GigabitEthernet0/0/1
 port hybrid pvid vlan 100
 port hybrid untagged vlan 100

interface GigabitEthernet0/0/2
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10

interface GigabitEthernet0/0/3
 port hybrid pvid vlan 20
 port hybrid untagged vlan 20

ospf 1                             #配置OSPF保证路由器和交换机之间的单播路由互通
 area 0.0.0.0
  network 192.168.10.0 0.0.0.255
  network 192.168.20.0 0.0.0.255
  network 192.168.100.0 0.0.0.255

 

3配置MCS服务器

配置好了就点“运行”,此时可以看以服务器的视频播放。

4 配置PC1 (PC2类似)

配置好了点“加入” “启动VLC

这个时候应该可以看到PC上播放的视频了,和服务器是一样的(会有一点滞后)


七、验证参数


[ar1220]display pim interface     #可以看到本路由器上参与pim的接口
 VPN-Instance: public net
 Interface           State NbrCnt HelloInt   DR-Pri     DR-Address
 Eth0/0/0            up    0      30         1          192.168.200.1   (local) 

 Eth0/0/1            up    1      30         1          192.168.100.100

#pim上在以太网上要选DR,(local)表示是自己为DR

[ar1220]display pim neighbor # 路由器上看到的邻居是交换机192.168.100.100
 VPN-Instance: public net
 Total Number of Neighbors = 1

 Neighbor        Interface           Uptime   Expires  Dr-Priority
 192.168.100.100 Eth0/0/1            00:19:43 00:01:23 1   


[ar1220]dis pim routing-table   #查看pim组播路由表的命令,也可以用dis multicast routing-table 

 VPN-Instance: public net
 Total 1 (*, G) entry; 1 (S, G) entry

 (*, 225.1.1.1)
     RP: 192.168.200.1 (local)
     Protocol: pim-sm, Flag: WC 
     UpTime: 00:01:23
     Upstream interface: Register
         Upstream neighbor: NULL
         RPF prime neighbor: NULL
     Downstream interface(s) information:
     Total number of downstreams: 1
         1: Ethernet0/0/1
             Protocol: pim-sm, UpTime: 00:01:23, Expires: 00:03:06

 (192.168.200.200, 225.1.1.1)
     RP: 192.168.200.1 (local)
     Protocol: pim-sm, Flag: SPT 2MSDP LOC ACT 
     UpTime: 00:03:39
     Upstream interface: Ethernet0/0/0
         Upstream neighbor: NULL
         RPF prime neighbor: NULL
     Downstream interface(s) information:
     Total number of downstreams: 1
         1: Ethernet0/0/1
             Protocol: pim-sm, UpTime: 00:01:23, Expires: 00:03:06

  

[sw5700]dis pim rp-info   #查看rp的信息,交换机上可以看到rp是路由器192.168.200.1
 VPN-Instance: public net
 PIM-SM BSR RP Number:1
 Group/MaskLen: 224.0.0.0/4
     RP: 192.168.200.1   #这里可以看到rp的地址是192.168.200.1,优先级是10,候选RP的优先级越高越容易成为RP。
     Priority: 10
     Uptime: 00:18:37
     Expires: 00:01:36

[sw5700]dis multicast routing-table   #交换机上的组播路由表
Multicast routing table
 Total 1 entry

 00001. (192.168.200.200, 225.1.1.1)
       Uptime: 00:01:53
       Upstream Interface: Vlanif100  #组播来源的接口是vlan100
       List of 2 downstream interfaces  #组播流去向:vlan10 vlan20
           1:  Vlanif10
           2:  Vlanif20


[sw5700]display igmp interface #查看参与IGMP的接口
Interface information
 Vlanif10(192.168.10.1): 
   IGMP is enabled     # IGMP
   Current IGMP version is 2  #IGMP版本是2
   IGMP state: up
   IGMP group policy: none
   IGMP limit: -
   Value of query interval for IGMP (negotiated): -
   Value of query interval for IGMP (configured): 60 s
   Value of other querier timeout for IGMP: 0 s
   Value of maximum query response time for IGMP: 10 s
   Querier for IGMP: 192.168.10.1 (this router) #查询路由器是本路由器
  Total 1 IGMP Group reported

 Vlanif20(192.168.20.1): 
   IGMP is enabled
   Current IGMP version is 2
   IGMP state: up
   IGMP group policy: none
   IGMP limit: -
   Value of query interval for IGMP (negotiated): -
   Value of query interval for IGMP (configured): 60 s
   Value of other querier timeout for IGMP: 0 s
   Value of maximum query response time for IGMP: 10 s
   Querier for IGMP: 192.168.20.1 (this router)

 

  • x
  • 常规:

点评 回复

跳转到指定楼层
沐雨听风
沐雨听风   发表于 2013-5-16 14:10:54 已赞(0) 赞(0)

楼主很强大呀,希望经常出些小实验,让大家共同学习一下
  • x
  • 常规:

点评 回复

sofatfish
sofatfish   发表于 2012-9-29 10:32:51 已赞(0) 赞(0)

这样都可以?!支持楼主的创新。
  • x
  • 常规:

点评 回复

guolichuanbj
guolichuanbj  导师 发表于 2013-3-28 22:36:38 已赞(0) 赞(0)

回复 16 楼

这个跟VLC播放器有关,在WIN7必须以管理员的身份运行,才可以!
  • x
  • 常规:

点评 回复

goldfox
goldfox   发表于 2013-3-29 10:04:50 已赞(0) 赞(0)

回复 18 楼

多谢,我已经模拟成功!
  • x
  • 常规:

点评 回复

习惯发呆
习惯发呆  新锐 发表于 2013-5-20 10:48:51 已赞(0) 赞(0)

学习了~  多谢~~~~~~
  • x
  • 常规:

点评 回复

chsyn
chsyn   发表于 2012-11-16 10:21:21 已赞(0) 赞(0)

顶,楼主真是个高手,学习了。
  • x
  • 常规:

点评 回复

CIS_006315
CIS_006315   发表于 2012-11-19 11:30:26 已赞(0) 赞(0)

按照上面方法做了几次,现象模拟不出来,不知道问题出在哪?没组播流量,

是不是不支持WIN7操作系统:

Windows version

Windows XP SP2, 2003 SP2, Vista SP1, 2008 SP1, 7 and 8

 

 

后来又测试了几次,有声音,没图像

  • x
  • 常规:

点评 回复

hiking
hiking  专家 发表于 2013-10-10 15:47:38 已赞(0) 赞(0)

[ar1220]dis pim routing-table   #查看pim组播路由表的命令,也可以用dis multicast routing-table 

查询不到任何信息,请问是何问题?? 谢谢
  • x
  • 常规:

点评 回复

qingqing6
qingqing6  精英 发表于 2013-1-4 11:12:51 已赞(0) 赞(0)

按照上面方法做了几次,现象模拟不出来,不知道问题出在哪?没组播流量。

 

 

请注意设置模拟器里面“电脑”的“目的mac”要和“组播源”的“组播组MAC地址”一样。用3700交换机来做模拟器里面的电脑可以拼通192.168.200.200组播服务器地址以及192.168.10.1,但是使用5700交换机来做电脑就无法拼通任何地址,但是组播可以实现正常接收播放。

 

 

  • x
  • 常规:

点评 回复

发表回复
您需要登录后才可以回帖 登录 | 注册

警告 内容安全提示:尊敬的用户您好,为了保障您、社区及第三方的合法权益,请勿发布可能给各方带来法律风险的内容,包括但不限于政治敏感内容,涉黄赌毒内容,泄露、侵犯他人商业秘密的内容,侵犯他人商标、版本、专利等知识产权的内容,侵犯个人隐私的内容等。也请勿向他人共享您的账号及密码,通过您的账号执行的所有操作,将视同您本人的行为,由您本人承担操作后果。详情请参看“隐私声明
如果附件按钮无法使用,请将Adobe Flash Player 更新到最新版本!
登录参与交流分享

登录参与交流分享

登录