Настройка IP FRR на маршрутизаторах Huawei

270 0 0 0

Рассмотрим настройку IP Fast reroute на примере простой топологии:

ip frr

На AR1 настроим IP FRR для быстрого переключения трафика с интерфейса GE 0/0/0 на Serial 0/0/0. Перейдем к базовой настройке:

AR1
interface LoopBack 0
   ip address 1.1.1.1 32
interface GigabitEthernet 0/0/0
   ip address 192.168.1.1 24
interface Serial 0/0/0
   ip address 192.168.3.1 24
ospf 1
   area 0
      network 1.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255

AR2
interface GigabitEthernet 0/0/0
   ip address 192.168.1.2 24
interface GigabitEthernet 0/0/1
   ip address 192.168.2.2 24
ospf 1
   area 0
network 192.168.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255

AR3
interface Serial 0/0/0
   ip address 192.168.3.2 24
interface Serial 0/0/1
   ip address 192.168.4.2 24
ospf 1
   area 0
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255

AR4
interface LoopBack 0
   ip address 4.4.4.4 32
interface GigabitEthernet 0/0/1
   ip address 192.168.2.1 24
interface Serial 0/0/1
   ip address 192.168.3.1 24
ospf 1
   area 0
      network 4.4.4.4 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.4.0 0.0.0.255

Проверимтаблицу маршрутизациина AR1:

[AR1] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
                  Destinations : 11               Routes : 11

Destination/Mask     Proto     Pre     Cost    Flags   NextHop       Interface

            1.1.1.1/32     Direct     0         0         D       127.0.0.1        LoopBack0
            4.4.4.4/32     OSPF    10        2         D       192.168.1.2    GigabitEthernet0/0/0
          127.0.0.0/8     Direct     0         0         D       127.0.0.1        InLoopBack0
        127.0.0.1/32
     Direct     0         0         D       127.0.0.1        InLoopBack0
    192.168.1.0/24 
    Direct     0         0         D       192.168.1.1    GigabitEthernet0/0/0
    192.168.1.1/32     Direct     0         0         D       127.0.0.1        GigabitEthernet0/0/0
    192.168.2.0/24
     OSPF    10        2         D       192.168.1.2    GigabitEthernet0/0/0
    192.168.3.0/24
     Direct     0        0          D       192.168.3.1    Serial0/0/0
    192.168.3.1/32
     Direct     0        0          D       127.0.0.1        Serial0/0/0
    192.168.3.2/32
     Direct     0        0          D       192.168.3.2    Serial0/0/0
    192.168.4.0/24
     OSPF    10       3124     D       192.168.3.2    Serial0/0/0

[AR1] display ip routing-table 4.4.4.4 verbose
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Table : Public
Summary Count : 1

Destination: 4.4.4.4/32
          Protocol:               OSPF Process ID: 1
      Preference:                               10 Cost: 2
        NextHop: 192.168.1.2      Neighbour: 0.0.0.0
               State: Active Adv                  Age: 00h04m56s
                  Tag: 0                            Priority: medium
               Label: NULL                  QoSInfo: 0x0
       IndirectID: 0x0 
RelayNextHop: 0.0.0.0                 Interface: GigabitEthernet0/0/0
         TunnelID: 0x0                           Flags: D

Видим, что до сети 4.4.4.4 маршрутизатор AR1 предпочитает маршрут, проходящий через AR2.

Теперь настроим на AR1 переключение трафика на запасной линк, без ожидания управляющего уровня. Делать мы это будем при помощи route policy:

ip ip-prefix frr index 10 permit 4.4.4.4 32

route-policy frr permit node 10
   if-match ip-prefix frr
   apply backup-nexthop 192.168.3.2
   apply backup-interface Serial 0/0/0

Идалее активируемфункцию fast reroute для нашейполитики:

ip frr route-policy frr

Теперь проверим, что изменилось в маршрутизации:

[AR1] display ip routing-table 4.4.4.4 verbose
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Table : Public
Summary Count : 1

Destination: 4.4.4.4/32
            Protocol: OSPF                Process ID: 1
        Preference: 10                               Cost: 2
           NextHop: 192.168.1.2      Neighbour: 0.0.0.0
                  State: Active Adv                 Age: 00h07m02s
                    Tag: 0                            Priority: medium
                 Label: NULL                  QoSInfo: 0x0
         IndirectID: 0x0
  RelayNextHop: 0.0.0.0                 Interface: GigabitEthernet0/0/0
           TunnelID: 0x0                           Flags: D
      BkNextHop: 192.168.3.2  BkInterface: Serial0/0/0
             BkLabel: NULL          SecTunnelID: 0x0
  BkPETunnelID: 0x0      BkPESecTunnelID: 0x0
     BkIndirectID: 0x0

Как видим, в маршруте до 4.4.4.4 теперь присутствует интерфейс Serial0/0/0 в качестве запасного. Если произойдет обрыв основного линка, то весь трафик будет незамедлительно перенаправлен на AR3.

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход
Быстрый ответ Вверх