BGP local preference

Опубликовано 2019-4-11 17:01:49 360 0 1 0

Атрибут Local Preference используется для управления исходящим трафиком BGP.

Характеристики атрибута Local preference:

1.    Указывает маршрутизаторам внутри автономной системы как выйти за её пределы.

2.    Этот атрибут передается только в пределах одной автономной системы.

3.    По умолчанию значение атрибута - 100.

4.    Точкой выхода из автономной системы будет тот маршрутизатор, у которого значение атрибута больше.

5.    Если eBGP-сосед получает обновление с выставленным значением local preference, он игнорирует этот атрибут.

Разберем атрибут Local preference на примере следующей топологии:

 bgp_lclpref

1.  AR1, AR2 и AR3 находятся в AS 50.

2. AR4находится в AS 500.

3. BGPобъявляет интерфейс loopback 1 маршрутизатора AR1 и loopback 0 маршрутизатора AR4.

В данном примере мы проверим работу параметра default local preference, который будет определять оптимальный маршрут для трафика, покидающего AS50. В нашем случае, мы сделаем так, что весь трафик покидающий AS 50 будет идти через AR3. Если BGP устройство получает несколько маршрутов от разных соседей и эти маршруты ведут в одно и тоже место назначения, то BGP устройство выберет маршрут с наибольшим значением local preference.

Настройки устройств выглядят следующим образом:

AR1

interface LoopBack0
               ip address 1.1.1.1 32
interface LoopBack1
               ip address 10.10.10.10 32

bgp 50
undo synchronization
undo summary automatic
group iBGP internal
peer iBGP next-hop-local
peer 10.1.1.2 group iBGP
peer 10.1.2.2 group iBGP
network 10.10.10.10 255.255.255.255

interface GigabitEthernet 0/0/0
               ip address 10.1.1.1 30

interface GigabitEthernet 0/0/1
               ip address 10.1.2.1 30

AR2

bgp 50
undo synchronization
undo summary automatic
group iBGP internal
peer iBGP next-hop-local
peer 10.1.1.1 group iBGP
peer 10.1.3.2 group iBGP
peer 5.1.1.2 as-number 500
network 5.1.1.0 255.255.255.252
default local-preference 200

interface GigabitEthernet 0/0/0
               ip address 10.1.1.2 30

interface GigabitEthernet 0/0/2
               ip address 10.1.3.1 30

interface GigabitEthernet 0/0/3
               ip address 5.1.1.1 30

AR3

bgp 50
undo synchronization
undo summary automatic
group iBGP internal
peer iBGP next-hop-local
peer 10.1.2.1 group iBGP
peer 10.1.3.1 group iBGP
peer 5.2.2.2 as-number 500
network 5.2.2.0 255.255.255.252
default local-preference 300

interface GigabitEthernet 0/0/1
               ip address 10.1.2.2 30

interface GigabitEthernet 0/0/2
               ip address 10.1.3.2 30

interface GigabitEthernet 0/0/3
               ip address 5.2.2.1 30

AR4

interface LoopBack0
               ip address 4.4.4.4 32

bgp 500
undo synchronization
undo summary automatic
peer 5.1.1.1 as-number 50
peer 5.2.2.1 as-number 50
network 4.4.4.4 255.255.255.255

interface GigabitEthernet 0/0/0
               ip address 5.1.1.2 30

interface GigabitEthernet 0/0/1
               ip address 5.2.2.2 30

Проверим IP и BGP таблицы маршрутизации на маршрутизаторе AR1:

[AR1] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
                  Destinations : 11               Routes : 11

Destination/Mask    Proto   Pre   Cost    Flags   NextHop     Interface

             1.1.1.1/32   Direct   0       0         D       127.0.0.1     LoopBack0
             4.4.4.4/32   IBGP   255    0         RD    10.1.1.2       GigabitEthernet0/0/0
             5.1.1.0/30   IBGP   255    0         RD    10.1.1.2       GigabitEthernet0/0/0
             5.2.2.0/30   IBGP   255    0         RD    10.1.2.2       GigabitEthernet0/0/1
           10.1.1.0/30   Direct   0       0         D       10.1.1.1       GigabitEthernet0/0/0
           10.1.1.1/32   Direct   0       0         D       127.0.0.1     GigabitEthernet0/0/0
           10.1.2.0/30   Direct   0       0         D       10.1.2.1       GigabitEthernet0/0/1
           10.1.2.1/32   Direct   0       0         D       127.0.0.1     GigabitEthernet0/0/1
     10.10.10.10/32   Direct   0       0         D       127.0.0.1     LoopBack1
           127.0.0.0/8   Direct   0       0         D       127.0.0.1     InLoopBack0
         127.0.0.1/32   Direct   0       0         D       127.0.0.1     InLoopBack0

[AR1] display bgp routing-table

BGP Local router ID is 1.1.1.1
  Status codes: * - valid, > - best, d - damped,
                             h - history, i - internal, s - suppressed, S - Stale
                             Origin : i - IGP, e - EGP, ? - incomplete

  Total Number of Routes: 5
            Network             NextHop      MED      LocPrf    PrefVal    Path/Ogn

*>i       4.4.4.4/32           10.1.1.2         0             100           0            500i
* i                                   10.1.2.2         0             100           0            500i
*>i       5.1.1.0/30           10.1.1.2         0             100           0              i
*>i       5.2.2.0/30           10.1.2.2         0             100           0              i
*>        10.10.10.10/32    0.0.0.0          0                              0              i

Как видим, в IP таблице маршрутизации, loopback0 маршрутизатора AR4 доступен через 10.1.1.2 AR2. В BGP таблице маршрутизации, мы видим, что до сети 4.4.4.4/32 есть два выхода. Обратим внимание на столбец LocPrf. В нашем случае, оба выхода имеют одинаковые значения (100). Попробуем поменять их, тогда BGP сможет выбрать наилучший маршрут в зависимости от величины параметра local preference:

[AR2]bgp 50
          default local-preference 200


[AR3]bgp 50
          default local-preference 300

Теперь снова проверим IP и BGP таблицы маршрутизации на AR1:

[AR1] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
                  Destinations : 11                Routes : 11

Destination/Mask   Proto   Pre   Cost   Flags   NextHop    Interface

            1.1.1.1/32   Direct   0       0        D       127.0.0.1    LoopBack0
            4.4.4.4/32   IBGP   255    0        RD    10.1.2.2      GigabitEthernet0/0/1
            5.1.1.0/30   IBGP   255    0        RD    10.1.1.2      GigabitEthernet0/0/0
            5.2.2.0/30   IBGP   255    0        RD    10.1.2.2      GigabitEthernet0/0/1
          10.1.1.0/30   Direct   0       0        D       10.1.1.1      GigabitEthernet0/0/0
          10.1.1.1/32   Direct   0       0        D       127.0.0.1    GigabitEthernet0/0/0
          10.1.2.0/30   Direct   0       0        D       10.1.2.1      GigabitEthernet0/0/1
          10.1.2.1/32   Direct   0       0        D       127.0.0.1    GigabitEthernet0/0/1
    10.10.10.10/32   Direct   0       0        D       127.0.0.1    LoopBack1
          127.0.0.0/8   Direct   0       0        D       127.0.0.1    InLoopBack0
        127.0.0.1/32   Direct   0       0        D       127.0.0.1    InLoopBack0

[AR1] display bgp routing-table

BGP Local router ID is 1.1.1.1
  Status codes: * - valid, > - best, d - damped,
                             h - history, i - internal, s - suppressed, S - Stale
                             Origin : i - IGP, e - EGP, ? - incomplete

  Total Number of Routes: 4
            Network              NextHop    MED    LocPrf    PrefVal   Path/Ogn

*>i       4.4.4.4/32           10.1.2.2      0           300          0              500i
*>i       5.1.1.0/30           10.1.1.2      0           200          0               i
*>i       5.2.2.0/30           10.1.2.2      0           300          0               i
*>        10.10.10.10/32    0.0.0.0       0                           0               i

Запустим трассировку до AR4 и посмотрим как пойдет трафик:

[AR1] tracert -a 10.10.10.10 4.4.4.4
traceroute to 4.4.4.4(4.4.4.4), max hops: 30 ,packet length: 40,press CTRL_C to break
1  10.1.2.2  30 ms 30 ms 60 ms
2  5.2.2.2    90 ms 90 ms 80 ms

Вывод показывает, что весь трафик выходящий из AS 50 идет через маршрутизатор AR3.

Теперь посмотрим IP таблицу маршрутизации на маршрутизаторе AR4:

[AR4] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
                  Destinations : 8 Routes : 8

Destination/Mask   Proto    Pre    Cost   Flags   NextHop   Interface

             4.4.4.4/32   Direct   0        0       D        127.0.0.1   LoopBack0
             5.1.1.0/30   Direct   0        0       D        5.1.1.2       GigabitEthernet0/0/0
             5.1.1.2/32   Direct   0        0       D        127.0.0.1   GigabitEthernet0/0/0
             5.2.2.0/30   Direct   0        0       D        5.2.2.2       GigabitEthernet0/0/1
             5.2.2.2/32   Direct   0        0       D        127.0.0.1   GigabitEthernet0/0/1
     10.10.10.10/32   EBGP   255    0       D        5.1.1.1       GigabitEthernet0/0/0
           127.0.0.0/8   Direct   0        0       D        127.0.0.1   InLoopBack0
         127.0.0.1/32   Direct   0        0       D        127.0.0.1   InLoopBack0

Как видим, трафик из AS 500 идет через маршрутизатор AR2. Из этого можем сделать вывод, что параметр BGP local preference влияет только на исходящий из AS трафик.

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Быстрый ответ Вверх