[FAQ] Пример настройки selective QinQ

Опубликовано 2019-4-4 10:09:31 275 0 2 1

Продолжим рассмотрение технологии QinQ. Selective QinQ предоставляет возможность избирательного добавления Outer Vlan тега в зависимости от тега Inner Vlan. Основной областью применения selective QinQ является организация в сети передачи данных схемы предоставления услуг “Vlan на сервис”.

В данном примере у нас одна корпоративная сеть с офисами в разных городах. Для разделения сервисов, в каждом офисе создано по 2 Vlan. Задача – трафик должен свободно передаваться из одного офиса в другой через сеть провайдера, также у пользователей из Vlan 10 не должно быть доступа в Vlan 20 и наоборот.

Топология

1

Конфигурация

1. Сначала настроим коммутаторы C и D. Настройки будут идентичны.

vlan batch 10 20
#
interface GigabitEthernet0/0/2
   port link-type access
   port default vlan 10

#
interface GigabitEthernet0/0/3
   port link-type access
   port default vlan 20

#
interface GigabitEthernet0/0/1
   port hybrid tagged vlan 10 20

2. Создадим Vlan 100 и 200 на остальных коммутаторах.

[SwitchA]  vlan batch 100 200
[SwitchB]  vlan batch 100 200
[ISP]  vlan batch 100 200

3. Разрешим передачу Vlan 100 и 200 между коммутаторами сети провайдера.

[SwitchA] interface GigabitEthernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type trunk
[SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 200
[SwitchB] interface GigabitEthernet 0/0/3
[SwitchB-GigabitEthernet0/0/3] port link-type trunk
[SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 200
[ISP] interface GigabitEthernet 0/0/2
[ISP-GigabitEthernet0/0/2] port link-type trunk
[ISP-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 200
[ISP] interface GigabitEthernet 0/0/3
[ISP-GigabitEthernet0/0/3] port link-type trunk
[ISP-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 200

4. Настраиваем selective QinQ на интерфейсах коммутаторов A и B. Настройки идентичны.

[SwitchA]interface GigabitEthernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] qinq vlan-translation enable
[SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 100 200
[SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 10 stack-vlan 100
[SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 20 stack-vlan 200

Selective QinQ рекомендуется использовать на hybrid интерфейсах и только для входящих пакетов. Все внешниеVlan теги удаляются и пакет будет передан как 802.1q пакет.

5. Проверим связь между PC в одном Vlan.

Vlan10_PC1>ping 192.168.10.2

Ping 192.168.10.2: 32 data bytes, Press Ctrl_C to break
From 192.168.10.2: bytes=32 seq=1 ttl=128 time=187 ms
From 192.168.10.2: bytes=32 seq=2 ttl=128 time=156 ms
From 192.168.10.2: bytes=32 seq=3 ttl=128 time=219 ms
From 192.168.10.2: bytes=32 seq=4 ttl=128 time=203 ms
From 192.168.10.2: bytes=32 seq=5 ttl=128 time=235 ms

--- 192.168.10.2 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 156/200/235 ms
Vlan20_PC1>ping 192.168.20.2

Ping 192.168.20.2: 32 data bytes, Press Ctrl_C to break
From 192.168.20.2: bytes=32 seq=1 ttl=128 time=203 ms
From 192.168.20.2: bytes=32 seq=2 ttl=128 time=172 ms
From 192.168.20.2: bytes=32 seq=3 ttl=128 time=203 ms
From 192.168.20.2: bytes=32 seq=4 ttl=128 time=203 ms
From 192.168.20.2: bytes=32 seq=5 ttl=128 time=203 ms

--- 192.168.20.2 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 172/196/203 ms

Также проверим, связь между PC в разныхVlan.

Vlan10_PC1>ping 172.16.20.2

Ping 172.16.20.2: 32 data bytes, Press Ctrl_C to break
From 172.16.10.1: Destination host unreachable

 

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход
Быстрый ответ Вверх