[Info] Между устройствами не устанавливается lldp соединение

Опубликовано 2019-3-11 20:44:00 880 0 1 0
084542tzyr2ra7rn72201y

Описание проблемы

Между коммутаторами A и C не устанавливается lldp соседство.

 

Файлы конфигурации

SwitchA
interface Vlanif 20
   ip address 1.1.1.1 255.255.255.0
interface Eth-Trunk100
interface Ethernet 0/0/0/0
   ip address 10.220.7.128 255.255.254.0
interface GigabitEthernet 1/1/1/23
   port link-type access
   port default vlan 20
ip route-static 0.0.0.0 0.0.0.0 10.220.6.1

SwitchB
interface Vlanif 20
   ip address 1.1.1.2 255.255.255.0
interface Vlanif 220
   ip address 10.220.7.121 255.255.254.0
interface Ethernet 0/0/23
   port link-type access
   port default vlan 20
   l2protocol-tunnel lldp enable
interface Ethernet 0/0/24
   port link-type access
   port default vlan 20
   l2protocol-tunnel lldp enable
interface GigabitEthernet 0/0/2
   port link-type trunk
   port trunk pvid vlan 220
   undo port trunk allow-pass vlan 1
   port trunk allow-pass vlan 220
ip route-static 0.0.0.0 0.0.0.0 10.220.6.1 

SwitchC
vlan batch 20 103 220
interface Vlanif 20
   ip address 2.1.1.1 255.255.255.0
interface Eth 0/0/1
   ip address 10.220.7.122 255.255.254.0
interface GigabitEthernet 0/0/24
   port link-type access
   port default vlan 20
ip route-static 0.0.0.0 0.0.0.0 10.220.6.1
ip route-static 1.1.1.0 255.255.255.0 2.1.1.2

Перейдем к решению проблемы

Шаг 1 Введем команду display lldp neighbor brief и проверим статус lldp соседства на каждом устройстве.

<SwitchA> display lldp neighbor brief
Local Intf     Neighbor Dev              Neighbor Intf       Exptime(s)
GE1/1/1/23      SwitchB                   Ethernet0/0/24          103

<SwitchB> display lldp neighbor brief
Local Intf           Neighbor Dev              Neighbor Intf       Exptime(s)
Ethernet0/0/23       SwitchA                   GE1/1/1/23           118
Ethernet0/0/24       SwitchC                   GE0/0/24              103

<SwitchC> display lldp neighbor brief
Local Intf Neighbor Dev Neighbor Intf Exptime(s)
GE0/0/24 SwitchB Ethernet0/0/24 113

Как видим, коммутаторы A и C не могут обмениваться друг с другом lldp сообщениями.

Шаг 2 Введем команду display l2protocol-tunnel statistics и проверим статистику передаваемых Layer 2 пакетов на коммутаторе B.

<SwitchB> display l2protocol-tunnel statistics Ethernet 0/0/23 lldp
--------------------------------------------------------------------------------
Port                  Protocol              Drop     Input       Output      Drop
                                            Threshold  Packets      Packets  Packets
--------------------------------------------------------------------------------
Ethernet0/0/23      lldp                    0          0                0            0

<SwitchB> display l2protocol-tunnel statistics Ethernet 0/0/24 lldp
--------------------------------------------------------------------------------
Port                  Protocol            Drop      Input        Output      Drop
                                          Threshold   Packets      Packets   Packets
--------------------------------------------------------------------------------
Ethernet0/0/24     lldp                  0            0                0           0 

Как видим, через коммутатор B не проходят lldp сообщения.

Шаг 3 Введем команду display current-configuration и проверим настройку layer 2 protocol transparent transmission на коммутаторе B:

Во-первых, должен быть указан групповой мультикаст MAC адрес для прозрачной передачи сообщений lldp.

Во-вторых, на интерфейсах, подключенных к коммутаторам A и C, должна быть разрешена передача lldp сообщений.

#
interface Ethernet0/0/23
port link-type access
port default vlan 20
l2protocol-tunnel lldp enable
#
interface Ethernet0/0/24
port link-type access
port default vlan 20
l2protocol-tunnel lldp enable
#

Как видим, на коммутаторе B забыли указать групповой мультикаст MAC.

Добавим его командой l2protocol-tunnel lldp group-mac xxxx-xxxx-xxxx.

Но не забывайте, что следующие адреса нельзя использовать:

§ MAC адреса назначения BPDU сообщений: от 0180-C200-0000 до 0180-C200-002F

§ MAC адрес назначения Smart Link пакетов: 010F-E200-0004

§ Особые мультикаст MAC адреса: 0100-0CCC-CCCC и 0100-0CCC-CCCD

§ Обычные мультикаст MAC адреса, используемые на оборудовании

[SwitchB] l2protocol-tunnel lldp group-mac 0100-0100-0100

Теперь снова дадим команду display lldp neighbor brief на коммутаторах A и C:

<SwitchA> display lldp neighbor brief
Local Intf      Neighbor Dev    Neighbor Intf      Exptime(s)
GE1/1/1/23    SwitchC            GE0/0/24             103

<SwitchC> display lldp neighbor brief
Local Intf      Neighbor Dev    Neighbor Intf      Exptime(s)
GE0/0/24       SwitchA            GE1/1/1/23          112

Как видим, коммутаторы A и C установили соседство и обмениваются lldp сообщениями.

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание! Внимание! С целью защиты ваших юридических прав и интересов, а также прав и интересов сообщества и третьих лиц не публикуйте контент, который может создавать правовые риски для всех сторон. К такому контенту может относиться, помимо прочего, контент, содержащий политически неоднозначные высказывания, информацию порнографического характера, рекламу азартных игр, наркотиков или запрещенного товара; контент, раскрывающий объекты интеллектуальной собственности или нарушающий права интеллектуальной собственности третьих лиц, включая коммерческие тайны, товарные знаки, авторские и патентные права, персональные и конфиденциальные данные. Не предоставляйте данные вашего аккаунта и пароля другим лицам. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом, и за их последствия.“Более подробную информацию читайте в Заявлении о конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Быстрый ответ Вверх