[FAQ] Не передаются маршруты после установки OSPF соседства

Опубликовано 2019-2-11 22:12:27 615 0 0 0

Описание ошибки
Коммутатор Huawei не получает маршруты после установления OSPF соседства с коммутатором Cisco.

Физическая топология сети
 123

Конфигурация
  S5720_A
sysname S5720_A 
vlan batch 10 20 
cluster enable 
ntdp enable 
ndp enable 
drop illegal-mac alarm 
diffserv domain default 
drop-profile default 
aaa 
 authentication-scheme default 
 authorization-scheme default 
 accounting-scheme default 
 domain default 
 domain default_admin 
 local-user admin password simple admin 
 local-user admin service-type http 
interface Vlanif1 
interface Vlanif10 
 ip address 192.168.1.254 255.255.255.0 
interface Vlanif20 
 ip address 192.168.12.1 255.255.255.0 
interface MEth0/0/1 
interface GigabitEthernet0/0/1 
 port link-type access 
 port default vlan 10 
interface GigabitEthernet0/0/2 
 port link-type access 
 port default vlan 20 
interface NULL0 
ospf 1 router-id 1.1.1.1 
 area 0.0.0.0 
  network 192.168.1.0 0.0.0.255 
  network 192.168.12.0 0.0.0.255 
user-interface con 0 
user-interface vty 0 4 

  S5720_B
sysname S5720_B 
vlan batch 30 40 
cluster enable 
ntdp enable 
ndp enable 
drop illegal-mac alarm 
diffserv domain default 
drop-profile default 
aaa 
 authentication-scheme default 
 authorization-scheme default 
 accounting-scheme default 
 domain default 
 domain default_admin 
 local-user admin password simple admin 
 local-user admin service-type http 
interface Vlanif1 
interface Vlanif30 
 ip address 192.168.23.1 255.255.255.0 
interface Vlanif40 
 ip address 192.168.2.254 255.255.255.0 
interface MEth0/0/1 
interface GigabitEthernet0/0/1 
 port link-type access 
 port default vlan 30 
interface GigabitEthernet0/0/2 
 port link-type access 
 port default vlan 40 
interface NULL0 
ospf 1 router-id 3.3.3.3 
 area 0.0.0.0 
  network 192.168.23.0 0.0.0.255 
  network 192.168.2.0 0.0.0.255 
user-interface con 0 
user-interface vty 0 4 

Вывод команды display ip routing-table показывает, что коммутатор не получает маршруты с Cisco.
[S5720_A] display ip routing-table 
Route Flags: R - relay, D - download to fib 
------------------------------------------------------------------------------ 
Routing Tables: Public 
         Destinations : 5        Routes : 5         
 
Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
 
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0 
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0 
    192.168.1.0/24  Direct  0    0           D   192.168.1.254   Vlanif10 
  192.168.1.254/32  Direct  0    0           D   127.0.0.1       Vlanif10 
    192.168.2.0/24  OSPF    10   3           D   192.168.12.2    Vlanif20 

Процесс устранения проблемы

Шаг 1      Проверьте статус OSPF соседства.
Введите команду display ospf peer чтобы проверить было ли установлено OSPF соседство.
[S5720_A] display ospf peer  
 
     OSPF Process 1 with Router ID 1.1.1.1 
         Neighbors  
 
 Area 0.0.0.0 interface 192.168.12.1(Vlanif20)'s neighbors 
 Router ID: 2.2.2.2          Address: 192.168.12.2     
   State: Full  Mode:Nbr is  Master  Priority: 1 
   DR: None   BDR: None   MTU: 0     
   Dead timer due in 34  sec  
   Retrans timer interval: 5  
   Neighbor is up for 00:03:08      
   Authentication Sequence: [ 0 ]
Вывод показывает, что OSPF соседство было установлено и его статус Full.

Шаг 2      Проверьте базу данных состояния каналов OSPF (LSDB).
Введите команду display ospf lsdb чтобы проверить содержит ли OSPF LSDB информацию о маршрутах.
[S5720_A] display ospf lsdb  
 
     OSPF Process 1 with Router ID 1.1.1.1 
         Link State Database  
 
                 Area: 0.0.0.0 
 Type      LinkState ID    AdvRouter          Age  Len   Sequence   Metric 
 Router    2.2.2.2         2.2.2.2            454  60    80000016       1 
 Router    1.1.1.1         1.1.1.1            453  60    80000017       1 
 Router    3.3.3.3         3.3.3.3           1609  48    8000000B       1 
 Network   192.168.23.2    2.2.2.2           1598  32    80000002       0
Вывод показывает, что LSDB содержит информацию о маршрутах.

Шаг 3      Проверьте подробную информацию в OSPF LSDB.
Введите команду display ospf lsdb <link-state-id>.
[S5720_A] display ospf lsdb router 1.1.1.1 
 
     OSPF Process 1 with Router ID 1.1.1.1 
                 Area: 0.0.0.0 
         Link State Database  
 
 
  Type      : Router 
  Ls id     : 1.1.1.1 
  Adv rtr   : 1.1.1.1   
  Ls age    : 21  
  Len       : 48  
  Options   :  E   
  seq#      : 80000019  
  chksum    : 0xf947 
  Link count: 2 
   * Link ID: 192.168.1.0   
     Data   : 255.255.255.0  
     Link Type: StubNet       
     Metric : 1  
     Priority : Low 
   * Link ID: 192.168.12.0  
     Data   : 255.255.255.0  
     Link Type: StubNet       
     Metric : 1  
     Priority : Low

[S5720_A] display ospf lsdb router 2.2.2.2 
 
    OSPF Process 1 with Router ID 1.1.1.1 
                Area: 0.0.0.0 
        Link State Database  
 
 
  Type      : Router 
  Ls id     : 2.2.2.2 
  Adv rtr   : 2.2.2.2   
  Ls age    : 633  
  Len       : 60  
  Options   :  E   
  seq#      : 80000016  
  chksum    : 0x315 
  Link count: 3 
   * Link ID: 1.1.1.1       
     Data   : 192.168.12.2  
     Link Type: P-2-P         
     Metric : 1 
   * Link ID: 192.168.12.0  
     Data   : 255.255.255.0  
     Link Type: StubNet       
     Metric : 1  
     Priority : Low 
   * Link ID: 192.168.23.2  
     Data   : 192.168.23.2  
     Link Type: TransNet      
     Metric : 1

Решение: Необходимо настроить на коммутаторе Huawei зону такого же типа, как на коммутаторе Cisco.
[S5720_A] interface vlanif 20 
[S5720_A-Vlanif20] ospf network p2p

После выполнения предыдущей команды, наберите команду display ip routing-table чтобы проверить IPv4 таблицу маршрутизации, теперь доступны маршруты с устройства Cisco.
[S5720_A] display ip routing-table 
Route Flags: R - relay, D - download to fib 
------------------------------------------------------------------------------ 
Routing Tables: Public 
         Destinations : 8        Routes : 8         
 
Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
 
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0 
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0 
    192.168.1.0/24  Direct  0    0           D   192.168.1.254   Vlanif10 
  192.168.1.254/32  Direct  0    0           D   127.0.0.1       Vlanif10 
    192.168.2.0/24  OSPF    10   3           D   192.168.12.2    Vlanif20 
   192.168.12.0/24  Direct  0    0           D   192.168.12.1    Vlanif20 
   192.168.12.1/32  Direct  0    0           D   127.0.0.1       Vlanif20 
   192.168.23.0/24  OSPF    10   2           D   192.168.12.2    Vlanif20

Основная причина
Ошибка в настройке типов OSPF сетей на соединенных между собой коммутаторах Huawei и Cisco.


Этот пост был последний раз изменен пользователем user_3299877 в 2019-2-11 22:44.

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Быстрый ответ Вверх