port-security

Опубликовано 2019-11-29 07:04:51Последний ответ ноя 29, 2019 13:43:00 186 11 0 0
  Награжденные Форбаллы: 0 (Проблема решена)

Добрый день!

Ситуация странная. На порту свича, пользователи получают и данные и телефонию. Но так же на портах настроен port-security, где количество маков ограничено, всего 2. Но некоторым пользователям, необходимо что бы на порту было три мака. Схема Телефон-ПК-МФУ. Вот и проблема 2 мака забирает телефон. Почему так происходит?


Конфиг порта: vl 110 - телефония. vl 8 - данные.

interface Ethernet0/0/14

voice-vlan 110 enable

voice-vlan mode manual

undo voice-vlan security enable

port hybrid pvid vlan 8

port hybrid untagged vlan 8 110

port-security enable

port-security max-mac-num 3

port-security mac-address sticky 


Смотрим маки:

[...Ethernet0/0/14]dis mac-add sticky ethe 0/0/14


805e-c02a-da74 8/-                               Eth0/0/14           sticky

b42e-995e-1802 8/-                               Eth0/0/14           sticky

805e-c02a-da74 110/-                             Eth0/0/14           sticky   


Спасибо

  • x

Избранные ответы
Alexey
Модератор Опубликовано 2019-11-29 09:38:02 Полезно(0) Полезно(0)

Добрый день.
Это нормальное поведение:)

Телефон ВСЕГДА использует 2 vlan'a, если нет доп настроек.

Первый "сигнальный" фрейм идет по дефолтному вилану 8. Потом уже переходит в 110. Я могу ошибаться, но помоему есть еще команда для port-secure для voice vlan'a.

  • x

artemrus38
artemrus38 Опубликовано 2019-11-29 09:47
Спасибо за совет, но к сожалению, нет такой команды. Думаю, придется руками прописывать маки, где будет возникать подобная ситуация  
Все ответы
Peterhof
Peterhof Опубликовано 2019-11-29 07:15:44 Полезно(0) Полезно(0)
Доброе утро!
Мне кажется, что проблема может быть в
port hybrid untagged vlan 8 110
снятии тега со 110 VLAN при отправке его клиентским устройствам. Если телефон умеет его сам ставить, то нужно его скорее в tagged записать. А 8 оставить для более "глупых" в сетевом плане устройств.
  • x

artemrus38
artemrus38 Опубликовано 2019-11-29 08:33
Да, телефон умеет работать как с тегом, так и без него. Сейчас переписал порт, ситуация не изменилась. Так же 3 мака и определяется.  
Peterhof
Peterhof Опубликовано 2019-11-29 09:05
Если телефон будет работать с тегами, то он не должен больше попадать в 8 vlan, но нужно 110 маркировать. Может он без тега шлёт пакет и тогда он метиться pvid. А потом не удаляется.  
artemrus38
artemrus38 Ответить Peterhof  Опубликовано 2019-11-29 09:48
как его маркировать?  
Peterhof
Peterhof Ответить artemrus38  Опубликовано 2019-11-29 10:05
port hybrid tagged vlan 110  
artemrus38
artemrus38 Ответить Peterhof  Опубликовано 2019-11-29 11:59
тогда отмаркировал этот vlan  
I%20am%20an%20IT%20engineer%20in%20the%20State%20Museum%20Reserve%20Peterhof.%20My%20job%20is%20keeping%20alive%20our%20network%2C%20servers%20and%20storages%20solutions%20and%20also%20preparing%20for%20purchasing%20new%20equipment%20and%20server%20software.
Alexey
Alexey Модератор Опубликовано 2019-11-29 09:38:02 Полезно(0) Полезно(0)

Добрый день.
Это нормальное поведение:)

Телефон ВСЕГДА использует 2 vlan'a, если нет доп настроек.

Первый "сигнальный" фрейм идет по дефолтному вилану 8. Потом уже переходит в 110. Я могу ошибаться, но помоему есть еще команда для port-secure для voice vlan'a.

  • x

artemrus38
artemrus38 Опубликовано 2019-11-29 09:47
Спасибо за совет, но к сожалению, нет такой команды. Думаю, придется руками прописывать маки, где будет возникать подобная ситуация  
artemrus38
artemrus38 Опубликовано 2019-11-29 11:33:11 Полезно(0) Полезно(0)
В общем пришлось руками настраивать маки. Но проблема другая появилась. При настройки портов и включении телефонов, коммутатор почему то стал отваливаться по управлению. На каждом порту поднят stp edged-port Похожая ситуация происходит, когда коммутаторы в STP работают и подключаешь новый в сеть.
При этом логи чистые, loopback не отрабатывает, про stp тоже ничего не пишет. Где можно еще глянуть, что бы увидеть, в чем проблема? Или возможно механизм поднять?
  • x

Alexey
Alexey Модератор Опубликовано 2019-11-29 13:43:00 Полезно(0) Полезно(0)
При падении порта нет никаких логов? Он падает окончательно или сам восстанавливается? Что значит loopback не отрабатывает? Если настроен port-security - то смотреть по какой причине он отключился спец коммандами. Если поднялся по sh, undo sh, то проблема в port-security. А какие настройки интерфейса?
  • x

artemrus38
artemrus38 Опубликовано 2019-11-30 06:21
К сожалению, ни какой информации в логах нет. Что происходит в такие моменты, неизвестно, и пока мне не понятно. Loopback думал сработает, потому что на некоторых портах подключен hub. Вдруг петля.  

Комментарий

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход