Huawei AR2220 и Cisco CME. Разрыв соединения через 5-6 сек. Протокол Н323.

Последний ответ окт 18, 2018 14:15:36 420 1 1 0
Добрый день.
Топология обеих сети  следующая:


УАТС1 (E1) -> ECisco1760 -> H323 -> Huawei2220 E1 -> (Е1) УАТС2

На Cisco и Huawei зарегистрированы SIP телефоны. Проблема в следующем: если позвонить с SIP телефона зарегистрированного на  Cisco1760 в сторону УАТС2 то происходит разрыв соединения, которое похоже инициирует Huawei2220. 
План нумерации со стороны Cisco1760 -УАТС1 №716100 (100),  SIP телефон №716200
План нумерации со стороны Huawei2220- УАТС2 №714500 (500),  SIP телефон №714400
т.е разрывается звонок если позвонить с 716200 на 714500, все остальные варианты работают без проблем.
конфиг Huawei
[V200R007C00SPCb00]
#
 sysname Huiwei
#
 board add 0/1 2VE1-MFT 
#
 drop illegal-mac alarm
#
 clock source 1 1/0/0 priority 1
#
 clock timezone MoscowStPetersburgVolgograd add 03:00:00
#
ipv6
#
dns resolve  
dns proxy enable
#
 set workmode slot 1 e1t1 e1-voice
#
dhcp enable
#
pki realm default
 enrollment self-signed
#
interface GigabitEthernet0/0/0
 ip address 10.43.31.252 255.255.255.0
#
interface GigabitEthernet0/0/1
 ip address 10.43.27.1 255.255.255.0
#
interface GigabitEthernet0/0/2
voice 
 voip-address media interface GigabitEthernet 0/0/0 10.43.31.252
 voip-address signalling interface GigabitEthernet 0/0/0 10.43.31.252
 pbx default-country-code 7 default-area-code 8332
 #
 h323-attribute
  localip 10.43.31.252
 #
 dsp-attribute
  rtcp vqm enable
  silence enable
 #
 callroute Route716
 #
 callroute RouteE1
 #
 callroute RouteGK
 #                                        
 enterprise default
 #
 sipserver
  signalling-address ip 10.43.31.252 port 5060
  media-ip 10.43.31.252
  register-uri Huiwei
  home-domain Huiwei
 #
 trunk-group 716 h323 symmetrical
  callroute Route716
  media-ip 10.43.31.252
  peer-address static 10.43.29.1 1720
 #
 trunk-group 7T h323 symmetrical
  callroute RouteGK
  media-ip 10.43.31.252
  peer-address static 10.43.31.253 1720
 #
 trunk-group AlmazE1 dss1-net
  outgoing-right all
  callroute RouteE1 
  trunk-pra 1/0/0
 #
 callprefix 4xx                           
  prefix 4
  call-type catego****asic-service attribute 0
  digit-length 3 32
 #
 callprefix 5xx
  prefix 5
  call-type catego****asic-service attribute 1
  digit-length 3 32
  callroute RouteE1
 #
 callprefix 7144xx
  prefix 7144
  call-type catego****asic-service attribute 0
  digit-length 4 32
 #
 callprefix 7145xx
  prefix 7145
  call-type catego****asic-service attribute 1
  digit-length 4 6
  callroute RouteE1
 #
 callprefix 716xxx
  prefix 716
  call-type catego****asic-service attribute 1
  digit-length 3 32
  callroute Route716
 #
 callprefix 7T
  prefix 7
  call-type catego****asic-service attribute 1
  digit-length 3 32
  callroute RouteGK
 #
 pbxuser 400 sipue
  sipue 400
  telno 400
  call-right out all
  eid-para password cipher %^%#k~~(#Q,!1Mu@8W0n<iz@WJ*R&:eK^0)xeK~+L'nW%^%#
  service-right mwi disable
 #
 pbxuser 414 sipue
  sipue 414
  telno 414
  call-right out all
  eid-para password cipher %^%#{"cf4L@Rh~!"{}SCKbd;!w8^LYNIGMZ@.28|wiUK%^%#
 #
 beforeroute-change sipfhone
  callprefix 7144xx                       
  caller no-change
  called del 1 3
 #
 afterroute-change add714aon
  callprefix 7T
  trunk-group 7T
  caller insert 1 714
  called no-change
 #
 afterroute-change add714aon716
  callprefix 716xxx
  trunk-group 716
  caller insert 1 714
  called no-change
 #
 diagnose
#
ops
#
autostart
#
return

конфиг Cisco1760
hostname Router
!
boot-start-marker
boot system flash c1700-entservicesk9-mz.124-15.T10.bin
boot-end-marker


clock timezone MSK 3
tdm clock E1 1/0 both export line
voice-card 1
!
voice-card 3
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.43.29.1 10.43.29.191
ip dhcp excluded-address 10.43.29.224 10.43.29.255
!
ip dhcp pool voice-pool
   network 10.43.29.0 255.255.255.0
   default-router 10.43.29.1 
   lease 0 4
!
!
multilink bundle-name authenticated
isdn switch-type primary-qsig
!
!
voice call send-alert
voice call carrier capacity active
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 h323
 sip
  bind control source-interface Vlan10
  bind media source-interface Vlan10
  registrar server expires max 3600 min 3600
!
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g729br8
 codec preference 3 g711alaw
 codec preference 4 g711ulaw
 codec preference 5 clear-channel
!
!
!
!
!
!
!
voice register global
 mode cme
 source-address 10.43.29.1 port 5060
 max-dn 144
 max-pool 24
!
voice register dn  1
 number 200
!
voice register dn  2
 number 201
!
voice register pool  1
 id mac 0026.8B01.93CE
 number 1 dn 1
 voice-class codec 1
 username 200 password 123456
!
voice register pool  2
 id mac 0026.8B01.9850
 number 1 dn 2
 voice-class codec 1
 username 201 password 123456
!
!
voice translation-rule 1
 rule 2 /^2/ /7162/
!
voice translation-rule 2
 rule 2 /^7162/ /2/
!
!
voice translation-profile 2xx
 translate called 2
!
voice translation-profile 716clip
 translate calling 1
!
voice translation-profile clip
 translate calling 2
!
!
interface FastEthernet0/0
 ip address 10.43.31.24 255.255.255.0
 speed auto
 service-policy output Voice-policy
!
interface FastEthernet0/1
 switchport access vlan 10
!
interface FastEthernet0/2
 switchport access vlan 10
!
interface FastEthernet0/3
 switchport access vlan 10
!
interface FastEthernet0/4
 switchport access vlan 10
!
interface Serial1/0:15
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-qsig
 isdn timer T310 120000
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 10.43.29.1 255.255.255.0
 h323-gateway voip interface
 h323-gateway voip id GK-Test ipaddr 10.43.31.253 1719
 h323-gateway voip h323-id gw-test
 h323-gateway voip tech-prefix 6#
 h323-gateway voip bind srcaddr 10.43.29.1
!         
voice-port 3/0
 supervisory disconnect dualtone mid-call
 cptone RU
 timeouts call-disconnect 5
!         
voice-port 3/1
 cptone RU
!         
voice-port 1/0:15
 cptone RU
 timeouts interdigit 2
!         
!         
!         
!         
!         
!         
dial-peer voice 716 pots
 destination-pattern 716...
 direct-inward-dial
 port 1/0:15
!         
dial-peer voice 1000 voip
 translation-profile outgoing 716clip
 destination-pattern .T
 voice-class codec 1
 session target ras
 dtmf-relay h245-signal
 ip qos dscp cs5 media
 no vad   
!         
dial-peer voice 1 voip
 translation-profile incoming 2xx
 incoming called-number 7162..
!         
dial-peer voice 714 voip
 destination-pattern 714...
 session target ipv4:10.43.31.252
 no vad   
!         
gateway   
 timer receive-rtp 1200

@
Т.е. при наборе 714500 звонок уходит через dial-peer voice 714 voip по Н323.
        31 ORG     T6     g729r8      VOIP        P714500     10.43.31.252:62712   D7F  
        30 ANS     T6     g729r8      VOIP        P200     10.43.29.192:10014   D7F  
Данная проблема в разных вариациях возникает если использовать схему с Gatekeeper на этом же Huawei2220 или Cisco 3745 - а именно разрываются звонки между  SIP телефонами и УАТС в одном направлении, в обратном направлении звонок не обрывается; соединения SIP телефон-SIP телефон, УАТС1-УАТС2 работают без проблем.

К сожалению информации по этой теме не нашел, надеюсь на вашу помощь.
  • x

user_2968737
Опубликовано 2018-10-18 14:15:36 Полезно(1) Полезно(1)
Привет! С таким кейсом лучше обратиться в ТАК, собрать дампы с обоих сторон и т.д.
Нужна подробная диагностика.
Напишите на cissupport@huawei.com
  • x

HCIA%20R%26S%2C%20HCIP%20R%26S

Комментарий

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход