[FAQ] Настройка QinQ termination

455 0 2 1

До этого мы рассмотрели как настроить QinQ tunneling и selective QinQ. Данные примеры могут быть использованы в простом Layer 2 VPN решении, для соединения двух и более офисов. Но нам может понадобиться доступ к внешним сервисам. Мы все еще можем использовать технологию QinQ, только необходимо будет избавиться от Vlan тега.

В данном примере рассмотрим как настроить QinQ termination, при использовании DHCP сервера, который находится вне нашей локальной сети.

Топология

1

Конфигурация

1. Настроим коммутаторы уровня доступа A и C.

SwitchA
vlan 100

#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 100

#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100

SwitchC
vlan 200

#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 200

#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 20

2. Настроим QinQ на коммутатореB и передачу пакетов c двумя тегами с коммутаторов A и C до DHCP сервера.

SwitchB
#
interface GigabitEthernet0/0/1
qinq vlan-translation enable
port hybrid untagged vlan 1000
port vlan-stacking vlan 100 stack-vlan 1000

#
interface GigabitEthernet0/0/2
qinq vlan-translation enable
port hybrid untagged vlan 1000
port vlan-stacking vlan 200 stack-vlan 1000

#
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 1000

3. Настроим Vlan tag termination на сабинтерфейсах DHCP-Relay маршрутизатора.

#
interface GigabitEthernet0/0/0.1
qinq termination pe-vid 1000 ce-vid 100
ip address 192.168.1.1 255.255.255.0
arp broadcast enable

#
interface GigabitEthernet0/0/0.2
qinq termination pe-vid 1000 ce-vid 200
ip address 192.168.2.1 255.255.255.0
arp broadcast enable

4. Далее настроим функцию DHCP Relay на сабинтерфейсах.

[DHCP-Relay]dhcp enable

[DHCP-Relay]interface GigabitEthernet0/0/0.1
                        dhcp select relay
                        dhcp relay server-ip 172.16.1.100


[DHCP-Relay]interface GigabitEthernet0/0/0.2
                        dhcp select relay
                        dhcp relay server-ip 172.16.1.100

5. И наконец зададим IP адрес на интерфейсе, направленном в сторону DHCP сервера.

[DHCP-Relay]interface GigabitEthernet0/0/1
                        ip address 172.16.1.1 255.255.255.0

6. Перейдем к настройке DHCP сервера.

dhcp enable
#
ip pool 1
   gateway-list 192.168.1.1
   network 192.168.1.0 mask 255.255.255.0

#
ip pool 2
   gateway-list 192.168.2.1
   network 192.168.2.0 mask 255.255.255.0

#
interface GigabitEthernet0/0/1
   ip address 172.16.1.100 255.255.255.0
   dhcp select global

7. Также необходимо прописать статические маршруты для доступа к Vlan 100 иVlan 200.

[DHCP-Server] ip route-static 192.168.1.0 255.255.255.0 172.16.1.1
[DHCP-Server] ip route-static 192.168.2.0 255.255.255.0 172.16.1.1

8. Проверка работы DHCP.

[DHCP-Relay] display dhcp relay all
DHCP relay agent running information of interface GigabitEthernet0/0/0.1 :
Server IP address [01] : 172.16.1.100
Gateway address in use : 192.168.1.1

DHCP relay agent running information of interface GigabitEthernet0/0/0.2 :
Server IP address [01] : 172.16.1.100
Gateway address in use : 192.168.2.1

 2

9. Проверка QinQ. Видим 2 тега, значит QinQ отработал правильно.

3

Далее проверяем QinQ Vlan termination. Как видим, у нас чистый IP пакет без каких-либо тегов.

 4

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Комментарий

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход