[FAQ] Базовая настройка QinQ tunneling

331 0 1 0

В традиционном 802.1Q протоколе необходимо присваивать разные Vlan ID пользователям в разных Vlan. Но на это у нас всего 4094 Vlan. Простой способ решить эту проблему – это использовать QinQ. Технология QinQ добавляет ещё один 802.1Q тег в пакет с 802.1Q тегом. Таким образом, трафик из приватного Vlan прозрачно передается через общедоступную сеть. Этот способ позволяет сократить число использующихся Vlan. Также QinQ позволяет организовать простой Layer 2 VPN для небольшой MAN или LAN сети.

QinQ tunneling на коммутаторах Huawei

Давайте предположим, что у нас есть 2 корпоративные сети – Enterprise_1 и Enterprise_2. У каждой сети есть по 2 офиса, которые расположены в разных городах. Нам необходимо чтобы обе корпоративные сети использовали VLAN 10 и трафик свободно передавался из одного офиса в другой через сеть провайдера. Также связь должна быть только между офисами одной корпоративной сети. Для этого мы можем использовать простой QinQ tunneling.

Топология

1

QinQ конфигурация

1. Сначала настроим коммутаторы C, D, E, F. Разрешим передачу пакетов с тегом Vlan 10. На всех коммутаторах будет одинаковая конфигурация.

vlan 10
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 10

2. Создадим Vlan 100 и 200 на остальных коммутаторах.

[SwitchA]vlan batch 100 200
[SwitchB]vlan batch 100 200
[ISP]vlan batch 100 200

3. Разрешим передачу 100 и 200 Vlan между коммутаторами сети провайдера.

[SwitchA]interface GigabitEthernet 0/0/3
[SwitchA-GigabitEthernet0/0/3]port link-type trunk
[SwitchA-GigabitEthernet0/0/2]port trunk allow-pass vlan 100 200

[SwitchB]interface GigabitEthernet 0/0/4
[SwitchB-GigabitEthernet0/0/4]port link-type trunk
[SwitchB-GigabitEthernet0/0/4]port trunk allow-pass vlan 100 200

[ISP]interface GigabitEthernet 0/0/3
[ISP-GigabitEthernet0/0/3]port link-type trunk
[ISP-GigabitEthernet0/0/3]port trunk allow-pass vlan 100 200

[ISP]interface GigabitEthernet 0/0/4
[ISP-GigabitEthernet0/0/4]port link-type trunk
[ISP-GigabitEthernet0/0/4]port trunk allow-pass vlan 100 200

4. Настроим интерфейсы коммутаторов A и B направленные в сторону Enteprise_1 и Enterprise_2 с VLAN тегами 100 и 200 соответственно.

[SwitchA]interface GigabitEthernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type dot1q-tunnel
[SwitchA-GigabitEthernet0/0/1] port default vlan 100

[SwitchA]interface GigabitEthernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type dot1q-tunnel
[SwitchA-GigabitEthernet0/0/2] port default vlan 200

[SwitchB]interface GigabitEthernet 0/0/1
[SwitchB-GigabitEthernet0/0/1] port link-type dot1q-tunnel
[SwitchB-GigabitEthernet0/0/1] port default vlan 100

[SwitchB]interface GigabitEthernet 0/0/2
[SwitchB-GigabitEthernet0/0/2] port link-type dot1q-tunnel
[SwitchB-GigabitEthernet0/0/2] port default vlan 200

5. Проверим связь между офисами в пределах одной корпоративной сети.

Enterprise_1_PC1>ping 172.16.1.2

Ping 172.16.1.2: 32 data bytes, Press Ctrl_C to break
From 172.16.1.2: bytes=32 seq=1 ttl=128 time=171 ms
From 172.16.1.2: bytes=32 seq=2 ttl=128 time=219 ms
From 172.16.1.2: bytes=32 seq=3 ttl=128 time=219 ms
From 172.16.1.2: bytes=32 seq=4 ttl=128 time=203 ms
From 172.16.1.2: bytes=32 seq=5 ttl=128 time=235 ms

--- 172.16.1.2 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 171/209/235 ms
Enterprise_2_PC2>ping 172.16.1.12

Ping 172.16.1.12: 32 data bytes, Press Ctrl_C to break
From 172.16.1.12: bytes=32 seq=1 ttl=128 time=172 ms
From 172.16.1.12: bytes=32 seq=2 ttl=128 time=203 ms
From 172.16.1.12: bytes=32 seq=3 ttl=128 time=188 ms
From 172.16.1.12: bytes=32 seq=4 ttl=128 time=235 ms
From 172.16.1.12: bytes=32 seq=5 ttl=128 time=188 ms

--- 172.16.1.12 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 172/197/235 ms

Посмотрим внутрь ICMP пакета:

2

Как видим, внутри пакета 2 VLAN тега, QinQ работает правильно.

6. Также проверим связь между офисами в разных корпоративных сетях.

Enterprise_1_PC1>ping 172.16.1.11

Ping 172.16.1.11: 32 data bytes, Press Ctrl_C to break
From 172.16.1.1: Destination host unreachable
From 172.16.1.1: Destination host unreachable
From 172.16.1.1: Destination host unreachable
From 172.16.1.1: Destination host unreachable
From 172.16.1.1: Destination host unreachable

--- 172.16.1.11 ping statistics ---
5 packet(s) transmitted
0 packet(s) received
100.00% packet loss

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход
Быстрый ответ Вверх