Типичная настройка BFD

63 0 0 1

BFD (Bidirectional Forwarding Detection)

Сетевое устройство должно быстро обнаруживать ошибки связи между соседними устройствами, чтобы можно было незамедлительно принять меры и предотвратить прерывание обслуживания. На практике для обнаружения неисправностей каналов используются аппаратные механизмы. Например аварийные сигналы синхронной цифровой иерархии (SDH - Synchronous Digital Hierarchy) используются для сообщения о неисправностях каналов. Однако не все носители поддерживают механизм аппаратного обнаружения. Приложения используют механизм Hello протокола маршрутизации верхнего уровня для обнаружения ошибок. Обнаружение неисправностей с использованием данного механизма занимает более 1 секунды, что слишком много для некоторых приложений. В сети 3–го уровня механизм обнаружения пакетов Hello не позволяет обнаружить ошибки для всех маршрутов, например статических маршрутов. Это означает, что достаточно трудно найти неисправность между взаимосвязанными системами.

BFD предоставляет механизм быстрого обнаружения ошибок независимо от протоколов передачи данных и протоколов маршрутизации. Благодаря механизму обнаружения неисправностей и коммутации, которые выполняются в течение нескольких миллисекунд, BFD подходит для сценариев, чувствительных к потере и задержке пакетов.

 

Замечания к настройке

·         Локальный дискриминатор локальной системы и удаленный дискриминатор удаленной системы должны быть одинаковыми. Если локальный дискриминатор локальной системы и удаленный дискриминатор удаленной системы отличаются друг от друга, то не удастся установить статический сеанс BFD. Изменить локальный дискриминатор и удаленный дискриминатор после настройки нельзя.

·         Если сеанс связи BFD привязан к адресу многоадресной рассылки по умолчанию, то локальный дискриминатор и удаленный дискриминатор должны отличаться друг от друга.

·         Если поддерживается установка времени WTR, то необходимо установить одинаковое время WTR на обоих устройствах. В противном случае при изменении статуса сеанса связи BFD на одном устройстве, приложения на обоих устройствах обнаружат разные статусы сеанса связи BFD.

 

Как показано на рисунке, SwitchA напрямую подключается к SwitchB на сетевом уровне, и между ними установлены устройства передачи 2-го уровня SwitchC и SwitchD. Требуется, чтобы SwitchA и SwitchB быстро обнаруживали неисправности каналов устройств передачи 2-го уровня для запуска быстрой конвергенции маршрутов.

1-1

 

Схема настройки заключается в следующем:


1. Настройте сеанс связи BFD на SwitchA и SwitchB для обнаружения неисправностей канала связи между SwitchA и SwitchB.

2. Настройте привязку между статусом сеанса связи BFD и статусом интерфейса на SwitchA и SwitchB после того, как сеанс связи BFD примет статус Up.

 

# Назначьте IP-адрес интерфейсу SwitchA.

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] vlan 10

[SwitchA-vlan10] quit

[SwitchA] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type hybrid

[SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10

[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10

[SwitchA-GigabitEthernet1/0/1] quit

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] ip address 10.1.1.1 24

[SwitchA-Vlanif10] quit

# Назначьте IP-адрес интерфейсу SwitchВ.

<HUAWEI> system-view

[HUAWEI] sysname SwitchB

[SwitchB] vlan 10

[SwitchB-vlan10] quit

[SwitchB] interface gigabitethernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type hybrid

[SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 10

[SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 10

[SwitchB-GigabitEthernet1/0/1] quit

[SwitchB] interface vlanif 10

[SwitchB-Vlanif10] ip address 10.1.1.2 24

[SwitchB-Vlanif10] quit

Шаг 2 Настройте BFD с одним переходом.

# Включите BFD на SwitchA и установите сеанс связи BFD с именем atob между SwitchA и SwitchB.

[SwitchA] bfd //Включите BFD глобально.

[SwitchA-bfd] quit

[SwitchA] bfd atob bind peer-ip default-ip interface gigabitethernet 1/0/1 //Настройте сеанс BFD с именем atob.

[SwitchA-bfd-session-atob] discriminator local 10 //Настройте локальный дискриминатор сеанса BFD. Локальный дискриминатор на коммутаторе должен быть таким же, как дистанционный дискриминатор на SwitchB.

[SwitchA-bfd-session-atob] discriminator remote 20 //Настройте дистанционный дискриминатор сеанса BFD. Дистанционный дискриминатор на SwitchA должен быть таким же, как локальный дискриминатор на SwitchB.

[SwitchA-bfd-session-atob] commit //Одайте сеанс BFD, чтобы настройка вступила в силу.

[SwitchA-bfd-session-atob] quit

# Включите BFD на SwitchB и установите сеанс связи BFD с именем btoa между SwitchB и SwitchA.

[SwitchB] bfd

[SwitchB-bfd] quit

[SwitchB] bfd btoa bind peer-ip default-ip interface gigabitethernet 1/0/1 //Настройте сеанс BFD с именем btoa.

[SwitchB-bfd-session-btoa] discriminator local 20

[SwitchB-bfd-session-btoa] discriminator remote 10

[SwitchB-bfd-session-btoa] commit

[SwitchB-bfd-session-btoa] quit

 

# После завершения настроек выполните команду display bfd session all verbose на SwitchA и SwitchB. Сеанс связи BFD с одним переходом установлен и его статус — Up.

В качестве примера используется SwitchA.

1-2

Шаг 3 Настройка привязки между статусом сеанса связи BFD и статусом интерфейса.

# Настройте привязку между статусом сеанса связи BFD и статусом интерфейса на SwitchA.

[SwitchA] bfd atob

[SwitchA-bfd-session-atob] process-interface-status

[SwitchA-bfd-session-atob] quit

# Настройте привязку между статусом сеанса связи BFD и статусом интерфейса на

SwitchB.

[SwitchB] bfd btoa

[SwitchB-bfd-session-btoa] process-interface-status

[SwitchB-bfd-session-btoa] quit

Шаг 4 Проверьте конфигурацию.

После завершения настроек выполните команду display bfd session all verbose на SwitchA и SwitchB. Поле Proc interface status примет значение Enable.

В качестве примера используется SwitchA.

 

1-3

Выполните команду shutdown на GE1/0/1 SwitchB для изменения статуса сеанса связи BFD на Down.

[SwitchB] interface gigabitethernet 1/0/1

[SwitchB-GigabitEthernet1/0/1] shutdown

[SwitchB-GigabitEthernet1/0/1] quit

Выполните команды display bfd session all verbose и display interface gigabitethernet 1/0/1 на SwitchA. Статус сеанса связи BFD: Down, a статус GE1/0/1: UP (BFD status down).

1-4

ПРИМЕЧАНИЕ

После выполнения команды display interface gigabitethernet 1/0/1 будет представлена только важная информация, "..." означает, что информация опущена.


  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход