Хорошо

Роутер на палочке

308 0 3 0 0


роутер на палочке

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 

роутер на палочке роутер на палочке     роутер на палочке роутер на палочке 



Всем привет, 

Последние несколько дней мы со школьниками, интересующими IT, играли с eNSP - симулятором сети Huawei, довольно крутым инструментом, который помог нам освоить ОС Comware. Comware OS - сетевая операционная система, используемая Huawei и бывшей 3Com (ныне известная как HP Networking).


Мы начали с простого дизайна и настроили роутер на палочке. У нас был маршрутизатор и пара коммутаторов, два ПК и один сервер. Основная цель - дать возможность ПК взаимодействовать друг с другом и с сервером: в основном настройка маршрутизации interVlan. Мы знаем, что в наши дни это не распространенный сценарий, потому что каждый будет использовать коммутатор L3 для логических интерфейсов VLAN и пускать слезу о роутере на палочке...


роутер на палочке


VLANs:

 

10 – Management – 10.0.10.0/24

20 – Servers -10.0.20.0/24

30 – PC – 10.0.30.0/24

 

RT1

Int g0/0/0.10 – 10.0.10.1

Int g0/0/0.20 – 10.0.20.1

Int g0/0/0.30 – 10.0.30.1

 

SW1

Int Vlan10 – 10.0.10.2

 

SW2

Int Vlan10 – 10.0.10.3

PC1-10.0.30.10

PC2-10.0.30.11

 

SERVER1 – 10.0.20.100

 

Сначала сконфигурировали роутер:



sysname R1

#

 

#

 lldp enable

#

interface GigabitEthernet0/0/0

 description to SW1

#

interface GigabitEthernet0/0/0.10

 description VLAN10

 dot1q termination vid 10

 ip address 10.0.10.1 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.20

 description VLAN20

 dot1q termination vid 20

 ip address 10.0.20.1 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.30

 description VLAN30

 dot1q termination vid 30

 ip address 10.0.30.1 255.255.255.0

 arp broadcast enable

#


Вот и все, дерево из сабинтерфейсов с настроенным IP-адресом. SW1:


sysname SW1

#

vlan batch 10 20 30

#

lldp enable

#

vlan 10

 description MANAGEMENT VLAN

vlan 20

 description SERVER VLAN

vlan 30

 description PC VLAN

#

interface Vlanif10

 description MANAGEMENT

 ip address 10.0.10.2 255.255.255.0

#

interface MEth0/0/1

#

interface GigabitEthernet0/0/1

 description to R1

 port link-type trunk

 port trunk allow-pass vlan 10 20 30

#

interface GigabitEthernet0/0/2

 description to SW2

 port link-type trunk

 port trunk pvid vlan 10

 port trunk allow-pass vlan 10 20 30

#

interface GigabitEthernet0/0/3

 description to PC1

 port link-type access

 port default vlan 30

#

ip route-static 0.0.0.0 0.0.0.0 10.0.10.1

#


Простая конфигурация, VLAN, интерфейс Vlan10, порты доступа и транка ... Как видите, синтаксис похож на IOS... возможно, это потому, что они используют один и тот же исходный код. 

SW2:


sysname SW2

#

vlan batch 10 20 30

#

#

vlan 10

 description MANAGEMENT

vlan 20

 description SERVERS

vlan 30

 description PC

#

interface Vlanif1

#

interface Vlanif10

 description VLAN10

 ip address 10.0.10.3 255.255.255.0

#

interface MEth0/0/1

#

interface GigabitEthernet0/0/1

 description to SERVER1

 port link-type access

 port default vlan 20

#

interface GigabitEthernet0/0/2

 description to SW1

 port link-type trunk

 port trunk pvid vlan 10

 port trunk allow-pass vlan 10 20 30

#

interface GigabitEthernet0/0/3

 description to PC2

 port link-type access

 port default vlan 30

#

#

ip route-static 0.0.0.0 0.0.0.0 10.0.10.1


Чтобы показать конфигурацию на устройстве Huawei, мы использовали команду display current-configuration. Чтобы показать краткое описание сконфигурированных интерфейсов на R1, использовали:


display ip int brief

*down: administratively down

^down: standby

(l): loopback

(s): spoofing

The number of interface that is UP in Physical is 5

The number of interface that is DOWN in Physical is 2

The number of interface that is UP in Protocol is 4

The number of interface that is DOWN in Protocol is 3

 

Interface                         IP Address/Mask      Physical   Protocol 

GigabitEthernet0/0/0              unassigned           up         down     

GigabitEthernet0/0/0.10           10.0.10.1/24         up         up       

GigabitEthernet0/0/0.20           10.0.20.1/24         up         up       

GigabitEthernet0/0/0.30           10.0.30.1/24         up         up


Чтобы показать статус интерфейса:


display interface GigabitEthernet 0/0/0.10

GigabitEthernet0/0/0.10 current state : UP

Line protocol current state : UP

Last line protocol up time : 2014-09-25 10:48 UTC-05:13

Description:VLAN10

Route Port,The Maximum Transmit Unit is 1500

Internet Address is 10.0.10.1/24

IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 00e0-fc3f-3278

Current system time: 2014-09-25 10:48-05:13

    Last 300 seconds input rate 0 bits/sec, 0 packets/sec

    Last 300 seconds output rate 0 bits/sec, 0 packets/sec

    Realtime 212 seconds input rate 0 bits/sec, 0 packets/sec

    Realtime 212 seconds output rate 0 bits/sec, 0 packets/sec

    Input: 34 packets,2556 bytes,

           18 unicast,16 broadcast,0 multicast

    Output:50 packets,3580 bytes,

           17 unicast,33 broadcast,0 multicast

    Input bandwidth utilization  :    0%

    Output bandwidth utilization :    0%


Потом мы перешли к SW1 и выполнили несколько команд display: Информация о VLAN10:


<SW1>display vlan 10

--------------------------------------------------------------------------------

U: Up;         D: Down;         TG: Tagged;         UT: Untagged;

MP: Vlan-mapping;               ST: Vlan-stacking;

#: ProtocolTransparent-vlan;    *: Management-vlan;

--------------------------------------------------------------------------------

 

VID  Type    Ports               

--------------------------------------------------------------------------------

10   common  UT:GE0/0/2(U)           

             TG:GE0/0/1(U)           

 

VID  Status  Property      MAC-LRN Statistics Description     

--------------------------------------------------------------------------------

10   enable  default       enable  disable    MANAGEMENT VLAN  


<SW1>display vlan summary

static vlan:

Total 4 static vlan.

  1 10 20 30

 

dynamic vlan:

Total 0 dynamic vlan.

 

reserved vlan:

Total 0 reserved vlan.



display   vlan 10 verbose

* : Management-VLAN

---------------------

  VLAN ID                     : 10

  VLAN Name                   :

  VLAN Type                   : Common

  Description                 : MANAGEMENT VLAN

  Status                      : Enable

  Broadcast                   : Enable

  MAC Learning                : Enable

  Smart MAC Learning          : Disable

  Current MAC Learning Result : Enable

  Statistics                  : Disable

  Property                    : Default

  VLAN State                  : Up

  ----------------

  Untagged      Port: GigabitEthernet0/0/2        

  ----------------

  Active Untag  Port: GigabitEthernet0/0/2       

  ----------------

  Tagged        Port: GigabitEthernet0/0/1       

  ----------------

  Active  Tag   Port: GigabitEthernet0/0/1       

-------------------

Interface                   Physical

GigabitEthernet0/0/1        UP     

GigabitEthernet0/0/2        UP 


Затем мы проверили связь между SW1 и RT1:


<SW1>ping 10.0.10.1

  PING 10.0.10.1: 56  data bytes, press CTRL_C to break

    Reply from 10.0.10.1: bytes=56 Sequence=1 ttl=255 time=60 ms

    Reply from 10.0.10.1: bytes=56 Sequence=2 ttl=255 time=10 ms

    Reply from 10.0.10.1: bytes=56 Sequence=3 ttl=255 time=30 ms

    Reply from 10.0.10.1: bytes=56 Sequence=4 ttl=255 time=20 ms

    Reply from 10.0.10.1: bytes=56 Sequence=5 ttl=255 time=20 ms

 

  --- 10.0.10.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 10/28/60 ms


И SW1 и SW2:


<SW1>ping 10.0.10.1

  PING 10.0.10.1: 56  data bytes, press CTRL_C to break

    Reply from 10.0.10.1: bytes=56 Sequence=1 ttl=255 time=60 ms

    Reply from 10.0.10.1: bytes=56 Sequence=2 ttl=255 time=10 ms

    Reply from 10.0.10.1: bytes=56 Sequence=3 ttl=255 time=30 ms

    Reply from 10.0.10.1: bytes=56 Sequence=4 ttl=255 time=20 ms

    Reply from 10.0.10.1: bytes=56 Sequence=5 ttl=255 time=20 ms

 

  --- 10.0.10.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 10/28/60 ms


<SW2>ping 10.0.10.1

  PING 10.0.10.1: 56  data bytes, press CTRL_C to break

    Reply from 10.0.10.1: bytes=56 Sequence=1 ttl=255 time=60 ms

    Reply from 10.0.10.1: bytes=56 Sequence=2 ttl=255 time=130 ms

    Reply from 10.0.10.1: bytes=56 Sequence=3 ttl=255 time=60 ms

    Reply from 10.0.10.1: bytes=56 Sequence=4 ttl=255 time=50 ms

    Reply from 10.0.10.1: bytes=56 Sequence=5 ttl=255 time=60 ms

 

  --- 10.0.10.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 50/72/130 ms


Потом мы проверили возможность подключения конечных устройств. Сначала отправили эхо-запрос с ПК1 на интерфейс R1 G0/0/0.30, затем с ПК1 на ПК2 и, наконец, с ПК1 на СЕРВЕР1.


PC>ping 10.0.30.1

 

Ping 10.0.30.1: 32 data bytes, Press Ctrl_C to break

From 10.0.30.1: bytes=32 seq=1 ttl=255 time=16 ms

From 10.0.30.1: bytes=32 seq=2 ttl=255 time=16 ms

From 10.0.30.1: bytes=32 seq=3 ttl=255 time=16 ms

From 10.0.30.1: bytes=32 seq=5 ttl=255 time=15 ms

 

--- 10.0.30.1 ping statistics ---

  5 packet(s) transmitted

  5 packet(s) received

  0.00% packet loss

  round-trip min/avg/max = 15/18/31 ms

 

PC>ping 10.0.30.11

 

Ping 10.0.30.11: 32 data bytes, Press Ctrl_C to break

From 10.0.30.11: bytes=32 seq=1 ttl=128 time=47 ms

From 10.0.30.11: bytes=32 seq=2 ttl=128 time=62 ms

From 10.0.30.11: bytes=32 seq=3 ttl=128 time=47 ms

From 10.0.30.11: bytes=32 seq=4 ttl=128 time=31 ms

From 10.0.30.11: bytes=32 seq=5 ttl=128 time=31 ms

 

--- 10.0.30.11 ping statistics ---

  5 packet(s) transmitted

  5 packet(s) received

  0.00% packet loss

  round-trip min/avg/max = 31/43/62 ms

 

PC>ping 10.0.20.100

 

Ping 10.0.20.100: 32 data bytes, Press Ctrl_C to break

From 10.0.20.100: bytes=32 seq=1 ttl=254 time=93 ms

From 10.0.20.100: bytes=32 seq=2 ttl=254 time=62 ms

From 10.0.20.100: bytes=32 seq=3 ttl=254 time=78 ms

From 10.0.20.100: bytes=32 seq=4 ttl=254 time=78 ms

From 10.0.20.100: bytes=32 seq=5 ttl=254 time=78 ms

 

--- 10.0.20.100 ping statistics ---

  5 packet(s) transmitted

  5 packet(s) received

  0.00% packet loss

  round-trip min/avg/max = 62/77/93 ms


Когда пинг работает - значит все хорошо. Дети были ради)

  • x

Комментарий

Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация
Отправить

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Пользовательское соглашение.”

My Followers

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход

Заблокировать
Вы уверены, что хотите заблокировать этого пользователя?
Пользователи из вашего черного списка не могут комментировать ваши посты, не могут упоминать вас, не могут отправлять личные сообщения.
Напоминание
Пожалуйста, привяжите свой мобильный номер чтобы получить бонус за приглашение.
О защите информации
Благодарим за использование Huawei ICT Club! Мы хотим рассказать вам о том, как мы собираем, используем и храним ваши данные. Пожалуйста, внимательно ознакомьтесь с Политикой конфиденциальности и Пользовательским соглашением.