Хорошо

помогите разобраться с маршрутизацией

Опубликовано 2021-3-10 09:06:54Последний ответ мар 19, 2021 21:43:57 589 7 0 0 0
  Награжденные Форбаллы: 0 (Проблема решена)

Добрый день всем. Кто знает подскажите- как пробросить доступ между вланами.

Есть S5720-32P-EI-AC, в него в обычный порт я впихнул интернет ростелекома с обычного роутера(в комплекте с интернетом был) , назначил порту 33 влан. Пробросил транками с него по оптике интернет дальше(вся цепочка S5720-32P-EI-AC - S5700-28C-HI-24S - S5700-28C-HI-24S - S5700-48TP-SI-AC - S2700-18TP-SI-AC). На S2700-18TP-SI-AC назначил портам аццесса влан 33 ну и интернет на компах появился. НО! дхцп работает с роутера ростелекома, а для работы требуется лазить в нескольких десятках внутренних вланов(разные видеонаблюдения, управления коммутаторами, пожарка, скуд и тд). Приходится постоянно менять принудительно влан на порту с2700, что не очень удобно. Домена нет, серверов нет...  :-( 

Можно ли как то сделать на коммутаторах дхцп сервер, шлюз и тд, чтобы он раздавал инет и разруливал маршрутизацию? и Собственно как сделать конкретным портам проброс по всем нужным вланам+интернет? к сожалению 2-3 сетевухи не доступны- только одна :-) 

Спасибо за советы.

  • x

Избранные ответы
Peterhof
MVE Опубликовано 2021-3-10 10:29:41
Здравствуйте!
Я думаю, что можно какой-нибудь из 5700 коммутаторов сделать ответственным за маршрутизацию и DHCP.
Для этого нужно настроить сеть так, чтобы на этот центральный коммутатор подходили все VLAN (анапример, через trunk-порты). Потом на этом коммутатре сделать VLANIF для каждого VLAN, между которыми требуется маршрутизация. После этого шага все хосты, у которых как шлюз по умолчанию будет прописан адрес соответствующего им VLANIF, смогут достучаться до любого другого VLAN. Далее останется только настроить DHCP для каждого VLANIF: https://support.huawei.com/enterprise/ru/doc/EDOC1000178170/609ffe30/configuring-a-dhcp-server

В итоге у Вас маршрутизация будет работать через виртуальные VLANIF, а не через физические интерфейсы, поэтому несколько VLAN смогут подходить к одному коммутатору по одному порту.
Чуть не забыл, для того, чтобы работал интернет, нужно на центральном коммутаторе прописать маршрут по умолчанию на шлюз Ростелекома как написано выше.
Развернуть
  • x

TORkus
TORkus Опубликовано 2021-3-11 02:57 (0) (0)
Спасибо! Я уже прописал все как вы написали, но не сообразил, что он должен являться шлюзом- видать заработался :-)))  
Все ответы
GIAP2020
GIAP2020 Опубликовано 2021-3-10 09:52:48
Здравствуйте. Попробуйте на S2700 Который у Вас перед роутером назначить VLANIF (https://support.huawei.com/enterprise/ru/doc/EDOC1000178172/433bc017/configuring-a-vlanif-interface). Например для 33 влана vlanif33 с ip-адресом 192.168.33.1. Для других вланов другие vlanif с другими ip-адресами. Так же на коммутаторе S2700 необходимо прописать дефолт роут: ip static-route 0.0.0.0/0 192.168.33.254(это ip интерфейса роутера ростелекома, такой адрес взят только для примера ).
Развернуть
  • x

Peterhof
Peterhof MVE Опубликовано 2021-3-10 10:29:41
Здравствуйте!
Я думаю, что можно какой-нибудь из 5700 коммутаторов сделать ответственным за маршрутизацию и DHCP.
Для этого нужно настроить сеть так, чтобы на этот центральный коммутатор подходили все VLAN (анапример, через trunk-порты). Потом на этом коммутатре сделать VLANIF для каждого VLAN, между которыми требуется маршрутизация. После этого шага все хосты, у которых как шлюз по умолчанию будет прописан адрес соответствующего им VLANIF, смогут достучаться до любого другого VLAN. Далее останется только настроить DHCP для каждого VLANIF: https://support.huawei.com/enterprise/ru/doc/EDOC1000178170/609ffe30/configuring-a-dhcp-server

В итоге у Вас маршрутизация будет работать через виртуальные VLANIF, а не через физические интерфейсы, поэтому несколько VLAN смогут подходить к одному коммутатору по одному порту.
Чуть не забыл, для того, чтобы работал интернет, нужно на центральном коммутаторе прописать маршрут по умолчанию на шлюз Ростелекома как написано выше.
Развернуть
  • x

TORkus
TORkus Опубликовано 2021-3-11 02:57 (0) (0)
Спасибо! Я уже прописал все как вы написали, но не сообразил, что он должен являться шлюзом- видать заработался :-)))  
Sergo_Stepanov
Sergo_Stepanov Опубликовано 2021-3-10 10:45:17

Приветсвую,


Маршрутизацию между вланами можно совершить двумя способами


1. Роутер на палочке, где вся маршрутизация производится силами роутера. На форуме есть пост с примером настройки.

https://forum.huawei.com/enterprise/ru/настройка-router-on-a-stick/thread/538693-100131


2. Адрес и основной шлюз являются зеркальными для устройств, которые пытаются комуницировать через разные vlan

2

https://support.huawei.com/hedex/hdx.do?docid=EDOC1100175712&id=EN-US_TASK_0177102495&lang=en


Развернуть
  • x

TORkus
TORkus Опубликовано 2021-3-11 02:38:29
Опубликовано пользователем GIAP2020 в 2021-03-10 09:52 Здравствуйте. Попробуйте на S2700 Который у Вас перед роу ...

вот такая конфа у меня сейчас- вроде все прописано как вы написали, но так не работает- поэтому и решил спросить на форуме :-) 

#
!Software Version V100R006C05
sysname -SW-001
#
vlan batch 2 11 to 20 33 to 35 41 to 60 102
#
stp mode rstp
stp pathcost-standard legacy
#
lldp enable
#
dhcp enable
#
undo http server enable
undo http secure-server enable
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher 
local-user admin privilege level 15
local-user admin service-type terminal ssh ftp http
#
ntp-service source-interface Vlanif2
ntp-service unicast-server 172.16.2.1
#
interface Vlanif1
shutdown
#
interface Vlanif2
description MGMT LVS
ip address 172.16.2.14 255.255.255.0
#
interface Vlanif33
ip address 192.168.10.253 255.255.255.0
#
interface Vlanif35
ip address 192.168.0.254 255.255.255.0
#
interface Ethernet0/0/1
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/2
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/3
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/4
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/5
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/6
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/7
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/8
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/9
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/10
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/11
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/12
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/13
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/14
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/15
port link-type access
port default vlan 33
stp edged-port enable
#
interface Ethernet0/0/16
port link-type access
port default vlan 33
stp edged-port enable
#
interface GigabitEthernet0/0/1
description -K-SW-001
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 11 to 20 33 to 35 41 to 60 102
#
interface GigabitEthernet0/0/2
description -WIFI
port link-type trunk
port trunk pvid vlan 35
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 35
#
interface NULL0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.10.1 (ип адрес роутера ростелекома)
ip route-static 0.0.0.0 0.0.0.0 172.16.2.1 (ип адрес центрального коммутатора)
#
stelnet server enable
ssh user admin
ssh user admin authentication-type all
ssh user admin service-type stelnet
#
header login information "
---------------------------------------
!!!!!!!!!!!!!220 Volt!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!Ne suy pal'ci!!!!!!!!!!!!!!!
-------------------------------"
#
user-interface con 0
authentication-mode aaa
user privilege level 15
idle-timeout 30 0
user-interface vty 0 4
authentication-mode aaa
protocol inbound ssh
#
port-group 1
group-member Ethernet0/0/2
group-member Ethernet0/0/3
group-member Ethernet0/0/4
group-member Ethernet0/0/5
group-member Ethernet0/0/6
group-member Ethernet0/0/7
group-member Ethernet0/0/8
group-member Ethernet0/0/9
group-member Ethernet0/0/10
group-member Ethernet0/0/11
group-member Ethernet0/0/12
group-member Ethernet0/0/13
group-member Ethernet0/0/14
group-member Ethernet0/0/15
group-member Ethernet0/0/16
#
return

Развернуть
  • x

GIAP2020
GIAP2020 Опубликовано 2021-3-11 12:37:03
Здравствуйте, этой командой "ip route-static 0.0.0.0 0.0.0.0 172.16.2.1 (ип адрес центрального коммутатора)" Вы пытаетесь настроить второй маршрут по умолчанию (default route)? Я думаю маршрут в Интернет(к провайдеру должен быть default route), а к центральному коммутатору путь известен "interface Vlanif2
description MGMT LVS
ip address 172.16.2.14 255.255.255.0" -этот интерфейс в одной локальной сети с центральным коммутатором.
Развернуть
  • x

GIAP2020
GIAP2020 Опубликовано 2021-3-19 21:43:57
Вопрос к TORkus: заработала ли у Вас система для доступа в Интернет. Хочу узнать какие настройки помогли и где были проблемы (для личного опыта использования оборудования)?
Развернуть
  • x

Комментарий

Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация
Отправить

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Пользовательское соглашение.”

My Followers

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход

Заблокировать
Вы уверены, что хотите заблокировать этого пользователя?
Пользователи из вашего черного списка не могут комментировать ваши посты, не могут упоминать вас, не могут отправлять личные сообщения.
Напоминание
Пожалуйста, привяжите свой мобильный номер чтобы получить бонус за приглашение.