Нет соединения SIP телефона.

Последний ответ апр 02, 2019 08:59:35 642 28 0 0
Добрый день!

Возникла трудность с подключением sip телефона Yealink T46S(ver ПО 66.84.0.15) к коммутатору Huawei S2318TP-EI(Version 5.70 (V100R006C03)). Суть проблемы в следующем - делаю порт access, прописываю влан, автоопределение порта, подключаю телефон, регистрации нет. Сделал эксперемент. Теже настройки выполнил на другом коммутаторе Eltex, подключаю телефон с тем же кабелем, телефон регится. В чем проблема? Почему порты настроены одинаково, а работают по разному? 
  • x

artemrus38
Опубликовано 2019-4-1 15:03:55 Полезно(0) Полезно(0)
Последняя конфигурация, которая может помочь, при той же ситуации, как у меня, когда в одном влане и голос и данные. Все зависит от SIP аппарат. У меня были Yealink разных прошивок, как оказалось, под каждую прошивку разные настройки порта.

#
interface Ethernet0/0/15
description --- port for test IP-tel ---
voice-vlan 47 enable
voice-vlan mode manual
undo voice-vlan security enable
voice-vlan legacy enable
port hybrid pvid vlan 47
undo port hybrid vlan 1
port hybrid tagged vlan 47
loopback-detect enable
#

Думаю, тему можно закрывать!
  • x

Jorian
Админ Опубликовано 2019-3-22 09:55:02 Полезно(0) Полезно(0)
Доброго дня.

Позвал к вам нашего спеца по данной тематике.
  • x

Хорошего дня!
Если что, то пишите в ТАС - CISsupport@huawei.com
Здесь можно узнать стоимость ИКТ-решений
Комьюнити-менеджер
Илья
user_2909167
Модератор Опубликовано 2019-3-22 10:11:01 Полезно(0) Полезно(0)
Здравствуйте. В каком режиме обработки vlan настроен телефон?
Попробуйте режим порта - hybrid.
А также уточнить - телефон получает IP адрес? на PBX есть ивенты о попытках регистрации?
Каков сервис дизайн по вланам между коммутатором и PBX?
  • x

artemrus38
Опубликовано 2019-3-24 07:54:10 Полезно(0) Полезно(0)
Опубликовано пользователем user_2909167 в 2019-03-22 10:11 Здравствуйте. В каком режиме обработки vlan настроен те ...
Добрый день!
1.Если я правильно понял Ваш вопрос, то на телефоне вообще не поднимался VLAN, стоит по умолчанию.
2. Вот режим гибрид я не пробовал, попробую. Опять же, коммутатор другого вендера спокойной справляется с задачей в режиме access.
3. Телефон не регится, и на АТС нет информации о регистрации телефона. Вся телефония настроена в статике.
4. Коммутатор к PBX имеет транковый порт, к телефонам access.
  • x

artemrus38
Опубликовано 2019-3-24 07:54:31 Полезно(0) Полезно(0)
  • x

user_2909167
Модератор Опубликовано 2019-3-25 11:51:10 Полезно(0) Полезно(0)
Здравствуйте. Возможно проблема в неполных настрйоках. Покажите пример конфига порта к телефону и аплинка. А также настройку сетевой карты телефона
  • x

artemrus38
Опубликовано 2019-3-25 12:49:36 Полезно(0) Полезно(0)
Опубликовано пользователем user_2909167 в 2019-03-25 11:51 Здравствуйте. Возможно проблема в неполных настрйок ...
Добрый день!

Конфиг Huawei
#
Ethernet0/0/15 current state : UP
Line protocol current state : UP
Description:--- port for test IP-tel ---
Switch Port, PVID :   47, TPID : 8100(Hex), The Maximum Frame Length is 2044
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 7054-f5a2-6db4
Port Mode: COMMON COPPER
Speed :  100,  Loopback: NONE
Duplex: FULL,  Negotiation: ENABLE
Mdi   : AUTO
Last 300 seconds input rate 0 bits/sec, 0 packets/sec
Last 300 seconds output rate 192 bits/sec, 0 packets/sec
Input peak rate 244659872 bits/sec, Record time: 2019-03-25 11:51
Output peak rate 187204088 bits/sec, Record time: 2019-03-25 11:51
Input:  0 packets, 0 bytes
Unicast        :                   0, Multicast          :                   0
Broadcast      :                   0, Jumbo              :                   0
CRC            :                   0, Giants             :                   0
Jabbers        :                   0, Fragments          :                   0
Runts          :                   0, DropEvents         :                   0
Alignments     :                   0, Symbols            :                   0
Ignoreds       :                   0, Frames             :                   0
Discard        :                   0, Total Error        :                   0
Output:  66 packets, 7322 bytes
Unicast        :                   0, Multicast          :                  26
Broadcast      :                  40, Jumbo              :                   0
Collisions     :                   0, Deferreds          :                   0
Late Collisions:                   0, ExcessiveCollisions:                   0
Buffers Purged :                   0
Discard        :                   0, Total Error        :                   0
    Input bandwidth utilization threshold : 100.00%
    Output bandwidth utilization threshold: 100.00%
    Input bandwidth utilization  : 0.00%
    Output bandwidth utilization : 0.01%

#
interface Ethernet0/0/15
description --- port for test IP-tel ---
port link-type access
port default vlan 47
loopback-detect enable
#

Конфиг коммутатора Eltex
!
interface gigabitethernet1/0/5
mdix on
description ---port_test_connect_to_IPTel---
switchport access vlan 47
!

!
gigabitethernet1/0/5 is up (connected)
  Interface index is 53
  Hardware is gigabitethernet, MAC address is e0:d9:e3:bc:47:45
  Description: ---port_test_connect_to_IPTel---
  Interface MTU is 1500
  Full-duplex, 1000Mbps, link type is auto, media type is 1G-Copper
  Link is up for 0 days, 0 hours, 2 minutes and 31 seconds
  Advertised link modes: 1000baseT/Full 100baseT/Full
                         100baseT/Half 10baseT/Full
                         10baseT/Half
  Flow control is off, MDIX mode is on
  15 second input rate is 0 Kbit/s
  15 second output rate is 11 Kbit/s
      90155 packets input, 11233910 bytes received
      430 broadcasts, 18039 multicasts
      0 input errors, 0 FCS, 0 alignment
      0 oversize, 0 internal MAC
      0 pause frames received
      6798379 packets output, 800287993 bytes sent
      3504708 broadcasts, 3267958 multicasts
      0 output errors, 0 collisions
      0 excessive collisions, 0 late collisions
      0 pause frames transmitted
      0 symbol errors, 0 carrier, 0 SQE test error
  !
  • x

user_2909167
Модератор Опубликовано 2019-3-25 13:24:48 Полезно(0) Полезно(0)
Здравствуйте,
А что с настрйоками телефона?
Каковы настройки uplink-порта (Вы прикрепили только статус)?
Правильно понимаю что ПК к IP телефону подключаться не будет?

Вот пример типичной настрйоки порта для телефона если ПК не будет. Но, нужно еще настройки теелфона посмтреть.
port link-type hybrid
port hybrid untagged vlan 47
port hybrid pvid vlan 47
  • x

artemrus38
Опубликовано 2019-3-26 04:50:51 Полезно(0) Полезно(0)
Опубликовано пользователем user_2909167 в 2019-03-25 13:24 Здравствуйте,А что с настрйоками телефона?Каковы наст ...
Добрый день!
Проблема в том, что ПК будет стоять за телефоном.
В телефонет прописаны только ip статика, маска, шлюз. Больше ничего хитрого.

последний конфиг. 
#
interface Ethernet0/0/15
 description --- port for test IP-tel ---
 port hybrid pvid vlan 47
 port hybrid untagged vlan 47
 loopback-detect enable
#
Ethernet0/0/15 current state : UP
Line protocol current state : UP
Description:--- port for test IP-tel ---
Switch Port, PVID :   47, TPID : 8100(Hex), The Maximum Frame Length is 2044
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 7054-f5a2-6db4
Port Mode: COMMON COPPER
Speed :  100,  Loopback: NONE
Duplex: FULL,  Negotiation: ENABLE
Mdi   : AUTO
Last 300 seconds input rate 64 bits/sec, 0 packets/sec
Last 300 seconds output rate 25232 bits/sec, 25 packets/sec


Сделал эксперемент. 
Подключил к еще один телефон, но только с более старой прошивкой. Телефон зарегился, работает стабильно, ПК после телефона сеть получает. 

#
interface Ethernet0/0/2
 description --- port connect to Yealink ---
 port link-type access
 port default vlan 47
 loopback-detect enable
#
Ethernet0/0/2 current state : UP
Line protocol current state : UP
Description:--- port connect to Yealink ---
Switch Port, PVID :   47, TPID : 8100(Hex), The Maximum Frame Length is 2044
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 7054-f5a2-6db4
Port Mode: COMMON COPPER
Speed :  100,  Loopback: NONE
Duplex: FULL,  Negotiation: ENABLE
Mdi   : AUTO
Last 300 seconds input rate 24 bits/sec, 0 packets/sec
Last 300 seconds output rate 1144 bits/sec, 1 packets/sec
#

В чем разница? Коммутотор один и тот же, телефоны одни и те же, только ПО разные. Можно было бы подумать на ПО телефона, но опять же, на коммутаторе другого вендора он работает!
  • x

user_2909167
Модератор Опубликовано 2019-3-26 11:32:00 Полезно(0) Полезно(0)
Здравствуйте.
Информацию про другого вендора комментировать и обсуждать не буду, спасибо за понимание =)
В сценариях с подключением ПК-Телефон-коммутатор, обычно используется схема когда от Телефона идет тегированный траффик, а от ПК - нет.
На коммутаторе порт в режиме hybrid. нетегированные кадры от ПК помещает в data vlan, все что идет о телефона - vlan для сервиса voice.
Голос - vlan 2
дата - vlan 3
Это стандартный вариант подключения телефонов, используемый максимально широко.
[Switch] interface gigabitethernet 0/0/1
[Switch-GigabitEthernet0/0/1] port link-type hybrid
[Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 3
[Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 3
[Switch-GigabitEthernet0/0/1] port hybrid tagged vlan 2
[Switch-GigabitEthernet0/0/1] quit
Дополнительно - voice-vlan 2 enable в интерфейса.
http://support.huawei.com/hedex/hdx.do?docid=EDOC1000135317&id=voice-vlan_enable&text=voice-vlan%252520enable&lang=en

Поскольку Вы установили что проблема в разных прошивках телефона - полагаю так же был заведен кейс в саппорт Yealink . Могу узнать вердикт коллег по разнице в прошивках?
  • x

123
К списку

Комментарий

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход