Хорошо

Настройка S5720 в режиме LACP при подключении к серверу ESX Популярное

Последний ответ авг 26, 2021 12:14:03 363 5 8 0 0



 Описание проблемы

 

  •  Признак неисправности:

    заказчик хотел заменить коммутатор Cisco на S5720, но у него возникли трудности при настройке дополнительных портов коммутатора в режиме LACP.  Пинг не работал.

  • Информация о версии: V200R010C00SPC600


 

Сценарий работы:


 Работающая конфигурация на Cisco была следующей:


interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

#

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

#

interface GigabitEthernet1/0/3

description pdsesxi01 Port 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

#


Конфигурация, которая использовалась на Huawei S5720:


interface Eth-Trunk1

port link-type trunk

port trunk pvid vlan 4

port trunk allow-pass vlan 2 to 4094

mode lacp

#

interface GigabitEthernet0/0/5

description vmesxi-viewR7-01 Port 1

eth-trunk 1

#

interface GigabitEthernet0/0/6

description vmesxi-viewR7-01 Port 2

eth-trunk 1


Решение


Решением этой проблемы было выбрано применение принудительной пересылки lacp в интерфейсе eth-trunk.  То есть до того, как сервер получит файл конфигурации, Interface1 являлся независимым физическим интерфейсом и не был настроен с помощью LACP.  

 

В результате согласование LACP на интерфейсе коммутатора не удавалось, и сервер не мог связаться с коммутатором.  Соответственно коммутатор не пересылал трафик по Eth-Trunk, и сервер не мог загрузить файл конфигурации через Interface1.


Чтобы решить эту проблему, на Eth-Trunk коммутатора запустим команду    lacp force-forward  .  Интерфейс-член Eth-Trunk в состоянии Up может по-прежнему пересылать пакеты данных, даже если удаленное устройство не поддерживает LACP.


    

LACP

 

 Заметка:


 Когда используется эта команда, хотя пересылка уровня 3 не поддерживается, интерфейс в состоянии ForceFwd может пересылать трафик уровня 2.  Состояние ForceFwd устанавливается автоматически при сбое согласования LACP и не может быть изменено вручную.  Используем команду display eth-trunk, чтобы проверить значение поля Status.

 

 Эта команда применима только к сценарию, когда Eth-Trunk присоединяется к VLAN в качестве интерфейсов доступа, гибридных, магистральных и dot1q-туннельных интерфейсов.

 Когда используется протокол связующего дерева (например, STP, RSTP или MSTP), интерфейсы находящиеся в состоянии ForceFwd, не могут быть заблокированы.  Интерфейсы в состоянии ForceFwd могут продолжать пересылать пакеты данных.  При использовании других протоколов предотвращения петель, таких как ERPS и RRPP, интерфейсы, находящиеся в состоянии ForceFwd, могут быть заблокированы и не могут пересылать пакеты данных.

 Эту команду нельзя использовать с E-Trunk.  То есть эту команду нельзя использовать на Eth-Trunk, который присоединяется к E-Trunk.

 Эту команду нельзя использовать с максимальным max active-linknumberили минимальным активным номером ссылки least active-linknumber.


  • x

Vasyo
Админ Опубликовано 2021-8-26 11:33:42
Настройка S5720 в режиме LACP при подключении к серверу ESX-4104181-1
Развернуть
  • x

Maksim
HCIE MVE Опубликовано 2021-8-26 12:14:03
Как опция - полезное знание, но в конкретном случае не проще временно переключить в "ручной" режим?
Развернуть
  • x

Vasyo
Vasyo Опубликовано 2021-8-26 12:27 (0) (0)
Как бы вы это исполнили в CLI?  
Maksim
Maksim Ответить Vasyo  Опубликовано 2021-8-26 12:31 (0) (0)
удалить mode в конфигурации транка?  
Vasyo
Vasyo Ответить Maksim  Опубликовано 2021-8-27 10:50 (0) (0)
mode manual load-balance
Вот тут нашел https://support.huawei.com/enterprise/en/doc/EDOC1100197892/93d95ae0/setting-the-link-aggregation-mode-to-manual  

Комментарий

Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация
Отправить

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Пользовательское соглашение.”

My Followers

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход

Заблокировать
Вы уверены, что хотите заблокировать этого пользователя?
Пользователи из вашего черного списка не могут комментировать ваши посты, не могут упоминать вас, не могут отправлять личные сообщения.
Напоминание
Пожалуйста, привяжите свой мобильный номер чтобы получить бонус за приглашение.
О защите информации
Благодарим за использование Huawei ICT Club! Мы хотим рассказать вам о том, как мы собираем, используем и храним ваши данные. Пожалуйста, внимательно ознакомьтесь с Политикой конфиденциальности и Пользовательским соглашением.