Настройка OSPF stub area

558 0 0 0

Тупиковая зона (stub area). Не принимает информацию о внешних маршрутах для автономной системы, но принимает маршруты из других зон. Если маршрутизаторам из тупиковой зоны необходимо передавать информацию за границу автономной системы, то они используют маршрут по умолчанию. Тупиковая зона уменьшает количество записей в таблице маршрутизации пограничного маршрутизатора и количество передаваемой маршрутной информации.

При настройке тупиковой зоны необходимо помнить:

·   Магистральная зона (backbone area) не может быть тупиковой.

·   На всех маршрутизаторах зоны должна быть указана “тупиковость”.

·   В тупиковой зоне не может находиться ASBR.

·   В тупиковой зоне нельзя настроить виртуальные линки.

На примере простой топологии рассмотрим, что произойдет если area 1 станет тупиковой (stub area).

ospf stub area

1.  Сначала настроим IP адреса на всех маршрутизаторах:

AR1
interface GigabitEthernet 0/0/0
ip address 192.168.1.1 24

interface LoopBack 0
ip address 1.1.1.1 32

AR2
interface GigabitEthernet 0/0/0
ip address 192.168.1.2 24

interface GigabitEthernet 0/0/1
ip address 172.16.1.1 24

interface LoopBack 0
ip address 2.2.2.2 32

AR3
interface GigabitEthernet 0/0/1
ip address 172.16.1.2 24

interface LoopBack 0
ip address 3.3.3.3 32

2.  Включим и настроим OSPF процесс на каждом маршрутизаторе:

AR1
ospf 1 router-id 1.1.1.1
  area 0
network 1.1.1.1 0.0.0.0
network 192.168.1.0 0.0.0.255

AR2
ospf 1 router-id 2.2.2.2
  area 0
network 2.2.2.2 0.0.0.0
network 192.168.1.0 0.0.0.255 
  area 1
network 172.16.1.0 0.0.0.255

AR3
ospf 1 router-id 3.3.3.3
  area 1
network 3.3.3.3 0.0.0.0
network 172.16.1.0 0.0.0.255

Настроим импорт маршрутов в ospf процесс на маршрутизаторе AR1:

[AR1] interface LoopBack 10
[AR1-LoopBack10] ip address 5.5.5.5 255.255.255.255

[AR1] int LoopBack 20
[AR1-LoopBack20] ip address 6.6.6.6 255.255.255.255

[AR1] ip route-static 10.10.10.0 255.255.255.0 NULL0
[AR1] ip route-static 20.20.20.0 255.255.255.0 NULL0

[AR1] ospf
[AR1-ospf-1] import-route direct
[AR1-ospf-1] import-route static

Проверим таблицу маршрутизации на AR3:

[AR3] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
                  Destinations : 12                Routes : 12

Destination/Mask      Proto      Pre    Cost    Flags   NextHop       Interface

            1.1.1.1/32      OSPF     10       2         D        172.16.1.1   GigabitEthernet0/0/1
            2.2.2.2/32      OSPF     10       1         D        172.16.1.1   GigabitEthernet0/0/1
            3.3.3.3/32      Direct     0         0         D        127.0.0.1     LoopBack0
            5.5.5.5/32      O_ASE  150     1         D        172.16.1.1   GigabitEthernet0/0/1
            6.6.6.6/32      O_ASE  150     1
         D        172.16.1.1   GigabitEthernet0/0/1
      10.10.10.0/24      O_ASE  150     1
         D        172.16.1.1   GigabitEthernet0/0/1
      20.20.20.0/24      O_ASE  150     1
         D        172.16.1.1   GigabitEthernet0/0/1
          127.0.0.0/8      Direct     0        0
         D         127.0.0.1     InLoopBack0
        127.0.0.1/32      Direct     0        0
         D        127.0.0.1      InLoopBack0
      172.16.1.0/24      Direct     0        0
         D        172.16.1.2   GigabitEthernet0/0/1
      172.16.1.2/32      Direct     0        0
         D        127.0.0.1     GigabitEthernet0/0/1
    192.168.1.0/24      OSPF     10      2
          D       172.16.1.1   GigabitEthernet0/0/1

[AR3] display ospf routing

                   OSPF Process 1 with Router ID 3.3.3.3
                                    Routing Tables

Routing for Network
Destination           Cost     Type            NextHop      AdvRouter      Area
3.3.3.3/32             0           Stub            3.3.3.3            3.3.3.3          0.0.0.1
172.16.1.0/24       1           Transit        172.16.1.2      3.3.3.3          0.0.0.1
1.1.1.1/32             2           Inter-area    172.16.1.1      2.2.2.2          0.0.0.1
2.2.2.2/32             1           Inter-area    172.16.1.1      2.2.2.2          0.0.0.1
192.168.1.0/24     2           Inter-area    172.16.1.1      2.2.2.2          0.0.0.1

Routing for ASEs
Destination          Cost      Type           Tag         NextHop          AdvRouter
5.5.5.5/32              1          Type2          1           172.16.1.1         1.1.1.1
6.6.6.6/32              1          Type2          1           172.16.1.1         1.1.1.1
10.10.10.0/24        1          Type2          1           172.16.1.1         1.1.1.1
20.20.20.0/24        1          Type2          1           172.16.1.1         1.1.1.1

Total Nets: 9
Intra Area: 2 Inter Area: 3 ASE: 4 NSSA: 0

[AR3] display ospf lsdb

                   OSPF Process 1 with Router ID 3.3.3.3
                                    Link State Database

                                                 Area: 0.0.0.1
Type             LinkState ID     AdvRouter        Age    Len    Sequence    Metric
Router           2.2.2.2              2.2.2.2              187     36      80000004      1
Router           3.3.3.3              3.3.3.3              176     48      80000005      1
Network       172.16.1.2         3.3.3.3              176     32      80000002      0
Sum-Net       2.2.2.2              2.2.2.2               235     28      80000001      0
Sum-Net       1.1.1.1              2.2.2.2               198     28      80000001     1
Sum-Net       192.168.1.0      2.2.2.2               235     28      80000001     1
Sum-Asbr     1.1.1.1              2.2.2.2               142     28      80000001     1


                               AS External Database
Type           LinkState ID     AdvRouter     Age   Len    Sequence    Metric
External     10.10.10.0         1.1.1.1            143    36     80000001      1
External     6.6.6.6               1.1.1.1            143    36     80000001      1
External     5.5.5.5               1.1.1.1            143    36     80000001      1
External     192.168.1.0       1.1.1.1            143    36     80000001      1
External     20.20.20.0         1.1.1.1            143    36     80000001      1
External     1.1.1.1               1.1.1.1            143    36     80000001      1

3.  Теперь настроим area1 как тупиковую и снова проверим таблицу маршрутизации наAR3.

[AR2] ospf
[AR2-ospf-1] area 1
[AR2-ospf-1-area-0.0.0.1] stub 

[AR3] ospf
[AR3-ospf-1] area 1
[AR3-ospf-1-area-0.0.0.1] stub

[AR3] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
                  Destinations : 9                Routes : 9

Destination/Mask         Proto     Pre    Cost    Flags   NextHop       Interface

0.0.0.0/0                       OSPF     10      2          D      172.16.1.1     GigabitEthernet0/0/1
1.1.1.1/32                     OSPF     10      2          D      172.16.1.1     GigabitEthernet0/0/1
2.2.2.2/32                     OSPF     10      1          D      172.16.1.1     GigabitEthernet0/0/1
3.3.3.3/32                     Direct     0       0           D     127.0.0.1       LoopBack0
127.0.0.0/8                   Direct     0       0           D     127.0.0.1       InLoopBack0
127.0.0.1/32                 Direct     0       0           D     127.0.0.1       InLoopBack0
172.16.1.0/24               Direct     0       0           D     172.16.1.2     GigabitEthernet0/0/1
172.16.1.2/32               Direct     0       0           D     127.0.0.1       GigabitEthernet0/0/1
192.168.1.0/24             OSPF     10      2          D     172.16.1.1      GigabitEthernet0/0/1

[AR3] display ospf routing

                   OSPF Process 1 with Router ID 3.3.3.3
                                     Routing Tables

Routing for Network
Destination              Cost     Type             NextHop      AdvRouter     Area
3.3.3.3/32                  0         Stub             3.3.3.3          3.3.3.3          0.0.0.1
172.16.1.0/24            1         Transit         172.16.1.2    3.3.3.3          0.0.0.1
0.0.0.0/0                    2         Inter-area   172.16.1.1    2.2.2.2          0.0.0.1
1.1.1.1/32                  2         Inter-area     172.16.1.1    2.2.2.2          0.0.0.1
2.2.2.2/32                  1         Inter-area     172.16.1.1    2.2.2.2          0.0.0.1
192.168.1.0/24          2         Inter-area     172.16.1.1    2.2.2.2          0.0.0.1

Total Nets: 6
Intra Area: 2 Inter Area: 4 ASE: 0 NSSA: 0

[AR3] display ospf lsdb

                   OSPF Process 1 with Router ID 3.3.3.3
                                    Link State Database

                                                Area: 0.0.0.1
Type             LinkState ID      AdvRouter      Age    Len    Sequence     Metric
Router          2.2.2.2                2.2.2.2             270     36     80000005        1
Router          3.3.3.3                3.3.3.3             264     48     80000005        1
Network       172.16.1.2          3.3.3.3             264     32     80000002        0
Sum-Net      0.0.0.0                2.2.2.2             325    28      80000001        1
Sum-Net       2.2.2.2               2.2.2.2              325    28     80000001        0
Sum-Net       1.1.1.1               2.2.2.2              325    28     80000001        1
Sum-Net       192.168.1.0       2.2.2.2              325    28     80000001        1

Как мы можем видеть, в тупиковой зоне не видны внешние маршруты. Вместо них, присутствует маршрут по умолчанию.

4.  Теперь остановим отправку Type 3 LSA сообщений в тупиковую зону.

[AR2] ospf
[AR2-ospf-1] area 1
[AR2-ospf-1-area-0.0.0.1] stub no-summary

И проверим таблицу маршрутизации на AR3:

[AR3] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
                  Destinations : 6 Routes : 6

Destination/Mask        Proto      Pre    Cost    Flags    NextHop       Interface

0.0.0.0/0                      OSPF      10      2         D         172.16.1.1    GigabitEthernet0/0/1
3.3.3.3/32                    Direct      0       0         D          127.0.0.1      LoopBack0
127.0.0.0/8                  Direct      0       0         D          127.0.0.1      InLoopBack0
127.0.0.1/32                Direct      0       0         D          127.0.0.1      InLoopBack0
172.16.1.0/24              Direct      0       0         D          172.16.1.2    GigabitEthernet0/0/1
172.16.1.2/32              Direct      0       0         D          127.0.0.1      GigabitEthernet0/0/1

[AR3] display ospf routing

                  OSPF Process 1 with Router ID 3.3.3.3
                                     Routing Tables

Routing for Network
Destination               Cost      Type               NextHop       AdvRouter      Area
3.3.3.3/32                   0          Stub               3.3.3.3            3.3.3.3          0.0.0.1
172.16.1.0/24             1          Transit           172.16.1.2      3.3.3.3          0.0.0.1
0.0.0.0/0                     2          Inter-area     172.16.1.1      2.2.2.2          0.0.0.1

Total Nets: 3
Intra Area: 2 Inter Area: 1 ASE: 0 NSSA: 0

[AR3] display ospf lsdb

                  OSPF Process 1 with Router ID 3.3.3.3
                                   Link State Database

                                                 Area: 0.0.0.1
Type             LinkState ID        AdvRouter      Age     Len     Sequence    Metric
Router           2.2.2.2                   2.2.2.2            75       36      80000007       1
Router           3.3.3.3                   3.3.3.3            73       48      8000000A      1
Network        172.16.1.2             3.3.3.3            73       32      80000002       0
Sum-Net        0.0.0.0                  2.2.2.2           454      28      80000001       1

На тупиковом маршрутизаторе записей в таблице маршрутизации стало ещё меньше и теперь у нас есть только маршрут по умолчанию в качестве выхода из зоны.

 

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход