Настройка L2TP LAC-auto-initiated туннеля

1257 0 0 0

Layer 2 tunneling protocol (L2TP) соединение может быть установлено одним из трёх следующих способов:

1. NAS-initializated

2. Client-initializated

3. LAC-auto-initializated.

В большинстве случаев, L2TP пользователь напрямую устанавливает соединение с LAC (L2TP Access Concentrator), и между пользователем и LAC устанавливается PPP соединение. В отличии от NAS-initializated и Client-initializated, в LAC-auto-initializated способе пользователи соединяются с LAC путем отправки IP пакетов. В тоже время между LAC и LNS (L2TP Network Server) должен быть установлен туннель. На двух концах L2TP туннеля находятся LAC и LNS, соответственно. Рассмотрим пример настройки L2TP соединения при помощи третьего способа на примере следующей топологии:

L2TP_1

Перейдем к настройке. Сначала присвоим IP адреса интерфейсам на наших маршрутизаторах:

LAC
interface GigabitEthernet0/0/0
ip address 202.1.1.1 255.255.255.0

interface GigabitEthernet0/0/1
ip address 192.168.1.1 255.255.255.0

LNS
interface GigabitEthernet0/0/0
ip address 202.1.1.2 255.255.255.0

interface GigabitEthernet0/0/1
ip address 192.168.2.1 255.255.255.0

Сначала будем настраивать LAC маршрутизатор. Далее необходимо глобально разрешить L2TP на маршрутизаторе и настроить параметры L2TP группы для установления L2TP соединения с другим маршрутизатором:

l2tp enable
l2tp-group 1
tunnel name lac
tunnel password cipher huawei
start l2tp ip 202.1.1.2 fullusername Huawei

Настраиваем способ аутентификации, имя пользователя и пароль для виртуального интерфейса. IP адрес мы будем получать от сервера:

interface Virtual-Template 1
ppp authentication-mode chap
ppp chap user huawei
ppp chap password cipher Huawei@1234
ip address ppp-negotiate

Также на виртуальном интерфейсе разрешаем устанавливать L2TP туннель:

l2tp-auto-client enable

И наконец задаем статический маршрут чтобы трафик до сети 192.168.2.0 шел через L2TP туннель:

ip route-static 192.168.2.0 255.255.255.0 Virtual-Template1

Теперь переходим к настройкам LNS:

aaa
local-user huawei password cipher Huawei@1234
local-user huawei service-type ppp

Настроим пул IP адресов, из которого будет выделен IP адрес для LAC интерфейса при установлении соединения:

ip pool 1
network 192.168.10.0 mask 255.255.255.0
gateway-list 192.168.10.1

Далее поднимаем виртуальный интерфейс и настраиваем параметры PPP соединения:

interface Virtual-Template1
ppp authentication-mode chap
remote address pool 1
ip address 192.168.10.1 255.255.255.0

Разрешаем L2TP и настраиваем параметры L2TP группы:

l2tp enable
l2tp-group 1

allow l2tp virtual-template 1 remote lac
tunnel password cipher huawei
tunnel name lns

Задаем статический маршрут чтобы трафик до сети 192.168.1.0 шел через L2TP туннель:

ip route-static 192.168.1.0 255.255.255.0 Virtual-Template1

Настройкаокончена.Проверим, установилась ли L2TP сессия:

[LAC] display l2tp session

LocalSID RemoteSID LocalTID
1 1 1

Total session = 1

[LAC] display l2tp tunnel

Total tunnel = 1
LocalTID RemoteTID RemoteAddress Port Sessions RemoteName
1 1 202.1.1.2 42246 1 lns

[LNS] display l2tp tunnel

Total tunnel = 1
LocalTID RemoteTID RemoteAddress Port Sessions RemoteName
1 1 202.1.1.1 42246 1 lac

Как видим, L2TP туннель был успешно установлен. Поймаем пакеты на линке между LAC и LNS маршрутизаторами и проверим их:

L2TP_2

Проверим соединение между хостами:

PC> ping 192.168.2.10

Ping 192.168.2.10: 32 data bytes, Press Ctrl_C to break
From 192.168.2.10: bytes=32 seq=1 ttl=126 time=31 ms
From 192.168.2.10: bytes=32 seq=2 ttl=126 time=31 ms
From 192.168.2.10: bytes=32 seq=3 ttl=126 time=31 ms
From 192.168.2.10: bytes=32 seq=4 ttl=126 time=16 ms
From 192.168.2.10: bytes=32 seq=5 ttl=126 time=31 ms

--- 192.168.2.10 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 16/28/31 msPC> ping 192.168.2.10

L2TP_3

У статьи есть другие ресурсы

Требуется войти для загрузки или просмотра. Нет аккаунта?Register

x
  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход
Быстрый ответ Вверх