Хорошо

Настройка ERPS с несколькими экземплярами

271 0 2 0 0

Поддерживаемые продукты и версии

Этот пример относится к CE12800 (без CE12800E) по версии V100R003C00 или более поздней версии, CE8800 по версии V100R006C00 или более поздней версии и CE7800, CE6800, CE5800 (за исключением CE6880EI) по версии V100R003C10 или более поздней версии.

Требования к сети

Рис. 1. показывает, что SwitchA через SwitchC представляет собой кольцевую сеть на уровне агрегации для реализации агрегации услуг на уровне 2 и обработки услуг уровня 3. ERPS используется в кольцевой сети для обеспечения переключения защиты для избыточных ссылок уровня 2. Кольцо ERPS 1 и кольцо ERPS 2 настроены на SwitchA через SwitchC. Eth-Trunk2 на SwitchA является заблокированным портом в кольце ERPS 1, а Eth-Trunk3 на SwitchB является заблокированным портом в кольце ERPS 2, реализующим балансировку нагрузки и резервное копирование ссылок.


download?uuid=363d3caf599b48a887cdedff29e3f510

Рисунок 1.  Организация сети ERPS с несколькими экземплярами

План конфигурации

1. Настройте тип ссылки всех портов, которые будут добавлены в кольца ERPS в качестве соединительной линии.

2. Создавайте кольца ERPS и настраивайте управляющие VLAN и экземпляры Ethernet Ring Protection (ERP) в кольцах ERPS.

3. Добавьте порты уровня 2 в кольца ERPS и укажите роли портов.

4. Настройте таймеры Guard и таймеры WTR в кольцах ERPS.

5. Настройте перенаправление второго уровня на SwitchA через SwitchC.

Procedure

1. Настройте тип ссылки для всех портов, которые будут добавлены в кольцо ERPS в качестве соединительной линии.

 

# Настройте SwitchA.

<HUAWEI> system-view

[~HUAWEI] sysname SwitchA

[*HUAWEI] commit

[~SwitchA] interface eth-trunk 1

[*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/1

[*SwitchA-Eth-Trunk1] trunkport 10ge 1/0/2

[*SwitchA-Eth-Trunk1] port link-type trunk

[*SwitchA-Eth-Trunk1] quit

[*SwitchA] interface eth-trunk 2

[*SwitchA-Eth-Trunk2] trunkport 10ge 1/0/3

[*SwitchA-Eth-Trunk2] trunkport 10ge 1/0/4

[*SwitchA-Eth-Trunk2] port link-type trunk

[*SwitchA-Eth-Trunk2] quit

[*SwitchA] commit

 

# Настройте SwitchB.

<HUAWEI> system-view

[~HUAWEI] sysname SwitchB

[*HUAWEI] commit

[~SwitchB] interface eth-trunk 1

[*SwitchB-Eth-Trunk1] trunkport 10ge 1/0/1

[*SwitchB-Eth-Trunk1] trunkport 10ge 1/0/2

[*SwitchB-Eth-Trunk1] port link-type trunk

[*SwitchB-Eth-Trunk1] quit

[*SwitchB] interface eth-trunk 3

[*SwitchB-Eth-Trunk3] trunkport 10ge 1/0/3

[*SwitchB-Eth-Trunk3] trunkport 10ge 1/0/4

[*SwitchB-Eth-Trunk3] port link-type trunk

[*SwitchB-Eth-Trunk3] quit

[*SwitchB] commit

 

# Настройте SwitchС.

<HUAWEI> system-view

[~HUAWEI] sysname SwitchC

[*HUAWEI] commit

[~SwitchC] interface eth-trunk 2

[*SwitchC-Eth-Trunk1] trunkport 10ge 1/0/3

[*SwitchC-Eth-Trunk1] trunkport 10ge 1/0/4

[*SwitchC-Eth-Trunk1] port link-type trunk

[*SwitchC-Eth-Trunk1] quit

[*SwitchC] interface eth-trunk 3

[*SwitchC-Eth-Trunk3] trunkport 10ge 1/0/1

[*SwitchC-Eth-Trunk3] trunkport 10ge 1/0/2

[*SwitchC-Eth-Trunk3] port link-type trunk

[*SwitchC-Eth-Trunk3] quit

[*SwitchC] commit

 

2. Создайте кольцо ERPS 1 и кольцо ERPS 2 и настройте экземпляры ERP в двух кольцах. Установите идентификатор VLAN управления для кольца ERPS с 1 по 10 и идентификатор VLAN управления кольца ERPS с 2 по 20. Включите кольцо ERPS 1 для передачи пакетов данных из VLAN с 100 по 200 и активируйте кольцо ERPS 2 для передачи пакетов данных из сетей VLAN с 300 по 400.

 

# Настройте SwitchA.

[~SwitchA] erps ring 1

[*SwitchA-erps-ring1] control-vlan 10

[*SwitchA-erps-ring1] protected-instance 1

[*SwitchA-erps-ring1] commit

[~SwitchA-erps-ring1] quit

[~SwitchA] stp region-configuration

[~SwitchA-mst-region] instance 1 vlan 10 100 to 200

[*SwitchA-mst-region] commit

[~SwitchA-mst-region] quit

[~SwitchA] erps ring 2

[*SwitchA-erps-ring2] control-vlan 20

[*SwitchA-erps-ring2] protected-instance 2

[*SwitchA-erps-ring2] commit

[~SwitchA-erps-ring2] quit

[~SwitchA] stp region-configuration

[~SwitchA-mst-region] instance 2 vlan 20 300 to 400

[*SwitchA-mst-region] commit

[~SwitchA-mst-region] quit

 

# Настройте SwitchB.

[~SwitchB] erps ring 1

[*SwitchB-erps-ring1] control-vlan 10

[*SwitchB-erps-ring1] protected-instance 1

[*SwitchB-erps-ring1] commit

[~SwitchB-erps-ring1] quit

[~SwitchB] stp region-configuration

[~SwitchB-mst-region] instance 1 vlan 10 100 to 200

[*SwitchB-mst-region] commit

[~SwitchB-mst-region] quit

[~SwitchB] erps ring 2

[*SwitchB-erps-ring2] control-vlan 20

[*SwitchB-erps-ring2] protected-instance 2

[*SwitchB-erps-ring2] commit

[~SwitchB-erps-ring2] quit

[~SwitchB] stp region-configuration

[~SwitchB-mst-region] instance 2 vlan 20 300 to 400

[*SwitchB-mst-region] commit

[~SwitchB-mst-region] quit

 

# Настройте SwitchС.

[~SwitchC] erps ring 1

[*SwitchC-erps-ring1] control-vlan 10

[*SwitchC-erps-ring1] protected-instance 1

[*SwitchC-erps-ring1] commit

[~SwitchC-erps-ring1] quit

[~SwitchC] stp region-configuration

[~SwitchC-mst-region] instance 1 vlan 10 100 to 200

[*SwitchC-mst-region] commit

[~SwitchC-mst-region] quit

[~SwitchC] erps ring 2

[*SwitchC-erps-ring2] control-vlan 20

[*SwitchC-erps-ring2] protected-instance 2

[*SwitchC-erps-ring2] commit

[~SwitchC-erps-ring2] quit

[~SwitchC] stp region-configuration

[~SwitchC-mst-region] instance 2 vlan 20 300 to 400

[*SwitchC-mst-region] commit

[~SwitchC-mst-region] quit

 

3. Добавьте порты уровня 2 в кольца ERPS и укажите роли портов. Настройте Eth-Trunk2 на SwitchA и Eth-Trunk3 на SwitchB как их соответствующие порты владельца RPL.

 

# Настройте SwitchA.

[~SwitchA] interface eth-trunk 1

[~SwitchA-Eth-Trunk1] stp disable

[*SwitchA-Eth-Trunk1] erps ring 1

[*SwitchA-Eth-Trunk2] erps ring 2

[*SwitchA-Eth-Trunk1] commit

[~SwitchA-Eth-Trunk1] quit

[~SwitchA] interface eth-trunk 2

[~SwitchA-Eth-Trunk2] stp disable

[*SwitchA-Eth-Trunk2] erps ring 1 rpl owner

[*SwitchA-Eth-Trunk2] erps ring 2

[*SwitchA-Eth-Trunk2] commit

[~SwitchA-Eth-Trunk2] quit

 

# Настройте SwitchB.

[~SwitchB] interface eth-trunk 1

[~SwitchB-Eth-Trunk1] stp disable

[*SwitchB-Eth-Trunk1] erps ring 1

[*SwitchB-Eth-Trunk1] erps ring 2

[*SwitchB-Eth-Trunk1] commit

[~SwitchB-Eth-Trunk1] quit

[~SwitchB] interface eth-trunk 3

[~SwitchB-Eth-Trunk3] stp disable

[*SwitchB-Eth-Trunk3] erps ring 1

[*SwitchB-Eth-Trunk3] erps ring 2 rpl owner

[*SwitchB-Eth-Trunk3] commit

[~SwitchB-Eth-Trunk3] quit

 

# Настройте SwitchС.

[~SwitchC] interface eth-trunk 2

[~SwitchC-Eth-Trunk2] stp disable

[*SwitchC-Eth-Trunk2] erps ring 1

[*SwitchC-Eth-Trunk2] erps ring 2

[*SwitchC-Eth-Trunk2] commit

[~SwitchC-Eth-Trunk2] quit

[~SwitchC] interface eth-trunk 3

[~SwitchC-Eth-Trunk3] stp disable

[*SwitchC-Eth-Trunk3] erps ring 1

[*SwitchC-Eth-Trunk3] erps ring 2

[*SwitchC-Eth-Trunk3] commit

[~SwitchC-Eth-Trunk3] quit

 

4. Настройте таймеры Guard и таймеры WTR в кольцах ERPS.

 

# Настройте SwitchA.

[~SwitchA] erps ring 1

[~SwitchA-erps-ring1] wtr-timer 6

[*SwitchA-erps-ring1] guard-timer 100

[*SwitchA-erps-ring1] commit

[~SwitchA-erps-ring1] quit

[~SwitchA] erps ring 2

[~SwitchA-erps-ring2] wtr-timer 6

[*SwitchA-erps-ring2] guard-timer 100

[*SwitchA-erps-ring2] commit

[~SwitchA-erps-ring2] quit

 

# Настройте SwitchB.

[~SwitchB] erps ring 1

[~SwitchB-erps-ring1] wtr-timer 6

[*SwitchB-erps-ring1] guard-timer 100

[*SwitchB-erps-ring1] commit

[~SwitchB-erps-ring1] quit

[~SwitchB] erps ring 2

[~SwitchB-erps-ring2] wtr-timer 6

[*SwitchB-erps-ring2] guard-timer 100

[*SwitchB-erps-ring2] commit

[~SwitchB-erps-ring2] quit

 

# Настройте SwitchС.

[~SwitchC] erps ring 1

[~SwitchC-erps-ring1] wtr-timer 6

[*SwitchC-erps-ring1] guard-timer 100

[*SwitchC-erps-ring1] commit

[~SwitchC-erps-ring1] quit

[~SwitchC] erps ring 2

[~SwitchC-erps-ring2] wtr-timer 6

[*SwitchC-erps-ring2] guard-timer 100

[*SwitchC-erps-ring2] commit

[~SwitchC-erps-ring2] quit

 

5. Настройте перенаправление второго уровня на SwitchA через SwitchC.

 

# Настройте SwitchA.

[~SwitchA] vlan batch 100 to 200 300 to 400

[*SwitchA] commit

[~SwitchA] interface eth-trunk 1

[~SwitchA-Eth-Trunk1] port trunk allow-pass vlan 100 to 200 300 to 400

[*SwitchA-Eth-Trunk1] commit

[~SwitchA-Eth-Trunk1] quit

[~SwitchA] interface eth-trunk 2

[~SwitchA-Eth-Trunk2] port trunk allow-pass vlan 100 to 200 300 to 400

[*SwitchA-Eth-Trunk2] commit

[~SwitchA-Eth-Trunk2] quit

 

# Настройте SwitchB.

[~SwitchB] vlan batch 100 to 200 300 to 400

[*SwitchB] commit

[~SwitchB] interface eth-trunk 1

[~SwitchB-Eth-Trunk1] port trunk allow-pass vlan 100 to 200 300 to 400

[*SwitchB-Eth-Trunk1] commit

[~SwitchB-Eth-Trunk1] quit

[~SwitchB] interface eth-trunk 3

[~SwitchB-Eth-Trunk3] port trunk allow-pass vlan 100 to 200 300 to 400

[*SwitchB-Eth-Trunk3] commit

[~SwitchB-Eth-Trunk3] quit

 

# Настройте SwitchС.

[~SwitchC] vlan batch 100 to 200 300 to 400

[*SwitchC] commit

[~SwitchC] interface eth-trunk 2

[~SwitchC-Eth-Trunk2] port trunk allow-pass vlan 100 to 200 300 to 400

[*SwitchC-Eth-Trunk2] commit

[~SwitchC-Eth-Trunk2] quit

[~SwitchC] interface eth-trunk 3

[~SwitchC-Eth-Trunk3] port trunk allow-pass vlan 100 to 200 300 to 400

[*SwitchC-Eth-Trunk3] commit

[~SwitchC-Eth-Trunk3] quit

Проверка конфигурации

# После того, как сеть станет стабильной, запустите команду display erps, чтобы проверить краткую информацию о кольце ERPS и портах, добавленных в кольцо ERPS. В качестве примера используется SwitchB.

 

[~SwitchB] display erps

D : Discarding

F : Forwarding

R : RPL Owner

N  : RPL Neighbour

FS : Forced Switch

MS : Manual Switch

Total number of rings configured = 2

Ring  Control  WTR Timer  Guard Timer  Port 1              Port 2

ID    VLAN     (min)      (csec)

--------------------------------------------------------------------------------

   1       10          6          100  (F)Eth-Trunk1       (F)Eth-Trunk3

   2       20          6          100  (F)Eth-Trunk1       (D,R)Eth-Trunk3

--------------------------------------------------------------------------------

 


# Выполните команду display erps verbose для отображения подробной информации о кольце ERPS и портах, добавленных в кольцо ERPS. В качестве примера используется SwitchB.

 

[~SwitchB] display erps verbose

Ring ID                             : 1

Description                         : Ring 1

Control Vlan                        : 10

Protected Instance                  : 1

Service Vlan                        : 100 to 200

WTR Timer Setting (min)             : 6      Running (s)           : 0

Guard Timer Setting (csec)          : 100    Running (csec)        : 0

Holdoff Timer Setting (deciseconds) : 0      Running (deciseconds) : 0

WTB Timer Running (csec)            : 0

Ring State                          : Idle

RAPS_MEL                            : 7

Revertive Mode                      : Revertive

R-APS Channel Mode                  : -

Version                             : 1

Sub-ring                            : No

Forced Switch Port                  : -

Manual Switch Port                  : -

TC-Notify                           : -

Time since last topology change     : 0 days 0h:35m:5s

--------------------------------------------------------------------------------

Port                Port Role     Port Status     Signal Status

--------------------------------------------------------------------------------

Eth-Tunk1           Common        Forwarding      Non-failed

Eth-Tunk3           Common        Forwarding      Non-failed

 

Ring ID                             : 2

Description                         : Ring 2

Control Vlan                        : 20

Protected Instance                  : 2

Service Vlan                        : 300 to 400

WTR Timer Setting (min)             : 6      Running (s)           : 0

Guard Timer Setting (csec)          : 100    Running (csec)        : 0

Holdoff Timer Setting (deciseconds) : 0      Running (deciseconds) : 0

WTB Timer Running (csec)            : 0

Ring State                          : Idle

RAPS_MEL                            : 7

Revertive Mode                      : Revertive

R-APS Channel Mode                  : -

Version                             : 1

Sub-ring                            : No

Forced Switch Port                  : -

Manual Switch Port                  : -

TC-Notify                           : -

Time since last topology change     : 0 days 0h:35m:30s

--------------------------------------------------------------------------------

Port                Port Role     Port Status     Signal Status

--------------------------------------------------------------------------------

Eth-Tunk1           Common        Forwarding      Non-failed

Eth-Tunk3           RPL Owner     Discarding      Non-failed

 

Файлы конфигурации

·         Файл конфигурации SwitchA

#

sysname SwitchA

#

vlan batch 10 20 100 to 200 300 to 400

#

stp region-configuration

 instance 1 vlan 10 100 to 200

 instance 2 vlan 20 300 to 400

#

erps ring 1

 control-vlan 10

 protected-instance 1

 wtr-timer 6

 guard-timer 100

#

erps ring 2

 control-vlan 20

 protected-instance 2

 wtr-timer 6

 guard-timer 100

#

interface Eth-Trunk1

 port link-type trunk

 port trunk allow-pass vlan 10 20 100 to 200 300 to 400

 stp disable

 erps ring 1

 erps ring 2

#

interface Eth-Trunk2

 port link-type trunk

 port trunk allow-pass vlan 10 20 100 to 200 300 to 400

 stp disable

 erps ring 1 rpl owner

 erps ring 2

#

interface 10GE1/0/1

 eth-trunk1

#

interface 10GE1/0/2

 eth-trunk1

#

interface 10GE1/0/3

 eth-trunk2

#

interface 10GE1/0/4

 eth-trunk2

#

return

·         Файл конфигурации SwitchB

#

sysname SwitchB

#

vlan batch 10 20 100 to 200 300 to 400

#

stp region-configuration

 instance 1 vlan 10 100 to 200

 instance 2 vlan 20 300 to 400

#

erps ring 1

 control-vlan 10

 protected-instance 1

 wtr-timer 6

 guard-timer 100

#

erps ring 2

 control-vlan 20

 protected-instance 2

 wtr-timer 6

 guard-timer 100

#

interface Eth-Trunk1

 port link-type trunk

 port trunk allow-pass vlan 10 20 100 to 200 300 to 400

 stp disable

 erps ring 1

 erps ring 2

#

interface Eth-Trunk3

 port link-type trunk

 port trunk allow-pass vlan 10 20 100 to 200 300 to 400

 stp disable

 erps ring 1

 erps ring 2 rpl owner

#

interface 10GE1/0/1

 eth-trunk1

#

interface 10GE1/0/2

 eth-trunk1

#

interface 10GE1/0/3

 eth-trunk3

#

interface 10GE1/0/4

 eth-trunk3

#

return

 

·         Файл конфигурации SwitchC

#

sysname SwitchC

#

vlan batch 10 20 100 to 200 300 to 400

#

stp region-configuration

 instance 1 vlan 10 100 to 200

 instance 2 vlan 20 300 to 400

#

erps ring 1

 control-vlan 10

 protected-instance 1

 wtr-timer 6

 guard-timer 100

#

erps ring 2

 control-vlan 20

 protected-instance 2

 wtr-timer 6

 guard-timer 100

#

interface Eth-Trunk2

 port link-type trunk

 port trunk allow-pass vlan 10 20 100 to 200 300 to 400

 stp disable

 erps ring 1

 erps ring 2

#

interface Eth-Trunk3

 port link-type trunk

 port trunk allow-pass vlan 10 20 100 to 200 300 to 400

 stp disable

 erps ring 1

 erps ring 2

#

interface 10GE1/0/1

 eth-trunk3

#

interface 10GE1/0/2

 eth-trunk3

#

interface 10GE1/0/3

 eth-trunk2

#

interface 10GE1/0/4

 eth-trunk2

#

return

 


  • x

Комментарий

Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация
Отправить

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Пользовательское соглашение.”

My Followers

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход

Заблокировать
Вы уверены, что хотите заблокировать этого пользователя?
Пользователи из вашего черного списка не могут комментировать ваши посты, не могут упоминать вас, не могут отправлять личные сообщения.
Напоминание
Пожалуйста, привяжите свой мобильный номер чтобы получить бонус за приглашение.
О защите информации
Благодарим за использование Huawei ICT Club! Мы хотим рассказать вам о том, как мы собираем, используем и храним ваши данные. Пожалуйста, внимательно ознакомьтесь с Политикой конфиденциальности и Пользовательским соглашением.