Хорошо

Настройка BFD для статических маршрутов

222 0 2 0 0


Поддерживаемые продукты и версии


Этот пример относится к CE12800, CE6800, CE5800 по версии V100R001C00 или более поздней версии, CE7800 по версии V100R003C00 или более поздней версии и CE8800 по версии V100R006C00.

Требования к сети


SwitchA и SwitchD подключены через транспортную сеть. Статический маршрут с целевым адресом 8.1.1.0/24 настроен на SwitchA, а статический маршрут с целевым адресом 7.1.1.0/24 настроен на SwitchD. Требуется, чтобы ошибки связи между SwitchA и SwitchD были обнаружены в течение миллисекунд, поэтому статические маршруты на SwitchA и SwitchD не становятся маршрутами черной дыры, когда устройства в транспортной сети неисправны.


Figure 2-20  Сеть BFD для статических маршрутов


download?uuid=e730f27d1c3047009f81fb6cc2a57369

Анализ требований


Привяжите статические сеансы BFD к статическим маршрутам на коммутаторах, чтобы BFD мог быстро обнаруживать неисправности, а статические маршруты не становятся черными.



Procedure


1. Создайте VLAN и добавьте интерфейсы к VLAN.


<HUAWEI>system-view

[~HUAWEI] sysname SwitchA

[*HUAWEI] commit

[~SwitchA] vlan 10

[*SwitchA-vlan10] quit

[*SwitchA] interface 10ge 1/0/1

[*SwitchA-10GE1/0/1] port link-type trunk

[*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10

[*SwitchA-10GE1/0/1] quit

[*SwitchA] commit


Конфигурации SwitchB, SwitchC и SwitchD аналогичны конфигурации SwitchA.


2. Настройте интерфейсы VLANIF и назначьте IP-адреса интерфейсам VLANIF.


[~SwitchA] interface vlanif 10

[*SwitchA-Vlanif10] ip address 7.1.1.1 24

[*SwitchA-Vlanif10] quit

[*SwitchA] commit


Конфигурации SwitchB, SwitchC и SwitchD аналогичны конфигурации SwitchA.


3. Настройте сеансы BFD между SwitchA и SwitchD.


# На SwitchA настройте сеанс BFD с помощью SwitchD.


[~SwitchA] bfd

[*SwitchA-bfd] quit

[*SwitchA] bfd atod bind peer-ip 8.1.1.2

[*SwitchA-bfd-session-atod] discriminator local 10

[*SwitchA-bfd-session-atod] discriminator remote 20

[*SwitchA-bfd-session-atod] commit

[~SwitchA-bfd-session-atod] quit

# На SwitchD настройте сеанс BFD с помощью SwitchA.


[~SwitchD] bfd

[*SwitchD-bfd] quit

[*SwitchD] bfd dtoa bind peer-ip 7.1.1.1

[*SwitchD-bfd-session-dtoa] discriminator local 20

[*SwitchD-bfd-session-dtoa] discriminator remote 10

[*SwitchD-bfd-session-dtoa] commit

[~SwitchD-bfd-session-dtoa] quit


4.Настройте статические маршруты по умолчанию и привяжите сеансы BFD к статическим маршрутам по умолчанию.

# На SwitchA, настройте статический маршрут по умолчанию во внешнюю сеть и привяжите статический маршрут по умолчанию к сеансу BFD с именем atod.


[~SwitchA] ip route-static 8.1.1.2 24 7.1.1.2 track bfd-session atod

[*SwitchA] commit


# На SwitchD настройте статический маршрут по умолчанию во внешнюю сеть и привяжите статический маршрут по умолчанию к сеансу BFD с именем dtoa.


[~SwitchD] ip route-static 7.1.1.1 24 8.1.1.1 track bfd-session dtoa

[*SwitchD] commit


Проверка конфигурации


# По завершении конфигурации запустите команду display bfd session all verbose на SwitchA и SwitchD. 

Вы можете видеть, что сеанс BFD настроен и его статус равен Up, и статический маршрут привязан к сеансу BFD.


В качестве примера используется SwitchA.


[~SwitchA] display bfd session all verbose

------------------------------------------------------------------------------

  Name : atod                    (Multi Hop)  State : Up

--------------------------------------------------------------------------------

  Local Discriminator    : 10               Remote Discriminator   : 20         

  Session Detect Mode    : Asynchronous Mode Without Echo Function              

  BFD Bind Type          : Peer IP Address                                      

  Bind Session Type      : Static                                               

  Bind Peer IP Address   : 8.1.1.2                                             

  Bind Interface         : -                                                    

  FSM Board Id           : 1                TOS-EXP                : 7          

  Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       

  Actual Tx Interval (ms): 3000             Actual Rx Interval (ms): 3000       

  WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       

  Local Detect Multi     : 3                Active Multi           : 3          

  Destination Port       : 4784             TTL                    : 254        

  Last Local Diagnostic  : No Diagnostic                                        

  Bind Application       : STATICRT                                    

  Session Description    : -                                                    

--------------------------------------------------------------------------------


     Total UP/DOWN Session Number : 1/0


# Выполните команду shutdown на 10GE1/0/1 SwitchB для имитации неисправности канала.


[~SwitchB] interface 10ge 1/0/1

[~SwitchB-10GE1/0/1] shutdown

[*SwitchB-10GE1/0/1] commit


# Выполните команду display bfd session all verbose на SwitchA и SwitchD. 

Вывод команды показывает, что состояние сеанса BFD имеет значение Down.


В качестве примера используется SwitchA.


[~SwitchA] display bfd session all verbose

------------------------------------------------------------------------------

  Name : atod                    (Multi Hop)  State : Down

--------------------------------------------------------------------------------

  Local Discriminator    : 10               Remote Discriminator   : 20         

  Session Detect Mode    : Asynchronous Mode Without Echo Function              

  BFD Bind Type          : Peer IP Address                                      

  Bind Session Type      : Static                                               

  Bind Peer IP Address   : 8.1.1.2                                              

  Bind Interface         : -                                                    

  FSM Board Id           : 1                TOS-EXP                : 7          

  Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       

  Actual Tx Interval (ms): 6761             Actual Rx Interval (ms): 6761       

  WTR Interval (ms)      : -                Detect Interval (ms)   : -          

  Local Detect Multi     : 3                Active Multi           : 3          

  Destination Port       : 4784             TTL                    : 254        

  Last Local Diagnostic  : Control Detection Time Expired                       

  Bind Application       : STATICRT                                             

  Session Not Up Reason  : In negotiation                                       

  Session Description    : -                                                    

--------------------------------------------------------------------------------


     Total UP/DOWN Session Number : 1/0


Файлы конфигурации


Файл конфигурации SwitchA


#

sysname SwitchA

#

vlan batch 10

#

bfd

#

interface Vlanif10

 ip address 7.1.1.1 255.255.255.0

#

interface 10GE1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

bfd atod bind peer-ip 8.1.1.2

 discriminator local 10

 discriminator remote 20

#

ip route-static 8.1.1.0 255.255.255.0 7.1.1.2 track bfd-session atod

#

return



Файл конфигурации SwitchB


#

sysname SwitchB

#

vlan batch 10

#

bfd

#

interface Vlanif10

 ip address 7.1.1.2 255.255.255.0

#

interface 10GE1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10

#

return


Файл конфигурации SwitchC


#

sysname SwitchC

#

vlan batch 20

#

bfd

#

interface Vlanif20

 ip address 8.1.1.1 255.255.255.0

#

interface 10GE1/0/1

 port link-type trunk

 port trunk allow-pass vlan 20

#

return


Файл конфигурации SwitchD


#

sysname SwitchD

#

vlan batch 20

#

bfd

#

interface Vlanif20

 ip address 8.1.1.2 255.255.255.0

#

interface 10GE1/0/1

 port link-type trunk

 port trunk allow-pass vlan 20

#

bfd dtoa bind peer-ip 7.1.1.1

 discriminator local 20

 discriminator remote 10

#

ip route-static 7.1.1.0 255.255.255.0 8.1.1.1 track bfd-session dtoa

#

return


Пост синхронизирован: Лаборатория конфигураций

  • x

Комментарий

Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация
Отправить

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Пользовательское соглашение.”

My Followers

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход

Заблокировать
Вы уверены, что хотите заблокировать этого пользователя?
Пользователи из вашего черного списка не могут комментировать ваши посты, не могут упоминать вас, не могут отправлять личные сообщения.
Напоминание
Пожалуйста, привяжите свой мобильный номер чтобы получить бонус за приглашение.
О защите информации
Благодарим за использование Huawei ICT Club! Мы хотим рассказать вам о том, как мы собираем, используем и храним ваши данные. Пожалуйста, внимательно ознакомьтесь с Политикой конфиденциальности и Пользовательским соглашением.