Хорошо

Настройка динамического BFD для OSPF

Последний ответ Sep 24, 2021 08:39:16 266 1 6 0 0


Поддерживаемые продукты и версии


  • Этот пример относится к CE12800, CE6800, CE5800 по версии V100R001C00 или более поздней версии, CE7800 по версии V100R003C00 или более поздней версии и CE8800 по версии V100R006C00.

Требования к сети

OSPF работает между SwitchA и SwitchB. Требуется, чтобы сбои на линии связи между SwitchA и SwitchB были быстро обнаружены и уведомлены OSPF.


Figure 2-21  Сеть BFD для OSPF
download?uuid=1d866b1b01a9483cba98427ead0204a3

Анализ требований


Настройте BFD для OSPF на SwitchA и SwitchB, чтобы быстро обнаруживать неисправности на линии связи между ними.


Procedure


1.Настройте функцию пересылки второго уровня на SwitchA и SwitchB.

Создайте VLAN 10 на SwitchA и SwitchB.


# Создайте VLAN 10 на SwitchA.


<HUAWEI>system-view

[~HUAWEI] sysname SwitchA

[*HUAWEI] commit

[~SwitchA] vlan batch 10

[*SwitchA] commit


# Создайте VLAN 10 на SwitchB.


<HUAWEI>system-view

[~HUAWEI] sysname SwitchB

[*HUAWEI] commit

[~SwitchB] vlan batch 10

[*SwitchB] commit


Добавьте интерфейсы 10GE1/0/1 на SwitchA и SwitchB к VLAN 10.


# Добавьте 10GE1/0/1 на SwitchA к VLAN 10.


[~SwitchA] interface 10ge 1/0/1

[~SwitchA-10GE1/0/1] port link-type trunk

[*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10

[*SwitchA-10GE1/0/1] port trunk pvid vlan 10

[*SwitchA-10GE1/0/1] commit

[~SwitchA-10GE1/0/1] quit


# Добавьте 10GE1/0/1 на SwitchB к VLAN 10.


[~SwitchB] interface 10ge 1/0/1

[~SwitchB-10GE1/0/1] port link-type trunk

[*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10

[*SwitchB-10GE1/0/1] port trunk pvid vlan 10

[*SwitchB-10GE1/0/1] commit

[~SwitchB-10GE1/0/1] quit


2.Настройте соединение между SwitchA и SwitchB.


# Назначьте IP-адрес для каждого интерфейса. SwitchA используется в качестве примера. Конфигурация SwitchB аналогична конфигурации SwitchA.


[~SwitchA] interface vlanif 10

[*SwitchA-Vlanif10] ip address 10.1.1.1 24

[*SwitchA-Vlanif10] quit

[*SwitchA] commit


# Настройте OSPF на SwitchA и SwitchB. SwitchA используется в качестве примера. Конфигурация SwitchB аналогична конфигурации SwitchA.


[~SwitchA] router id 1.1.1.1

[*SwitchA] ospf 1

[*SwitchA-ospf-1] area 0

[*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[*SwitchA-ospf-1-area-0.0.0.0] quit

[*SwitchA-ospf-1] quit

[*SwitchA] commit


3.Настройте BFD для OSPF.


# Включите глобальный BFD на SwitchA.


[~SwitchA] bfd

[*SwitchA-bfd] quit

[*SwitchA] ospf

[*SwitchA-ospf-1] bfd all-interfaces enable

[*SwitchA-ospf-1] quit

[*SwitchA] commit


# Включите глобальный BFD на SwitchB.


[~SwitchB] bfd

[*SwitchB-bfd] quit

[*SwitchB] ospf

[*SwitchB-ospf-1] bfd all-interfaces enable

[*SwitchB-ospf-1] quit

[*SwitchB] commit


4.Настройте параметры BFD на интерфейсах.


# Настройте BFD на VLANIF 10 SwitchA и установите как минимальные интервалы для отправки и приема BFD-пакетов до 100 мс, так и локального множителя обнаружения до 4.


[~SwitchA] interface vlanif 10

[~SwitchA-Vlanif10] ospf bfd enable

[*SwitchA-Vlanif10] ospf bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4

[*SwitchA-Vlanif10] quit

[*SwitchA] commit


5.Настройте BFD на VLANIF 10 SwitchB и установите как минимальные интервалы для отправки и приема BFD-пакетов до 100 мс, так и локального множителя обнаружения до 4.


[~SwitchB] interface vlanif 10

[~SwitchB-Vlanif10] ospf bfd enable

[*SwitchB-Vlanif10] ospf bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4

[*SwitchB-Vlanif10] quit

[*SwitchB] commit


Проверка конфигурации


# После завершения настройки запустите команду display ospf bfd session all на SwitchA. 

Видно, что BFDState имеет значение up.


[~SwitchA] display ospf bfd session all

                                                                                

  OSPF Process 1 with Router ID 1.1.1.1                            

  Area 0.0.0.0 interface 10.1.1.1(Vlanif10)'s BFD Sessions                    

                                                                                

 NeighborId:2.2.2.2    AreaId:0.0.0.0               Interface:Vlanif10         

 BFDState:up                 rx    :100                       tx       :100              

 Multiplier:4                BFD Local Dis:8193      LocalIpAdd:10.1.1.1      

 RemoteIpAdd:10.1.1.2        Diagnostic Info:No diagnostic information 


# После завершения настройки запустите команду display ospf bfd session all на SwitchB. 

Вы можете видеть, что BFDState имеет значение up.


[~SwitchB] display ospf bfd session all

                                                                                

         OSPF Process 1 with Router ID 2.2.2.2                            

  Area 0.0.0.0 interface 10.1.1.2(Vlanif10)'s BFD Sessions                    

                                                                                

 NeighborId:1.1.1.1         AreaId:0.0.0.0            Interface:Vlanif10         

 BFDState:up                   rx    :100                           tx       :100              

 Multiplier:4                BFD Local Dis:8192      LocalIpAdd:10.1.1.2      

 RemoteIpAdd:10.1.1.1        Diagnostic Info:No diagnostic information 


Файлы конфигурации


Файл конфигурации SwitchA


#

 sysname SwitchA

#

 router id 1.1.1.1

#

 vlan batch 10

#

 bfd

#

interface Vlanif10

 ip address 10.1.1.1 255.255.255.0

 ospf bfd enable

 ospf bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4

#

interface 10GE1/0/1

 port link-type trunk

 port trunk pvid vlan 10

 port trunk allow-pass vlan 10

#

ospf 1

 bfd all-interface enable

 area 0.0.0.0

  network 10.1.1.0 0.0.0.255

#

return


Файл конфигурации SwitchB


#

 sysname SwitchB

#

 router id 2.2.2.2

#

vlan batch 10

#

 bfd

#

interface Vlanif10

 ip address 10.1.1.2 255.255.255.0

 ospf bfd enable

 ospf bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4

#

interface 10GE1/0/1

 port link-type trunk

 port trunk pvid vlan 10

 port trunk allow-pass vlan 10

#

ospf 1

 bfd all-interface enable

 area 0.0.0.0

  network 10.1.1.0 0.0.0.255

#

return


Пост синхронизирован: Лаборатория конфигураций

  • x

networkthor
Опубликовано 2021-9-24 08:39:16
Классная идея с выделением текста, хочу позаимствовать))
Развернуть
  • x

Комментарий

Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация
Отправить

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Пользовательское соглашение.”

My Followers

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход

Заблокировать
Вы уверены, что хотите заблокировать этого пользователя?
Пользователи из вашего черного списка не могут комментировать ваши посты, не могут упоминать вас, не могут отправлять личные сообщения.
Напоминание
Пожалуйста, привяжите свой мобильный номер чтобы получить бонус за приглашение.
О защите информации
Благодарим за использование Huawei ICT Club! Мы хотим рассказать вам о том, как мы собираем, используем и храним ваши данные. Пожалуйста, внимательно ознакомьтесь с Политикой конфиденциальности и Пользовательским соглашением.