Конфигурирование сервера DHCP на комм. для VoIP

583 0 0 0

Требования к сети

Потоки данных услуг HSI, VoIP и IPTV передаются в сети. Пользователи требуют высокого качества услуги VoIP. Поэтому потоки голосовых данных должны передаваться с высоким приоритетом. Если голосовое устройство поддерживает DHCP и имеет высокий приоритет 802.1p (например, 5), можно настроить LLDP и голосовую VLAN на коммутаторе. Затем коммутатор использует протокол DHCP для доставки голосового VLAN ID к голосовому устройству и не меняет приоритета пакетов.


Как показано на рисунке ниже, голосовое устройство не поддерживает конфигурацию VLAN. В этом случае сервер DHCP на коммутаторе может доставить VLAN ID к голосовому устройству через Option 184.


Конфигурирование сервера DHCP для обеспечения доступа VoIP

7e33bade110e434d84554a9047aa10ce

 

План конфигурации


План конфигурации выглядит следующим образом:

1.    Создайте VLAN.

2.    Сконфигурируйте тип канала и VLAN по умолчанию интерфейса, подключенного к IP-телефону.

3.    Сконфигурируйте интерфейс, чтобы доверять приоритету 802.1p пакетов.

4.    Сконфигурируйте пул IP-адресов.

5.    Сконфигурируйте опцию 184 в адресном пуле.

6.    Включите DHCP глобально и сконфигурируйте сервер DHCP на интерфейсе VLANIF для распределения IP-адресов с помощью глобального пула IP-адресов.

 

Подготовка данных


Для завершения конфигурирования необходимы следующие данные:

    Голосовые VLAN и VLAN, через которые IP-телефон применяется для IP-адреса: VLAN 2 и VLAN 6

    Сетевой сегмент пула IP-адресов

    Содержание Option 184: voice-vlan 6

Процедура


1.    Сконфигурируйте VLAN и интерфейс на коммутаторе.

# Создайте VLAN 2 и VLAN 6.

<Quidway> system-view

[Quidway] vlan batch 2 6

# Сконфигурируйте тип канала и VLAN по умолчанию XGigabitEthernet0/0/1.

[Quidway] interface xgigabitethernet 0/0/1

[Quidway-XGigabitEthernet0/0/1] port hybrid pvid vlan 2

[Quidway-XGigabitEthernet0/0/1] port hybrid tagged vlan 6

[Quidway-XGigabitEthernet0/0/1] port hybrid untagged vlan 2

[Quidway-XGigabitEthernet0/0/1] quit


2.    Сконфигурируйте на коммутаторе пул IP-адресов.

# Создайте пул IP-адресов.

[Quidway] ip pool ip_access

# Сконфигурируйте диапазон адресов в пуле IP-адресов.

[Quidway-ip-pool-ip_access] network 192.168.10.1 mask 24

[Quidway-ip-pool-ip_access] gateway-list 192.168.10.254

[Quidway-ip-pool-ip_access] option184 voice-vlan 6


3.    Сконфигурируйте интерфейс, чтобы доверять приоритету 802.1p пакетов.

[Quidway] interface xgigabitethernet 0/0/1

[Quidway-XGigabitEthernet0/0/1] trust 8021p


4.    Включите DHCP глобально,

[Quidway] dhcp enable


5.    Создайте интерфейс VLANIF, соответствующий VLAN XGigabitEthernet0/0/1 по умолчанию. Сконфигурируйте сервер DHCP на интерфейсе VLANIF для распределения IP-адресов с помощью глобального пула адресов.

[Quidway] interface Vlanif2

[Quidway-Vlanif2] ip address 192.168.10.1 255.255.255.0

[Quidway-Vlanif2] dhcp select global

 

Файлы конфигурации


Конфигурационный файл коммутатора

#

sysname Quidway

#

vlan batch 2 6

#                                                                              

dhcp enable                                                                    

#

ip pool ip_access                                                              

 gateway-list 192.168.10.254

 network 192.168.10.0 mask 255.255.255.0                                       

 option184 voice-vlan 6

#                                                                              

interface Vlanif2                                                               

 ip address 192.168.10.1 255.255.255.0                                         

 dhcp select global                                                            

#                                                                               

interface XGigabitEthernet0/0/1                                                 

 port hybrid pvid vlan 2                                                        

 port hybrid tagged vlan 6     

 port hybrid untagged vlan 2                                                

 trust 8021p

#

return

 


  • x

Ответ

Отправить
Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация

Внимание Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Политика конфиденциальности..”
Если кнопка вложения недоступна, обновите Adobe Flash Player до последней версии.
Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход