Хорошо

В чем ошибка! Не вижу vlan между S5720 и AR6140

Опубликовано 2021-10-4 12:58:01Последний ответ окт 06, 2021 11:25:50 631 14 6 0 0
  Награжденные Форбаллы: 0 (Проблема решена)

Проблема в следующем: есть S5720 и AR6140 на ar6140 не вижу не маков не vlan

порт 1 (ПК) - сидить в vlan 10

порт 23 на S5720 настроен на TRUNK пример CLI:

[s5720] vlan batch 10 20

[s5720] int g0/0/1

[g0/0/1] port link-type access

[g0/0/1] port default vlan 10

[s5720] int g0/0/23

[g0/0/23] port link-type trunk

[g0/0/23] port trunk allow-pass vlan 10

[g0/0/23] undo port trunk allow-pass vlan 1


[ar6140] int g0/0/1

[g0/0/1] port link-type trunk

[ar6140] dis mac-add g0/0/1

[ar6140] ОБАНА ПУСТАЯ ТАБЛИЦА

[ar6140] dis port vlan

[ar6140] g0/0/1 trunk pvid 1 trunk 1 - вот такая запись...в таблице

Пост синхронизирован: Траблшутинг коммутаторов S-серии

  • x

Избранные ответы

Лучший ответ

Рекомендуемые ответы

mkabanov
MVE Author Опубликовано 2021-10-6 11:25:50
Я бы попробовал (раз такая х-ня получается на транке) изменить поход (все вы верно настроили с т. з. L2):
1) Со стороны AR изменить терминирование 802.1Q :
1-1) Сейчас Вы на L2 Там делаете, и судя по тому, что пишите (при разрешении VLAN 1...) просто и тупо интерфейс работает как приличный сниффер :)
Мне кажется, что интерфейс не заработал на L2.
Т.е. проблема программная, считаю, нужно "Перебирать" софты...
1-2) переделайте это все на L3 подинтерфейсах (на AR) ПРИМЕР:
int gi 0/0
undo portswitch
int gi 0/0.20
dot1q termination vid 20
ip add
Развернуть
  • x

mkabanov
mkabanov Опубликовано 2021-10-6 11:28 (0) (0)
Еще схемку накидайте на бумажке (фото сюда) - что в итоге-то нужно?
Вам же не транк ради транка, а пробросить...
P. S. Схемку считаем рабочей, если на ней есть номера интерфейсов, IP-адреса  
Все ответы
user_2909167
user_2909167 Модератор Опубликовано 2021-10-4 13:31:00
ДД.
на AR6140 g0/0/1 переведен в L2 через portswitch, верно?
на AR6140 g0/0/1 добавлен ли - port trunk allow-pass vl 10 ?
Развернуть
  • x

Andrsoon
Andrsoon Опубликовано 2021-10-4 15:30:25

естественно! даже в режиме просто транк на стороне ar6140 я должен видеть маки и влан, но нет ничего..

Развернуть
  • x

Andrsoon
Andrsoon Опубликовано 2021-10-4 15:31:40
самое интересное на другой стороне cisco все vlan вижу с маками.... порт trunk на обоих сторонах
Развернуть
  • x

Andrsoon
Andrsoon Опубликовано 2021-10-4 15:35:13
т.е. у меня есть еще порт g0/0/2 который тракном смотрит на циску, там все ок... вижу вланы циски с маками.... такое ощущение что s5720 не дружить c ar6140 имеется ввиду huawei
Развернуть
  • x

mkabanov
mkabanov MVE Author Опубликовано 2021-10-4 16:05:15
Мне кажется, что со стороны 5720 нужно убрать undo port trunk allow-pass vlan 1
+
если не сложно, то приложите dis cur с обоих устройств
Развернуть
  • x

Andrsoon
Andrsoon Опубликовано 2021-10-4 16:17:41
я пробовал убрать vlan 1, но при этом получаю весть трафик на стороне ar6140 в vlan 1, т.е не тагетированный... к сожалению оперативно не могу предоставить конфиг, так как объект удаленный и там нет интернета... вопрос в чем... почему при техже настройках с циско вижу влан, а между huawei нет...как то странно.... пользуясь мануалом от huawei по построению кампусной сети эффект такой как описал выше - порты трак между s5720 и ar6140 разрешены виланы от s5720 на стороне ar6140 тишина полная ни маков ни вилан, только не надо говорить чтоб проверить патчкор... проверено исправно....
Развернуть
  • x

Maksim
Maksim HCIE MVE Опубликовано 2021-10-4 22:05:48

На маршрутизаторе как ловите? Как порт настроен? vlan создан?

Развернуть
  • x

Andrsoon
Andrsoon Опубликовано 2021-10-5 11:48:42

S5720

#

vlan batch 20 40

#

interface GigabitEthernet0/0/1

 port link-type access

 port default vlan 20

 port description desktop

#

interface GigabitEthernet0/0/2

 port link-type access

 port default vlan 40

 port description desktop

#

interface GigabitEthernet0/0/24

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 20 40

#

[S5720]dis mac-add g0/0/24

-------------------------------------------------------------------------------

MAC Address    VLAN/VSI/BD                       Learned-From        Type

-------------------------------------------------------------------------------

0000-5e00-0115 20/-/-                            GE0/0/24            dynamic

0000-5e00-011f 40/-/-                            GE0/0/24            dynamic

-------------------------------------------------------------------------------

Total items displayed = 2


AR6140

interface GigabitEthernet0/0/0 - подключен патчкордом к порту S5720 GE0/0/24

 description INBOUND VLAN 20 40

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 20 40

#

[AR6140]dis mac-add g0/0/0

-------------------------------------------------------------------------------

MAC Address       VLAN/Bridge/VSI/BD      Learned-From               Type

-------------------------------------------------------------------------------

????????????????????????????????????????????????/

-------------------------------------------------------------------------------

Total items displayed = 0

ВОТ ЧТО НЕ ТАК? ГДЕ МАКИ ВИЛАНЫ


Развернуть
  • x

Maksim
Maksim Опубликовано 2021-10-5 22:19 (0) (0)
Если Вы переводите порт в режим коммутатора, то на маршрутизаторе стоит создать vlan-ы
Той же самой vlan batch
MAC-и на коммутаторе - это маки сгенерированные (VRRP)  
user_2909167
user_2909167 Модератор Опубликовано 2021-10-5 17:42:12
ДД. а какая полная модель маршрутизатора? 6140?
Используемый g0/0/0 - это не менеджемент интерфейс?
Вы пробовали настроить ту же схему но использовав отличающийся от g0/0/0 интерфейс?
Развернуть
  • x

12
К списку

Комментарий

Выполните вход в систему, чтобы ответить на пост. Вход | Регистрация
Отправить

Внимание! В целях защиты правовых интересов Вас, сообщества и третьих лиц, не публикуйте любой материал, содержащий политические высказывания, порнографию, упоминание азартных игр, употребление наркотиков, а также материал, нарушающий коммерческую тайну или содержащий персональные данные пользователей. Также не предоставляйте данные от вашей учетной записи. Вы будете нести ответственность за все действия, выполняемые под вашим аккаунтом. Подробная информация: “Пользовательское соглашение.”

My Followers

Авторизуйтесь и пользуйтесь всеми преимуществами участника!

Вход

Заблокировать
Вы уверены, что хотите заблокировать этого пользователя?
Пользователи из вашего черного списка не могут комментировать ваши посты, не могут упоминать вас, не могут отправлять личные сообщения.
Напоминание
Пожалуйста, привяжите свой мобильный номер чтобы получить бонус за приглашение.
О защите информации
Благодарим за использование Huawei ICT Club! Мы хотим рассказать вам о том, как мы собираем, используем и храним ваши данные. Пожалуйста, внимательно ознакомьтесь с Политикой конфиденциальности и Пользовательским соглашением.