j'ai compris

Un guide d'interfonctionnement et de remplacement du DTP

publié il y a  2020-4-28 23:33:05 55 0 0 0 0

Ce poste met l'accent sur un guide d'interfonctionnement et de remplacement du DTP. Veuillez voir ci-dessous pour plus de détails.


1.1 Présentation du protocole

Huawei LNP

Le protocole de négociation de type liaison (LNP) négocie dynamiquement si une interface Ethernet est l'interface d'accès ou de jonction. Les commutateurs de la série Huawei S prennent en charge le LNP à partir de V200R005.

Tableau 1-1 NNP négociation

Type de lien local

Type de liaison à distance ou état de négociation

Type de lien négocié localement

État final de l'interface distante

Négociation souhaitable / Négociation automatique

Accès (négociation LNP activée)

Accès

Accès

Hybride (négociation LNP activée)

Tronc

Hybride

Tunnel Dot1q (négociation LNP activée)

Accès

Tunnel Dot1q

Tronc (négociation LNP activée)

Tronc

Tronc

Négociation LNP non prise en charge ou désactivée

Accès

Incertain

Négociation souhaitable

Négociation souhaitable

Tronc

Tronc

Négociation souhaitable

Négociation-auto

Tronc

Tronc

Négociation-auto

Négociation-auto

Accès

Accès

 

20170323144328330004.jpg

l   Le nom de domaine VCMP affecte la négociation LNP. Une interface de jonction n'est négociée que lorsque les noms de domaine aux deux extrémités d'un lien sont cohérents ou lorsque le nom de domaine d'au moins une extrémité est vide; sinon, une interface d'accès est négociée.

l   L'interface Ethernet négociée en tant qu'interface d'accès rejoint le VLAN 1 par défaut. L'interface Ethernet qui est négociée en tant qu'interface de jonction autorise tous les VLAN par défaut.

Cisco DTP

Le protocole Dynamic Trunking Protocol (DTP) négocie dynamiquement si une interface Ethernet est l'interface d'accès ou de jonction.

Tableau 1-2 Négociation DTP

Type de lien configuré d'une interface

Type de lien négocié d'une interface

Switchport mode d' accès

L'interface est configurée pour fonctionner en mode d'accès de force.

Mode de commutation automatique dynamique

Si l'interface distante fonctionne en jonction ou en mode souhaitable, l'interface locale fonctionne en mode jonction via la négociation.

Dynamique du mode Switchport souhaitable

Si l'interface distante fonctionne en mode jonction, souhaitable ou automatique, l'interface locale fonctionne en mode jonction via la négociation.

Switchport mode trunk

L'interface est configurée pour fonctionner en mode tronc de force.

Switchport nonegotiate

Cette commande est utilisée pour permettre à l'interface de ne pas envoyer de paquets DTP et ne peut être utilisée que sur l'interface en mode de jonction ou d'accès.

Pour établir un lien de jonction, vous devez configurer manuellement les interfaces aux deux extrémités pour fonctionner en mode jonction.

 

20170323144328330004.jpg

l Les   périphériques aux deux extrémités doivent avoir le même nom de domaine VTP pour garantir la réussite de la négociation DTP.

l   DTP prend en charge la liaison inter-commutateurs (ISL) et IEEE 802.1Q. ISL est un protocole d'encapsulation propriétaire de Cisco et IEEE 802.1Q est un protocole standard.

1.2 Comparaison d'implémentation

 

 

Tableau 1-3 Prise en charge des fonctions

Une fonction

Commutateurs Huawei série S

Commutateurs Cisco

Activation ou désactivation de la négociation automatique globale du type de lien d'une interface

Prise en charge

La négociation automatique globale du type de lien d'une interface est activée par défaut.

Pour les périphériques tels que les périphériques d'accès qui ne nécessitent pas de négociation dynamique, LNP peut être désactivé globalement. Une fois le LNP désactivé, l'appareil cesse d'envoyer des paquets LNP. La charge réseau est donc réduite.

Non supporté

Activation ou désactivation de la négociation automatique du type de lien d'une interface

Prise en charge

La négociation automatique du type de lien d'une interface est activée par défaut.

Prise en charge

Voir la documentation Cisco.

Négociation dynamique du type de lien

Prise en charge

Prise en charge

Fourniture d'informations VLAN sur une interface en fonction du résultat de la négociation après la négociation dynamique du type de lien

Prise en charge

Prise en charge

Affichage des informations de négociation sur le type de lien d'une interface

Prise en charge

Prise en charge

Récupération automatique de l'état de liaison négocié dynamiquement après le basculement actif / veille

Prise en charge

Prise en charge

 

Tableau 1-4 Différences dans les formats de commande

Une fonction

Commande sur les commutateurs Huawei S Series

Commande sur les commutateurs Cisco

Configurez le mode de négociation dynamique de lien sur Auto.

négociation de type liaison port-auto

mode de commutation automatique dynamique

Configurez le mode de négociation dynamique de liaison comme souhaité.

négociation de type liaison de port - souhaitable

dynamique du mode switchport souhaitable

Supprimez une interface d'un VLAN en mode négociation. Par exemple, supprimez une interface du VLAN 10.

Aucune commande n'est utilisée pour supprimer une interface du VLAN 10. Vous pouvez spécifier les VLAN auxquels les interfaces peuvent être ajoutées.

port trunk allow-pass only-vlan 1 à 9 11 à 4094

coffre de switchport autorisé vlan supprimer 10

Désactivez la négociation automatique d'une interface.

désactivation de la négociation de port

switchport nonegotiate

Désactivez la LNP globale.

lnp disable

Non supporté

Modifiez le mode d'encapsulation des paquets.

Huawei ne prend en charge que l'encapsulation basée sur le protocole standard, sans aucune configuration.

encapsulation de tronc de switchport dot1q

 

1.3 Analyse de la solution d'interfonctionnement et de remplacement

 

 

 

 

Le DTP et le LNP sont tous deux des protocoles propriétaires, ils ne peuvent donc pas interagir. Les deux protocoles peuvent se remplacer l'un l'autre. Deux solutions sont disponibles:

l    Remplacement à l'échelle du réseau: tous les commutateurs Cisco DTP sont remplacés par des commutateurs Huawei série S qui prennent en charge LNP.

l    Remplacement unique: un commutateur Cisco est remplacé par un commutateur Huawei série S. Le commutateur distant est toujours un commutateur Cisco. Dans cette situation, vous devez configurer l'interface du commutateur Cisco distant pour fonctionner en mode non-négociation.

1.3.1 Solution de remplacement sur l'ensemble du réseau

Aperçu

Le remplacement à l'échelle du réseau indique que tous les commutateurs Cisco DTP sont remplacés par des commutateurs de la série Huawei S qui prennent en charge LNP. Ce qui suit décrit la configuration de Huawei LNP.

Notes de configuration

l    Cet exemple s'applique aux commutateurs de la série S de Huawei V200R005 et versions ultérieures.

l    Sur les commutateurs Huawei S, le LNP est utilisé globalement et sur les interfaces par défaut. L'interface négociée en tant qu'interface d'accès rejoint le VLAN 1 par défaut et l'interface négociée en tant qu'interface de jonction rejoint tous les VLAN par défaut. En règle générale, il vous suffit de modifier la configuration du VLAN sur une interface basée sur la mise en réseau.

Exigences de mise en réseau

Dans la figure 1-1 , les utilisateurs du terminal sont connectés au réseau via des commutateurs. Pour implémenter la connectivité de couche 2, configurez le type de liaison sur chaque interface et ajoutez des interfaces aux VLAN. Si l'échelle du réseau est grande, la configuration est très complexe. Pour simplifier les configurations, les commutateurs sont connectés via la liaison de jonction, et les commutateurs et les terminaux utilisateur sont connectés via des liaisons d'accès et ajoutés aux VLAN.

Figure 1-1 Mise en réseau pour configurer LNP pour implémenter la négociation automatique du type de liaison d'une interface Ethernet

20170323144329001005.png

 

Feuille de route de configuration

La feuille de route de configuration est la suivante:

1.          Activez LNP dans la vue système et la vue d'interface pour implémenter la négociation automatique du type de lien d'une interface. Étant donné que les PC ne prennent pas en charge le LNP, les interfaces de commutation connectées aux terminaux sont utilisées comme interfaces d'accès et les interfaces entre les commutateurs sont utilisées comme interfaces de jonction lors de la négociation.

2.          Ajoutez des interfaces aux VLAN pour implémenter la connectivité de couche 2.

Procédure

                               Étape 1     Activez le LNP global.

Par défaut, le LNP global est activé. Si LNP est désactivé, exécutez la commande undo lnp disable dans la vue système pour l'activer.

                               Étape 2     Créez des VLAN.

Les commutateurs de la série Huawei S prennent en charge deux modes de création de VLAN:

l    Créez manuellement des VLAN sur des commutateurs.

l    Créez des VLAN sur Switch3 uniquement et configurez VCMP pour synchroniser les VLAN sur Switch3 avec d'autres commutateurs. Si VCMP est utilisé pour créer des VLAN, configurez Switch3 comme serveur VCMP et Switch1 et Switch2 comme clients VCMP. Pour plus de détails, voir "Configuration VCMP".

Ce qui suit décrit comment créer manuellement des VLAN.

# Créez VLAN 10 et VLAN 20 sur Switch1, Switch2 et Switch3.

<HUAWEI> system-view
[HUAWEI] sysname Switch1
[Switch1] vlan batch 10 20

<HUAWEI> system-view
[HUAWEI] sysname Switch2
[Switch2] vlan batch 10 20

<HUAWEI> system-view
[HUAWEI] sysname Switch3
[Switch3] vlan batch 10 20


                               Étape 3     Activez le LNP sur les interfaces et ajoutez des interfaces de commutation connectées aux PC aux VLAN comme interfaces d'accès et des interfaces entre les commutateurs aux VLAN comme interfaces de jonction.

Par défaut, LNP sur une interface est activé. Si LNP est désactivé, exécutez la commande d' annulation de négociation de port d'annulation dans la vue d'interface pour l'activer.

# Configurer Switch1.

[Switch1] interface GigabitEthernet 1/0/1
[Switch1-GigabitEthernet1/0/1] port default vlan 10  
[Switch1-GigabitEthernet1/0/1] quit
[Switch1] interface GigabitEthernet 1/0/2
[Switch1-GigabitEthernet1/0/2] port trunk allow-pass only-vlan 10 20  
[Switch1-GigabitEthernet1/0/2] quit
[Switch1] interface GigabitEthernet 1/0/3
[Switch1-GigabitEthernet1/0/3] port default vlan 20
[Switch1-GigabitEthernet1/0/3] quit

# Configurez Switch2.

[Switch2] interface GigabitEthernet 1/0/1
[Switch2-GigabitEthernet1/0/1] port default vlan 10
[Switch2-GigabitEthernet1/0/1] quit
[Switch2] interface GigabitEthernet 1/0/2
[Switch2-GigabitEthernet1/0/2] port trunk allow-pass only-vlan 10 20
[Switch2-GigabitEthernet1/0/2] quit
[Switch2] interface GigabitEthernet 1/0/3
[Switch2-GigabitEthernet1/0/3] port default vlan 20
[Switch2-GigabitEthernet1/0/3] quit

# Configurez Switch3.

[Switch3] interface GigabitEthernet 1/0/1
[Switch3-GigabitEthernet1/0/1] port trunk allow-pass only-vlan 10 20
[Switch3-GigabitEthernet1/0/1] quit
[Switch3] interface GigabitEthernet 1/0/2
[Switch3-GigabitEthernet1/0/2] port trunk allow-pass only-vlan 10 20
[Switch3-GigabitEthernet1/0/2] quit

                               Étape 4     Vérifiez la configuration.

Une fois la configuration précédente terminée, exécutez la commande display-lnp interface interface-type interface-number pour vérifier la négociation automatique sur l'interface de couche 2 spécifiée.

[Switch1] display lnp interface gigabitethernet1/0/2
LNP information for GigabitEthernet1/0/2:
  Port link type: trunk
  Negotiation mode: desirable
  Hello timer expiration(s): 7
  Negotiation timer expiration(s): 0
  Trunk timer expiration(s): 278
  FSM state: trunk
 
  Packets statistics
  56 packets received
    0 packets dropped
      bad version: 0, bad TLV(s): 0, bad port link type: 0,
      bad negotiation state: 0, other: 0
  58 packets output
    0 packets dropped
      other: 0

Exécutez la commande display lnp summary pour vérifier les informations de négociation automatique sur toutes les interfaces du périphérique de couche 2.

[Switch1] display lnp summary
Global LNP : Negotiation enable
-------------------------------------------------------------------------------
C: Configured; N: Negotiated; *: Negotiation disable;
Port         link-type(C)   link-type(N)   InDropped   OutDropped  FSM         
-------------------------------------------------------------------------------
GE1/0/1      desirable      access         0           0           access
GE1/0/2      desirable      trunk          0           0           trunk
GE1/0/3      desirable      access         0           0           access

----Fin

Fichiers de configuration

l    Fichier de configuration Switch1

#
sysname Switch1
#
vlan batch 10 20
#
interface GigabitEthernet1/0/1
 port default vlan 10
#
interface GigabitEthernet1/0/2
 port trunk allow-pass only-vlan 10 20
#
interface GigabitEthernet1/0/3
 port default vlan 20
#
return

l    Fichier de configuration Switch2

#
sysname Switch2
#
vlan batch 10 20
#
interface GigabitEthernet1/0/1
 port default vlan 10
#
interface GigabitEthernet1/0/2
 port trunk allow-pass only-vlan 10 20
#
interface GigabitEthernet1/0/3
 port default vlan 20
#
return

l    Fichier de configuration Switch3

#
sysname Switch3
#
vlan batch 10 20
#
interface GigabitEthernet1/0/1
 port trunk allow-pass only-vlan 10 20
#
interface GigabitEthernet1/0/2
 port trunk allow-pass only-vlan 10 20
#
return

1.3.2 Solution de remplacement d'un seul appareil

Aperçu

Lors du remplacement d'un seul périphérique, vous devez configurer l'interface connectée du périphérique Cisco comme non-négociation.

Notes de configuration

l    Cet exemple s'applique à toutes les versions de commutateurs de la série S.

l    Pendant l'interfonctionnement et le remplacement des commutateurs Cisco et des commutateurs de la série Huawei S, le mode d'encapsulation doit être IEEE 802.1Q.

Exigences de mise en réseau

Dans la figure 1-2 , trois périphériques Cisco utilisent le protocole DTP pour négocier dynamiquement les types de liaison des interfaces. Un appareil est remplacé par un commutateur de la série Huawei S, et les trois commutateurs doivent implémenter la connectivité de couche 2.

Figure 1-2 Interfonctionnement des commutateurs de la série Huawei S et des commutateurs Cisco

20170323144330557006.png

 

Feuille de route de configuration

La feuille de route de configuration est la suivante:

1.          Configurez manuellement les types de liens des interfaces. Le DTP sur les commutateurs Cisco et le LNP sur les commutateurs de la série Huawei S sont tous deux des protocoles propriétaires et ne peuvent pas interagir. Lorsque les commutateurs Huawei S series sont connectés à des commutateurs Cisco, le type de liaison d'une interface ne peut pas être négocié dynamiquement.

2.          Configurez manuellement les types de liaison des interfaces sur deux commutateurs en tant que jonction et spécifiez le mode d'encapsulation des paquets sur les commutateurs Cisco comme IEEE 802.1Q.

Procédure

                               Étape 1     Modifiez manuellement le type de lien Fa0 / 2 sur le commutateur Cisco en jonction. La configuration de deux commutateurs Cisco est la même.

CiscoA# configure terminal
CiscoA(config)# interface fastEthernet 0/2
CiscoA(config-if)# switchport trunk encapsulation dot1q
CiscoA(config-if)# switchport mode trunk

                               Étape 2     Configurez le type de lien de l'interface sur le commutateur Huawei S series comme tronc.

<Huawei> system-view
[Huawei] interface GigabitEthernet1/0/2
[Huawei-GigabitEthernet1/0/2] port link-type trunk
[Huawei-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 4094  

                               Étape 3     Vérifiez la configuration.

l    Exécutez la commande show interfaces fastEthernet 0/2 switchport pour vérifier si le champ de type de lien sur le commutateur Cisco est Administrative Mode: trunk .

l    Exécutez la commande display interface gigabitethernet 1/0/2 pour vérifier si le champ de type de lien sur le commutateur Cisco est de type Link: trunk (configuré) .



  • x
  • Standard:

Commentaire

Connectez-vous pour répondre. Se connecter | Enregistrer
envoyer

Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».

My Followers

Connectez-vous pour participer à la communication et au partage

S'identifier

Bloquer
Êtes-vous sûr de bloquer cet utilisateur?
Les utilisateurs de votre liste noire ne peuvent ni commenter votre publication,ni vous mentionner, ni vous envoyer de messages privés.
Rappel
Veuillez lier votre numéro de téléphone pour obtenir un bonus d'invitation.