j'ai compris

[Tout sur les commutateurs] 27 La technologie QinQ

publié il y a  2020-3-31 20:51:18 123 0 0 0 0

La plupart des gens s'intéressent beaucoup à QinQ, mais ils rencontrent des difficultés lors de l'utilisation de QinQ. Je vais décrire comment utiliser QinQ.

12.gif Tout d'abord, je vais vous présenter QinQ.

QinQ est souvent déployé au niveau de la couche d'agrégation. Les paquets QinQ portent des balises VLAN doubles et contiennent une balise VLAN supplémentaire de quatre octets par rapport aux paquets de couche 2 courants. La technologie QinQ peut identifier de manière flexible les services.

12.gif Quel est l'arrière-plan de QinQ?

Sur un réseau de couche 2, un commutateur ajoute une balise VLAN aux paquets pour isoler les domaines de diffusion; cependant, IEEE 802.1Q inflige une amende de seulement 4096 ID de VLAN. Les 4096 ID de VLAN sont insuffisants. Pour résoudre ce problème, la technologie QinQ est utilisée. La technologie QinQ, définie par IEEE 802.1ad, encapsule les doubles balises VLAN en paquets, étendant l'espace VLAN à 4096x4096.

20170510144506879002.png

12.gif Les commutateurs de la série S prennent-ils en charge QinQ? Comment QinQ est-il implémenté?

À l'exception des commutateurs bas de gamme S2300EI & SI et S2700EI & SI, les autres commutateurs de la série S de toutes les versions prennent en charge QinQ.

QinQ tombe dans QinQ de base et QinQ sélectif.

? ? QinQ de base

QinQ de base, également appelé QinQ commun, est implémenté sur la base d'interfaces. Autrement dit, une balise VLAN est ajoutée à tous les paquets passant par une interface.

Les paquets de VLAN 10, VLAN 20 et VLAN 30 arrivent à la sortie du périphérique d'agrégation et sont étiquetés avec VLAN 100. Les paquets qui sont transmis sur le réseau public portent des étiquettes VLAN doubles. Les paquets sont transmis dans le VLAN spécifié par l'étiquette externe, et l'étiquette VLAN interne est transmise sous forme de données dans des paquets. (Le commutateur apprend-il l'adresse MAC des paquets QinQ en fonction de la balise VLAN externe ou interne? La question recevra une réponse plus tard.)

20170510144507476003.png

? ? QinQ sélectif, également appelé empilement VLAN

Selective QinQ est implémenté en fonction des ID et des interfaces VLAN. En d'autres termes, le commutateur ajoute uniquement une balise VLAN au paquet qui passe par une interface et correspond à l'ID VLAN spécifié.

Les paquets de VLAN 10, VLAN 20 et VLAN 30 arrivent à la sortie du périphérique d'agrégation et sont étiquetés avec VLAN 100, VLAN 200 et VLAN 300, respectivement. Lorsque des paquets utilisateur sont transmis sur le réseau public, les paquets portent des étiquettes VLAN doubles et sont transmis dans des VLAN spécifiés par d'autres étiquettes.

(Réponse: le commutateur apprend l'adresse MAC des paquets QinQ en fonction de la balise VLAN externe. Cela est dû au fait que la balise VLAN interne est transmise en tant que données dans les paquets.)

20170510144508334004.png

12.gif Comment sont configurés QinQ de base et QinQ sélectif?

Type

Configuration

La description

QinQ de base

port link-type dot1q-tunnel

port default vlan 100


Les configurations sur les commutateurs fixes et modulaires sont les mêmes. Il vous suffit de configurer deux commandes.

QinQ sélectif

port link-type hybrid

qinq vlan-translation enable

port hybrid untagged vlan 100 200 300

port vlan-stacking vlan 10 stack-vlan 100

port vlan-stacking vlan 20 stack-vlan 200

port vlan-stacking vlan 30 to 39 stack-vlan 300


qinq vlan-translation enable

La commande précédente doit être configurée sur le commutateur fixe mais pas sur le commutateur modulaire.

La configuration sélective QinQ est flexible et QinQ sélective est largement utilisée.

12.gif Passons aux scénarios d'application de QinQ de base et de QinQ sélectif.

? ? QinQ de base

La société S souhaite se connecter au réseau ISP, l'opérateur attribue le VLAN 1000 à la société S et les services de la société S appartiennent à différents VLAN.

20170510144508954005.png

Feuille de route de configuration

Il vous suffit de configurer QinQ de base sur les interfaces PE connectées au CE de la société S. Le PE marque tous les paquets de la société S avec VLAN 1000, sans avoir besoin de modifier la configuration du CE.

Dispositif

Configuration de GE1 / 0/1

Configuration de GE1 / 0/2

PE

port link-type dot1q-tunnel

port default vlan 1000


port link-type trunk

port trunk allow-pass vlan 1000


Une fois la configuration effectuée, les services de l'entreprise S peuvent accéder au réseau ISP.

? ? QinQ sélectif

Les entreprises A et B sont situées dans différentes régions. Les services de données et de voix de la société A sont transmis respectivement dans le VLAN 10 et le VLAN 30. Les services de données et de voix de la société B sont également transmis dans le VLAN 10 et le VLAN 30, respectivement. Le PE du réseau ISP est requis pour transmettre les services de données dans le VLAN 100 et les services vocaux dans le VLAN 30. Les services de données et de voix des sociétés A et B doivent être correctement transmis sans changer le réseau.

20170510144509491006.png b

Feuille de route de configuration

1. Pour les services de données dans différents VLAN, il vous suffit de configurer QinQ sélectif sur le PE afin que les sociétés A et B puissent communiquer.

2.   Pour les services vocaux dans le même VLAN, vous devez configurer une transmission transparente sur le PE.

Dispositif

Configuration de GE1 / 0/1

Configuration de GE1 / 0/2

PE1

port link-type hybrid

port hybrid tagged vlan 30

port hybrid untagged vlan 100

port vlan-stacking vlan 10 stack-vlan 100


port link-type trunk

port trunk allow-pass vlan 30 100


PE2

port link-type hybrid

port hybrid tagged vlan 30

port hybrid untagged vlan 100

port vlan-stacking vlan 10 stack-vlan 100


port link-type trunk

port trunk allow-pass vlan 30 100


http://support.huawei.com/ecommunity/showimage-10092113-10132081-083194e69a94eb040cff07d3bb44ed6e.jpg Astuce 1: Exécutez la commande de port vlan-stacking pour configurer QinQ sélectif sur GE1 / 0/1 connecté au CE afin que le même ID PE-VLAN soit ajouté aux paquets de différents CE-VLAN. Configurez GE1 / 0/2 connecté au réseau public pour transmettre de manière transparente les paquets du PE-VLAN. N'oubliez pas cette configuration.

http://support.huawei.com/ecommunity/showimage-10092113-10132081-083194e69a94eb040cff07d3bb44ed6e.jpg Astuce 2: GE1 / 0/1 connecté au CE doit être ajouté au PE-VLAN en mode non balisé. Lorsque GE1 / 0/1 transfère les paquets étiquetés avec le VLAN externe 100, il supprime l'étiquette VLAN externe afin que le CE puisse traiter correctement les paquets.

12.gif Une fois la configuration terminée, les sociétés A et B ne peuvent plus communiquer. Pourquoi?

La cause courante est que le VLAN externe n'est pas créé sur le PE. Exécutez la commande display vlan summary pour vérifier s'il existe des VLAN 100 et VLAN 30 externes.

20170510144511490008.png

12.gif Une fois les VLAN créés globalement, les services de données peuvent être correctement transmis, mais pas les services vocaux. Autrement dit, les paquets à double étiquette peuvent être transmis, contrairement aux paquets à étiquette unique.

Le problème précédent se produit souvent sur les cartes de la série SA et les commutateurs fixes des S5300EI / S5700EI et S3300EI & SI / S3700EI & SI. Sur les cartes de la série SA et les commutateurs fixes S5300EI / S5700EI et S3300EI & SI / S3700EI & SI, le mappage VLAN doit être configuré pour mapper le VLAN sur lui-même à partir duquel les paquets à étiquette unique doivent être transmis de manière transparente.

Sur GE1 / 0/1 de PE1 et PE, exécutez la commande port vlan-mapping vlan 30 map-vlan 30 

20170510144512788009.png

12.gif La présentation est terminée. Pour plus de détails sur d'autres fonctions QinQ telles que QinQ sélectif basé sur le flux, visitez https://support.huawei.com/enterprise/en/doc/EDOC1100038339/ded44dec/overview-of-qin q


                 ★★★ Résumé ★★★ Tout sur les fonctionnalités et les configurations des commutateurs Huawei


  • x
  • Standard:

Commentaire

Connectez-vous pour répondre. Se connecter | Enregistrer
envoyer

Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».

My Followers

Connectez-vous pour participer à la communication et au partage

S'identifier

Bloquer
Êtes-vous sûr de bloquer cet utilisateur?
Les utilisateurs de votre liste noire ne peuvent ni commenter votre publication,ni vous mentionner, ni vous envoyer de messages privés.
Rappel
Veuillez lier votre numéro de téléphone pour obtenir un bonus d'invitation.