[Partage d'initié] Conflit d'adresse IP secondaire résolu via le tweak VRRP

10 0 0 0


Vous souhaitez mettre à niveau votre infrastructure réseau mais, malheureusement, cela signifie arrêter les anciens périphériques et les remplacer par de nouveaux équipements. Vous savez que vous ne pouvez pas simplement dire à vos clients de faire une pause d'une journée dans les services pour lesquels ils vous paient, alors comment sortir de cette situation?

Pour aggraver les choses, vous avez quelques services clients sur Vlan 100, c’est donc une catastrophe si, tout à coup, l’une de vos passerelles de vlan 100 se déconnecte, même pendant quelques minutes.

Je sais qu’à ce stade, vous pensez qu’il n’ya pas de problème. Je peux simplement configurer cette passerelle sur un équipement redondant en tant qu’adresse IP secondaire. Ce que vous ne saviez pas, c’est que votre routeur AR1200VW ne prend pas en charge la configuration d’une adresse IP secondaire de la même plage sur l’interface Vlanif 100. Je l'ai essayé, merci de vous référer à la sortie CLI ci-dessous:

#

[AR-Vlanif12]ip add 12.0.0.2 24 sub                                            

Error: The specified address conflicts with another address.

#

J'ai la solution parfaite à votre problème, mais avant de présenter la solution, pour clarifier les choses, jetez un œil à la conception du réseau ci-dessous:

222248ixi3iz6lbj3imzbc.png
La configuration des appareils est listée ci-dessous:

###################################################

[AR1200]dis curr                                                                

[V200R003C01SPC900]                                                            

#                                                                              

 sysname AR1200                                                                                                                        

#                                                                              

vlan batch 100                                                                                       

#                                                                              

interface Vlanif100                                                            

 ip address 10.0.0.1 255.255.255.0                                              

 vrrp vrid 1 virtual-ip 10.0.0.2                                               

 vrrp vrid 1 timer advertise 255                                               

#

interface Ethernet0/0/1                                                        

 port link-type trunk                                                          

 port trunk allow-pass vlan 100                                                

#

#                                                                              

ip route-static 192.168.1.0 255.255.255.0 10.0.0.10                            

#                                                                                                                                                                                                                      

return             


##########################################################

[S5700-1]dis curr                                                                

!Software Version V200R003C00SPC300                                             

#                                                                              

sysname S5700-1                                                                                                                                                                                                              

#                                                                              

vlan batch 100 200                                                     

#                                                                               

interface Vlanif100                                                            

 ip address 10.0.0.10 255.255.255.0                                            

#                                                                               

interface Vlanif200                                                            

 ip address 192.168.1.1 255.255.255.0                                          

#                                                                               

interface GigabitEthernet0/0/18                                                

 port link-type trunk                                                          

 port trunk allow-pass vlan 100                                                 

#                                                                              

interface GigabitEthernet0/0/20                                                

 port link-type trunk                                                           

 port trunk allow-pass vlan 200                                                

#                                                                          

return        

########################################################         

[S57-2]dis curr                                                                

!Software Version V200R002C00SPC100                                            

#                                                                              

sysname S57-2                                                                                                                                                                                                        

#                                                                              

vlan batch 200                        

#                                                         

interface Vlanif200                                                             

 ip address 192.168.1.2 255.255.255.0                                                                                    

#                                                                              

interface GigabitEthernet0/0/1                                                  

 port link-type trunk                                                          

 port trunk allow-pass vlan 3970                                               

#                                                                               

interface GigabitEthernet0/0/20                                                

 port link-type trunk                                                          

 port trunk allow-pass vlan 200                                                                                                                                                          

#                                                                              

ip route-static 0.0.0.0 0.0.0.0 192.168.1.1                                                                                            

#                                                                              

return                                                                         

############################################################

Comme vous pouvez le constater, la première étape de cette mise à niveau consiste à supprimer le vieil AR200 et à le remplacer par un nouvel appareil. Je passe l’AR200 à un AR1200.

Maintenant, pour garder toutes les adresses accessibles, je dois configurer l'adresse 10.0.0.2 sur AR-1 en tant qu'adresse IP secondaire. Parce que je ne peux pas le faire en utilisant la commande ip address sub, je vais utiliser VRRP. En créant une instance VRRP, je peux configurer 10.0.0.2 en tant qu'adresse IP virtuelle.

La CLI pour cette opération est répertoriée ci-dessous:

#

[S77-1]vrrp vrid 1 virtual-ip 10.0.0.2

#

Après cette configuration, je vais tester la connectivité de mon noeud S77-1 et, comme vous pouvez le voir dans les lignes suivantes, tout se vérifie:

[S57-2]ping 10.0.0.1                                                            

  PING 10.0.0.1: 56  data bytes, press CTRL_C to break                         

    Reply from 10.0.0.1: bytes=56 Sequence=1 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=2 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=3 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=4 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=5 ttl=254 time=1 ms                 

                                                                                

  --- 10.0.0.1 ping statistics ---                                             

    5 packet(s) transmitted                                                    

    5 packet(s) received                                                        

    0.00% packet loss                                                          

    round-trip min/avg/max = 1/1/1 ms                                          

                                                                                

[S57-2]ping 10.0.0.2                                                            

  PING 10.0.0.2: 56  data bytes, press CTRL_C to break                         

    Reply from 10.0.0.2: bytes=56 Sequence=1 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=2 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=3 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=4 ttl=254 time=1 ms                  

    Reply from 10.0.0.2: bytes=56 Sequence=5 ttl=254 time=1 ms                 

                                                                               

  --- 10.0.0.2 ping statistics ---                                              

    5 packet(s) transmitted                                                    

    5 packet(s) received                                                       

    0.00% packet loss                                                           

round-trip min/avg/max = 1/1/1 ms  


Pour le moment, vous pensez peut-être que ce n'est pas une bonne solution car elle introduit du trafic de multidiffusion non souhaité (généré par les messages vrrp - vrrp advertise) sur votre réseau. Pour réduire ce trafic à un minimum acceptable, il est conseillé de configurer le temporisateur de publication vrrp sur la valeur maximale (255) à l'aide de la commande ci-dessous:

#

[S77-1] vrrp vrid 1 timer advertise 255

#

Comme vous pouvez le constater à l’heure actuelle, votre trafic multicast supplémentaire est réduit au strict minimum.

(1 message toutes les 255 secondes). D'autre part, vous avez maintenant une adresse IP secondaire sur votre interface Vlanif 100 et êtes maintenant prêt pour le swap.


J'espère que cela vous aide autant que cela m'a aidé!
  • x
  • Standard:

Responder

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.

Connectez-vous pour participer à la communication et au partage

S'identifier
Réponse rapide Accéder au haut de page