[Série de diagnostique] Cas 27 Un flux de trafic inaccessible sur le VxLAN-unok

144 0 0 0

Topologie de réseau physique

réseau où le flux de trafic est inaccessible sur le VxLAN

111536zcv31dp9a3zq00q1.png

 

Description du défaut

Il est impossible d'accéder à la passerelle du serveur à la passerelle C de sa passerelle lorsqu'elle passe par le tunnel VxLAN.

Fichiers de configuration

l    SwitchA

!Software Version V100R005C10SPC200
dfs-group 1
 source ip 10.1.1.1 
#
ip tunnel mode gre
#
bridge-domain 10
 vxlan vni 5010
#
interface Eth-Trunk1
 peer-link 1
 port vlan exclude 1000 
#
interface Eth-Trunk10
 port default vlan 1000
 dfs-group 1 m-lag 500
#
interface Eth-Trunk10.1 mode l2
 encapsulation dot1q vid 4000
 bridge-domain 10
#  
interface 10GE2/0/1
 undo portswitch
 ip address 102.1.1.2 255.255.255.0
 device transceiver 1000BASE-X
#
interface Nve1
 source 5.5.5.5
 vni 5010 head-end peer-list 1.1.1.1
#
bgp 10088
 peer 102.1.1.1 as-number 10086
 #
 ipv4-family unicast
  import-route direct  
  peer 102.1.1.1 enable
#
ospf 100
 import-route direct
 import-route static
 area 0.0.0.0   
  network 5.5.5.5 0.0.0.0
  network 102.1.1.0 0.0.0.255

l    SwitchB

!Software Version V100R005C10SPC200
dfs-group 1
 source ip 10.1.1.2 
#
ip tunnel mode gre
#
mpls lsr-id 5.5.5.5
#
bridge-domain 10
 vxlan vni 5010
#
trill
#
traffic classifier test type or
 if-match ipv6 acl 3000
#
traffic behavior test
 redirect interface 10GE3/0/9
#
traffic policy test
 classifier test behavior test precedence 5
#
ospfv3 100
 area 0.0.0.0
#
interface Vlanif100
 ip address 10.1.1.2 255.255.255.0
 pim silent
 pim sm
 igmp enable
#
interface Vlanif1000
 ipv6 enable
 ip address 100.100.1.103 255.255.255.0
 ipv6 address 1000:1000::1/64
 vrrp vrid 1 virtual-ip 100.100.1.101
 vrrp6 vrid 2 virtual-ip FE80::5 link-local
 vrrp6 vrid 2 virtual-ip 1000:1000::1000
 traffic-policy test inbound 
#
interface Eth-Trunk1
 peer-link 1
 port vlan exclude 1000 
#
interface Eth-Trunk10
 port default vlan 1000
 dfs-group 1 m-lag 500
#
interface Eth-Trunk10.1 mode l2
 encapsulation dot1q vid 4000
 bridge-domain 10
#
interface 10GE3/0/2
 undo portswitch
 mtu 1300
 ipv6 enable
 ip address 107.1.1.2 255.255.255.0
 ipv6 address 100::2/64
 ospfv3 100 area 0.0.0.0
 jumboframe enable 1536
 device transceiver 1000BASE-X

interface Nve1
 source 5.5.5.5
 vni 5010 head-end peer-list 1.1.1.1
#
interface Tunnel1
 ipv6 enable
 ip address 13.13.13.14 255.255.255.0
 ipv6 address 100:100::100/64
 tunnel-protocol gre
 source 107.1.1.2
 destination 107.1.1.1
 ospfv3 100 area 0.0.0.0
#
bgp 10089
 peer 107.1.1.1 as-number 10086
 #
 ipv4-family unicast
  import-route direct  
  peer 107.1.1.1 enable
#
ospf 100
 import-route direct
 import-route static
 area 0.0.0.0
  network 5.5.5.5 0.0.0.0
  network 13.13.13.0 0.0.0.255
  network 107.1.1.0 0.0.0.255

l    SwitchC

!Software Version V100R005C10SPC200
dfs-group 1
 source ip 10.1.1.2 
#
ip tunnel mode gre
#
bridge-domain 10
 vxlan vni 5010
#
trill
#
acl ipv6 number 3000
 rule 1 permit ipv6 destination 100::/64
#
traffic classifier test type or
 if-match ipv6 acl 3000
#
traffic behavior test
 redirect interface 10GE3/0/9
#
traffic policy test
 classifier test behavior test precedence 5
#
ospfv3 100
 area 0.0.0.0
#
interface Vlanif100
 ip address 10.1.1.2 255.255.255.0
 pim silent
 pim sm
 igmp enable
#
interface Vlanif1000
 ipv6 enable
 ip address 100.100.1.103 255.255.255.0
 ipv6 address 1000:1000::1/64
 vrrp vrid 1 virtual-ip 100.100.1.101
 vrrp6 vrid 2 virtual-ip FE80::5 link-local
 vrrp6 vrid 2 virtual-ip 1000:1000::1000
 traffic-policy test inbound 
#
interface Eth-Trunk1
 peer-link 1
 port vlan exclude 1000 
#
interface Eth-Trunk10
 port default vlan 1000
 dfs-group 1 m-lag 500
#
interface Eth-Trunk10.1 mode l2
 encapsulation dot1q vid 4000
 bridge-domain 10
#
interface 10GE3/0/2
 undo portswitch
 mtu 1300
 ipv6 enable
 ip address 107.1.1.2 255.255.255.0
 ipv6 address 100::2/64
 ospfv3 100 area 0.0.0.0
 jumboframe enable 1536
 device transceiver 1000BASE-X
#
interface Nve1
 source 5.5.5.5
 vni 5010 head-end peer-list 1.1.1.1
#
interface Tunnel1
 ipv6 enable
 ip address 13.13.13.14 255.255.255.0
 ipv6 address 100:100::100/64
 tunnel-protocol gre
 source 107.1.1.2
 destination 107.1.1.1
 ospfv3 100 area 0.0.0.0
#
bgp 10089
 peer 107.1.1.1 as-number 10086
 #
 ipv4-family unicast
  import-route direct  
  peer 107.1.1.1 enable
#
ospf 100
 import-route direct
 import-route static
 area 0.0.0.0
  network 5.5.5.5 0.0.0.0
  network 13.13.13.0 0.0.0.255
  network 107.1.1.0 0.0.0.255 

l    Serveur

!Software Version V100R005C10SPC200
interface Vlanif1000
 ipv6 enable
 ip address 100.100.1.1 255.255.255.0
 ipv6 address 1000:1000::2/64
 ipv6 address auto link-local
#
interface Vlanif4000
 ip address 17.1.1.100 255.255.255.0
#
interface Eth-Trunk100
 port link-type trunk
 port trunk allow-pass vlan 4000
#
ip route-static 0.0.0.0 0.0.0.0 100.100.1.101
#
ipv6 route-static :: 0 1000:1000::1000 

Procédure de dépannage

 Étape 1       Utilisez la commande " display arp " pour vérifier si l'entrée ARP est normale sur le serveur et découvrez qu'il n'y a pas d'entrée ARP de passerelle, cela provoque le PING inaccessible.

111537iqvwcvbrl72q41no.png

Étape 2       Configurez la stratégie de trafic et capturez les paquets sur le trafic entrant, recherchez les paquets ARP reçus, mais ces paquets ARP ne sont pas envoyés via le tunnel VxLAN.

111538mj3fe8p4gacpp303.png

 Étape 3       Vérifiez l'état et les informations du tunnel VxLAN, vérifiez qu'il est normal d'établir le tunnel VxLAN.

[~R4U13-CE12800-SWITCH-B]display vxlan tunnel

Number of vxlan tunnel : 1

Tunnel ID      Source              Destination      State  Type

--------------------------------------------------------------

4026531841     5.5.5.5          1.1.1.1          up     static

 

Nous soupçonnons que le mode de transfert VxLAN est incorrect et nous vérifions le document du produit. Nous constatons qu'il doit être configuré en mode VxLAN, mais il s'agit du mode de transfert de tunnel GRE.

Soultion: Après la modification du mode de transfert en mode de transfert VxLAN, puis le redémarrage du commutateur, toutes les entreprises fonctionnent correctement. Nous vérifions l'entrée ARP sur le serveur, l'entrée ARP est apprise normalement

111539jmc3f3m75x66he6i.png

Et vérifiez l'entrée ARP sur la passerelle, c'est également normal.

111540i4yvqz7x748jolvv.png

Cause première

La configuration des modes de transmission du tunnel GRE et du tunnel VxLAN est mutuellement exclusive sur le commutateur CE12800. il doit être configuré en mode tunnel VxLAN pour VxLAN business. S'il s'agit du mode GRE, le flux de trafic sera abandonné sur le commutateur.


  • x
  • Standard:

Responder

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.
Connectez-vous pour participer à la communication et au partage

Connectez-vous pour participer à la communication et au partage

S'identifier