[Série de dépannage] Cas 34 Une erreur de ping survient dans les scénarios M-LAG

17 0 0 0

Topologie de réseau physique

161823z030eoue6o3ouz7q.png

 

Description du défaut

Échec de l'envoi d'une requête ping à l'adresse IP de l'interface de bouclage sur le SwitchC à partir du serveur.

Fichiers de configuration

l    SwitchA

!Software Version V100R005C10SPC200 

#
dfs-group 1 
 source ip 10.1.1.1  

interface Eth-Trunk1 
 peer-link 1 
 port vlan exclude 1000  

interface Eth-Trunk10 
 port default vlan 1000 
 dfs-group 1 m-lag 500 

interface Eth-Trunk10.1 mode l2 
 encapsulation dot1q vid 4000 
 bridge-domain 10 

interface 10GE2/0/0 

bgp 10088 
 peer 102.1.1.1 as-number 10086 
 # 
 ipv4-family unicast 
  import-route direct   
  peer 102.1.1.1 enable 

ospf 100 
 import-route direct 
 import-route static 
 area 0.0.0.0    
  network 5.5.5.5 0.0.0.0 
  network 102.1.1.0 0.0.0.255 

l    SwitchB

[~R4U13-CE12800-SWITCH-B]dis cu 

dfs-group 1 
 source ip 10.1.1.2  

traffic classifier test type or 
 if-match ipv6 acl 3000 

traffic behavior test 
 redirect interface 10GE3/0/9 

traffic policy test 
 classifier test behavior test precedence 5 

ospfv3 100 
 area 0.0.0.0 

interface Vlanif100 
 ip address 10.1.1.2 255.255.255.0 
 pim silent 
 pim sm 
 igmp enable 

interface Eth-Trunk1 
 peer-link 1 
 port vlan exclude 1000  

interface Eth-Trunk10 
 port default vlan 1000 
 dfs-group 1 m-lag 500 

interface Eth-Trunk10.1 mode l2 
 encapsulation dot1q vid 4000 
 bridge-domain 10 

interface 10GE3/0/9 
 eth-trunk 1     
 device transceiver 1000BASE-X 

interface 10GE3/0/10 
 eth-trunk 10 
 device transceiver 1000BASE-X 

interface 10GE3/0/11 

interface Nve1 
 source 5.5.5.5 
 vni 5010 head-end peer-list 1.1.1.1 

interface Tunnel1 
 ipv6 enable 
 ip address 13.13.13.14 255.255.255.0 
 ipv6 address 100:100::100/64 
 tunnel-protocol gre 
 source 107.1.1.2 
 destination 107.1.1.1 
 ospfv3 100 area 0.0.0.0 

bgp 10089 
 peer 107.1.1.1 as-number 10086 
 # 
 ipv4-family unicast 
  import-route direct   
  peer 107.1.1.1 enable 

ospf 100 
 import-route direct 
 import-route static 
 area 0.0.0.0 
  network 5.5.5.5 0.0.0.0 
  network 13.13.13.0 0.0.0.255 
  network 107.1.1.0 0.0.0.255 

l    SwitchC

!Software Version V100R005C10SPC200 

dfs-group 1 
 source ip 10.1.1.2  

bridge-domain 10 
 vxlan vni 5010 

acl ipv6 number 3000 
 rule 1 permit ipv6 destination 100::/64 

traffic classifier test type or 
 if-match ipv6 acl 3000 

traffic behavior test 
 redirect interface 10GE3/0/9 

traffic policy test 
 classifier test behavior test precedence 5 

ospfv3 100 
 area 0.0.0.0 

interface Vlanif100 
 ip address 10.1.1.2 255.255.255.0 
 pim silent 
 pim sm 
 igmp enable 

interface Vlanif1000 
 ipv6 enable 
 ip address 100.100.1.103 255.255.255.0 
 ipv6 address 1000:1000::1/64 
 vrrp vrid 1 virtual-ip 100.100.1.101 
 vrrp6 vrid 2 virtual-ip FE80::5 link-local 
 vrrp6 vrid 2 virtual-ip 1000:1000::1000 
 traffic-policy test inbound  

interface Eth-Trunk1 
 peer-link 1 
 port vlan exclude 1000  

interface Eth-Trunk10 
 port default vlan 1000 
 dfs-group 1 m-lag 500 

interface Eth-Trunk10.1 mode l2 
 encapsulation dot1q vid 4000 
 bridge-domain 10 

interface 10GE3/0/2 
 undo portswitch 
 mtu 1300 
 ipv6 enable 
 ip address 107.1.1.2 255.255.255.0 
 ipv6 address 100::2/64 
 ospfv3 100 area 0.0.0.0 
 jumboframe enable 1536 
 device transceiver 1000BASE-X 

 eth-trunk 1     
 device transceiver 1000BASE-X 

interface 10GE3/0/10 
 eth-trunk 10 
 device transceiver 1000BASE-X 

interface Nve1 
 source 5.5.5.5 
 vni 5010 head-end peer-list 1.1.1.1 

interface Tunnel1 
 ipv6 enable 
 ip address 13.13.13.14 255.255.255.0 
 ipv6 address 100:100::100/64 
 tunnel-protocol gre 
 source 107.1.1.2 
 destination 107.1.1.1 
 ospfv3 100 area 0.0.0.0 

bgp 10089 
 peer 107.1.1.1 as-number 10086 
 # 
 ipv4-family unicast 
  import-route direct   
  peer 107.1.1.1 enable 

ospf 100 
 import-route direct 
 import-route static 
 area 0.0.0.0 
  network 5.5.5.5 0.0.0.0 
  network 13.13.13.0 0.0.0.255 
  network 107.1.1.0 0.0.0.255 

l    Serveur

!Software Version V100R005C10SPC200 

interface Vlanif1000 
 ipv6 enable 
 ip address 100.100.1.1 255.255.255.0 
 ipv6 address 1000:1000::2/64 
 ipv6 address auto link-local 

interface Vlanif4000 
 ip address 17.1.1.100 255.255.255.0 

interface MEth0/0/0 

interface Eth-Trunk100 
 port link-type trunk 
 port trunk allow-pass vlan 4000 

interface 10GE1/0/14 
 eth-trunk 100 
 device transceiver 1000BASE-X 

interface 10GE1/0/23 
 eth-trunk 100   
 device transceiver 1000BASE-X 

ip route-static 0.0.0.0 0.0.0.0 100.100.1.101 

ipv6 route-static :: 0 1000:1000::1000 

Procédure de dépannage

                               Étape 1       Selon les résultats du test, le serveur peut parfois exécuter une commande ping via SwitchC, mais parfois ne pas effectuer de commande ping via SwitchC. Lorsqu'il ne peut pas effectuer de ping normalement, il reçoit un paquet de requête de ping de SwitchB, mais ne reçoit pas ce message. On peut donc en conclure que le message est envoyé au périphérique SwitchB et qu'aucun message n'est envoyé.

161824v0rfyrb8ymlfblbbb.png

                               Étape 2       Essayez d’envoyer une requête ping à l’interrupteur SwitchB sur l’interrupteur SwitchC et découvrez qu’elle peut s’exécuter. Par conséquent, on peut en conclure que le paquet est rejeté lorsqu'il entre dans la direction entrante du périphérique SwitchB:

161825brsuejzrrwsejqul.png

                               Étape 3       Vérifiez l'état du voisin DFS sur les périphériques SwitchA et SwitchB.

Exécutez la commande display dfs-group pour vérifier les informations de M-LAG. Nous constatons que le statut M-LAG est normal.

161826oty2d1z3lz1jx2c6.png

Et ensuite, nous vérifions les paquets reçus du serveur:

161826j3xfl4hgoyp1phnn.png

Nous constatons que l’adresse MAC de destination n’est pas l’adresse MAC de l’interface VLAN de SwitchB, c’est ce qui cause ce problème et le flux de trafic est supprimé lorsque le trafic est envoyé à SwitchB.

161827gkxm8box83mexob3.png

Nous vérifions que le trafic fonctionne correctement lorsqu'il est envoyé à SwitchA et que l'adresse MAC de destination est l'adresse MAC de l'interface VLAN sur SwitchA.

Solution: Prenez une référence du document produit. Il est recommandé de configurer la passerelle double VRRP ou la même adresse IP et la même adresse MAC sur l'interface VLAN. Configurez la même adresse IP et la même adresse MAC:

# SwitchA 
[~SwitchA]    interface vlanif 1000 
[*SwitchA-Vlanif1000] ip address 100.100.1.101 24 
[*SwitchA-Vlanif1000] mac-address 0000-5e00-0101 
[*SwitchA-Vlanif1000] quit 
[*SwitchA] commit 
# SwitchB
 
[~SwitchB]    interface vlanif 1000 
[*SwitchB-Vlanif1000] ip address 100.100.1.101 24 
[*SwitchB-Vlanif1000] mac-address 0000-5e00-0101 
[*SwitchB-Vlanif1000] quit 
[*SwitchB] commit

 

Après avoir effectué cette configuration, tout fonctionne correctement.

161828tvswt0su5ysbygvs.png

Cause première

Sur le voisin M-LAG, le serveur accède à deux passerelles en fonction du mode d'équilibrage de charge de l'Eth-Trunk. Par conséquent, les deux périphériques compatibles M-LAG sont tous des périphériques de passerelle et doivent utiliser la même adresse MAC de passerelle.


  • x
  • Standard:

Responder

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.

Connectez-vous pour participer à la communication et au partage

S'identifier
Réponse rapide Accéder au haut de page