j'ai compris

QinQ sélectif transporté par MPLS L2VC simulé sur eNSP

publié il y a  2021-5-9 14:26:52 172 0 0 0 0

            Le MPLS apporte de nombreuses fonctionnalités aux FAI, favorisant la possibilité de fournir des transports via des VPN, dont le VPWS, qui fournit une liaison point à point qui peut être configurée sur un VLAN spécifique ou sur un port physique dédié pour un client.


        Lorsqu'il est configuré sur un port physique, le VPWS transportera toutes les données insérées sur ce port directement de l'autre côté du tunnel, y compris tous les ID VLAN existants.


        Mais, à un moment donné, le client peut demander que se réalise la sélection de certains VLAN vers un tunnel spécifique et d'autres VLAN vers un autre tunnel. Pour cela, il est nécessaire d'utiliser une technique appelée QinQ sélectif, où nous créons des VLAN de transport pour relier le tunnel et insérer sur ces VLAN l'ID de VLAN sélectionné créant un double TAG.


        Pour démontrer l'opération, j'ai créé un LAB avec les prémisses suivantes:

                · Le  client A doit transporter les VLAN 1030 et 2030 vers le routeur R1 et le VLAN 530 vers le routeur R2.

                · Le  client B doit transporter les VLAN 1035 et 2035 vers le routeur R1 et le VLAN 535 vers le routeur R2.


        Avec cela, nous créons les VLAN de transport comme vous pouvez le voir ci-dessous:

    ·  VLAN30 = CLI_A -> R1

    ·  VLAN35 = CLI_B -> R1

    ·  VLAN300 = CLI_A -> R2

    ·  VLAN350 = CLI_B -> R2

 


1


        Des adresses IP ont été placées sur les VLAN afin que nous puissions réaliser des tests de ping pour valider le travail de transport correct. Voici la configuration de chaque équipement de ce LAB à reproduire par vous.


[CLI_A]

vlan batch 530 1030 2030

#

interface Vlanif530

 ip address 50.50.30.1 255.255.255.0

#

interface Vlanif1030

 ip address 10.10.30.1 255.255.255.0

#

interface Vlanif2030

 ip address 20.20.30.1 255.255.255.0

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 530 1030 2030

 

[CLI_B]

vlan batch 535 1035 2035

#

interface Vlanif535

 ip address 50.50.35.1 255.255.255.0

#

interface Vlanif1035

 ip address 10.10.35.1 255.255.255.0

#

interface Vlanif2035

 ip address 20.20.35.1 255.255.255.0

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 535 1035 2035

 

[PE1]

vlan batch 30 35 100 to 101 300 350

#

mpls lsr-id 1.1.1.1

mpls

#

mpls l2vpn

#

mpls ldp

#

interface Vlanif30

 mpls l2vc 2.2.2.2 30

#

interface Vlanif35

 mpls l2vc 2.2.2.2 35

#

interface Vlanif100

 ip address 10.0.0.1 255.255.255.252

 ospf network-type p2p

 ospf enable 1 area 0.0.0.0

 mpls

 mpls ldp

#

interface Vlanif101

 ip address 10.0.0.5 255.255.255.252

 ospf network-type p2p

 ospf enable 1 area 0.0.0.0

 mpls

 mpls ldp

#

interface Vlanif300

 mpls l2vc 3.3.3.3 300

#

interface Vlanif350

 mpls l2vc 3.3.3.3 350

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 100

#

interface GigabitEthernet0/0/2

 qinq vlan-translation enable

 port hybrid untagged vlan 30 300

 port vlan-stacking vlan 10 stack-vlan 30

 port vlan-stacking vlan 20 stack-vlan 30

 port vlan-stacking vlan 50 stack-vlan 300

#

interface GigabitEthernet0/0/3

 qinq vlan-translation enable

 port hybrid untagged vlan 35 350

 port vlan-stacking vlan 10 stack-vlan 35

 port vlan-stacking vlan 20 stack-vlan 35

 port vlan-stacking vlan 50 stack-vlan 350

#

interface GigabitEthernet0/0/4

 port link-type trunk

 port trunk allow-pass vlan 101

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

 ospf enable 1 area 0.0.0.0

#

ospf 1 router-id 1.1.1.1

 area 0.0.0.0

#

 

[PE2]

vlan batch 30 35 100

#

mpls lsr-id 2.2.2.2

mpls

#

mpls l2vpn

#

mpls ldp

#

interface Vlanif30

 mpls l2vc 1.1.1.1 30

#

interface Vlanif35

 mpls l2vc 1.1.1.1 35

#

interface Vlanif100

 ip address 10.0.0.2 255.255.255.252

 ospf network-type p2p

 ospf enable 1 area 0.0.0.0

 mpls

 mpls ldp

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 100

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 30 35

#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255

 ospf enable 1 area 0.0.0.0

#

ospf 1 router-id 1.1.1.1

 area 0.0.0.0

#

 

[PE3]

vlan batch 300 350 101

#

mpls lsr-id 3.3.3.3

mpls

#

mpls l2vpn

#

mpls ldp

#

interface Vlanif300

 mpls l2vc 1.1.1.1 300

#

interface Vlanif350

 mpls l2vc 1.1.1.1 350

#

interface Vlanif101

 ip address 10.0.0.6 255.255.255.252

 ospf network-type p2p

 ospf enable 1 area 0.0.0.0

 mpls

 mpls ldp

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 101

#

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 300 350

#

interface LoopBack0

 ip address 3.3.3.3 255.255.255.255

 ospf enable 1 area 0.0.0.0

#

ospf 1 router-id 1.1.1.1

 area 0.0.0.0

#

 

[R1]

#

interface GigabitEthernet0/0/0.3010

 qinq termination pe-vid 30 ce-vid 1030

 ip address 10.10.30.2 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.3020

 qinq termination pe-vid 30 ce-vid 2030

 ip address 20.20.30.2 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.3510

 qinq termination pe-vid 35 ce-vid 1035

 ip address 10.10.35.2 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.3520

 qinq termination pe-vid 35 ce-vid 2035

 ip address 20.20.35.2 255.255.255.0

 arp broadcast enable

#

 

[R2]

#

interface GigabitEthernet0/0/0.3050

 qinq termination pe-vid 300 ce-vid 530

 ip address 50.50.30.2 255.255.255.0

 arp broadcast enable

#

interface GigabitEthernet0/0/0.3550

 qinq termination pe-vid 350 ce-vid 535

 ip address 50.50.35.2 255.255.255.0

 arp broadcast enable

#


  • x
  • Standard:

Commentaire

Connectez-vous pour répondre. Se connecter | Enregistrer
envoyer

Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Accord utilisateur ».

My Followers

Connectez-vous pour participer à la communication et au partage

S'identifier

Bloquer
Êtes-vous sûr de bloquer cet utilisateur?
Les utilisateurs de votre liste noire ne peuvent ni commenter votre publication,ni vous mentionner, ni vous envoyer de messages privés.
Rappel
Veuillez lier votre numéro de téléphone pour obtenir un bonus d'invitation.