Problème de deux liens Trunk entre S5700 et AR201

57 0 0 0

Déscription du problème:


Je ne sais pas s'il s'agit ou non d'un bug dans eNSP, mais la création de deux liens Trunk entre S5700 et AR201 entraîne la duplication 

des ID de routeur OSPF. Arrêter un lien Trunk et laisser l’autre lien intact résout le problème. Voici mon explication: Lorsque le routeur ou 

le commutateur essaie d’envoyer un paquet de protocole OSPF, il le reçoit à cause de la boucle provoquée par deux liens Trunks vers le même 

périphérique. Cela fait que le routeur ou le commutateur pense que son propre paquet est envoyé par un autre périphérique que les ID de routeur

OSPF doivent dupliquer.


J'ai créé deux liens Trunks pour la redondance. Maintenant, je pense créer un canal Link-aggregation à la place.


Voici les configurations pour votre compréhension:


521616c8105ce.png

Erreurs:


Aug 22 2013 18:47:03-08:00 CE1 %%01OSPF/4/CONFLICT_ROUTERID_INTF(l)[1]:OSPF Route

r id conflict is detected on interface. (ProcessId=200, RouterId=2.1.1.1, AreaId=

0.0.0.0, InterfaceName=Vlanif60, IpAddr=60.60.60.5, PacketSrcIp=60.60.60.5)

 

Aug 22 2013 18:47:09-08:00 CE1 %%01OSPF/4/CONFLICT_ROUTERID_INTF(l)[2]:OSPF Route

r id conflict is detected on interface. (ProcessId=100, RouterId=1.1.1.1, AreaId=

0.0.0.0, InterfaceName=Vlanif50, IpAddr=50.50.50.5, PacketSrcIp=50.50.50.5)

---------------------------------------------------------------------------------------------------------------------------------------------------------

Configuration CE1:

interface Vlanif50
description CE-PE1-Service_1
ip binding vpn-instance SERVICE_1
ip address 50.50.50.5 255.255.255.252
#
interface Vlanif60
description CE-PE1-Service_2
ip binding vpn-instance SERVICE_2
ip address 60.60.60.5 255.255.255.252
#
interface LoopBack0
ip binding vpn-instance SERVICE_1
ip address 1.1.1.1 255.255.255.255
#
interface LoopBack1
ip binding vpn-instance SERVICE_2
ip address 2.1.1.1 255.255.255.255
#
ospf 100 router-id 1.1.1.1 vpn-instance SERVICE_1
area 0.0.0.0
network 1.1.1.1 0.0.0.0 network 50.50.50.4 0.0.0.3
#
ospf 200 router-id 2.1.1.1 vpn-instance SERVICE_2
area 0.0.0.0
network 2.1.1.1 0.0.0.0
network 60.60.60.4 0.0.0.3
#
interface GigabitEthernet0/0/7
description S=CE1#D=PE1
eth-trunk 2
#
interface GigabitEthernet0/0/8
description S=CE1#D=PE1
eth-trunk 2

Configuration PE1:
ip vpn-instance SERVICE_1
 description SERVICE_1
 ipv4-family
  route-distinguisher 100:1#
ip vpn-instance SERVICE_2
 description SERVICE_2
 ipv4-family
  route-distinguisher 100:2
#
interface Vlanif50
 description PE1-CE1-Service_1
 ip binding vpn-instance SERVICE_1
 ip address 50.50.50.6 255.255.255.252 
#
interface Vlanif60
 description PE1-CE1-Service_2
 ip binding vpn-instance SERVICE_2
 ip address 60.60.60.6 255.255.255.252 
#
interface Ethernet0/0/0
 description S=PE1#D=CE1
 port link-type trunk
 port trunk allow-pass vlan 50 60
#
interface Ethernet0/0/1
 description S=PE1#D=CE1
 port link-type trunk
 port trunk allow-pass vlan 50 60
#
interface LoopBack0
 ip binding vpn-instance SERVICE_1
 ip address 1.1.1.3 255.255.255.255 
#
interface LoopBack1
 ip binding vpn-instance SERVICE_2
 ip address 2.1.1.3 255.255.255.255 
#
ospf 100 router-id 1.1.1.3 vpn-instance SERVICE_1
 area 0.0.0.0 
  network 1.1.1.3 0.0.0.0 
  network 50.50.50.4 0.0.0.3 #
ospf 200 router-id 2.1.1.3 vpn-instance SERVICE_2
 area 0.0.0.0 
  network 2.1.1.3 0.0.0.0 
  network 60.60.60.4 0.0.0.3




  • x
  • Standard:

Responder

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.

Connectez-vous pour participer à la communication et au partage

S'identifier
Réponse rapide Accéder au haut de page