[Partage d'initié] Scénario de double hébergement CE - Quelle est la meilleure méthode d'accès VPLS?

30 0 0 0


Salut les gars,

Je voudrais commencer une discussion sur la façon d'accéder au circuit VPLS du côté CE. Comme vous le savez peut-être, la fiabilité est très importante de nos jours, mais la technologie VPLS est assez difficile à mettre en œuvre, en particulier lorsque vous ajoutez de nombreux liens redondants qui tentent de réaliser le scénario dual-CE.

Le scénario d'accès VPLS le plus courant est comme ci-dessous. Pour CE, nous pouvons adopter un scénario dual home et réaliser la redondance PE. De plus, chaque circuit PE-CE est constitué de 2 liaisons redondantes.

171607cf6r4de46g1fdkke.png
Afin de prendre en charge le scénario CE à double hébergement, la configuration VPLS des PE doit être ajustée en conséquence. Tout d’abord, vous devez utiliser le mode de signalisation Kompella, Martini n’est pas pris en charge. Configurez ensuite deux VSI avec le même attribut sur deux PE à double hébergement.

Si les VSI de deux PE auxquels une entité CE est hébergée en double sont Up, le PE avec la priorité la plus élevée fonctionne en tant que PE maître, alors que le PE avec la priorité la plus basse fonctionne en tant que PE de sauvegarde.

Du côté de l'accès, nous aurons certainement des problèmes avec Spanning Tree. Comme il y a tellement de liens redondants, certains ports seront bloqués, rendant l'accès VPLS non disponible. Vous devrez modifier la configuration STP. Quoi qu'il en soit, certains liens finiront par être indisponibles. Nous ne pouvons pas utiliser toute la bande passante disponible. Le temps de convergence n’est pas suffisant, c’est basé sur le protocole STP.

Nous pouvons surmonter la limitation STP en utilisant des eth-trunks.

Du côté du PE, nous ajouterons les 2 interfaces redondantes qui connectent le CE. Du côté de la CE, nous allons ajouter tous les liens allant à la CE dans un même tronc. Vérifiez ci-dessous:

171645emikemimionoe5mz.png
Mais ici, si Kompella n’a pas mis en œuvre la double configuration VPLS avec signalisation, vous aurez un problème. Par exemple, CE communique avec un autre CE sur le réseau VPLS via PE1. Si PE1 ou la liaison Eth-Trunk entre CE1 et PE1 échoue, CE1 ne peut pas communiquer avec CE2. Nous pouvons empêcher les interruptions de service et configurer une E-Trunk sur PE1 et PE2. Lorsque la communication entre CE1 et PE1 échoue, le trafic est basculé sur PE2 afin que CE1 puisse communiquer avec CE2 via PE2. Lorsque PE1 ou la liaison Eth-Trunk entre CE1 et PE1 est rétablie, le trafic redevient PE1. L'E-Trunk implémente la sauvegarde des groupes d'agrégation de liens entre PE1 et PE2 et améliore la fiabilité du réseau. De plus, nous pouvons installer BFD pour suivre le statut du groupe d'agrégation de liens et activer le temps de convergence millisecondes. Vérifiez ci-dessous la topologie et la configuration associée.

171721scp4gcz9ptoznthp.png

-------------

#

 sysname CE

#

 vlan batch 10

#

interface Eth-Trunk0

 port link-type trunk

 port trunk allow-pass vlan 10

 mode lacp

#

interface GigabitEthernet0/0/1

 eth-trunk 0

#

interface GigabitEthernet0/0/2

 eth-trunk 0

#

interface GigabitEthernet0/0/3

 eth-trunk 0

#

interface GigabitEthernet0/0/4

 eth-trunk 0

#

return 

---------------

#

 sysname PE1

#

 vlan batch 100

#

 lacp e-trunk system-id 00e0-fc00-0000

 lacp e-trunk priority 1

#

e-trunk 1

 priority 10

 peer-address 2.2.2.9 source-address 1.1.1.9

 timer hello 9

 timer hold-on-failure multiplier 3

 e-trunk track bfd-session session-name hello1

#

 bfd

#

 mpls lsr-id 1.1.1.9

 mpls

#

 mpls l2vpn

#

vsi vpls_lan static

 pwsignal ldp

  vsi-id 2

  peer 3.3.3.9

#

mpls ldp

#

interface Vlanif 100

 ip address 10.1.1.1 255.255.255.0

 mpls

 mpls ldp

#

interface Eth-Trunk1

 mode lacp

 e-trunk 1

#

interface Eth-Trunk10.1

 dot1q termination vid 10

 l2 binding vsi vpls_lan

#

interface GigabitEthernet0/0/3

 port link-type trunk

 port trunk allow-pass vlan 100

#

interface GigabitEthernet0/0/1

 eth-trunk 1

#

interface GigabitEthernet0/0/2

 eth-trunk 1

#

interface LoopBack1

 ip address 1.1.1.9 255.255.255.255

#

bfd hello1 bind peer-ip 2.2.2.9 source-ip 1.1.1.9

 discriminator local 1

 discriminator remote 2

 commit

#

ospf 1

 area 0.0.0.0

  network 1.1.1.9 0.0.0.0

  network 10.1.1.0 0.0.0.255

#

return    

---------------

#

 sysname PE2

#

 vlan batch 200

#

 lacp e-trunk system-id 00e0-fc00-0000

 lacp e-trunk priority 1

#

e-trunk 1

 priority 20

 peer-address 1.1.1.9 source-address 2.2.2.9

 e-trunk track bfd-session session-name hello2

#

 bfd

#

 mpls lsr-id 2.2.2.9

 mpls

#

 mpls l2vpn

#

vsi vpls_lan static

 pwsignal ldp

  vsi-id 2

  peer 3.3.3.9

#

mpls ldp

#

interface Vlanif 200

 ip address 10.1.2.1 255.255.255.0

 mpls

 mpls ldp

#

interface Eth-Trunk 1

 mode lacp

 e-trunk 1

#

interface Eth-Trunk10.1

 dot1q termination vid 10

 l2 binding vsi vpls_lan

#

interface GigabitEthernet0/0/3

 port link-type trunk

 port trunk allow-pass vlan 200

#

interface GigabitEthernet0/0/1

 eth-trunk 1

#

interface GigabitEthernet0/0/2

 eth-trunk 1

#

interface LoopBack1

 ip address 2.2.2.9 255.255.255.255

#

bfd hello2 bind peer-ip 1.1.1.9 source-ip 2.2.2.9

 discriminator local 2

 discriminator remote 1

 commit

#

ospf 1

 area 0.0.0.0

  network 2.2.2.9 0.0.0.0

  network 10.1.2.0 0.0.0.255

#

return

------------------

Concernant la discussion que j’ai entamée, je pense que l’accès VPLS avec Eth-Trunk et E-trunk est le meilleur choix pour les raisons suivantes:

1. Nous évitons la surcharge de la configuration VPLS pour les systèmes CE à double hébergement et les limitations de signalisation, ne fonctionnons que pour Kompella.

2. Nous utilisons pleinement la bande passante.

3. Le temps de convergence est meilleur en BFD - niveau milliseconde.
  • x
  • Standard:

Responder

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.

Connectez-vous pour participer à la communication et au partage

S'identifier
Réponse rapide Accéder au haut de page