j'ai compris

[Partage d'initié] Conflit d'adresse IP secondaire résolu via un ajustement VRRP

publié il y a  2020-4-27 16:03:06 13 0 0 0

Vous souhaitez mettre à niveau votre infrastructure réseau mais, malheureusement, cela signifie arrêter les anciens appareils et les remplacer par de nouveaux équipements. Vous savez que vous ne pouvez pas simplement dire à vos clients de faire une pause d'une journée des services pour lesquels ils vous paient, alors comment sortir de cette situation?

Pour aggraver les choses, vous disposez de quelques services client sur le Vlan 100, donc c'est un désastre si, soudainement, l'une de vos passerelles dans le vlan 100 se déconnecte, même pendant quelques minutes.

Je sais qu'à ce stade, vous pensez, pas de problème, je peux simplement configurer cette passerelle sur un équipement redondant en tant qu'adresse IP secondaire. Ce que vous ne saviez pas, c'est que votre   routeur AR1200VW  ne prend pas en charge la configuration d'une adresse IP secondaire à partir de la même plage sur l'interface Vlanif 100. J'ai essayé donc veuillez vous référer à la sortie CLI ci-dessous:

#

[AR-Vlanif12]ip add 12.0.0.2 24 sub                                            

Error: The specified address conflicts with another address.

#



J'ai la solution parfaite pour votre problème, mais avant de présenter la solution, pour clarifier les choses, jetez un œil à la conception du réseau ci-dessous:

La configuration des appareils est répertoriée ci-dessous:

###################################################

[AR1200]dis curr                                                                

[V200R003C01SPC900]                                                            

#                                                                              

 sysname AR1200                                                                                                                        

#                                                                              

vlan batch 100                                                                                       

#                                                                              

interface Vlanif100                                                            

 ip address 10.0.0.1 255.255.255.0                                              

 vrrp vrid 1 virtual-ip 10.0.0.2                                               

 vrrp vrid 1 timer advertise 255                                               

#

interface Ethernet0/0/1                                                        

 port link-type trunk                                                          

 port trunk allow-pass vlan 100                                                

#

#                                                                              

ip route-static 192.168.1.0 255.255.255.0 10.0.0.10                            

#                                                                                                                                                                                                                      

return             


##########################################################

[S5700-1]dis curr                                                                

!Software Version V200R003C00SPC300                                             

#                                                                              

sysname S5700-1                                                                                                                                                                                                              

#                                                                              

vlan batch 100 200                                                     

#                                                                               

interface Vlanif100                                                            

 ip address 10.0.0.10 255.255.255.0                                            

#                                                                               

interface Vlanif200                                                            

 ip address 192.168.1.1 255.255.255.0                                          

#                                                                               

interface GigabitEthernet0/0/18                                                

 port link-type trunk                                                          

 port trunk allow-pass vlan 100                                                 

#                                                                              

interface GigabitEthernet0/0/20                                                

 port link-type trunk                                                           

 port trunk allow-pass vlan 200                                                

#                                                                          

return        

########################################################         

[S57-2]dis curr                                                                

!Software Version V200R002C00SPC100                                            

#                                                                              

sysname S57-2                                                                                                                                                                                                        

#                                                                              

vlan batch 200                        

#                                                         

interface Vlanif200                                                             

 ip address 192.168.1.2 255.255.255.0                                                                                    

#                                                                              

interface GigabitEthernet0/0/1                                                  

 port link-type trunk                                                          

 port trunk allow-pass vlan 3970                                               

#                                                                               

interface GigabitEthernet0/0/20                                                

 port link-type trunk                                                          

 port trunk allow-pass vlan 200                                                                                                                                                          

#                                                                              

ip route-static 0.0.0.0 0.0.0.0 192.168.1.1                                                                                            

#                                                                              

return                                                                         

############################################################


Comme vous pouvez le voir, ma première étape dans cette mise à niveau consiste à se débarrasser de l'ancien AR200 et à le remplacer par un tout nouvel appareil. Je passe l'AR200 à un AR1200.

Maintenant, pour garder toutes les adresses accessibles, je dois   configurer l'adresse 10.0.0.2 sur AR-1 comme adresse IP secondaire. Parce que je ne peux pas le faire en utilisant la sous- commande ip address , j'utiliserai VRRP. En créant une instance VRRP, je peux configurer 10.0.0.2 comme une adresse IP virtuelle.

La CLI de cette opération est répertoriée ci-dessous:

#

[S77-1] vrrp vrid 1 virtual-ip 10.0.0.2

#

Après cette configuration, je testerai la connectivité à partir de mon nœud S77-1 et comme vous   pouvez le voir dans les lignes suivantes, tout est vérifié:

[S57-2]ping 10.0.0.1                                                            

  PING 10.0.0.1: 56  data bytes, press CTRL_C to break                         

    Reply from 10.0.0.1: bytes=56 Sequence=1 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=2 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=3 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=4 ttl=254 time=1 ms                 

    Reply from 10.0.0.1: bytes=56 Sequence=5 ttl=254 time=1 ms                 

                                                                                

  --- 10.0.0.1 ping statistics ---                                             

    5 packet(s) transmitted                                                    

    5 packet(s) received                                                        

    0.00% packet loss                                                          

    round-trip min/avg/max = 1/1/1 ms                                          

                                                                                

[S57-2]ping 10.0.0.2                                                            

  PING 10.0.0.2: 56  data bytes, press CTRL_C to break                         

    Reply from 10.0.0.2: bytes=56 Sequence=1 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=2 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=3 ttl=254 time=1 ms                 

    Reply from 10.0.0.2: bytes=56 Sequence=4 ttl=254 time=1 ms                  

    Reply from 10.0.0.2: bytes=56 Sequence=5 ttl=254 time=1 ms                 

                                                                               

  --- 10.0.0.2 ping statistics ---                                              

    5 packet(s) transmitted                                                    

    5 packet(s) received                                                       

    0.00% packet loss                                                           

round-trip min/avg/max = 1/1/1 ms 


À l'heure actuelle, vous pensez peut-être que ce n'est pas une bonne solution car elle introduit du trafic de multidiffusion indésirable (généré par vrrp - messages publicitaires vrrp) dans votre réseau. Pour réduire ce trafic à un minimum acceptable, je conseille de configurer le temporisateur de publicité vrrp à la valeur maximale (255) en utilisant la commande ci-dessous:

#

[S77-1] vrrp vrid 1 timer advertise 255

#


Comme vous pouvez le voir maintenant, vous avez réduit le trafic de multidiffusion supplémentaire au strict minimum

(1 message toutes les 255 secondes). D'un autre côté, vous avez maintenant une adresse IP secondaire sur votre interface Vlanif 100 et vous êtes maintenant prêt pour le swap.


J'espère que cela vous aide autant qu'il m'a aidé!


  • x
  • Standard:

Commentaire

envoyer
Connectez-vous pour répondre. Se connecter | Enregistrer

Remarque Remarque : Afin de protéger vos droits et intérêts légitimes, ceux de la communauté et des tiers, ne divulguez aucun contenu qui pourrait présenter des risques juridiques pour toutes les parties. Le contenu interdit comprend, sans toutefois s'y limiter, le contenu politiquement sensible, le contenu lié à la pornographie, aux jeux d'argent, à l'abus et au trafic de drogues, le contenu qui peut divulguer ou enfreindre la propriété intellectuelle d'autrui, y compris les secrets professionnels, les marques commerciales, les droits d'auteur et les brevets, ainsi que la vie privée personnelle. Ne partagez pas votre nom d'utilisateur ou votre mot de passe avec d'autres personnes. Toutes les opérations effectuées à partir de votre compte seront considérées comme vos propres actions, et toutes les conséquences en découlant vous seront imputées. Pour plus de détails, voir « Politique de confidentialité ».
Si le bouton de la pièce-jointe n'est pas disponible, mettez à jour Adobe Flash Player à la dernière version.

My Followers

Connectez-vous pour participer à la communication et au partage

S'identifier

Communauté de Support de Huawei Entreprise
Communauté de Support de Huawei Entreprise
Bloquer
Êtes-vous sûr de bloquer cet utilisateur?
Les utilisateurs de votre liste noire ne peuvent ni commenter votre publication,ni vous mentionner, ni vous envoyer de messages privés.